Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Lisp
  probleme mit acad startdatei

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
  
Gut zu wissen: Hilfreiche Tipps und Tricks aus der Praxis prägnant, und auf den Punkt gebracht für Autodesk Produkte
Autor Thema:  probleme mit acad startdatei (186 mal gelesen)
Bauvermesser
Mitglied
Vermesser


Sehen Sie sich das Profil von Bauvermesser an!   Senden Sie eine Private Message an Bauvermesser  Schreiben Sie einen Gästebucheintrag für Bauvermesser

Beiträge: 457
Registriert: 18.03.2006

AMD 2600, 2024RAM ,WIN XP PROF-SP3, ACAD 2005, Firmenrechner,

erstellt am: 14. Jan. 2022 10:51    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

ich bitte um Ratschläge zu folgenden Problem:
ich musste notgedrungen meinen alten XP Rechner neu aufsetzten und dabei auch ACAD 2005 neu installieren. Ich kann sagen, das ich fast alles gespiegelt habe, also auch alle Acad-einstellungen mit den individuellen Startdateien.
Nun wird für mich nicht nachvollziehbar die Abarbeitung in der ACAD- Startdatei völlig unterschiedlich ausgeführt.
Alle Befehle in der LSP werden ganz ausführlich und endlos lang aufgelistet. Wieso? Dadurch geht einem die Übersicht zu Fehlermeldungen verloren. Was ist hier los. Wieso wird immer "Option eingeben" aufgelistet?


Bsp: alte Befehlausführung in Startdatei
_LAYER Ma 0-Hilfslinien FArbe 1 Ltyp LStõrke 0.090000000000000 Plot Kein


Ausgabe in neuer Installation des gleichen Befehls:
Option eingeben
[?/Machen/SEtzen/Neu/EIn/Aus/FArbe/Ltyp/LStõrke/Plot/PStil/FRieren/Tauen/SPerren
/ENtsperren/STatus]: Ma
Namen f³r neuen Layer eingeben (wird aktueller Layer) <0>: 0-Hilfslinien Option
eingeben
[?/Machen/SEtzen/Neu/EIn/Aus/FArbe/Ltyp/LStõrke/Plot/PStil/FRieren/Tauen/SPerren
/ENtsperren/STatus]: FArbe
Neue Farbe [Truecolor/Farbbuch] : 1
Namensliste der/des Layer/s f³r Farbe eingeben 1 (rot) <0-Hilfslinien>: Option
eingeben
[?/Machen/SEtzen/Neu/EIn/Aus/FArbe/Ltyp/LStõrke/Plot/PStil/FRieren/Tauen/SPerren
/ENtsperren/STatus]: Ltyp
Namen des geladenen Linientyps eingeben oder [?] <Continuous>: Option eingeben
[?/Machen/SEtzen/Neu/EIn/Aus/FArbe/Ltyp/LStõrke/Plot/PStil/FRieren/Tauen/SPerren
/ENtsperren/STatus]: LStõrke
Linienstõrke eingeben (0.0mm - 2.11mm): 0.090000000000000
Namensliste der/des Layer/s f³r Linienstõrke eingeben 0.09mm <0-Hilfslinien>:
Option eingeben
[?/Machen/SEtzen/Neu/EIn/Aus/FArbe/Ltyp/LStõrke/Plot/PStil/FRieren/Tauen/SPerren
/ENtsperren/STatus]: Plot
Voreinstellung zum Plotten eingeben [Plot/Kein plot] <Plot>: Kein

------------------
Gruß vom Bauvermesser;

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 21036
Registriert: 03.06.2002

Alles

erstellt am: 14. Jan. 2022 11:01    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bauvermesser 10 Unities + Antwort hilfreich

Hi,

>>"Alle Befehle in der LSP werden ganz ausführlich und endlos lang aufgelistet. Wieso?"
Ganz normal, du startest einen Befehl und fütterst diesen mit Eingaben,
was du ins im Bild zeigst ist die ganz normale Rückgabe dieses/dieser Befehle.

>>"Dadurch geht einem die Übersicht zu Fehlermeldungen verloren. Was ist hier los."
Standardrückgabe, nichts "besonderes".

>>"Wieso wird immer "Option eingeben" aufgelistet?"
Weil der Befehl eine Option vom Benutzer mitgeteilt haben möchte, diesen Wunsch teilt das Programm schon seit Jahrzehnten mit diesem Wortlaut mit.


Was mich etwas wundert ist dass die die Befehlsrückgabe anscheinend gänzlich unbekannt ist,  aber okay.

Vermutung: Ich nehme an du hattest vorher irgendwie "erfolgreich" geschafft vorher immer CMDECHO auszuschalten und bei deinem aktuellen Setup ist das nicht der Fall. 

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Bauvermesser
Mitglied
Vermesser


Sehen Sie sich das Profil von Bauvermesser an!   Senden Sie eine Private Message an Bauvermesser  Schreiben Sie einen Gästebucheintrag für Bauvermesser

Beiträge: 457
Registriert: 18.03.2006

AMD 2600, 2024RAM ,WIN XP PROF-SP3, ACAD 2005, Firmenrechner,

erstellt am: 17. Jan. 2022 10:58    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo, und Danke aber so einfach scheint es  nicht zu sein. Auf die Umschaltung von cmdecho wird nicht reagiert. Das Verschieben der Sicherungsdatei mit -savefilepath- wird nicht angenommen, sondern es werden die bak Dateien im Verzeichnis der orig. dwg gespeichert. Habe cmdecho extra am Schluss der Startlsp nochmal auf 0 gesetzt, beim Start steht dieser Befehl wieder auf 1. Die anderen am Start beteiligten LSP wurden diesbezüglich ebenfalls geprüft. Bin als Admin angemeldet, System WINXP . Irgend eine Einstellung scheint hier alles zu überschreiben. Wer hat noch einen Rat? Habe auch geprüft das nur eine Startlsp -acad.lsp- existiert. Ist ja eigentlich alles gut überschaubar, hier scheint aber irgendetwas im Hintergrund zu werkeln. Auch das immer wieder neu anlegen der ISO Bemaßung war am alten Rechner nicht so aufgetreten. Habe vor der Neuinstallation des Rechners alle Sys-Einstellungen über die EXpress Tools gesichert und kann alle Einstellungen von neu zu alt prüfen. Ich finde keinen fehler.
Eine Rep-install der ACAD-Registry wurde bereits durchgeführt.

------------------
Gruß vom Bauvermesser;

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 21036
Registriert: 03.06.2002

Alles

erstellt am: 17. Jan. 2022 11:32    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bauvermesser 10 Unities + Antwort hilfreich


220117_DIMTEST1.dwg

 
Hallo,

>>"Das Verschieben der Sicherungsdatei mit -savefilepath- wird nicht angenommen, sondern es werden die bak Dateien im Verzeichnis der orig. dwg gespeichert."
Die Variable hat auch nichts mit der "händisch" gespeicherten *.bak zutun?

>>"Habe cmdecho extra am Schluss der Startlsp nochmal auf 0 gesetzt, beim Start steht dieser Befehl wieder auf 1."
Macht ja wenig Sinn bei einer Voreinstellung =1, welche nicht gespeichert wird.

>>"Irgend eine Einstellung scheint hier alles zu überschreiben. Wer hat noch einen Rat?"
Führe erneut eine Suche nach CMDECHO in allen beteiligten Dateien durch
und als temporären "Funktionstest" schreibst du die "CMDECHO" "0" Anweisung einmal direkt in deine (Command Layer Sequenz, also (command "CMDECHO" "0" "_.-LAYER"....deine Eingaben)

>>"Habe auch geprüft das nur eine Startlsp -acad.lsp- existiert."
ACAD.lsp? Die ist ja nur für die erste Datei gedacht (es sei denn man missbraucht diese acaddoc / ACADLSPASDOC).
Testest du also immer mit ACAD schließen, öffnen ... oder hast du acadlspasdoc eingeschaltet?

>>"Ist ja eigentlich alles gut überschaubar, hier scheint aber irgendetwas im Hintergrund zu werkeln."
Dafür sehe ich noch keinen Hinweis, aber ich sehe ja auch weniger wie du und darf noch etwas mehr an deinem "setup" zweifeln wie du dass selbst machst.

>>"Auch das immer wieder neu anlegen der ISO Bemaßung war am alten Rechner nicht so aufgetreten."
Das müßtest du etwas genauer erklären (bitte). Beim copy&paste oder beim ACAD-öffnen, oder Datei-Neu? Oder wie genau?


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Entsorger01
Ehrenmitglied V.I.P. h.c.
Techniker



Sehen Sie sich das Profil von Entsorger01 an!   Senden Sie eine Private Message an Entsorger01  Schreiben Sie einen Gästebucheintrag für Entsorger01

Beiträge: 3222
Registriert: 07.07.2006

ACAD 2006
ACAD 2008 - SP1
VPstudio (Raster)
Acrobat 7.0 Prof.
Acrobat Distiller
Photoshop CS2
Nvidia Quadro FX1400
Win 2000 Prof.

erstellt am: 17. Jan. 2022 12:01    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bauvermesser 10 Unities + Antwort hilfreich

Für das Verbiegen des BAK-Speicherpfades ist der Befehl MOVEBACK zuständig.

Was die Auflistung betrifft, kann ich cadffm auch nur zustimmen. Kenne es auch nur so ausführlich.

------------------
Gruß

Michi

""Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."
Karl Valentin

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Bernhard GSD
Mitglied



Sehen Sie sich das Profil von Bernhard GSD an!   Senden Sie eine Private Message an Bernhard GSD  Schreiben Sie einen Gästebucheintrag für Bernhard GSD

Beiträge: 477
Registriert: 29.08.2002

AutoCAD 2020(Deu); Windows 10 PRO x64(Deu)

erstellt am: 17. Jan. 2022 16:31    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bauvermesser 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Entsorger01:
Für das Verbiegen des BAK-Speicherpfades ist der Befehl MOVEBACK zuständig.

Gab es das überhaupt schon in ACAD 2005?

------------------
Gruß aus Wien
Bernhard

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 21036
Registriert: 03.06.2002

Alles

erstellt am: 17. Jan. 2022 17:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bauvermesser 10 Unities + Antwort hilfreich

Bauvermesser
Mitglied
Vermesser


Sehen Sie sich das Profil von Bauvermesser an!   Senden Sie eine Private Message an Bauvermesser  Schreiben Sie einen Gästebucheintrag für Bauvermesser

Beiträge: 457
Registriert: 18.03.2006

AMD 2600, 2024RAM ,WIN XP PROF-SP3, ACAD 2005, Firmenrechner,

erstellt am: 17. Jan. 2022 22:43    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo und Danke für die Hilfe
also
1. ACAD.lsp? Die ist ja nur für die erste Datei gedacht (es sei denn man missbraucht diese acaddoc / ACADLSPASDOC).
Testest du also immer mit ACAD schließen, öffnen ... oder hast du acadlspasdoc eingeschaltet?
>>>> habe alle wichtigen Startbefehle in die ACAD.Lsp gepackt, die acaddoc habe ich so belassen wie installiert.

2. MOVEBACK  gibt es unter 2005 nicht, jedenfalls bei mir
>>>>kann die nach 5min automatisch angelegte Sicherung *.bak leider nicht in einen anderen speziellen Sicherungsordner festlegen
>>> schade
3. schreibst du die "CMDECHO" "0" Anweisung einmal direkt in deine (Command...
habe ich eingefügt und ist sehr gut , läuft so wie ich es haben will und die lange meldung zu ISO Bemaßungsstil ist dadurch auch weg

Nachtrag: mein Vorgänger hatte die Expresstools 2005 installiert mit deutscher Version, Installation ist ja gut beschreiben. Es gibt aber noch
die ET2005bonus- Tools. Kann ich diese einfach in den Ordner darüber kopieren. Es sind 19 Dateien mit Datum 25.05.2004? Werden die dann auch im Express-Menü mit erkannt oder verarbeitet?

------------------
Gruß vom Bauvermesser;

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 21036
Registriert: 03.06.2002

Alles

erstellt am: 18. Jan. 2022 00:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bauvermesser 10 Unities + Antwort hilfreich


>>1. Testest du also immer mit ACAD schließen, öffnen ... oder hast du acadlspasdoc eingeschaltet?
>>>> habe alle wichtigen Startbefehle in die ACAD.Lsp gepackt, die acaddoc habe ich so belassen wie installiert.
Weder ACAD.lsp noch ACADDOC.lsp gehören zum Programmumfang bei AUTOCAD dazu.
Etwas "zu belassen" was es nicht gibt liest sich merkwürdig!?
Auf die Frage wie deine Einstellung acadlspasdoc ist und wie getestet wurde fehlt die Antwort noch.

>>2. MOVEBACK  gibt es unter 2005 nicht, jedenfalls bei mir
MOVEBAK ist für die .bak Datei welche beim Speichern im Ordner der Zeichnungsdatei angelegt wird (soweit ISAVEBAK aktiviert ist),
da es Teil der Expresstools Version kann es sein dass du diese überhaupt nicht, oder nur die abgespeckte Version von CD installiert hast
und movebak und Vielem andere nicht vorhanden war.

>>>>kann die nach 5min automatisch angelegte Sicherung *.bak leider nicht in einen anderen speziellen Sicherungsordner festlegen
Hier muss ich mich etwas aus dem Fenster lehnen da ich wegen der 2005er Version nicht 1:1 testen kann.
Du speicherst also nicht im nativen Dateiformat dwg2004 (richtig? warum eigentlich nicht?)
>>> schade
Ich wüßte aktuell nicht warum es in 2005 anders funktioniert sollte, schau doch bitte noch einmal nach auf was die Variable steht.
(hast du ja sicher schon, aber solange du es uns nicht schreibst - wissen wir es nicht)

>>3. schreibst du die "CMDECHO" "0" Anweisung einmal direkt in deine (Command...
>>>habe ich eingefügt und ist sehr gut , läuft so wie ich es haben will und die lange meldung zu ISO Bemaßungsstil ist dadurch auch weg
Da frage ich mich dann WIE und WO du es zuvor versucht hast?

>>>Nachtrag: mein Vorgänger hatte die Expresstools 2005 installiert mit deutscher Version, Installation ist ja gut beschreiben."
Deutsche Expresstools brauchen keine Beschreibung,
sprichst du vielleicht von den engl. Expresstoosl V1-9 (die enthalten auch MOVEBAK IMHO),
und darüber würde dann "nach Anleitung" das deutsche Übersetzungspaket installiert?
SO würde es Sinn machen für mich.

>>" Es gibt aber noch die ET2005bonus- Tools."
?
Du meinst ORDNER im Dateisystem?
Beim Ordnernamen "ET2005bonus" statt "ET2005bonus- Tools" würde ich auf einen Ordner der deutschen Übersetzung der engl.Tools tippen

>>"Kann ich diese einfach in den Ordner darüber kopieren."
Wir wissen nicht wohin (und warum?), daher etwas schwierig zu beurteilen.

>>"Es sind 19 Dateien mit Datum 25.05.2004?"
Zu 19 Stück, da fällt mir spontan nichts ein. Zeig doch mal her (Screenshot der Dateinamen).


>>"Werden die dann auch im Express-Menü mit erkannt oder verarbeitet?"
Wir sehen doch nicht was du siehst, außer du zeigst es uns 

Vorweg: die engl. "ETV1-9" mit der deutschen Übersetzung ist genau die richtige Wahl.


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Bauvermesser
Mitglied
Vermesser


Sehen Sie sich das Profil von Bauvermesser an!   Senden Sie eine Private Message an Bauvermesser  Schreiben Sie einen Gästebucheintrag für Bauvermesser

Beiträge: 457
Registriert: 18.03.2006

AMD 2600, 2024RAM ,WIN XP PROF-SP3, ACAD 2005, Firmenrechner,

erstellt am: 20. Jan. 2022 22:00    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


acadlsp-alt.txt


acad-lsp-neu.txt

 
hallo, hat etwas gedauert . Ich habe versucht, mit dem ausgeschiedene Kollegen die Installation von ACAD 2005 abzuklären um die Fehler einzukreisen. Wichtig erstmal , es gibt in der Firma nur eine Istall. CD mit 2005. Alle Daten wurden von dem alten WINXP SP2 auf den "neuen" Rechner mit Win xp Sp3 übernommen. Dies trifft besonders für alle am Start beteiligten ACAD- dateien zu und die, welche über die Autoload Funktion geladen werden. Die Installation wurde allerdings nur als ADMIN getätigt und kein weiterer Nutzer angelegt, da der alte Rechner nicht am Netz hängt. Könnte da der Fehler liegen das ACAD einen extra Nutzer voraussetzt?
Die EXPRESS Tools wurden von der Seite www.cadwiesel heruntergeladen und müssten??? eigentlich für 2005 die richtigen (ET2K5dt.zip) und (et2005bonus.zip) sein. Ich denke, das diese für ACAD2005 noch aktuelle sind.
(kann diese als zip nicht anhängen)
Die auf der Installation-CD bereitgestellten Express Tools sind laut Auszug aus der ini Datei Version=2.0.2600.1.

Ich hänge mal von beiden Rechner die Start acad.lsp mit dem dazugehörigen Protokoll alter Rechner und neuer Rechner hier mit an. Sonst wird das hier alles zu lang. Die unterschiedlich Protokollierung muss ja einen Grund haben.
Wenn ich von Start rede, meine ich den Start von ACAD2005 für eine neue Zeichnungsvorlage im metrischen System.
Für mich ist erstmal das wichtigste und dafür bitte ich nochmal um Hilfe

1. Warum werden in den Button keine deutschen Befehle mehr erkannt (VonLayer, Ein,Aus; frieren, tauen ec..)hängt dies mit der acad.mnu oder mns zusammmen. Welche Datei muss ich von´m alten Rechner überspielen. Was ist mit der acad.mnl und mnc ??? Ich müsste ansonsten mühsam alle Befehle durchforsten, wo was in Deutsch steht.

2. Die Sicherungsdateien welche während des arbeiten's angelegt werden, werden auf meinen vorgeschriebenen Pfad gesichert(*.sc$ und *.dwl). aber die *.bak Datei eben nicht.

3. Der Befehl Moveback ist in den Express Tools vorhanden wird aber nicht erkannt, auch nicht, wenn ich die moveback.lsp in die Oberfläche ziehe kommt "Befehl nicht erkannt".
Läuft moveback nur mit den Deutschen express Tools?

4. ist die ET2K5dt.zip die richtige letzt gültige für 2005.

------------------
Gruß vom Bauvermesser;

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 21036
Registriert: 03.06.2002

Alles

erstellt am: 21. Jan. 2022 01:10    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bauvermesser 10 Unities + Antwort hilfreich

Ich teile meine Rückmeldung auf mehrere Posts auf:

{OT &schön: Gerade hat sich wie sooft bestätigt warum ich dies hier (zum Teil) mache: Auch in diesem Thread lernte ich dazu }

Es war wirklich viel Arbeit(=Zeit), denn du hast da ein paar Specials drin, so kann man es nicht plug&play testen
und ich hatte viele 'OMG' beim Lesen der Anhänge(99% davon ist Offtopic) + mir war ein Acad-Verhalten nicht bewußt.

Die Rückgabe deiner setvar/Command-Anweisungen
Ab und an denkt man echt "hier"(Internet) sind fast nur Trolle an Werk  
(Nein, nichts Persönliches, wollte nur mal (m)eine Gedanken mitteilen und bedenke - ich lese 100 Posts täglich..)

>>aber so einfach scheint es  nicht zu sein. Auf die Umschaltung von cmdecho wird nicht reagiert.
Das ja doch darauf reagiert wird haben wir zwischendurch geprüft (mit dem cmdecho im command..),
dank dank deiner Anhänge und diesem Puzzleteil:
>>Habe cmdecho extra am Schluss der Startlsp nochmal auf 0 gesetzt, beim Start steht dieser Befehl wieder auf 1.
CADffm: Macht ja wenig Sinn bei einer Voreinstellung =1, welche nicht gespeichert wird.

kann ich dir nun auch gerne noch folgendes aufzeigen:

Also noch einmal:
Das CMDECHO immer wieder auf 1 steht ist ja dokumentiert und ganz normal, wird nicht gespeichert und Vorgabe ist 1
Was nicht dokumentiert ist: Es ist eine Dokumenteinstellung, also pro Datei - besser pro Dateisitzung, da ungespeichert..
Aus diesem Grund ist es nötig CMDECHO in jeder Datei wieder auszuschalten,
dafür eignet sich die ACADDOC.lsp (oder die ACAD.lsp im SDI-Modus, oder Ihr mißbraucht die ACAD.lsp als ACADDOC.lsp)

Ich fragte mal nach: "Testest du also immer mit ACAD schließen, öffnen ... oder hast du acadlspasdoc eingeschaltet?"
die Antwort auf die Frage blieb aus, anhand neuester Erkenntnisse muss ich aber nun darauf bestehen etwas mehr zu erfahren!
Also noch einmal eindeutig gefragt:
1. Steht ACADLSPASDOC auf 1 oder auf 0 ?
2. Arbeitet Ihr im SDI-Modus (SDI=1) ?
3. Bitte starte das Programm neu und  wenn Zeichnung1 offen ist, schau in das Textfenster[F2]
   3a.Ist es "noch" so wie von dir beschrieben (also die "lange" Rückgabe)?
   3b.Falls die Rückgabe KURZ wie gewünscht war: Öffne die nächste Datei (während derselben Programmsitzung), wie ist es dort? [F2]

Jetzt mal zu deinen Anhängen, lasse uns diese eine Zeile einmal übersetzen - auch wenn dies nur die halbe Lösung ist.

>>(if (/= (getvar "cmdecho") 1) (setvar "cmdecho" 0))

ander formatiert:
(if = WENN nachfolgender Ausdruck WAHR ist:
(/= (getvar "cmdecho") 1) = "Der Wert von CMDECHO ist nicht 1" (wobei 1 = eingeschaltet bedeutet, es wird also geprüft ob CMDECHO AUSgeschaltet ist - was es aber an der Stelle NIE ist)
(setvar "cmdecho" 0) = DANN stelle cmdecho aus - was aber nie ausgeführt wird, weil (/= (getvar "cmdecho") 1) nie zutrifft.
)

Fazit: Du stellst CMDECHO überhaupt nicht aus!

Was sinnvoll wäre, wäre dies:
(if (/= (getvar "cmdecho") 0) (setvar "cmdecho" 0))  => Wenn es nicht aus ist, stelle es aus.

Aber das abfragen kann man sich sparen, man kann ja einfach ausschalten, egal wie der aktuelle Wert ist!
also:
; (if (/= (getvar "cmdecho") 1) (setvar "cmdecho" 0))
(setvar "cmdecho" 0)


ABER!
cmdecho=0 bedeutet KEINE Rückgabe! (falls du das noch besser findest: Bitteschön, aber lasse es zunächst so falsch und lasse uns das erst zu Ende bringen, darauf bestehe ich)
Bei dir gab es aber eine Rückgabe, ich hatte es nur nicht richtig verstanden!
Dies hatte ich nicht als Rückgabe interpretiert, sondern als Info darüber was getan wird
"_LAYER Ma 0-Hilfslinien FArbe 1 Ltyp LStõrke 0.090000000000000 Plot Kein"

Jetzt dachte ich die Lösung zu haben: Du schaltest CMDECHO nicht aus, hast aber NOMUTT eingeschaltet,
Genau dann sieht die Eingabe nämlich eigentlich so aus, was aber nicht der Fall ist  


Ich habe hier "bestimmt" schon die richtige Antwort parat,
dafür hätte ich gerne die Antworten zu 1) 2) 3) a und b
bevor ich verzweifle oder dir die letzte Rückfrage stelle vor der Lösung.

 

War spannend  

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 21036
Registriert: 03.06.2002

Alles

erstellt am: 21. Jan. 2022 01:28    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bauvermesser 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Bauvermesser:
Die Installation wurde allerdings nur als ADMIN getätigt und kein weiterer Nutzer angelegt, da der alte Rechner nicht am Netz hängt.
Könnte da der Fehler liegen das ACAD einen extra Nutzer voraussetzt?
Nein, das ist so in Ordnung

Die EXPRESS Tools wurden von der Seite www.cadwiesel heruntergeladen und müssten??? eigentlich für 2005 die richtigen
(ET2K5dt.zip) und (et2005bonus.zip) sein. Ich denke, das diese für ACAD2005 noch aktuelle sind.
Das sind die richtigen Dateien, aber nur die deutsch-Übersetzen. Also wie in der Anleitung: Expresstools von Adesk-CD installieren,
den Expresstools Ordner einmal als Backup zippen/kopieren und dann den Ordnerinhalt mit den Dateien aus den beiden Zip überschreiben

(kann diese als zip nicht anhängen)
Das sollte funktionieren, aber mache es bitte nicht. Ein Link zur Quelle wäre ausreichend und fairer - für den Thread hier aber komplett egal.

Übrigens: Auch MOVEBAK wurde übersetzt und ist in der ET2K5dt.zip enthalten, der Befehl würde also laufen wenn alles ordentlich eingerichtet wäre


 

3. Der Befehl Moveback ist in den Express Tools vorhanden wird aber nicht erkannt,
auch nicht, wenn ich die moveback.lsp in die Oberfläche ziehe kommt "Befehl nicht erkannt".
Läuft moveback nur mit den Deutschen express Tools?

Eigentlich mit den Englischen lol, aber ich möchte das nicht weiter erklären - also nach Anleitung:
Deutsche Installation mit Expresstools, dann die Dateien mit dem Inhalt aus den beiden Zip überschreiben
usw. siehe Info in der Zip

4. ist die ET2K5dt.zip die richtige letzt gültige für 2005.
Beide genannte zip! Ja, das passt.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 21036
Registriert: 03.06.2002

Alles

erstellt am: 21. Jan. 2022 02:00    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bauvermesser 10 Unities + Antwort hilfreich

Zitat:
2. Die Sicherungsdateien welche während des arbeiten's angelegt werden

Ich frage jetzt noch einmal ganz direkt (auch wenn es sich ggf. merkwürdig anhören mag)
um das so schnell wie möglich zu lösen:

a. Öffnen eine Datei (falls dazu eine *.bak vorhanden ist in dem Ordner - benenne diese um)
  und mach >was auch immer<, speichere aber NIE bis die automatische Sicherung durchgeführt wurde.
  Frage: Hast du jetzt eine .bak dazu in dem Ordner der Zeichnungsdatei?

b. Movebak ist imo nur für "händische Speicherungen", also wenn du KSICH machst und Acad dabei eine .bak erstellt

.bak Dateien durch automatische Sicherungen dürfte es nur geben wenn man nicht im nativen Format arbeitet,
aber dann werden diese nicht im Zeichnungsordner erstellt.

>>"2. Die Sicherungsdateien welche während des arbeiten's angelegt werden, werden auf meinen vorgeschriebenen Pfad gesichert(*.sc$ "
*.sv$ meinst du? Das sollte auch so sein, genau.

[i] und *.dwl).
.dwl ?? Wow, die sollten eigentlich im Zeichnungsordner landen - nur dort machen diese auch Sinn.

Ich denke entweder bin ich zu lange raus aus der 2005er Zeit, um mich an so kleine Details möglicher Änderungen
der Versionen erinnern zu können, oder ich habe ein Brett vorm Kopf.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 21036
Registriert: 03.06.2002

Alles

erstellt am: 21. Jan. 2022 02:12    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bauvermesser 10 Unities + Antwort hilfreich

1. Warum werden in den Button keine deutschen Befehle mehr erkannt
hatte ich das zuvor überlesen?

hängt dies mit der acad.mnu oder mns zusammmen.
Nein, die deutschen Programmdateien und zumindest heute teilweise auch: Sauber Registry-Einträge
Zuviel jetzt zum erklären <Blick auf die Uhr>


(VonLayer, Ein,Aus; frieren, tauen ec..)
Bitte noch einmal von vorne, was geht wann nicht und welche Meldung kommt etc.?

Befehl: LINIE funktioniert nicht? Unbekannter Befehl?
Sorry, kann gerade nicht folgen - wovon redest du?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2022 CAD.de | Impressum | Datenschutz