Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  PTC Creo Allgemein
  Probleme mit STP aus Creo

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Probleme mit STP aus Creo (304 mal gelesen)
Cliff
Mitglied



Sehen Sie sich das Profil von Cliff an!   Senden Sie eine Private Message an Cliff  Schreiben Sie einen Gästebucheintrag für Cliff

Beiträge: 75
Registriert: 03.06.2013

V5R19, Win7 64bit,

erstellt am: 09. Okt. 2019 15:00    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


AuszugStucklistePodestanlage2.pdf

 
Hallo zusammen,
von einem Kunden haben wir eine STP erhalten, die mit Creo erstellt wurde. Wenn wir diese öffnen und in Catia oder Solid Edge einlesen, werden gleiche Teile mit unterschiedlichem Namen dargestellt. Der Namensunterschied resultiert aus einem Zusatz, der an den vom Konstrukteur vergebenen Namen automatisch angehängt wurde. Es handelt sich um diverse Zusätze á la .01.01.02.01.01 oder 2.1.3.01_1
Diese Namenszusätze sind m.E. bereits so in der STP drin, da sie sowohl bei Catia als auch bei SE auftreten. Sieht man auch während des Einlesens (da wo die Dateinamen so schnell durchlaufen und ein blauer Balken wächst - Catia).

Hier habe ich was gelesen, daß Creo evtl. bei Teilen die nicht fixiert sind diese Zusätze macht:
http://ww3.cad.de/foren/ubb/Forum581/HTML/001452.shtml#000000

Im Anhang habe ich einen Auszug aus einer von mir erstellten und farbig gekennzeichneten Stückliste, in der das Problem deutlich wird. Wir können mit so einer Stückliste nicht mit Bestimmtheit sagen, welche Teile jetzt wirklich gleich und welche verschieden sind. Die gesamte Baugruppe ist leider zu groß, um hier "zu Fuß" die Gleichteile zu bestimmen.

Kennt jemand von Euch diese Problematik? Kann man über die Exporteinstellungen bei Creo hier eingreifen?
Ich selber hab kein Creo und auch keine Erfahrung damit...

Danke für Tipps!
Cliff

------------------
Frei nach Pippi Langstrumpf: Widdewiddewitt - ich mach mir die Welt, wie sie mir gefällt!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ibgross
Mitglied
freiberuflicher Ingenieur


Sehen Sie sich das Profil von ibgross an!   Senden Sie eine Private Message an ibgross  Schreiben Sie einen Gästebucheintrag für ibgross

Beiträge: 55
Registriert: 04.04.2013

CAD 2D: Autocad
CAD 3D: Pro/E, Creo/Parametrics
FEM: Pro/M Structure, Creo/Simulate
MKS: Pro/M Motion, Creo/ASE

erstellt am: 09. Okt. 2019 19:04    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Cliff 10 Unities + Antwort hilfreich

Hallo Cliff;

ich würde in die Stückliste das Bauteilgewicht aufnehmen.
Das könnte einen Anhalt für identische Teile liefern.

Wenn eigentlich gleiche Teile mit marginal unterschiedlichem Gewicht auftauchen, tippe ich auf Baugruppen-Features in Creo, die dann beim Import mit den Anhängen versehen werden.

Das hilft dir jetzt nicht wirklich weiter, aber wenn hier das Problem liegen sollte, könntest du den Kunden bitten einen erneuten Export mit unterdrückten Baugruppen-KE's durchzuführen.

Beste Grüße
Michael

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Cliff
Mitglied



Sehen Sie sich das Profil von Cliff an!   Senden Sie eine Private Message an Cliff  Schreiben Sie einen Gästebucheintrag für Cliff

Beiträge: 75
Registriert: 03.06.2013

erstellt am: 09. Okt. 2019 23:41    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Michael,

danke für den Tipp!
Das ist schon mal ein Lösungsansatz, wie ich die Klippe umschiffen kann. Wenngleich ich kein Freund von "Problem nicht an der Wurzel packen" bin.
Hab mit dem Konstrukteur noch was probiert und eine evtl. Ursache gefunden:
Er hat bei Geländerelementen mit 5 gleiche Geländerpfosten den ersten und letzten anders eingefärbt, damit er Stöße in dem sehr langen Gesamtgeländer erkennen kann. Das führt dazu, daß von diesem Geländerelement 2 einen anderen "Code" verpaßt bekommen als die 3 anderen. Entsprechend erscheinen sie bei mir als 2+3 Geländerpfosten.
Anschließend hat er die Farbe wieder gleich gemacht, der Fehler blieb allerdings. Ob durch das Angleichen der Farbe die Teile für Creo jedoch gleich sind weiß ich nicht. Sicher wäre es gewesen, er hätte schnell mal ein neues Geländerelement zusammengebaut und dann gesteppt.

Evtl. kann ich meine Excel-Stückliste etwas mißbrauchen, so daß ich nur die ersten paar Buchstaben oder so erfaße und dann die Teile zählen lasse.

Mal sehn...

Grüße!

------------------
Frei nach Pippi Langstrumpf: Widdewiddewitt - ich mach mir die Welt, wie sie mir gefällt!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

U_Suess
Moderator
CAD-Admin / manchmal Konstrukteur




Sehen Sie sich das Profil von U_Suess an!   Senden Sie eine Private Message an U_Suess  Schreiben Sie einen Gästebucheintrag für U_Suess

Beiträge: 10261
Registriert: 14.11.2001

CREO 4 M100 (+SUT 2018 M020)
PDMLink 11.0 M030
NVIDIA Quadro 2000
Intel Core i7-2700K / 32GB RAM
Win 7 Prof. 64Bit

erstellt am: 10. Okt. 2019 09:36    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Cliff 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Cliff:
... Anschließend hat er die Farbe wieder gleich gemacht, der Fehler blieb allerdings. Ob durch das Angleichen der Farbe die Teile für Creo jedoch gleich sind weiß ich nicht. Sicher wäre es gewesen, er hätte schnell mal ein neues Geländerelement zusammengebaut und dann gesteppt. ...
Das Aussehen kann man auf verschiedene Arten ändern. Vielleicht wurden die Komponenten nur mit der ursprünglichen Farbe wieder übermalt und vorher hat man vielleicht die Flächen eingefärbt. Könnte mir vorstellen, dass Creo diese Information weitergeben möchte.

------------------
Gruß
Udo              Keine Panik, Du arbeitest mit CREO (ehemals Pro/E)! Und Du hast cad.de gefunden!

Neu hier?     Verwundert über die Antworten?    Dann schnell nachfolgende Links durchlesen. 
Richtig FragenNettiquetteSuchfunktionSystem-InfoPro/E-Konfig7er-Regel      • Unities

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Cliff
Mitglied



Sehen Sie sich das Profil von Cliff an!   Senden Sie eine Private Message an Cliff  Schreiben Sie einen Gästebucheintrag für Cliff

Beiträge: 75
Registriert: 03.06.2013

erstellt am: 10. Okt. 2019 19:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Udo,

ja, so denk ich mir das auch. Vllt kann ich den Konstrukteur zu einem neuen Test bewegen...

Schöne Grüße und Danke

------------------
Frei nach Pippi Langstrumpf: Widdewiddewitt - ich mach mir die Welt, wie sie mir gefällt!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ffabian1
Mitglied
Industriedesigner


Sehen Sie sich das Profil von ffabian1 an!   Senden Sie eine Private Message an ffabian1  Schreiben Sie einen Gästebucheintrag für ffabian1

Beiträge: 776
Registriert: 21.10.2002

HP ZBook17, i7-4800MQ,
16GB,256GB SSD + 1TB HDD, Quadro K3100M,
Win 7/64bit
ProE WF2 bis CREO3 (Commercial)
SUT 2016
KeyShot + Network Rendering
SWX 2010-2014
ACAD 2007
und: HIRN 43.3
sowie: GLÜCK 52/15/12

erstellt am: 10. Okt. 2019 20:33    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Cliff 10 Unities + Antwort hilfreich

Servus Cliff,

ich glaube es gibt eine Config-Option in Creo, die genau diese "willkürliche" Namenserweiterung beim Export unterbindet.
Muss ich morgen mal nach suchen - grade kein Creo zur Hand...

Gleiche Teile, die in der Baugruppe jedoch unterschiedlich eingefärbt sind, bekommen aber wohl schon unterschiedliche Namen verpasst.
Es sei denn, man unterbindet die Ausgabe farbiger STEP-Files.
Dazu gibt es eine ganze Reihe Optionen - ich habe lange danach gesucht, meine STEPs MIT Farben ausgeben zu können;-)

Des weiteren kommt es auch auf die STEP-Variante (AP203 vs. AP214) an. Auch hier liegen unterschiedliche Standards zugrunde, die sich sicherlich lohnen auszuprobieren.

Ich schaue morgen mal nach, was ich finden kann.
Grüße!

Felix

------------------
-->   X   <-- Hier Bohren für neuen Monitor

Richtig Fragen -
Netiquette -
Suchfunktion -
Sysinfo


Fabian Industrie-Design

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

arni1
Ehrenmitglied V.I.P. h.c.



Sehen Sie sich das Profil von arni1 an!   Senden Sie eine Private Message an arni1  Schreiben Sie einen Gästebucheintrag für arni1

Beiträge: 3580
Registriert: 17.12.2002

Pro/E seit Version 11
Creo3 M150 produktiv
Creo5 testen
HP Z210
Intel Xeon 3.3GHz; 20 GB RAM
NVIDIA Quadro 2000
HP ZR30w
Win10 64bit

erstellt am: 11. Okt. 2019 07:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Cliff 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von ffabian1:

ich glaube es gibt eine Config-Option in Creo, die genau diese "willkürliche" Namenserweiterung beim Export unterbindet.

Ich vermute diese Option:
export_3D_force_default_naming yes
Standard ist no

Gruß
Arni

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Cliff
Mitglied



Sehen Sie sich das Profil von Cliff an!   Senden Sie eine Private Message an Cliff  Schreiben Sie einen Gästebucheintrag für Cliff

Beiträge: 75
Registriert: 03.06.2013

erstellt am: 11. Okt. 2019 11:02    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Guten Morgen die Herren,

vielen Dank für die Tipps.
Ähnliches bzgl. Config vermute ich auch, bin aber leider überhaupt nicht firm mit Creo um hier mitreden zu können.

AP203 und AP2014 haben wir probiert. In der 14er Version ist die Datei bei mir schön farbig, in der 03er nur grau. Der Zirkus der Namensgebung ist aber in 03 das gleiche.
Würde jetzt in mein Verständnis passen, daß in der 03er Version zwar die Farben unterbunden sind, jedoch Creo die Ursprungsinfo, DASS eine unterschiedliche Färbung vorliegt, weitergibt.

Wie die beschriebene Config-Option eingegeben werden kann weiß ich nicht, werde aber den Konstrukteur drauf ansprechen. (Ist auch die gleiche Config wie aus dem Link meines ersten Beitrags...)

Grüße
Cliff

------------------
Frei nach Pippi Langstrumpf: Widdewiddewitt - ich mach mir die Welt, wie sie mir gefällt!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz