Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  PTC Creo Allgemein
  Ladeoptionen

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Ladeoptionen (636 mal gelesen)
ugsol32
Mitglied


Sehen Sie sich das Profil von ugsol32 an!   Senden Sie eine Private Message an ugsol32  Schreiben Sie einen Gästebucheintrag für ugsol32

Beiträge: 5
Registriert: 09.02.2017

erstellt am: 09. Feb. 2017 12:36    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Zusammen,

ich habe folgende/s  Frage / Problem.
Ich habe in verschiedenen Files, nennen wir sie Teil A und Teil B , am Anfang eine Externe Kopie Geom, die aus einem bestimmten
Elternteil eine Publizierte Geometrie lädt.
Nun ist es so das beim Aufruf von Teil A das Elternteil automatisch mit in den Speicher geladen wird, beim Aufruf von Teil B aber nicht.

Ich möchte grundsätzlich das Elternteil NICHT automatisch mit laden und hab daher in der Config.pro den
Schalter "retrieve_data_sharing_ref_parts" auf no gesetzt.

Hat aber leider nichts gebracht.......

Jemand ne Idee an welcher Stelle ich auf dem Schlauch stehe ?


Vielen Dank schon mal für eure Hilfe

Ach so, bin neu im Forum und arbeite mit Creo 2

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

U_Suess
Moderator
CAD-Admin / manchmal Konstrukteur




Sehen Sie sich das Profil von U_Suess an!   Senden Sie eine Private Message an U_Suess  Schreiben Sie einen Gästebucheintrag für U_Suess

Beiträge: 10249
Registriert: 14.11.2001

CREO 4 M080 (+SUT 2018 M020)
PDMLink 11.0 M030
NVIDIA Quadro 2000
Intel Core i7-2700K / 32GB RAM
Win 7 Prof. 64Bit

erstellt am: 09. Feb. 2017 12:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für ugsol32 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von ugsol32:
... Nun ist es so das beim Aufruf von Teil A das Elternteil automatisch mit in den Speicher geladen wird, beim Aufruf von Teil B aber nicht. ...
Dann würde ich jetzt einfach mal die Vermutung äußern, dass im Teil A keine externe Kopiegeometrie vorhanden ist. Das scheint dann wohl nur eine Kopiegeometrie zu sein.

------------------
Gruß
Udo              Keine Panik, Du arbeitest mit CREO (ehemals Pro/E)! Und Du hast cad.de gefunden!

Neu hier?     Verwundert über die Antworten?    Dann schnell nachfolgende Links durchlesen. 
Richtig FragenNettiquetteSuchfunktionSystem-InfoPro/E-Konfig7er-Regel      • Unities

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ugsol32
Mitglied


Sehen Sie sich das Profil von ugsol32 an!   Senden Sie eine Private Message an ugsol32  Schreiben Sie einen Gästebucheintrag für ugsol32

Beiträge: 5
Registriert: 09.02.2017

erstellt am: 09. Feb. 2017 13:02    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo und Danke für die schnelle Rückmeldung.

Aber es ist so das in Teil A+B jeweils diese Info zu finden ist wenn ich auf KE Info gehe:  "KE REFERENZIERT MODELL 11610-MARKEN-REF_KOMBI EXTERN "

Und dieses Elternteil wird bei Teil A geladen, bei Teil B nicht.

Grüße

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

arni1
Ehrenmitglied V.I.P. h.c.



Sehen Sie sich das Profil von arni1 an!   Senden Sie eine Private Message an arni1  Schreiben Sie einen Gästebucheintrag für arni1

Beiträge: 3556
Registriert: 17.12.2002

Pro/E seit Version 11
Creo3 M140 produktiv
Creo4 M040 zum Spielen
HP Z210
Intel Xeon 3.3GHz; 20 GB RAM
NVIDIA Quadro 2000
HP ZR30w
Win10 64bit

erstellt am: 09. Feb. 2017 13:20    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für ugsol32 10 Unities + Antwort hilfreich

Zeigt #Info #Referenzviewer #Abhängigkeiten #Info #Referenz
irgend einen Unterschied bei den zwei Modellen?

Gruß
Arni

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ugsol32
Mitglied


Sehen Sie sich das Profil von ugsol32 an!   Senden Sie eine Private Message an ugsol32  Schreiben Sie einen Gästebucheintrag für ugsol32

Beiträge: 5
Registriert: 09.02.2017

erstellt am: 09. Feb. 2017 13:38    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Arni,

ist bis auch die Unterschiedlichen Dateinamen von Teil A+B ist alles identisch.
Eine Zeile weicht ab bei Teil B, dort steht Warnung: Das referenzierte Modell befindet sich nicht in der Sitzung.

Aber das ist ja bekannt, so möchte ich es ja auch bei Teil A lesen können.

Aber danke für den Hinweis, mit dem Referenzviewer muß ich mich demnächst mal intensiver beschäftigen.

Grüße
Hartmut

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ugsol32
Mitglied


Sehen Sie sich das Profil von ugsol32 an!   Senden Sie eine Private Message an ugsol32  Schreiben Sie einen Gästebucheintrag für ugsol32

Beiträge: 5
Registriert: 09.02.2017

erstellt am: 16. Feb. 2017 12:15    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo nochmal,

habe jetzt heraus gefunden mit was dieses automatisch laden zusammenhängt.
Nochmal zur Erklärung.
In einem Teil , nennen wir es Basis Part, erzeuge ich z.B. Planes, Achsen, Ebenen, Koordinatensysteme, Kurven etc.
Teilweise werden diese noch gemustert usw. Dann erzeuge ich wenn benötigt, von z.B. einem gemusterten Ksys
eine Publizierte Geometrie, welche ich dann auch Mustere.
Nun hole ich mir in eine neues Teil A, die Publizierte Geometrie aus dem Basis Part, hier im Beispiel das gemusterte Ksys,
welches ich dann auch Mustere.
Gleiches mache ich bei Teil B mit dem Unterschied, dass ich hier nur die Publizierte Geometrie hole, aber diese nicht Mustere.

Wenn ich nun die Teile neu lade, wird beim aufrufen von Teil A das Basis Part mit geladen, beim aufrufen von Teil B
aber nicht. Das heißt es liegt daran das Teil A die Info aus dem Basis Part benötigt um die Muster Funktion auszuführen.
Das ist nachvollziehbar, ich würde aber gerne trotzdem entscheiden können ob ich nun das Basis Part im Arbeitsspeicher haben
will oder aber nicht.

Gibt es daher irgendwo die Möglichkeit diesen Aufruf von zugehörigen Teilen zu unterbinden ?

Wie schon beschrieben, der Schalter "retrieve_data_sharing_ref_parts" auf no gesetzt hat nichts gebracht.

Danke schon mal fürs lesen auch wenn vielleicht niemand helfen kann
Grüße
Hartmut

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

frank08
Mitglied
Konstrukteur


Sehen Sie sich das Profil von frank08 an!   Senden Sie eine Private Message an frank08  Schreiben Sie einen Gästebucheintrag für frank08

Beiträge: 1466
Registriert: 22.01.2004

Creo 4.0 M030
Windchill PDMLink 10.2
Windows 7x64, Dell Prec. T7810
NVIDIA Quadro M2000
2.66 GHz, 16 GB RAM
SUT 2017

erstellt am: 16. Feb. 2017 13:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für ugsol32 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von ugsol32:
...

Gibt es daher irgendwo die Möglichkeit diesen Aufruf von zugehörigen Teilen zu unterbinden ?

...


Wenn Du bei der Kopiegeometrie von "Aktiv" auf "Unabhängig" (Reiter "Optionen") umstellst, sollte der Aufruf des Basis Part unterbleiben. Natürlich werden in diesem Status Änderungen im Basis Part nicht automatisch übernommen. Dazu muss man erst wieder auf "Aktiv" zurück stellen.

------------------
Gruß Frank

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ugsol32
Mitglied


Sehen Sie sich das Profil von ugsol32 an!   Senden Sie eine Private Message an ugsol32  Schreiben Sie einen Gästebucheintrag für ugsol32

Beiträge: 5
Registriert: 09.02.2017

erstellt am: 16. Feb. 2017 14:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Zitat:
Original erstellt von frank08:

Wenn Du bei der Kopiegeometrie von "Aktiv" auf "Unabhängig" (Reiter "Optionen") umstellst, sollte der Aufruf des Basis Part unterbleiben. Natürlich werden in diesem Status Änderungen im Basis Part nicht automatisch übernommen. Dazu muss man erst wieder auf "Aktiv" zurück stellen.



Hallo und danke für den Tip,

habe es versucht mit #Ke selektieren #rechte Maus, Definition editieren #Optionen #Haken entfernt bei Abhängig
bestätigt und gespeichert.
Arbeitsspeicher leer gemacht, Datei neu aufgerufen Basis Part immer noch mit geladen......

Trotzdem Danke


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz