Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Rund um AutoCAD
  Renderkontext

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
  
Gut zu wissen: Hilfreiche Tipps und Tricks aus der Praxis prägnant, und auf den Punkt gebracht für Autodesk Produkte
Autor Thema:  Renderkontext (2664 mal gelesen)
Dienstag
Mitglied



Sehen Sie sich das Profil von Dienstag an!   Senden Sie eine Private Message an Dienstag  Schreiben Sie einen Gästebucheintrag für Dienstag

Beiträge: 25
Registriert: 19.01.2012

CPU
intel(R) Core(TM)
i5 3.30GHz<P>Arbeitsspeicher: 8 GB <P>Grafik:
Nvidia Quadro FX580<P>System:
Windows 7 Ultimate<P>Software:
Autocad 2011
Adobe CS4

erstellt am: 20. Jan. 2012 00:01    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Forum,
ich habe noch eine Frage.

Ich will in einer Darstellung gerenderte Gebäudeteile und Strichzeichnung kombinieren:

Ich erstelle ein 2D-Abbild meines 3D-Objektes, richte mir ein Layout ein und drucke ein Vektor-PDF. Ich erhalte eine Strichzeichnung mit Rahmen drumherum. Jetzt möchte ich mein 3D-Objekt rendern. Damit ich beide Zeichnungen später gut überlagern kann, bleibe ich im Layoutbereich, wähle unter Renderkontext als Ziel "Ansichtsfenster", aktiviere das Ansichtsfenster so daß es zu Modellbereich wird, stelle meine gewünschten Pixelmasse ein und rendere. Jetzt habe ich ein gerendertes Bild, das genau an der gleichen Stelle innerhalb des Rahmens sitzt wie die Strichzeichnung.

Problem: Wenn ich das Bild speichere, erhalte ich zwar die gewünschten Proportionen aber nicht die vorher gewählten Pixelmasse. Die Bilder sind viel zu klein. Das passiert beim Renderfenster nicht. Aber da kann ich nicht exakt steuern wo innerhalb des gerenderten Bildes das objekt landet.

Ich hoffe, ich hab mich verständlich ausgedrückt. Und ich hoffe, jemand weiß Rat. Ich sitz schon viel zu lang daran.

Grüße, Dienstag

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Cadzer
Mitglied
Architekt; Dozent


Sehen Sie sich das Profil von Cadzer an!   Senden Sie eine Private Message an Cadzer  Schreiben Sie einen Gästebucheintrag für Cadzer

Beiträge: 41
Registriert: 31.01.2004

aca 2013/2019

erstellt am: 20. Jan. 2012 17:46    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Dienstag 10 Unities + Antwort hilfreich

Servus Dienstag,

nur so ins Unreine: erstelle dein Rendering in der Größe (Pixelmaße), die du für die weitere Arbeit brauchst und die Vektorzeichnung in beliebiger Größe. Beim zusammenfügen skalierst du die Vektorzeichnung (da Vektor, verlustfrei) auf die Größe des Renderings - fertig.

Frohes Schaffen
Jan

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Dienstag
Mitglied



Sehen Sie sich das Profil von Dienstag an!   Senden Sie eine Private Message an Dienstag  Schreiben Sie einen Gästebucheintrag für Dienstag

Beiträge: 25
Registriert: 19.01.2012

CPU
intel(R) Core(TM)
i5 3.30GHz<P>Arbeitsspeicher: 8 GB <P>Grafik:
Nvidia Quadro FX580<P>System:
Windows 7 Ultimate<P>Software:
Autocad 2011
Adobe CS4

erstellt am: 20. Jan. 2012 21:49    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Jan,
klar geht das. Aber dann habe ich ziemlich Mühe beides aneinander auszurichten. Und sie passen auch nie so richtig übereinander. Außerdem habe ich 27 solcher Zeichnungen anzufertigen, da wäre es schön beide zu überlagernden Elemente hätten einen gleichgroßen Rahmen und wären innerhalb dieses Rahmens an der richtigen Stelle, eben ohne hin und herschieben und skalieren und einzelne Linien zurechtzuppeln.

Was ich gerne verstehen würde ist: Ich kann unter erweiterte Rendereinstellungen in der Kategorie Renderkontext zwischen Ansichtsfenster und (Render-)Fenster wählen. Ich kann für beides die gewünschte Größe definieren und das Renderergebnis in einer Datei speichern. Nur das ins Renderfenster gerenderte Bild hat dann auch tatsächlich die eingestellten Pixelmaße. Möglicherweise hat es etwas mit dem Ansichtsfenster selbst zu tun. Keine Ahnung.

Grüsse, Dienstag

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Cadzer
Mitglied
Architekt; Dozent


Sehen Sie sich das Profil von Cadzer an!   Senden Sie eine Private Message an Cadzer  Schreiben Sie einen Gästebucheintrag für Cadzer

Beiträge: 41
Registriert: 31.01.2004

aca 2013/2019

erstellt am: 21. Jan. 2012 11:51    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Dienstag 10 Unities + Antwort hilfreich

Wenn es ohne Nachbearbeitung sein soll, dann würde ich zwei Ansichtsfenster mit identischem Ausschnitt (Stichwort 'Benannte Ansichten') übereinander legen. Schattierungsplot-Einstellungen beim unteren auf 'gerendert', beim oberen auf 'verborgen' und DISPSILH auf 0 setzen.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Dienstag
Mitglied



Sehen Sie sich das Profil von Dienstag an!   Senden Sie eine Private Message an Dienstag  Schreiben Sie einen Gästebucheintrag für Dienstag

Beiträge: 25
Registriert: 19.01.2012

CPU
intel(R) Core(TM)
i5 3.30GHz<P>Arbeitsspeicher: 8 GB <P>Grafik:
Nvidia Quadro FX580<P>System:
Windows 7 Ultimate<P>Software:
Autocad 2011
Adobe CS4

erstellt am: 21. Jan. 2012 18:28    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Du meinst Ansichtsfenster im Layoutbereich? Das ist eben genau mein Problem. Wenn ich ins Ansichtsfenster rendere kriege ich nicht meine gewünschte Pixelanzahl. Ich gebe beispielsweise 4000x4000 Pixel ein und das Ergebnis-tif hat dann nur 543x543.

Rendere ich ins Renderfenster - wo ich die Position des Gerenderten nicht exakt bestimmen kann - kriege ich problemlos die von mir gewählte Pixelzahl.

(DISPSILH steht übrigens auf 0. Brauch ich aber nicht.)

Es gibt noch mehr Schwierigkeiten:
Um einen guten Schatten zu kriegen, brauche ich den Himmel. Der funktioniert offenbar nur im perspektivischen Bereich. Da funktioniert  das 2D-Abbild nicht so gut. Ich muß für die Ansicht eines unverzerrten Ergebnisses in die Draufsicht wechseln....im orthogonalen 3D kann ich das 2D-Abbild bequem am 3D-Modell ausrichten, dann einen Rahmen ziehen, der für beides gilt. Das 3D-Modell rendern und als Ausschnitt den Rahmen festlegen(Hier wieder: Auflösung funktioniert nicht). Das 2D-Abbild als wmf mit Rahmen exportieren. Beides nach Illustrator und nun mit Hilfe der Rahmen ausrichten.

Werde vorläufig aufs rendern verzichten. Über weitere Tipps würd ich mich aber freuen.

Gruß+Dank,
Dienstag

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Cadzer
Mitglied
Architekt; Dozent


Sehen Sie sich das Profil von Cadzer an!   Senden Sie eine Private Message an Cadzer  Schreiben Sie einen Gästebucheintrag für Cadzer

Beiträge: 41
Registriert: 31.01.2004

aca 2013/2019

erstellt am: 21. Jan. 2012 21:34    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Dienstag 10 Unities + Antwort hilfreich

Korrigiere mich, wenn ich falsch liege, aber ich war bisher immer davon ausgegangen, dass die Ausgabegröße in den Rendereinstellungen nur für das Renderfenster von Bedeutung ist.

Mein Vorgehen wäre:
- Layout in der gewünschten Größe erstellen
- 2 deckungsgleiche Ansichtsfenster auf selbigem platzieren
- in beiden Ansichtsfenster die gewünschte benannte Ansicht aktivieren
- Schattierungsplot-Einstellungen wie im vorigen Post beschrieben (DISPSILH wird bei gekrümmten Objekten interessant)
- Layout plotten

Das ganze 2D-Abbild-Gewurschtel entfällt damit.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Dienstag
Mitglied



Sehen Sie sich das Profil von Dienstag an!   Senden Sie eine Private Message an Dienstag  Schreiben Sie einen Gästebucheintrag für Dienstag

Beiträge: 25
Registriert: 19.01.2012

CPU
intel(R) Core(TM)
i5 3.30GHz<P>Arbeitsspeicher: 8 GB <P>Grafik:
Nvidia Quadro FX580<P>System:
Windows 7 Ultimate<P>Software:
Autocad 2011
Adobe CS4

erstellt am: 21. Jan. 2012 22:32    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Renderfenster
In den erweiterten Rendervoreinstellungen gibt es gleich ganz oben unter "Allgemein" die Kategorie Render-Kontext. Da kann man wählen was wohin gerendert werden soll und die Auflösung festlegen. Das Menü zumindest erweckt den Eindruck, man könnte auch in ein Ansichtsfenster eines Layouts rendern. Das geht auch prima. Nur das gesichterte Ergebnis hat eben zu wenig Pixel.

Die vorgeschlagene Vorgehensweise
von Dir hab ich jetzt ausprobiert. Gebe ich unter Schattierungs-Plot "gerendert" ein und plotte, passiert ewig gar nichts und dann stürzt das Programm ab oder es geht ganz schnell und es wird lediglich der Ansichtsfenster-Rahmen gedruckt. Ich kannte diese Option nicht. Ist das dann richtig gerendert oder mehr als-ob-gerendert...wenn es nicht gerade wie bei mir abstürzt?

2D-Abbild-Gewurstel
ist für mich die zuverlässigste Methode präzise 2D-Vektor-Zeichnungen von 3D-Objekten zu kriegen. Beim Drucken mit Schattierungs-Plot-Option "Alt verborgen" - was die einzig funktionierende Möglichkeit ist Vektoren mit verdeckten Linien von 3D-Objekten auszudrucken - werden bei mir ziemlich oft Linien verschluckt.

Gruß
Dienstag

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Cadzer
Mitglied
Architekt; Dozent


Sehen Sie sich das Profil von Cadzer an!   Senden Sie eine Private Message an Cadzer  Schreiben Sie einen Gästebucheintrag für Cadzer

Beiträge: 41
Registriert: 31.01.2004

aca 2013/2019

erstellt am: 22. Jan. 2012 11:57    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Dienstag 10 Unities + Antwort hilfreich


renderbeispiel.jpg

 
Wo du die Ausgabegröße und das Ziel einstellst ist mir schon klar. Meiner Meinung nach hängt die Größe beim rendern ins Ansichtsfenster aber einzig und allein von der des Ansichtsfenster ab. Also musst du zusehen, dass du das Ansichtsfenster auf die gewünschte Größe bekommst.

Dass der Plot mit gerendertem Ansichtsfenster länger dauert ist schon richtig … es muss ja schließlich das Rendering (ja, das ist ein richtiges Rendering) erstellt werden. Alternativ würde es vermutlich auch funktionieren, wenn du das Rendering im AF erstellst und bei den Plotoptionen auf 'wie angezeigt' stellst. Spart in der Summe aber keine Zeit.

Verschluckte Linien beim verdeckt plotten sind mir noch nie untergekommen, kann ich also nichts zu sagen.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Dienstag
Mitglied



Sehen Sie sich das Profil von Dienstag an!   Senden Sie eine Private Message an Dienstag  Schreiben Sie einen Gästebucheintrag für Dienstag

Beiträge: 25
Registriert: 19.01.2012

CPU
intel(R) Core(TM)
i5 3.30GHz<P>Arbeitsspeicher: 8 GB <P>Grafik:
Nvidia Quadro FX580<P>System:
Windows 7 Ultimate<P>Software:
Autocad 2011
Adobe CS4

erstellt am: 23. Jan. 2012 15:50    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Wo du die Ausgabegröße und das Ziel einstellst ist mir schon klar.

> Ich arbeite mich gerade erst ein. Da ist das für mich halt eine Entdeckung.

Meiner Meinung nach hängt die Größe beim rendern ins Ansichtsfenster aber einzig und allein von der des Ansichtsfenster ab. Also musst du zusehen, dass du das Ansichtsfenster auf die gewünschte Größe bekommst.

> Das funktioniert jetzt dank Deines Hinweises (siehe unten). Ein A3-Render-Plot hat dann z.B. 9925x7016.5 Pixel. Mein System scheint aber mit dem Rechnen eines solchen Plots überfordert zu sein. Das Programm stürzt meist sofort ab.

Dass der Plot mit gerendertem Ansichtsfenster länger dauert ist schon richtig … es muss ja schließlich das Rendering (ja, das ist ein richtiges Rendering) erstellt werden. Alternativ würde es vermutlich auch funktionieren, wenn du das Rendering im AF erstellst und bei den Plotoptionen auf 'wie angezeigt' stellst. Spart in der Summe aber keine Zeit.

> Vielen Dank für den Hinweis, dass man rendern als Schattierungs-plot-Option einstellen kann. Ist genau, was ich suche!!
Was bei mir noch nicht klappt, ist ein brauchbarer Schatten. Der Schatten wird komplett schwarz, unabhängig von den gewählten Renderoptionen....die im Renderfenster brauchbare Schatten erzeugen.
So einen Schatten wie in Deinem Beispiel, krieg ich nicht hin.

Verschluckte Linien beim verdeckt plotten sind mir noch nie untergekommen, kann ich also nichts zu sagen.

> Das ist ein echtes Problem. Ich hatte es in Autocad 2010 und hab es auch jetzt. Sobald ich irgendeine Druckoption mit verborgenen Linien wähle, kommt nur Murks heraus. Es werden Teile des Modells gar nicht gedruckt und/oder Linien, die verborgen sein sollten werden mitgedruckt. 


> Vielen Dank für Deine Hinweise! Ich bin schon ein Stück weiter mit meinem Darstellungsproblem.


Gruß,
Dienstag

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Cadzer
Mitglied
Architekt; Dozent


Sehen Sie sich das Profil von Cadzer an!   Senden Sie eine Private Message an Cadzer  Schreiben Sie einen Gästebucheintrag für Cadzer

Beiträge: 41
Registriert: 31.01.2004

aca 2013/2019

erstellt am: 28. Jan. 2012 11:31    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Dienstag 10 Unities + Antwort hilfreich

Dann versuch ich mal noch zwei Hinweise zu geben, die vielleicht helfen:

Rendergröße
Brauchst du das Rendering wirklich so groß - was soll damit am Ende passieren? Deine ca. 10000 auf 7000 Pixel sind halt schon ne Hausnummer.

Schatten
Einstellungen zu Sonne/Himmel/Schatten sind pro Ansichtsfenster zu setzen. Ich vermute mal, dass du im gerenderten Ansichtsfenster den Himmel ausgeschaltet hast.

'verschluckte' Linien
Sind mir wie gesagt bisher nicht untergekommen, kannst aber gerne mal eine betroffene Datei zum testen hier anhängen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Dienstag
Mitglied



Sehen Sie sich das Profil von Dienstag an!   Senden Sie eine Private Message an Dienstag  Schreiben Sie einen Gästebucheintrag für Dienstag

Beiträge: 25
Registriert: 19.01.2012

CPU
intel(R) Core(TM)
i5 3.30GHz<P>Arbeitsspeicher: 8 GB <P>Grafik:
Nvidia Quadro FX580<P>System:
Windows 7 Ultimate<P>Software:
Autocad 2011
Adobe CS4

erstellt am: 28. Jan. 2012 17:21    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Ha!!!-

Als ich die Datei zum Anhängen abgespeckt hatte, habe ich noch mal drucken mit "alt verborgen" und drucken mit rendern ausprobiert.....und alles hat geklappt. Alle Linien waren, wo sie sein sollen und auch das Rendering mit schönem Schatten und 4825x3089 pixeln.

Die Datei mit der es gar nicht ging war 6 MB groß, nach dem Abspecken war sie 2 MB groß und dann ging es.

Vielen Dank für Deine Hinweise!!!!


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2023 CAD.de | Impressum | Datenschutz