Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Rund um AutoCAD
  Text sieht ausgefranst aus

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Text sieht ausgefranst aus (929 mal gelesen)
oberh
Mitglied



Sehen Sie sich das Profil von oberh an!   Senden Sie eine Private Message an oberh  Schreiben Sie einen Gästebucheintrag für oberh

Beiträge: 19
Registriert: 12.10.2006

MS Windows XP, SP 3 Built 2600
X86 PC 2800 Mhz, AM Bios 080015
3 GB RAM; ATI Radeon HD 4350
AutoCad Civil 3D 2011

erstellt am: 12. Okt. 2006 12:38    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallöchen!

Ich arbeite mit AutoCad LT 2004.
Aus einem ALK-GIAP Verfahren wurde ein DXF-File erstellt.
Zwei Texte mit den gleichen Eigenschaften sehen unterschiedlich aus.
Der Eine wird korrekt dargestellt, der Andere ausgefranst.
Ich habe hier im Forum einen Tip gefunden, der besagt, dass man bei dem fehlerhaft dargestellten Text den Z-Wert erst auf 1 und dann wieder zurück auf 0 stellen soll. Tatsächlich korrigiert sich dann das Aussehen.
Wenn ich mir aber die Eigenschaften der Texte im DXF-File anschaue:

Zitat:
TEXT
  8
001
62
    7
10
2576294.0333
20
5653206.6000
40
  1.2500
  1
4721
  7
STANDARD
  0

TEXT
  8
001
62
    7
10
2576291.0333
20
5653222.9000
40
  1.2500
  1
4722
  7
STANDARD
  0


dann sind doch alle, bis auf den Textinhalt identisch !?!

Woran kann das liegen, dass Autocad einmal z als 0 einliest, und beim zweiten Text z als "gegen" 0 einstellt?

Danke im Voraus
Olaf

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

j-sc
Ehrenmitglied



Sehen Sie sich das Profil von j-sc an!   Senden Sie eine Private Message an j-sc  Schreiben Sie einen Gästebucheintrag für j-sc

Beiträge: 1824
Registriert: 14.07.2003

W7 64Bit
intel core I7 2,8GHz / 4GB
ATI FIRE PRO V5800
acad2011
acad2015
acad2018
Athena
Expresstools

erstellt am: 12. Okt. 2006 15:11    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für oberh 10 Unities + Antwort hilfreich

Umso erstaunlicher, da die Z-Koordinate hier in dem Textbesispiel gar nicht dabei ist (DXF Gruppencode 30). Vielleicht wird da an anderen Stellen mit -> ELEVATION rumgespielt, oder Skalierfaktoren - oder der Rundung/Genauigkeit oder ... es hat damit gar nix zu tun sondern mit dem Textbreitenfaktor oder der Variable TEXTQLTY.

------------------
Ciao
J-SC
  ... geht's vielleicht doch?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

oberh
Mitglied



Sehen Sie sich das Profil von oberh an!   Senden Sie eine Private Message an oberh  Schreiben Sie einen Gästebucheintrag für oberh

Beiträge: 19
Registriert: 12.10.2006

erstellt am: 13. Okt. 2006 08:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


002424.zip

 
Hi!

Danke erst einmal für Deine Antwort.
Da der DXF Gruppencode 30 fehlt, sollte dann nicht standartmäßig 0 für z vergeben werden?
Wie bereits beschrieben erhalten einige Texte für z 0, andere eben einen Wert nahe 0.
ELEVATION hat in der Zeichnung den Wert 0.00.
TEXTQLTY hat 50, wirkt sich aber doch auf alle Texte aus.
Auch Deine anderen Vorschläge habe ich überprüft und komme doch zu keinem Ergebnis.
Ich hänge mal die DXF-Datei an. Vielleicht findet darin jemand eine fehlerhafte Einstellung.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Treppenflätz
Mitglied
Tischler / CAD-Zeichner / Fassadenkonstrukteur


Sehen Sie sich das Profil von Treppenflätz an!   Senden Sie eine Private Message an Treppenflätz  Schreiben Sie einen Gästebucheintrag für Treppenflätz

Beiträge: 93
Registriert: 07.07.2005

WinXP SP2; MAXDATA Pentium 4 mit 2GB RAM;
ACAD 2007 und AutoSTRUCTURE-Konstruktionserweiterung, Drucker HP CP1700 und HP Designjet 430

erstellt am: 13. Okt. 2006 08:48    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für oberh 10 Unities + Antwort hilfreich

Hallo Olaf!
sag mal, tritt der Fehler beim Layer 051_txt auf? Hab mir die Eigenschaften ALLER Objekte auf den 3 Text-Layern grad mal anschauen wollen und bei diesem Layer war zumindest ein Unterschied festzustellen (052 und 053 wurden mit allen Eigenschaften Angezeigt nur bei 051 klappt das nit) Was jetzt allerdings der Unterschied zwischen den Elementen auf Layer52/53 und denen auf 51 ist, hab ich noch nit gefunden....

Gruß
Thomas   

------------------
Hinzufallen ist weder ein Unglück noch eine Schande. Liegenbleiben aber beides!

[Diese Nachricht wurde von Treppenflätz am 13. Okt. 2006 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

j-sc
Ehrenmitglied



Sehen Sie sich das Profil von j-sc an!   Senden Sie eine Private Message an j-sc  Schreiben Sie einen Gästebucheintrag für j-sc

Beiträge: 1824
Registriert: 14.07.2003

W7 64Bit
intel core I7 2,8GHz / 4GB
ATI FIRE PRO V5800
acad2011
acad2015
acad2018
Athena
Expresstools

erstellt am: 13. Okt. 2006 10:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für oberh 10 Unities + Antwort hilfreich

high,
wie wäre es, wenn du dem textstil standard einfach 'nen shx-font zuordnest und keinen truetype ?

------------------
Ciao
J-SC
  ... geht's vielleicht doch?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

j-sc
Ehrenmitglied



Sehen Sie sich das Profil von j-sc an!   Senden Sie eine Private Message an j-sc  Schreiben Sie einen Gästebucheintrag für j-sc

Beiträge: 1824
Registriert: 14.07.2003

W7 64Bit
intel core I7 2,8GHz / 4GB
ATI FIRE PRO V5800
acad2011
acad2015
acad2018
Athena
Expresstools

erstellt am: 13. Okt. 2006 10:10    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für oberh 10 Unities + Antwort hilfreich

High, an der dxf-Datei liegt's definitv nicht - ALLE Texte liegen exakt auf z=0, haben den gleichen Breitenfaktor, Stil, Ausrichtung, Neigung und Drehung.
Es muss etwas mit den Grundeinstellungen deines Systems zu tun haben, die durch's Einlesen der DXF-Daten nicht beeinflusst werden.

------------------
Ciao
J-SC
  ... geht's vielleicht doch?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

oberh
Mitglied



Sehen Sie sich das Profil von oberh an!   Senden Sie eine Private Message an oberh  Schreiben Sie einen Gästebucheintrag für oberh

Beiträge: 19
Registriert: 12.10.2006

erstellt am: 13. Okt. 2006 10:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hi Nochmal!

@Thomas
Also, die fehlerhaften Texte liegen ausschließlich im Layer 001.

@J-SC
Die installierten SHX-Schriften sehen leider sehr bescheiden aus.
(Habe alle gerade mal durchprobiert.)
Wir haben hier bei uns vereinbart, die Standartschrift auf Times.ttf einzustellen.

Tja, die Grundeinstellungen!
Die Systemvariablen aus Deinem ersten Posting hab ich ja schon leider ergebnislos überprüft.

-Verzweifel-

Mein Kollege hat eine Vollversion, in der er mit einem Lisp-Tool die Eigenschaften der beiden Beispieltexte ausgeben kann.
Der z-Wert des Textes 4722 ist bei ihm 1.061e-313.

Mal einmal abgesehen davon, dass hier der Z-Wert fehlerhaft interpretiert wird - alle Texte, die z <> 0 haben, werden ausgefranst dargestellt.
Könnte es sich hierbei eventuell um einen Bug handeln?

Danke im Voraus
Olaf

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

j-sc
Ehrenmitglied



Sehen Sie sich das Profil von j-sc an!   Senden Sie eine Private Message an j-sc  Schreiben Sie einen Gästebucheintrag für j-sc

Beiträge: 1824
Registriert: 14.07.2003

W7 64Bit
intel core I7 2,8GHz / 4GB
ATI FIRE PRO V5800
acad2011
acad2015
acad2018
Athena
Expresstools

erstellt am: 13. Okt. 2006 11:00    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für oberh 10 Unities + Antwort hilfreich


dxf_text.jpg


dxf_romans.jpg


dxf_times.jpg

 
Bug halte ich für unwahrscheinlich - tippe immer noch auf unterschiedliche Systemeinstellungen. Ich habe kein Prob. mit der dxf - weder mit shx noch mit ttf. -> siehe Bilder

------------------
Ciao
J-SC
  ... geht's vielleicht doch?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CADdog
Ehrenmitglied V.I.P. h.c.




Sehen Sie sich das Profil von CADdog an!   Senden Sie eine Private Message an CADdog  Schreiben Sie einen Gästebucheintrag für CADdog

Beiträge: 2085
Registriert: 30.04.2004

Intel Xeon 3,6 GHz
32 GB RAM
NVIDIA Quadro P2000
Windows 10 Enterprise
AutoCADmap 3D 2018
WS-Landcad 2018
QGIS 3.0

erstellt am: 13. Okt. 2006 11:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für oberh 10 Unities + Antwort hilfreich

 
Zitat:
Original erstellt von oberh:
Könnte es sich hierbei eventuell um einen Bug handeln?

na ich sage mal, es ist ein typisches "Verhalten" von AutoCAD seit der Version 2000. Bei TT-Texten mit Höhe 0 und Breitenfaktor 1 übernimmt Windows die Darstellung, ansonsten AutoCAD. Diese Darstellung dürfte sich jedoch aussschließlich auf den Bildschirm beziehen, der Plot sollte normal aussehen.

Dies erklärt aber nicht, warum bei dir die Texte auf Höhen ungleich Null liegen, das ist bei mir nicht der Fall und die Darstellung bei mir ist einwandfrei.

------------------
   

gruß CADdog, the dog formerly known as TR

AutoCAD spricht mit einem, aber viele hören nicht zu.

[Diese Nachricht wurde von CADdog am 13. Okt. 2006 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

oberh
Mitglied



Sehen Sie sich das Profil von oberh an!   Senden Sie eine Private Message an oberh  Schreiben Sie einen Gästebucheintrag für oberh

Beiträge: 19
Registriert: 12.10.2006

erstellt am: 13. Okt. 2006 11:09    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hi CADdog!

Danke für Deinen Hinweis aber
Nööö!

Auf dem Plot werden die Texte fetter dargestellt.

Gruß
Olaf

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

oberh
Mitglied



Sehen Sie sich das Profil von oberh an!   Senden Sie eine Private Message an oberh  Schreiben Sie einen Gästebucheintrag für oberh

Beiträge: 19
Registriert: 12.10.2006

MS Windows XP, SP 3 Built 2600
X86 PC 2800 Mhz, AM Bios 080015
3 GB RAM; ATI Radeon HD 4350
AutoCad Civil 3D 2011

erstellt am: 13. Okt. 2006 11:14    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Bewege Dich in der Zeichnung mal ein paar Meter die Straße hinunter nach Süden. Am Ende findest Du den Text 4681. Bei Times als Standarttextstil wird bei mir dieser Text fetter und ausgefranster dargestellt.

Gruß
Olaf

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

j-sc
Ehrenmitglied



Sehen Sie sich das Profil von j-sc an!   Senden Sie eine Private Message an j-sc  Schreiben Sie einen Gästebucheintrag für j-sc

Beiträge: 1824
Registriert: 14.07.2003

W7 64Bit
intel core I7 2,8GHz / 4GB
ATI FIRE PRO V5800
acad2011
acad2015
acad2018
Athena
Expresstools

erstellt am: 13. Okt. 2006 11:47    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für oberh 10 Unities + Antwort hilfreich


dxf_4681.jpg

 
???

  Momanet mal ... Fetter??? Größer???  Könnte das vielleicht daran liegen dass die Flurstücke EINE ANDERE HÖHE haben als die Messpunkte und Du 'ne Truetype-Schrift verwendest?

------------------
Ciao
J-SC
    ... geht's vielleicht doch?

[Diese Nachricht wurde von j-sc am 13. Okt. 2006 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

oberh
Mitglied



Sehen Sie sich das Profil von oberh an!   Senden Sie eine Private Message an oberh  Schreiben Sie einen Gästebucheintrag für oberh

Beiträge: 19
Registriert: 12.10.2006

erstellt am: 13. Okt. 2006 12:57    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hi!

Ja, Truetype wird gewollt verwendet.

Ich muß meine Fehlerbeschreibung ein wenig korrigieren.
Da wir die ursprünglichen ganz o.g. Texte per Kopieren mit Basispunkt in eine neue Zeichnung kopiert hatten, war der ausgefranste Text nahe 0.
In der Originaldatei (die ich oben angehangen hatte) sind die fehlerhaften Texte gegen unendlich.
Ein paar Polylinien der Flurstücke haben ebenfalls eine Erhebung gegen Unendlich.

Es gibt aber auch Flurstücksnummern, wo die Flurstücksgrenzen keine Erhebungen haben. Aus diesem Grunde schließe ich einmal aus, dass hier eine Wechselwirkung besteht.
Außerdem sind die Texte lose, d.h. an kein anderes Objekt im CAD-Sinne gebunden.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

j-sc
Ehrenmitglied



Sehen Sie sich das Profil von j-sc an!   Senden Sie eine Private Message an j-sc  Schreiben Sie einen Gästebucheintrag für j-sc

Beiträge: 1824
Registriert: 14.07.2003

W7 64Bit
intel core I7 2,8GHz / 4GB
ATI FIRE PRO V5800
acad2011
acad2015
acad2018
Athena
Expresstools

erstellt am: 13. Okt. 2006 15:09    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für oberh 10 Unities + Antwort hilfreich


dxf_text.jpg

 
ich wiederhole mich ungern, aber  in der oben angehängten DXF-Datei liegt kein Text über oder unter Z=0 - Der Fehler muss sich NACH dem dxf-Import reinmogeln oder VOR dem Import in den Grundeinstellungen liegen.

------------------
Ciao
J-SC
  ... geht's vielleicht doch?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

oberh
Mitglied



Sehen Sie sich das Profil von oberh an!   Senden Sie eine Private Message an oberh  Schreiben Sie einen Gästebucheintrag für oberh

Beiträge: 19
Registriert: 12.10.2006

erstellt am: 17. Okt. 2006 07:41    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hi J-SC!

Vielen Dank noch mal an Dich und alle Anderen.
Ich sehe das mittlerweile genau so, bin aber leider auch nicht weiter gekommen.

Beim Import in die LT-Version steht bei z immer 0.00, bei der Vollversion meines Kollegen 4.04E+93.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz