Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  NX
  Hinzufügen und Verknüpfen neuer Teile in einer Baugruppe

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Hinzufügen und Verknüpfen neuer Teile in einer Baugruppe (200 mal gelesen)
Ösi89
Mitglied
CAD-/PLM-Administrator (Supporter)


Sehen Sie sich das Profil von Ösi89 an!   Senden Sie eine Private Message an Ösi89  Schreiben Sie einen Gästebucheintrag für Ösi89

Beiträge: 30
Registriert: 27.02.2015

NX12.0.2.9 MP2
Teamcenter 10.1.7
ePlan Fluid 2.7

erstellt am: 13. Jun. 2019 09:49    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen,

wenn man in NX ein neues Teil zu einer Baugruppe hinzufügen will, hat man ja die Möglichkeit, dieses mit bereits in der Baugruppe vorhandenen Teilen zu verknüpfen. Hierfür kann man z.B. mit dem Vorschaufenster oder der Teilevorschau im Hauptfenster die Verknüpfungsbedingungen definieren.
Allerdings: Sollte eines der Bauteile in der Baugruppe noch nicht vollständig verknüpft oder fixiert sein und will man dann ein neues Teil ausgerechnet auf diesem - noch nicht vollständig verknüpften oder fixierten - Teil mittels Zwangsbedingungen befestigen, dann verschiebt NX das bereits in der Baugruppe vorhandene Teil zum neuen Teil hin.
Salopp gesprochen ist es also bei NX so, wie wenn der Schwanz mit dem Hund wackelt und nicht der Hund mit dem Schwanz.
Lässt sich dieses Verhalten irgendwie abstellen/umstellen?

Gruß Ösi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Markus_30
Moderator
CAx-Consultant




Sehen Sie sich das Profil von Markus_30 an!   Senden Sie eine Private Message an Markus_30  Schreiben Sie einen Gästebucheintrag für Markus_30

Beiträge: 4942
Registriert: 21.03.2005

Windows 7 x64 SP1
NX 10.0.3.5 MP07
NX Nastran 10.0
Teamcenter 11.2.2

erstellt am: 13. Jun. 2019 16:48    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Ösi89 10 Unities + Antwort hilfreich

Hallo Ösi,

kenn ich, nervt mich auch. Aber das ist mit den "neuen" Assembly Constraints (die so neu eigentlich gar nicht mehr sind) leider so: Die kennen ihre Richtung nicht, deshalb kann das von dir angesprochene Verhalten vorkommen.

Früher mit den "alten" Matings war es so, dass man zuerst die Objekte am zu positionierenden Teil anklickte und dnach die Objekte am Zielteil (zu dem das zu positionierende Teil verknüpft werden soll) anwählte. Diese Matings waren richtungsbezogen. Soll heißen: Eine Platte war komplett unbestimmt, eine Schraube wurde mit der Bohrung ausgerichtet, die Kopfauflage mit der Oberfläche der Platte verknüpft und die Drehung z. B. über eine Parallelbedingung gesperrt. Ergebnis war: Eine vollständig bestimmte Schraube, aber eine unvollständig bestimmte Platte, die Schraube hat sich zur Platte hin bewegt und nicht umgekehrt. An der Schraube hingen (wegen der Richtungsgebundenheit) auch nur drei Matings drauf.

Leider wirst du das Verhalten nicht abstellen können. Ich mach mir teilweise aus lauter Verzweiflung zusätzliche Fix-Constraints rein, damit sich die Teile beim Verknüpfen wie von mir gewollt bewegen. Die zusätzlichen Fixes löse ich aber später wieder auf, so dass max. ein Fix in der Baugruppe verbleibt. Ist etwas lästig, funktioniert aber zuverlässig.

------------------
Gruß 

Markus

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Ösi89
Mitglied
CAD-/PLM-Administrator (Supporter)


Sehen Sie sich das Profil von Ösi89 an!   Senden Sie eine Private Message an Ösi89  Schreiben Sie einen Gästebucheintrag für Ösi89

Beiträge: 30
Registriert: 27.02.2015

NX12.0.2.9 MP2
Teamcenter 10.1.7
ePlan Fluid 2.7

erstellt am: 19. Jun. 2019 10:43    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Markus,

vielen Dank für die Info.
Ist zwar die Antwort, die ich befürchtet, aber nicht erhofft hatte.
Bleibt wohl nur die Notlösung über zusätzliche temporäre Fixes

Gruß Ösi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz