Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  NX
  NX 7 oder 8 auf Ubuntu Linux und Rundumschlag

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
  
Gut zu wissen: Version NX1899: Axialfläche vergrößern (Radiate Face)
Autor Thema:   NX 7 oder 8 auf Ubuntu Linux und Rundumschlag (9125 mal gelesen)
thomasmueller3000
Mitglied
Student

Sehen Sie sich das Profil von thomasmueller3000 an!   Senden Sie eine Private Message an thomasmueller3000  Schreiben Sie einen Gästebucheintrag für thomasmueller3000

Beiträge: 5
Registriert: 08.08.2012

erstellt am: 08. Aug. 2012 16:10    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

ich möchte NX 7.5 auf Ubuntu LINUX installieren, was jedoch nicht geht,
auch nicht nachdem ich einen Hack versucht habe.

Ist dies mit NX 8 möglich oder hat dies jemand geschafft?
Mit NX 6 soll es diverser Foren ja schoneinamal geklappt haben.

Ich wehre mich gegen Suse Enterprise Linux oder Red Hat, da beide Jahresgebühren kosten.
In Opensuse 12.1 habe ich es zum laufen gebracht, aber das GUI sieht richtig schlecht aus,
die Reiter aus der linken Toolbar lösen sich alle raus beim anklicken, irgendwie seltsam.
Unter Windows wurden die angenehm umgeklappt.

Mich regt die Gängelung der Software Unternehmen ganz schön auf.
Warum wird Ubuntu von haus aus nicht unterstützt?
Laut distrowatch sind die weiter verbreitet als SLED und RHEL zusammen.

Weiterhin möchte ich Ubuntu verwenden da es als einziges für mein
Thinkpad x220 tablet zertifiziet ist, da kann ich nicht als mobiler poweruser auf die langwierigen
und teuren updates von suse und redhat verlassen.
Apropos mobil: diese gängelung mit lizenzservern hat sich doch wieder irgend ein bwl'er ausgedacht.
Ich habe ein i7 core prozessor, ssd platte und 8 gb ram, der einzige flaschenhals in der CAD
Bearbeitung ist die VPN Verbindung zum Linzenserver meiner Studentenversion von NX7.5.
Immer hakt das programm kurz beim speichern oder laden von modulen da ja immer erst schoen mit dem vpn
kommuniziert werden muss. nervtötend!

Vielen Dank!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ThomasZwatz
Moderator
cadadmin




Sehen Sie sich das Profil von ThomasZwatz an!   Senden Sie eine Private Message an ThomasZwatz  Schreiben Sie einen Gästebucheintrag für ThomasZwatz

Beiträge: 5079
Registriert: 19.05.2000

(07-2020)
[stable][testing]
NX12.0.2.9 MP12 + TC12.1.0.8, RAC +AWC 4.2.3
SingleSite 4Tier, DocMgt, Client4Office, MRO, ReqMgt, SchedMgt, T4S, TcVis Mockup 12.4, TcSSO
BCT-Inspector Neutral V18.8
[unstable]
NX1930
@M7720 Win10 (1909)

erstellt am: 08. Aug. 2012 16:21    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Ich bezweifle, dass der Check nach den zertifizierten Linux OS aus dem InstallScript irgendwann verschwinden wird.

Den muss man halt aus dem InstallScript rausnehmen bzw. ans eigene OS anpassen und schon gehts los ... würd ich nicht einmal als Hack bezeichnen ...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

thomasmueller3000
Mitglied
Student

Sehen Sie sich das Profil von thomasmueller3000 an!   Senden Sie eine Private Message an thomasmueller3000  Schreiben Sie einen Gästebucheintrag für thomasmueller3000

Beiträge: 5
Registriert: 08.08.2012

erstellt am: 08. Aug. 2012 16:32    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

ich habe eine Anleitung für die Installation unter Ubuntu hier gefunden,
allerdings nur unter Ubuntu 10.04, die aktuellste ist 12.04 und ich erhielt immer
eine Fehlermeldung. ( http://www.linautom.fr/web/node/8 )

Ich poste die Meldung hier sobald ich es wieder unter Ubuntu versucht habe.
Ist das abändern des Installationsskriptes schoneinmal hier beschrieben worden
und setzt jemand erfolgreich NX 7 oder 8 auf Ubuntu ein?
Ich verwende 7.5, ist es mit 8 eventuell einfacher in Ubuntu zu installieren?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Netzer
Mitglied



Sehen Sie sich das Profil von Netzer an!   Senden Sie eine Private Message an Netzer  Schreiben Sie einen Gästebucheintrag für Netzer

Beiträge: 358
Registriert: 30.07.2004

NX7.5
TC8.3
Win7 Pro x64

erstellt am: 08. Aug. 2012 16:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Hallo Thomas.

Gute Frage. Ich wollte bei Gelegenheit mal versuchen, NX unter WINE zu installieren.

Ansonsten hat es mal jemand mit NX6 versucht, mit eher bescheidenem Erfolg:

http://ww3.cad.de/foren/ubb/Forum4/HTML/008839.shtml

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ThomasZwatz
Moderator
cadadmin




Sehen Sie sich das Profil von ThomasZwatz an!   Senden Sie eine Private Message an ThomasZwatz  Schreiben Sie einen Gästebucheintrag für ThomasZwatz

Beiträge: 5079
Registriert: 19.05.2000

(07-2020)
[stable][testing]
NX12.0.2.9 MP12 + TC12.1.0.8, RAC +AWC 4.2.3
SingleSite 4Tier, DocMgt, Client4Office, MRO, ReqMgt, SchedMgt, T4S, TcVis Mockup 12.4, TcSSO
BCT-Inspector Neutral V18.8
[unstable]
NX1930
@M7720 Win10 (1909)

erstellt am: 08. Aug. 2012 21:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von thomasmueller3000:
Hallo,

ich habe eine Anleitung für die Installation unter Ubuntu hier gefunden,
allerdings nur unter Ubuntu 10.04, die aktuellste ist 12.04 und ich erhielt immer
eine Fehlermeldung. ( http://www.linautom.fr/web/node/8 )

Ich poste die Meldung hier sobald ich es wieder unter Ubuntu versucht habe.
Ist das abändern des Installationsskriptes schoneinmal hier beschrieben worden
...


Die o.g. Beschreibung stimmt soweit ich das sehe - was im InstallScript zu ändern ist, steht gleich am Anfang unter "Installation" (grau eingefärbt ).
Allerdings kann ich kein Französisch ... und da ich keine Ubuntu Installation bisher gemacht hab weiss ich natürlich auch nicht obs komplett ist ...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

thomasmueller3000
Mitglied
Student

Sehen Sie sich das Profil von thomasmueller3000 an!   Senden Sie eine Private Message an thomasmueller3000  Schreiben Sie einen Gästebucheintrag für thomasmueller3000

Beiträge: 5
Registriert: 08.08.2012

erstellt am: 23. Aug. 2012 17:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

ich habe jetzt mehrmals versucht Siemens / UG NX 7.5 auf UBUNTU Linux zu installieren.

Dabei bin ich gemaess der website http://www.linautom.fr/web/node/8 vorgegangen.

Sobald man die Datei nx_lib.conf, darin stehen die Verzeichnisse die im Text weiter aufgelistet sind, einfügt und  den befehl ldconfig ausführt, kann das System nicht meher herunterfahren. Startet man den Computer "hart" neu so verliert der Rechner jedesmal den X Server.
(Black Screen, nach alt f1 login im Textmodus moeglich, Startx oder initx funktioniert nicht)

Die logfile gab auch keinen Aufschluss, ich habe hier in Berlin auf einem Technikfestival bereits viele Fachleute befragt die mir nicht weiterhelfen konnten.

Es ist echt nervig und hat mich wahnsinnig viel Zeit gebraucht, aber ich bekomme es nicht zum laufen. Die installation funktioniert, jedoch fehlen verschiedene Bibliotheken offensichtlich, wenn man

ldd /usr/ugs075/ugii/ugraf

ausführt.Die Datei libXm.so.3.0.3 ist anscheinend veraltet, so werden Dateien von openmotif3 verwendet, openmotif4 hingegen ist aktuell installiert.

Bin kein Experte aber das muesste doch zu loesen sein.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

thomasmueller3000
Mitglied
Student

Sehen Sie sich das Profil von thomasmueller3000 an!   Senden Sie eine Private Message an thomasmueller3000  Schreiben Sie einen Gästebucheintrag für thomasmueller3000

Beiträge: 5
Registriert: 08.08.2012

erstellt am: 23. Aug. 2012 17:28    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Einzige möglichkeit die mir gerade einfällt, Ubuntu in der alten version 10.04 installieren, dann NX 7.5 drauf, dann Update auf Ubuntu 12.04 - was haltet Ihr davon?

VG

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

schulze
Ehrenmitglied V.I.P. h.c.
CAD/CAE Manager


Sehen Sie sich das Profil von schulze an!   Senden Sie eine Private Message an schulze  Schreiben Sie einen Gästebucheintrag für schulze

Beiträge: 2312
Registriert: 26.03.2001

TC_8.1, NX6
( und andere )

erstellt am: 23. Aug. 2012 17:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

>>was haltet Ihr davon?

Ich denke, Du solltest Dich an die Vorgaben des Herstellers halten und keine solchen Experimente unternehmen.

------------------
R.Schulze

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

thomasmueller3000
Mitglied
Student

Sehen Sie sich das Profil von thomasmueller3000 an!   Senden Sie eine Private Message an thomasmueller3000  Schreiben Sie einen Gästebucheintrag für thomasmueller3000

Beiträge: 5
Registriert: 08.08.2012

erstellt am: 24. Aug. 2012 12:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

So einfach ist das nicht... die Vorgaben sind überholt. NX ist das einzige professionelle CAD System für Linux da könnte man auch das laut distrowatch am meisten heruntergelandene Linux, nämlich Ubuntu, unterstützen.

Ich habe auch CentOS, ein freies RedHat Enterprise Linux ausprobiert, das wiederum läuft nicht auf laptops bzw. das power managment ist dafuer nicht ausgelegt (Netzteil und Laptop werden sehr heiss)

Bis in Kürze

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

eineisbaer
Mitglied
CAD-Support


Sehen Sie sich das Profil von eineisbaer an!   Senden Sie eine Private Message an eineisbaer  Schreiben Sie einen Gästebucheintrag für eineisbaer

Beiträge: 205
Registriert: 10.02.2005

NX9.025 / Agile 6.12 Win7 64 Enterprise
Dell

erstellt am: 24. Aug. 2012 13:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Hallo Thomas,
da wirst Du viel Entwicklungsarbeit reinstecken müssen. Seit UBUNTU 10 hat sich die Grafik von GNOME zur neuen UBUNTU Eigenentwicklung geändert. Dass NX damit Probleme hat ist also damit erklärbar.
Es gibt aber Linux Mint, das auf UBUNTU basiert, aber die ältere Gnome Grafik unterstützt, die bei UBUNTU rausgeflogen ist.

Das ist vielleicht ein Versuch wert.

Viel Erfolg !

------------------
der Kopf ist rund, damit das Denken die Richtung ändern kann

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Ubprocad
Mitglied
Konstruktionsmechaniker

Sehen Sie sich das Profil von Ubprocad an!   Senden Sie eine Private Message an Ubprocad  Schreiben Sie einen Gästebucheintrag für Ubprocad

Beiträge: 1
Registriert: 28.09.2013

erstellt am: 28. Sep. 2013 20:07    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Hi Leute,
Ich wollte fragen, ob es auch möglich wäre, das mit der Ubuntu Gnome Edition dafür zu nutzen?
Da ja hier von der Gnome-Grafik die rede war bezüglich Kompatibilität.
Gruß Ubprocad

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Big King
Ehrenmitglied
NX/Tc Admin


Sehen Sie sich das Profil von Big King an!   Senden Sie eine Private Message an Big King  Schreiben Sie einen Gästebucheintrag für Big King

Beiträge: 1538
Registriert: 06.12.2010

TC11.6_Patch_12
(Testing .....)
NX1899serie 1903
(Testing 1926)
BCT 18.12 Products & Inspector & Raster
(Testing Products & Inspector & Raster)
DQM 11.2.0 15704
(Testing DQM xx.x)
-Server VM
-HP Workstation z640
Intel Xeon E5-1620v3 3.5GHz
NVIDA Quatro M4000 3GB
32GB DDR3-1866 RAM
Samsung Enterprise 240GB SSD
Win10 Enterprice 1809 - 17763.1039
(Testing ...)

erstellt am: 30. Sep. 2013 17:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Unterstützte Betriebssysteme NX8.5

Microsoft Windows (64-Bit) - Microsoft Windows 7 Pro und Enterprise-Version

Linux (64-Bit)  - SuSE Linux Enterprise Server/Desktop 11 SP1
- Red Hat Enterprise Linux Server/Desktop 6.0

Mac OS X - Version 10.6.8

------------------
“Vision without action is a daydream. Action without vision is a nightmare.”

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ThomasZwatz
Moderator
cadadmin




Sehen Sie sich das Profil von ThomasZwatz an!   Senden Sie eine Private Message an ThomasZwatz  Schreiben Sie einen Gästebucheintrag für ThomasZwatz

Beiträge: 5079
Registriert: 19.05.2000

(07-2020)
[stable][testing]
NX12.0.2.9 MP12 + TC12.1.0.8, RAC +AWC 4.2.3
SingleSite 4Tier, DocMgt, Client4Office, MRO, ReqMgt, SchedMgt, T4S, TcVis Mockup 12.4, TcSSO
BCT-Inspector Neutral V18.8
[unstable]
NX1930
@M7720 Win10 (1909)

erstellt am: 30. Sep. 2013 19:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Ubprocad:
...Ich wollte fragen, ob es auch möglich wäre, das mit der Ubuntu Gnome Edition dafür zu nutzen?
Da ja hier von der Gnome-Grafik die rede war bezüglich Kompatibilität. ...

Probiers doch aus.
Zum Ausprobieren reichts mal, das InstallScript ( das prüft obs eine zertifizierte Linux Distri ist ) entsprechend anzupassen und dann zu schauen was wie läuft.
Mit Gnome selbst hat das IMHO wenig zu tun, kritischer sind da andere Bibliotheken wie zB OpenMotif.

Ich schätze die Erfolgschancen bei den freien Derivaten der zugehörigen Version von der zertifizierten  SuSE/RedHat  ( d.h. OpenSuse oder CentOS ) höher ein als bei Ubuntu, auch dort dürfte es abenteuerlich genug sein ...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

UdoMM
Mitglied
Senior Consultant CAX


Sehen Sie sich das Profil von UdoMM an!   Senden Sie eine Private Message an UdoMM  Schreiben Sie einen Gästebucheintrag für UdoMM

Beiträge: 254
Registriert: 02.07.2004

NX1 ... 12 & Continuous
I-deas MS6 ... NXI6.1m1 (15)
Pro/E WF4
TCE9.1/TCX4 ... TC12
WindchillPDMLink10 CMM

erstellt am: 01. Okt. 2013 09:55    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Zitat:
das GUI sieht richtig schlecht aus,
die Reiter aus der linken Toolbar lösen sich alle raus beim anklicken, irgendwie seltsam.

Das ist ein Fall von "Works as Designed": Die Ressorcenleiste funktioniert nur unter Windows so wie unter Windows. Steht auch irgendwo in der NX-Doku drin. Auf den anderen Plattformen bekommt man die freien Fenster. Empfand ich auch ungewohnt.

------------------
Gruß
UdoMM
:
<><

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

mseufert
Ehrenmitglied V.I.P. h.c.
Freiberuflicher CAD/CAM Ingenieur


Sehen Sie sich das Profil von mseufert an!   Senden Sie eine Private Message an mseufert  Schreiben Sie einen Gästebucheintrag für mseufert

Beiträge: 2438
Registriert: 18.10.2005

HP Z420
WIN XP32 / WIN7 64
UG NX6-11
SUN Ultra 60
Solaris 7
CADDS5
3D Printer Prusa MK2 S

erstellt am: 03. Okt. 2013 13:27    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich


nx5-ubuntu.zip

 
Anbei eine Anleitung zur Installation unter Ubuntu. Ist zwar etwas älter, hilft evtl. immer noch weiter.

Gruß, Michael

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

operator from hell
Mitglied
Dipl.-Ing. (Univ.) Gruppenleiter/ Labor / Konstruktion


Sehen Sie sich das Profil von operator from hell an!   Senden Sie eine Private Message an operator from hell  Schreiben Sie einen Gästebucheintrag für operator from hell

Beiträge: 86
Registriert: 15.08.2008

Dell Latitude M4600
Core i7 2.8Ghz;
20 Gb Arbeitsspeicher (WIN10 64Bit)
NVIDIA Geforce K2000 512MB
Pro/E Wildfire 3.0
Inventor2008Prof SP3
Inventor2011Prof
SolidWorks 2012
Siemens NX9 & TeamCenterExpress9.1
Siemens NX11 & TeamCenter10.1

erstellt am: 27. Jan. 2014 10:08    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von ThomasZwatz:

Probiers doch aus.
Zum Ausprobieren reichts mal, das InstallScript ( das prüft obs eine zertifizierte Linux Distri ist ) entsprechend anzupassen und dann zu schauen was wie läuft.
Mit Gnome selbst hat das IMHO wenig zu tun, kritischer sind da andere Bibliotheken wie zB OpenMotif.

Ich schätze die Erfolgschancen bei den freien Derivaten der zugehörigen Version von der zertifizierten  SuSE/RedHat  ( d.h. OpenSuse oder CentOS ) höher ein als bei Ubuntu, auch dort dürfte es abenteuerlich genug sein ...


Installation unter CentOS funktioniert einwandfrei. Man muss lediglich ein paar Bibliotheken per yum nachladen. Da hilft google dann weiter.
GUI ist auch stabil.

------------------
Die Summe aller Probleme ist immer konstant.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

operator from hell
Mitglied
Dipl.-Ing. (Univ.) Gruppenleiter/ Labor / Konstruktion


Sehen Sie sich das Profil von operator from hell an!   Senden Sie eine Private Message an operator from hell  Schreiben Sie einen Gästebucheintrag für operator from hell

Beiträge: 86
Registriert: 15.08.2008

Dell Latitude M4600
Core i7 2.8Ghz;
20 Gb Arbeitsspeicher (WIN10 64Bit)
NVIDIA Geforce K2000 512MB
Pro/E Wildfire 3.0
Inventor2008Prof SP3
Inventor2011Prof
SolidWorks 2012
Siemens NX9 & TeamCenterExpress9.1
Siemens NX11 & TeamCenter10.1

erstellt am: 21. Nov. 2014 14:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von mseufert:
Anbei eine Anleitung zur Installation unter Ubuntu. Ist zwar etwas älter, hilft evtl. immer noch weiter.

Gruß, Michael


Hat mal jemand diese Anleitung mit neueren Versionen von NX und Ubuntu getestet? Die Ergebnisse würden mich sehr interessieren!
Viele Grüße

------------------
Die Summe aller Probleme ist immer konstant.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

juup
Mitglied
Ingenieur


Sehen Sie sich das Profil von juup an!   Senden Sie eine Private Message an juup  Schreiben Sie einen Gästebucheintrag für juup

Beiträge: 38
Registriert: 03.06.2015

NX11
Mach 3 Ind Design

erstellt am: 03. Jun. 2015 22:00    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Moin zusammen,

ich wechsle derzeit von CATIA auf NX10 und bin stark an dem Betrieb unter Linux interessiert.

Zu diesem Zweck habe ich es sowohl auf CentOS7 und Linuxmint 17.1 (auf Ubuntubasis) versucht.
Wie beschrieben müssen noch einige Pakete nachinstalliert werden, mindestens:
CentOS7:
yum install ksh glibc.i686 libXp.x86_64 libXp-1.0.0-15.1.el6.x86_64 libpng12.x86_64
Ubuntu:
sudo apt-get install libjpeg62 libmotif-dev

Installation unter CentOS läuft so durch, für Ubuntu habe ich ug_install.sh angepasst (ab Zeile 112):

Code:
    else # Couldnt detect SuSE or Red Hat so give unsuppored message and quit.
      X11_DEFS_DIR=/usr/share/X11/app-defaults
#exit 1

Nun zu meiner Frage operator from hell, was verstehst Du unter GUI ist stabil? Ich werde wahnsinnig mit der Resourcenleiste. Die Resourcenfenster springen beim Wechseln weg und sind nur über Ein- und Ausblenden per Rechtsklick wieder an einen ordendlichen Platz zu bekommen. Die Rahmen bekäme man zumindest unter KDE ja sogar über "Weitere Aktionen - Keine Umrandung" versteckt. Nur müssten dafür zumindest die Fenster an Ort und Stelle bleiben. Hast Du dafür noch spezielle Einstellungen vorgenommen?

Ein anderes Thema betrifft die Verwendung eines Dongle für den Lizensserver. Unter Windows erkennt das Lizenzkonfigurationstool alle LAN und WLAN Karten mit ihrer MAC-Adresse. Unter Linux wird in dem Tool nur eine LAN-Karte angezeigt, obwohl WLAN-Dongle und Bluetooth vom Betriebssystem verwendet werden können.

Für jeden Tipp dankbar
juup

[Diese Nachricht wurde von juup am 03. Jun. 2015 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

operator from hell
Mitglied
Dipl.-Ing. (Univ.) Gruppenleiter/ Labor / Konstruktion


Sehen Sie sich das Profil von operator from hell an!   Senden Sie eine Private Message an operator from hell  Schreiben Sie einen Gästebucheintrag für operator from hell

Beiträge: 86
Registriert: 15.08.2008

Dell Latitude M4600
Core i7 2.8Ghz;
20 Gb Arbeitsspeicher (WIN10 64Bit)
NVIDIA Geforce K2000 512MB
Pro/E Wildfire 3.0
Inventor2008Prof SP3
Inventor2011Prof
SolidWorks 2012
Siemens NX9 & TeamCenterExpress9.1
Siemens NX11 & TeamCenter10.1

erstellt am: 04. Jun. 2015 09:51    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Also bei mir war das nur ein kurzer Test. Produktiv verwenden wir hier natürlich Windows.
Aber meine Testumgebung war ein CentOS 6.4 mit NX8.5. Das hätte ich vielleicht gleich dazuschreiben sollen... Sorry!
Ich habe ja auch schon selber mal nachgefragt im Forum, ob schon jemand mal neuere Versionen probiert hat.

Super funktioniert die Installation übrigens unter MAC(Version weiss ich jetzt nicht) mit NX10. Das habe ich auf einem iMac von 2013 getestet. Und es war wirklich nur Doppelklick und Lizenzserver eingeben  - Fertig!

------------------
Die Summe aller Probleme ist immer konstant.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

operator from hell
Mitglied
Dipl.-Ing. (Univ.) Gruppenleiter/ Labor / Konstruktion


Sehen Sie sich das Profil von operator from hell an!   Senden Sie eine Private Message an operator from hell  Schreiben Sie einen Gästebucheintrag für operator from hell

Beiträge: 86
Registriert: 15.08.2008

Dell Latitude M4600
Core i7 2.8Ghz;
20 Gb Arbeitsspeicher (WIN10 64Bit)
NVIDIA Geforce K2000 512MB
Pro/E Wildfire 3.0
Inventor2008Prof SP3
Inventor2011Prof
SolidWorks 2012
Siemens NX9 & TeamCenterExpress9.1
Siemens NX11 & TeamCenter10.1

erstellt am: 04. Jun. 2015 10:03    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Achso bevor ich das vergesse: Testrechner war ein ziemlich alter Lenovo Thinkpad mit Ati Grafikkarte. Da hatte ich mit CentOS aber auch keine größeren Probleme. Der Rechner wird nicht sehr heiß. Der Lüfter läuft zwar permanent, aber nicht auf der höchsten Drehzahl. Man hört es kaum...

------------------
Die Summe aller Probleme ist immer konstant.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

juup
Mitglied
Ingenieur


Sehen Sie sich das Profil von juup an!   Senden Sie eine Private Message an juup  Schreiben Sie einen Gästebucheintrag für juup

Beiträge: 38
Registriert: 03.06.2015

NX11
Mach 3 Ind Design

erstellt am: 04. Jun. 2015 11:03    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Danke für die schnelle Antwort. Wie schaute es denn mit der GUI in Deiner Konfiguration aus? Blieben die Fenster bedienbar?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

operator from hell
Mitglied
Dipl.-Ing. (Univ.) Gruppenleiter/ Labor / Konstruktion


Sehen Sie sich das Profil von operator from hell an!   Senden Sie eine Private Message an operator from hell  Schreiben Sie einen Gästebucheintrag für operator from hell

Beiträge: 86
Registriert: 15.08.2008

Dell Latitude M4600
Core i7 2.8Ghz;
20 Gb Arbeitsspeicher (WIN10 64Bit)
NVIDIA Geforce K2000 512MB
Pro/E Wildfire 3.0
Inventor2008Prof SP3
Inventor2011Prof
SolidWorks 2012
Siemens NX9 & TeamCenterExpress9.1
Siemens NX11 & TeamCenter10.1

erstellt am: 04. Jun. 2015 14:41    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Unter NX8.5 lief die GUI stabil. Ich habe halt sehr kurz damit "gespielt". Einen Klotz gemacht mit Löchern versehen und dann in eine Baugruppe platziert.
Ich habe aber mal NX9.0 installiert, die funktioniert überhaupt nicht. Startet zwar, aber das war es auch. Keine Ahnung warum, aber NX8.5 startet seither auch nicht mehr. UGraf Process stürzt gleich nach dem start ab.
Vielleicht teste ich mal NX10 auf einem neuen CentOS7 oder so.

------------------
Die Summe aller Probleme ist immer konstant.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

operator from hell
Mitglied
Dipl.-Ing. (Univ.) Gruppenleiter/ Labor / Konstruktion


Sehen Sie sich das Profil von operator from hell an!   Senden Sie eine Private Message an operator from hell  Schreiben Sie einen Gästebucheintrag für operator from hell

Beiträge: 86
Registriert: 15.08.2008

Dell Latitude M4600
Core i7 2.8Ghz;
20 Gb Arbeitsspeicher (WIN10 64Bit)
NVIDIA Geforce K2000 512MB
Pro/E Wildfire 3.0
Inventor2008Prof SP3
Inventor2011Prof
SolidWorks 2012
Siemens NX9 & TeamCenterExpress9.1
Siemens NX11 & TeamCenter10.1

erstellt am: 29. Aug. 2016 10:03    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

NACHTRAG:
Ich habe NX9 auf einem CENTOS7 installiert. Getestet habe ich aber nur einmal eine einfache Extrusion und ein Loch rein. Nix weiter...
Dennoch würde ich gerne einen Schritt weiter gehen: NX über ssh -X aufrufen.
Der Aufruf selber geht. Aber ich bekomme dann eine Fehlermeldung auf dem Client:

libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swrast
Bis hierhin geht es dennoch weiter, aber dann kommt das:

Failed to handle error condition correctly - exiting Fatal Qt Error - Cannot mix incompatible Qt library (version 0x40805) with this library (version 0x40801)

Da bricht NX dann endgültig ab. Hat jemand dazu eine Idee?

Vielen Dank und Grüße

------------------
Die Summe aller Probleme ist immer konstant.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

mseufert
Ehrenmitglied V.I.P. h.c.
Freiberuflicher CAD/CAM Ingenieur


Sehen Sie sich das Profil von mseufert an!   Senden Sie eine Private Message an mseufert  Schreiben Sie einen Gästebucheintrag für mseufert

Beiträge: 2438
Registriert: 18.10.2005

HP Z420
WIN XP32 / WIN7 64
UG NX6-11
SUN Ultra 60
Solaris 7
CADDS5
3D Printer Prusa MK2 S

erstellt am: 29. Aug. 2016 12:10    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von operator from hell:
Cannot mix incompatible Qt library (version 0x40805) with this library (version 0x40801)

Ich würd' mal versuchen, das installierte QT zu aktualisieren. Von JAVA kennt man ja die Überempfindlichkeit bezüglich der verwendeten Versionen, das ist bei QT anscheinend ähnlich.

Gruß, Michael

------------------
Ein Mensch wird laut, wenn er was will;
wenn er's erst hat, dann wird er still;
Das "Danke" ist, nach alter Sitte,
Weit seltner als das "Bitte, Bitte".

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

operator from hell
Mitglied
Dipl.-Ing. (Univ.) Gruppenleiter/ Labor / Konstruktion


Sehen Sie sich das Profil von operator from hell an!   Senden Sie eine Private Message an operator from hell  Schreiben Sie einen Gästebucheintrag für operator from hell

Beiträge: 86
Registriert: 15.08.2008

Dell Latitude M4600
Core i7 2.8Ghz;
20 Gb Arbeitsspeicher (WIN10 64Bit)
NVIDIA Geforce K2000 512MB
Pro/E Wildfire 3.0
Inventor2008Prof SP3
Inventor2011Prof
SolidWorks 2012
Siemens NX9 & TeamCenterExpress9.1
Siemens NX11 & TeamCenter10.1

erstellt am: 29. Aug. 2016 13:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Danke für die Rückmeldung!
Das habe ich auch schon gedacht. Ist aber genau die gleiche meldung bei rausgekommen. Allerdings ohne Neustart.
vielleicht teste ich das nochmal und mache vorher auch nochmal ein yum update...

------------------
Die Summe aller Probleme ist immer konstant.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Mi-Lan
Mitglied
Konstrukteur

Sehen Sie sich das Profil von Mi-Lan an!   Senden Sie eine Private Message an Mi-Lan  Schreiben Sie einen Gästebucheintrag für Mi-Lan

Beiträge: 6
Registriert: 14.02.2011

erstellt am: 22. Jan. 2017 14:57    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Die Grafikkarte ist der Schlüssel für die meisten Probleme. Alle CAD Systeme benötigen mehr als 512 Mb Grafikspeicher. Außerdem sind ein schneller GPU und ein Open GL Treiber notwendig. Die besten Grafikkarten für CAD sind NVIDIA FX Serie oder entsprechend ATI z.B. Fire Pro. Ich verwende eine NVIDIA FX3800 mit 1Gb RAM und alles geht wie geschmiert. FX3800 gebraucht gibt es bei ebay schon ab 70€, und der Linux-Treiber wird auf der NVIDIA-Site frei zum Herunterladen bereitgestellt.
Gruß MT

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

operator from hell
Mitglied
Dipl.-Ing. (Univ.) Gruppenleiter/ Labor / Konstruktion


Sehen Sie sich das Profil von operator from hell an!   Senden Sie eine Private Message an operator from hell  Schreiben Sie einen Gästebucheintrag für operator from hell

Beiträge: 86
Registriert: 15.08.2008

Dell Latitude M4600
Core i7 2.8Ghz;
20 Gb Arbeitsspeicher (WIN10 64Bit)
NVIDIA Geforce K2000 512MB
Pro/E Wildfire 3.0
Inventor2008Prof SP3
Inventor2011Prof
SolidWorks 2012
Siemens NX9 & TeamCenterExpress9.1
Siemens NX11 & TeamCenter10.1

erstellt am: 23. Jan. 2017 08:49    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

Danke für die Rückmeldung! Mittlerweile sind wir da auch einen Schritt weiter. Es liegt wohl ziemlich eindeutig an der Hardware, von der NX aufgerufen wird. Einige laufen wunderbar, andere wiederum gar nicht. Du scheinst also mit deiner Vermutung goldrichtig zu liegen. Wir haben generell ein Problem mit ATI Karten.
Grüße

------------------
Die Summe aller Probleme ist immer konstant.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

operator from hell
Mitglied
Dipl.-Ing. (Univ.) Gruppenleiter/ Labor / Konstruktion


Sehen Sie sich das Profil von operator from hell an!   Senden Sie eine Private Message an operator from hell  Schreiben Sie einen Gästebucheintrag für operator from hell

Beiträge: 86
Registriert: 15.08.2008

Dell Latitude M4600
Core i7 2.8Ghz;
20 Gb Arbeitsspeicher (WIN10 64Bit)
NVIDIA Geforce K2000 512MB
Pro/E Wildfire 3.0
Inventor2008Prof SP3
Inventor2011Prof
SolidWorks 2012
Siemens NX9 & TeamCenterExpress9.1
Siemens NX11 & TeamCenter10.1

erstellt am: 23. Jan. 2017 08:54    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasmueller3000 10 Unities + Antwort hilfreich

P.S.: Das liegt aber vermutlich wiederum nicht an den ATI Karten selber. Sondern an der Treiber-Unterstützung/Konfiguration....

------------------
Die Summe aller Probleme ist immer konstant.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz