Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Autodesk GIS Produkte
  Mapimport - fehlende Daten

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Mapimport - fehlende Daten (1096 mal gelesen)
RL13
Ehrenmitglied V.I.P. h.c.
Dipl.-Ing. Bauwesen


Sehen Sie sich das Profil von RL13 an!   Senden Sie eine Private Message an RL13  Schreiben Sie einen Gästebucheintrag für RL13

Beiträge: 2373
Registriert: 23.10.2008

erstellt am: 29. Jan. 2013 15:34    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


130129-_mapimport.jpg

 
Hallo zusammen,

stehe vor dem Problem, dass ich Daten aus einer SDF nicht korrekt als Objektdaten mit dem Befehl _mapimport importiert bekomme.

Ich habe im Schema des SDF mehrere Datentypen verwendet:
Zeichenfolge
Boolean
Datum/Zeit
Int16
Int32
Von den Datentypen werden die Zeichenfolgen und die Int32 korrekt als Objektdaten abgelegt aber bei
Boolean stehen überall 0
Datum/Uhrzeit werden Ziffenfolgen ohne Trennzeichen (bspw: aus 01.01.1996 15:34:51 wird 19960101153400)
Int16 stehen überall 0

Gibt es eine Einstellung in den Treiberoptionen bzw. wie komme ich überhaupt in diese Einstellungsseite (ist bei mir immer grau)?

------------------
mfg Roman

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

RL13
Ehrenmitglied V.I.P. h.c.
Dipl.-Ing. Bauwesen


Sehen Sie sich das Profil von RL13 an!   Senden Sie eine Private Message an RL13  Schreiben Sie einen Gästebucheintrag für RL13

Beiträge: 2373
Registriert: 23.10.2008

Civil 3D 2018.1
Civil 3D 2016 64 Bit SP 3
mit DACH und Extensions
W7 Professional 64Bit
HP Z440
Intel Xeon CPU E5-1620 v4
32 GB RAM
NVIDIA Quadro P4000

erstellt am: 29. Jan. 2013 15:51    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen,

habe eine gangbare Krücken-Lösung für mich gefunden

Die SDF mit "Layerdaten in SQLite exportieren" und anschließendem _mapimport
jetzt sind alle Objektdaten bis auf das Datum (hier immer noch die Ziffernfolge mit abgeschnittenen Sekunden) korrekt.

Wenn mir jemand sagen kann was hier schief gelaufen ist 

------------------
mfg Roman

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Mistfink
Mitglied
GISler


Sehen Sie sich das Profil von Mistfink an!   Senden Sie eine Private Message an Mistfink  Schreiben Sie einen Gästebucheintrag für Mistfink

Beiträge: 217
Registriert: 08.06.2006

Map 3D / 2013
AIMS 2013
Win 7, 64bit

erstellt am: 29. Jan. 2013 16:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für RL13 10 Unities + Antwort hilfreich

Hallo Roman,

bei den Objektdatentabellen sind nur die Datentypen Ganzzahl, Zeichen, Punkt (?), Reelle Zahl möglich. Alle anderen Datentypen werden beim Import dann entsprechend wohl konvertiert. Ich wüsste nicht, wie man das beeinflussen kann - ausser das man nur diese Datentypen in der SDF verwendet, so dass beim Import später keine (grösseren) Probleme auftreten.

Robert

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Guenther P
Mitglied
Techniker


Sehen Sie sich das Profil von Guenther P an!   Senden Sie eine Private Message an Guenther P  Schreiben Sie einen Gästebucheintrag für Guenther P

Beiträge: 1133
Registriert: 14.05.2010

AutoCAD 11 -->
--> AutoCAD Civil 3D 2017 64bit SP1.1
--> Autodesk InfraWorks 360
Autodesk Infrastructure Design Suite Premium 2017 64bit
OoC, HMap
Windows 7 x64 Enterprise SP1
Lenovo ThinkCentre M800 MT
Intel Core i7-4770 @3.40GHz 3.40 GHz
32,0 GB RAM
NVIDIA Quadro K2000D
2*24"
HP EliteBook Revolve 810

erstellt am: 29. Jan. 2013 16:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für RL13 10 Unities + Antwort hilfreich

Hi Roman,

kannst du da Testdaten zur Verfügung stellen, komme aber erst morgen dazu zu probieren.

------------------
- gü -

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

RL13
Ehrenmitglied V.I.P. h.c.
Dipl.-Ing. Bauwesen


Sehen Sie sich das Profil von RL13 an!   Senden Sie eine Private Message an RL13  Schreiben Sie einen Gästebucheintrag für RL13

Beiträge: 2373
Registriert: 23.10.2008

erstellt am: 29. Jan. 2013 17:18    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Test_Druckleitungen.sdf.txt

 
Hallo,

@Robert - und eben diese Konvertierung klappt bei mir nur wenn ich vorher ein SQLite erstelle und diese Datei importiere

@Günther - im Anhang die Beispieldatei

Frage an Beide: Kommt ihr irgendwie in die o.g. Treiberoptionen?

------------------
mfg Roman

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Guenther P
Mitglied
Techniker


Sehen Sie sich das Profil von Guenther P an!   Senden Sie eine Private Message an Guenther P  Schreiben Sie einen Gästebucheintrag für Guenther P

Beiträge: 1133
Registriert: 14.05.2010

AutoCAD 11 -->
--> AutoCAD Civil 3D 2017 64bit SP1.1
--> Autodesk InfraWorks 360
Autodesk Infrastructure Design Suite Premium 2017 64bit
OoC, HMap
Windows 7 x64 Enterprise SP1
Lenovo ThinkCentre M800 MT
Intel Core i7-4770 @3.40GHz 3.40 GHz
32,0 GB RAM
NVIDIA Quadro K2000D
2*24"
HP EliteBook Revolve 810

erstellt am: 30. Jan. 2013 08:02    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für RL13 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von RL13:
Hallo,

@Robert - und eben diese Konvertierung klappt bei mir nur wenn ich vorher ein SQLite erstelle und diese Datei importiere 

@Günther - im Anhang die Beispieldatei

Frage an Beide: Kommt ihr irgendwie in die o.g. Treiberoptionen?



Hi Roman,

leider kann ich dir da nicht wirklich weiter helfen, im C3D2013 verhält sich das Ganze genauso wie bei dir.
Blöde Frage: Wieso verwendest du nicht gleich die sdf´s ?

------------------
- gü -

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

RL13
Ehrenmitglied V.I.P. h.c.
Dipl.-Ing. Bauwesen


Sehen Sie sich das Profil von RL13 an!   Senden Sie eine Private Message an RL13  Schreiben Sie einen Gästebucheintrag für RL13

Beiträge: 2373
Registriert: 23.10.2008

erstellt am: 30. Jan. 2013 09:09    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Guten Morgen Günther,

Der Grund warum ich das so mache ist folgender:

Ich möchte die GIS-Daten vollständig in das AutoCAD-Format umwandeln, weil ja nicht jeder AutoCAD oder gar MAP hat.
Bei der Kartenerstellung, Stilisierung und anschließendem _mapexportcurrentmaptodwg werden nicht alle Label übernommen
siehe auch Beitrag:

http://ww3.cad.de/foren/ubb/Forum285/HTML/000842.shtml#000000

Deshalb hangel ich von einer Krücke zur anderen um an das Ziel zu kommen
Es könnte so einfach sein, wenn das Prog 100% so funktionieren würde, wie man es erwartet


------------------
mfg Roman

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Guenther P
Mitglied
Techniker


Sehen Sie sich das Profil von Guenther P an!   Senden Sie eine Private Message an Guenther P  Schreiben Sie einen Gästebucheintrag für Guenther P

Beiträge: 1133
Registriert: 14.05.2010

AutoCAD 11 -->
--> AutoCAD Civil 3D 2017 64bit SP1.1
--> Autodesk InfraWorks 360
Autodesk Infrastructure Design Suite Premium 2017 64bit
OoC, HMap
Windows 7 x64 Enterprise SP1
Lenovo ThinkCentre M800 MT
Intel Core i7-4770 @3.40GHz 3.40 GHz
32,0 GB RAM
NVIDIA Quadro K2000D
2*24"
HP EliteBook Revolve 810

erstellt am: 30. Jan. 2013 09:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für RL13 10 Unities + Antwort hilfreich

und das mit den MAX_LABELS

Nicht alle Label werden gezeichnet

hilft nicht ?

------------------
- gü -

[Diese Nachricht wurde von Guenther P am 30. Jan. 2013 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

RL13
Ehrenmitglied V.I.P. h.c.
Dipl.-Ing. Bauwesen


Sehen Sie sich das Profil von RL13 an!   Senden Sie eine Private Message an RL13  Schreiben Sie einen Gästebucheintrag für RL13

Beiträge: 2373
Registriert: 23.10.2008

erstellt am: 30. Jan. 2013 13:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Günther,

nee, das ändern der Registry bringt bei mir nix

------------------
mfg Roman

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz