Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SIMULIA/ABAQUS
  Problem mit tie constrain

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Problem mit tie constrain (2101 mal gelesen)
  
Die Gewinne der Zukunft werden mit intelligenten, autonomen Elektrofahrzeugen eingefahren. (3DEXPERIENCE)
kmarc87
Mitglied
computational engineer

Sehen Sie sich das Profil von kmarc87 an!   Senden Sie eine Private Message an kmarc87  Schreiben Sie einen Gästebucheintrag für kmarc87

Beiträge: 4
Registriert: 27.04.2015

ABAQUS/CAE 6.14-2

erstellt am: 27. Apr. 2015 10:21    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


big.png


small.png

 
Hallo alle zusammen,

Im Rahmen einer Simulation ermittle ich u.a. die Spannungsintensitätsfaktoren an einer Probe. Ein Ausschnitt dieser Probe wurde in Form eines sehr flachen Viertel-Zylinders mit einer an der Oberfläche angebrachten künstlichen Fehlstelle, die ebenfalls geviertelt auftritt, modelliert. Siehe Anhang Dateien "big", die den viertel Zylinder zeigt und "small", die die künstliche Fehlstelle vergrößert darstellt.

Da ich ein relativ großes Gebiet modelliere, von dem eigentlich nur ein kleiner Teil im Bereich der Fehlstelle relevant ist, um die Symetrien auszunutzen, wollte ich die Elementanzahl möglichst gering halten indem ich C3D10-Elemente (10-node quadratic terahedron) benutzte. Um nun aber Spannungsintensitätsfaktoren berechnen zu können brauchte ich im Bereich der Rissspitze C3D8R (8-node linear brick, reduced integration, hour glass control) um die Konturintegrale legen zu können.

Die beiden Bereiche habe ich über 3 tie-constrains mit "surface to surface" verbunden (eine Fläche normal zur jeweiligen Raumrichtung). Um die Spannungen etc zu berechnen hat das auch wunderbar funktioniert. Die *.odb-Datei dieser Spannungssimulation habe ich dann als orphan mesh in eine neue Datei importiert um mich an die Spannungsintensitätsfaktoren zu wagen. Habe wieder 3 tie-constraints, sowie die load, BC's und den Riss etc definiert und den job abgeschickt.


Kommen wir nun zum eigentlichen Problem:

Die Simulation läuft auch fehlerfrei durch, jedoch stellt sich bei den tie constraints folgendes Problem ein. Wie im Anhang in der Datei "scale_factor" zu sehen ist sind die relevanten flächen scheinbar nur am Rand über die Knoten verbunden (hab in dem Bild den besagten scale_factor erhöht um durch die übertriebene deformation mein Problem besser darzustellen). In den tie-constrains habe ich aber eindeutig die gesamten Flächen und surface-to-surface contact definiert. Dies alles führt jedenfalls zu ungewollten Spannungsspitzen an den Übergängen der constraint-Flächen ...

Bin jetzt etwas Ratlos und würde mich über weiteren Input von euch freuen.
Schonmal Danke für die Hilfe und habt bitte etwas Geduld mit mir. Poste zum Ersten mal etwas in so einem Forum ^^
Hoffe auch das das Dateien anhängen funktioniert hat

MfG Marc

[Diese Nachricht wurde von kmarc87 am 27. Apr. 2015 editiert.]

[Diese Nachricht wurde von kmarc87 am 27. Apr. 2015 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

kmarc87
Mitglied
computational engineer

Sehen Sie sich das Profil von kmarc87 an!   Senden Sie eine Private Message an kmarc87  Schreiben Sie einen Gästebucheintrag für kmarc87

Beiträge: 4
Registriert: 27.04.2015

ABAQUS/CAE 6.14-2

erstellt am: 27. Apr. 2015 10:27    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


scale_factor.png

 
Hier nochmal das "scale-factor" Bild.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Mustaine
Ehrenmitglied V.I.P. h.c.



Sehen Sie sich das Profil von Mustaine an!   Senden Sie eine Private Message an Mustaine  Schreiben Sie einen Gästebucheintrag für Mustaine

Beiträge: 3393
Registriert: 04.08.2005

Abaqus

erstellt am: 27. Apr. 2015 23:19    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für kmarc87 10 Unities + Antwort hilfreich

Wie hast du das Ausgangsmodell aufgebaut? Ist das ein Bauteil mit Partitionen für die beiden Netze oder sind es wirklich zwei verschiedene Bauteile?

Bei Variante 1 würde CAE automatisch beim vernetzen melden, dass die Bereiche inkompatibel sind, außen gemeinsame Knoten generieren und im inneren Tie-Constraints.

Außerdem solltest du mal nach der Rechnung in die .dat schauen, ob da Warnungen zu den Ties stehen.

Vielleicht auch mal node-to-surface testen.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

rombik
Mitglied



Sehen Sie sich das Profil von rombik an!   Senden Sie eine Private Message an rombik  Schreiben Sie einen Gästebucheintrag für rombik

Beiträge: 77
Registriert: 21.07.2009

erstellt am: 29. Apr. 2015 08:27    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für kmarc87 10 Unities + Antwort hilfreich

Versuch mit POSITION TOLERANCE den Abstand zwischen den Kontaktflächen zu vergrößern.
Des Weiteren, überprüfe ob die Master und Slave Flächen richtig definiert sind. (fein vernetzt – slave, grob vernetzt - master)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

kmarc87
Mitglied
computational engineer

Sehen Sie sich das Profil von kmarc87 an!   Senden Sie eine Private Message an kmarc87  Schreiben Sie einen Gästebucheintrag für kmarc87

Beiträge: 4
Registriert: 27.04.2015

ABAQUS/CAE 6.14-2

erstellt am: 29. Apr. 2015 09:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Erst einmal danke für die Antwort.

Das Modell besteht aus einem Part, welches ich dann einfach partitioniert habe. Nach dem Partitionieren habe ich dann unter Mesh/controls zwei Regionen mit unterschiedlichen Meshmethoden definiert. Also Eben einmal "Hex" im Bereich der künstlichen Fehlstelle und einmal "Tet" für den Rest.

Die Meldung mit der Inkompatibilität der Netze habe ich erhalten und darauf hin wurden die drei Tie-constraints automatisch definiert. Allerdings wurden diese danach nicht in den constraints angezeigt ... (Ist das normal?)

Danach habe ich erst einmal die Spannungen, Dehnungen etc berechnen lassen. hat auch wunderbar funktioniert. in der *.odb halten die Flächen aneinander und die Spannungen etc ergeben Sinn.

Diese *.odb habe ich dann in einer neuen Datei als Orphanmesh importiert.In dieser tauchen nun auch die automatisch erstellten Tie-constraints auf. (6 constraints, Beeichnungen: ASSEMBLY_T0( /1/2 )_Modellname( -Node )) Wenn ich nun einen Datacheck starte bekomme ich folgende Meldung:

In Model: ...
following constraints are applied to regions that have been either deleted, renamed or suppressed:
ASSEMBLY_To_Modellname-Node
ASSEMBLY_T1_Modellname-Node
ASSEMBLY_T2_Modellname-Node

Am Ende habe ich diese constraints gelöscht und einfach drei eigene definiert.


In der .dat sind einige Warnungen erschienen. Hier die vier Haupttypen:

***WARNING: THE CONTACT AREA OR DISTRIBUTING WEIGHT ASSOCIATED WITH THE NSET
            ASSEMBLY__T0_PROBENSCHNITT-1_SN IS ZERO OR NEGATIVE. A ONE IS
            ASSUMED FOR THE CONTACT AREA IF THIS SURFACE IS USED IN A CONTACT
            CALCULATION. A ZERO IS ASSUMED FOR DISTRIBUTING WEIGHT FACTOR IF
            THE SURFACE IS USED IN A *COUPLING OR *SHELL TO SOLID COUPLING
            DEFINITION. PLEASE CHECK THAT THIS IS APPROPRIATE.
  *surface, type=ELEMENT, name=ASSEMBLY__T1_PROBENSCHNITT-1_M
  *surface, type=ELEMENT, name=ASSEMBLY__T1_PROBENSCHNITT-1_S
  *surface, type=NODE, name=ASSEMBLY__T1_PROBENSCHNITT-1_SN

***WARNING: IF SIGNIFICANT CLEARANCE/OVERCLOSURE EXISTS BETWEEN SURFACE PAIR
            (ASSEMBLY__T0_PROBENSCHNITT-1_S,ASSEMBLY__T0_PROBENSCHNITT-1_M)
            AND THE MASTER SURFACE DOES NOT HAVE ROTATIONAL DEGREES OF
            FREEDOM, ADJUSTMENT IS RECOMMENDED FOR CORRECT ENFORCEMENT OF THE
            TIE CONSTRAINT
  *tie, name=ASSEMBLY__T0_PROBENSCHNITT-1-NODES, adjust=NO
# Habe irgendwie das Gefühl, das es sich hierbei um die entscheidende Warnung handelt?

***WARNING: SLAVE SURFACE ASSEMBLY__T0_PROBENSCHNITT-1_SN IS A NODE-BASED
            SURFACE USED WITH SURFACE TO SURFACE APPROACH.  IN ORDER TO OBTAIN
            IMPROVED STRESS ACCURACY WITH THIS APPROACH, AN ELEMENT-BASED
            SURFACE SHOULD BE USED INSTEAD.

***WARNING: OVERCONSTRAINT CHECKS: NODE 90773 INSTANCE PROBENSCHNITT-1 IS USED
            MORE THAN ONCE AS A SLAVE NODE IN THE *TIE KEYWORD.  THE
            CONSTRAINT BETWEEN THIS NODE AND THE MASTER SURFACE WITH NODE 79
            INSTANCE PROBENSCHNITT-1 IS REMOVED.
# Hier handelt es sich einfach um die Slave-Nodes auf den inneren Kanten die für zwei constraints benutzt wurden. Diese scheint er aber einfach gelöscht zu haben.

node-to surface habe ich probiert ... hat leider nicht geholfen.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

kmarc87
Mitglied
computational engineer

Sehen Sie sich das Profil von kmarc87 an!   Senden Sie eine Private Message an kmarc87  Schreiben Sie einen Gästebucheintrag für kmarc87

Beiträge: 4
Registriert: 27.04.2015

ABAQUS/CAE 6.14-2

erstellt am: 29. Apr. 2015 09:31    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke für die Antwort.

Die Einstellung der Position Tolerance habe ich bisher automatisch vornehmen lassen. Teste es gleich mal mit einer manuellen Einstellung.

Bei den Master-Slave Flächen habe ich beide Varianten ausprobiert, da die Nettze am Übergang relativ gleich groß sind. Hat keinen Unterschied gemacht.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz