Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SolidWorks
  Performanceproblem mit importierter STEP-Datei

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Performanceproblem mit importierter STEP-Datei (629 mal gelesen)
Maybaum
Mitglied
Dipl.-Ing. (FH); Konstrukteur


Sehen Sie sich das Profil von Maybaum an!   Senden Sie eine Private Message an Maybaum  Schreiben Sie einen Gästebucheintrag für Maybaum

Beiträge: 22
Registriert: 27.09.2004

SolidWorks Premium 2018-SP4
DELL Precision 7820 Tower
Intel(R)Xeon(R)Gold 6134 CPU @ 3.2GHz 3.19GHz
32GB RAM; 64 bit; NVIDIA Quadro P5000
Windows 10 Pro für Workstations Vers. 1803

erstellt am: 15. Feb. 2019 13:02    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

vom Kunden habe ich eine 590MB große STEP-Datei (PKW-Getriebe mit inneren Komponenten) erhalten und in 25 Minuten auf lokaler Festplatte importiert. Als SWX-ASM-Datei hat sie 446 MB. Dies ist natürlich eine recht große Datei. Sie reagiert zeitweise sehr gut auf zoomen, drehen, Befehle wie Bauteile ausblenden oder unterdrücken. Dann plötzlich friert die Anwendung für unbestimmte Zeit ein. Ausblenden bzw. Unterdrücken von aktuell nicht benötigten Komponenten bringt etwas, aber auch dann stockt es immer wieder. Da ich schon lokal arbeite und der Rechner eine sehr hochwertige Ausstattung hat, frage ich mich, was ich noch anders einstellen muss oder ob irgendeine Hardware falsche Einstellungen hat. Die Grafik macht ja auch zeitweise Probleme- siehe separates Thema. Mir ist schon bewußt, das diese importierten Dateien Probleme machen, aber ich muss ja damit arbeiten und das permanente Warten, das der Rechner wieder reagiert, nervt gewaltig! Zumal einem die Zeit davon läuft...
Aktuell versuche ich es noch mit anderen Importoptionen, da ich festgestellt habe, das die Baugruppe keine zugehörigen Bauteile extern gespeichert hat. Als ich sie mit Pack and Go vom Server nach lokal kopieren wollte, sah ich das noch 6 Step-Dateien verknüpft sind. Diese wurden aber beim Speichern nach dem Import nicht gespeichert, sind also nich sichtbar.
Weiß jemand Rat?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Krümmel
Moderator
Dreher Produktentwicklung Prototypenbau




Sehen Sie sich das Profil von Krümmel an!   Senden Sie eine Private Message an Krümmel  Schreiben Sie einen Gästebucheintrag für Krümmel

Beiträge: 6149
Registriert: 14.09.2008

Was mit SWX so alles geht ;-)

erstellt am: 15. Feb. 2019 14:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Maybaum 10 Unities + Antwort hilfreich

Hallo,

hast Du eine Importdiagnose ausgeführt ?

Wenn in einer Datei dieser Größe auch noch Geometriefehler vorhanden sind...... 

Grüße Andreas 

------------------
Stillstand ist Rückschritt

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Heiko Soehnholz
Ehrenmitglied V.I.P. h.c.
Dipl.-Ing. Maschinenbau



Sehen Sie sich das Profil von Heiko Soehnholz an!   Senden Sie eine Private Message an Heiko Soehnholz  Schreiben Sie einen Gästebucheintrag für Heiko Soehnholz

Beiträge: 3965
Registriert: 03.07.2002

SOLIDWORKS seit 2001
CSWS-TSO/MD/TMD
CSWS-C/D/I/MBD/VIS
CSWP-Core/DT/MT/SM/SU/WD
CSWE CSSP CSPP CSWI SWPUC
SOLIDWORKS 2019SP1
Simulation, Composer, MBD,
Inspection, PDMP, Visualize,
TopsWorks, TableAddIn etc.
WIN10x64 1809 HP ZBook 17 G5

erstellt am: 15. Feb. 2019 14:59    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Maybaum 10 Unities + Antwort hilfreich

Hallo,

und dann ist da noch die Frage, wie du damit arbeiten musst. Also: Was brauchst du wann wofür.

Ohne die Antwort bleibt die Frage, wie vereinfacht werden kann und darf, leider offen. Und es bleibt nur das Statement, dass die Performance Probleme schon durch das Gussgehäuse allein, erheblich sein dürften...

------------------
Einen schönen Gruß von Heiko
www.dps-software.dewww.iknow-solidworks.dewww.youtube.de/dpssoftwaregmbh

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Maybaum
Mitglied
Dipl.-Ing. (FH); Konstrukteur


Sehen Sie sich das Profil von Maybaum an!   Senden Sie eine Private Message an Maybaum  Schreiben Sie einen Gästebucheintrag für Maybaum

Beiträge: 22
Registriert: 27.09.2004

SolidWorks Premium 2018-SP4
DELL Precision 7820 Tower
Intel(R)Xeon(R)Gold 6134 CPU @ 3.2GHz 3.19GHz
32GB RAM; 64 bit; NVIDIA Quadro P5000
Windows 10 Pro für Workstations Vers. 1803

erstellt am: 15. Feb. 2019 16:46    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Heiko,
im aktuellen Fall benötige ich alle Bauteile. Ich muss prüfen ob ich Wellen mit Zahnrädern, die innerhalb des Gehäuses sind, nach außen verlängern und von dort antreiben kann.
Grüße
Peter

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Maybaum
Mitglied
Dipl.-Ing. (FH); Konstrukteur


Sehen Sie sich das Profil von Maybaum an!   Senden Sie eine Private Message an Maybaum  Schreiben Sie einen Gästebucheintrag für Maybaum

Beiträge: 22
Registriert: 27.09.2004

SolidWorks Premium 2018-SP4
DELL Precision 7820 Tower
Intel(R)Xeon(R)Gold 6134 CPU @ 3.2GHz 3.19GHz
32GB RAM; 64 bit; NVIDIA Quadro P5000
Windows 10 Pro für Workstations Vers. 1803

erstellt am: 15. Feb. 2019 16:56    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Andreas,
die Importdiagnose wurde laut Importoptionen automatisch durchgeführt und es gibt keine Fehlermeldung.
Grüße Peter

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Krümmel
Moderator
Dreher Produktentwicklung Prototypenbau




Sehen Sie sich das Profil von Krümmel an!   Senden Sie eine Private Message an Krümmel  Schreiben Sie einen Gästebucheintrag für Krümmel

Beiträge: 6149
Registriert: 14.09.2008

Was mit SWX so alles geht ;-)

erstellt am: 15. Feb. 2019 18:31    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Maybaum 10 Unities + Antwort hilfreich


F2_031940_1.JPG


F2_031940_2.JPG

 
Hallo,

hast Du diese Prüfung wirklich mit allen Bauteilen einzeln ausgeführt ? --------------------->

Dieser Haken in den Optionen gesetzt gilt , soweit mir bekannt , nur für Einzelteile nicht für einen Baugruppenimport.------------->

Such Dir mal ein komplexes ( Getriebegehäuse z.B.) Bauteil , mach einen Rechtsklick auf den Import und dann mal auf Importdiagnose klicken.

Grüße Andreas 

------------------
Stillstand ist Rückschritt

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Christian_W
Ehrenmitglied V.I.P. h.c.
Konstrukteur (Dipl-Ing)


Sehen Sie sich das Profil von Christian_W an!   Senden Sie eine Private Message an Christian_W  Schreiben Sie einen Gästebucheintrag für Christian_W

Beiträge: 2180
Registriert: 04.04.2001

SWX 2016sp5 WIN7-64
proAlpha6.2e/calinkV9
(Tactonworks)
(Medusa7, NesCAD2010,
solidEdge19) CSWP 12/2015

erstellt am: 17. Feb. 2019 02:02    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Maybaum 10 Unities + Antwort hilfreich

Zitat:
... zeitweise sehr gut auf zoomen, drehen, Befehle wie Bauteile ausblenden oder unterdrücken. Dann plötzlich friert die Anwendung für unbestimmte Zeit ein...

Hallo,

springt da die temporäre Sicherung an?

Gruß, Christian

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Maybaum
Mitglied
Dipl.-Ing. (FH); Konstrukteur


Sehen Sie sich das Profil von Maybaum an!   Senden Sie eine Private Message an Maybaum  Schreiben Sie einen Gästebucheintrag für Maybaum

Beiträge: 22
Registriert: 27.09.2004

SolidWorks Premium 2018-SP4
DELL Precision 7820 Tower
Intel(R)Xeon(R)Gold 6134 CPU @ 3.2GHz 3.19GHz
32GB RAM; 64 bit; NVIDIA Quadro P5000
Windows 10 Pro für Workstations Vers. 1803

erstellt am: 05. Mrz. 2019 12:58    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Andreas,
ich habe eben mal versucht, die den Befehl Importdiagnose nachträglich auszuwählen, aber er erscheint nicht! Wie beschrieben hat SWX übergeordnet eine Baugruppe erzeugt und im Featurebaum befinden sich Dateien mit Endung STP. Im Auswahlfenster durch Rechtsklick erscheint keine Importdiagnose.


Inzwischen habe ich beim Kunden Rohdaten angefordert und eine CATIA-Datei von 654 MB erhalten. Import lokal dauerte 24 h plus ca. 1h speichern. Leider ist diese Datei jetzt 1300 MB groß und ein Part. Falls ich noch Zeit für weitere Tests habe, werde ich mal versuchen, die Komponenten aufzulösen.

Bei diesem Import habe ich die Importdiagnose nicht durchgeführt, da diese vermutlich Tage dauern würde. Jetzt will mir der Kunde einzelne Bauteile exportieren, damit ich voran komme.


Gruß Peter


[Diese Nachricht wurde von Maybaum am 05. Mrz. 2019 editiert.]

[Diese Nachricht wurde von Maybaum am 05. Mrz. 2019 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Maybaum
Mitglied
Dipl.-Ing. (FH); Konstrukteur


Sehen Sie sich das Profil von Maybaum an!   Senden Sie eine Private Message an Maybaum  Schreiben Sie einen Gästebucheintrag für Maybaum

Beiträge: 22
Registriert: 27.09.2004

SolidWorks Premium 2018-SP4
DELL Precision 7820 Tower
Intel(R)Xeon(R)Gold 6134 CPU @ 3.2GHz 3.19GHz
32GB RAM; 64 bit; NVIDIA Quadro P5000
Windows 10 Pro für Workstations Vers. 1803

erstellt am: 05. Mrz. 2019 13:16    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Christian,
die Autosicherung war bisher auf 5 Minuten eingestellt und sie dauert sicher auch einige Zeit bei der Datenmenge. Ich versuche es jetzt mal mit 10 Minuten...
Grüße
Peter

[Diese Nachricht wurde von Maybaum am 05. Mrz. 2019 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

goofy_ac
Mitglied
Produktentwickler


Sehen Sie sich das Profil von goofy_ac an!   Senden Sie eine Private Message an goofy_ac  Schreiben Sie einen Gästebucheintrag für goofy_ac

Beiträge: 813
Registriert: 20.06.2006

Dell Precision 7720; i7/7920@3,1GHz
Quadro P5000; 32GB; Win10x64 prof.
SWX2017 SP5; dbWorks 16 SP 2.0

erstellt am: 05. Mrz. 2019 16:38    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Maybaum 10 Unities + Antwort hilfreich

Hi Peter

es erfordert Disziplin, aber... wir sind von der Autosicherung komplett weg, haben sie deaktiviert. Man gewöhnt sich sehr schnell daran, abzuwägen, ob ein neuer Speichervorgang angebracht ist, oder nicht. Und dann speichert SWX eben nur dann, wenn ICH es möchte, und nicht, wenn das Programm es will... Gerade bei richtig großen BG bekommst Du einen ganz anderen Rhythmus, ein anderes Tempo. Es ist ja nicht so, dass Du ohne die Daten unterwegs bist, die bekommen halt nur DEINEN Speicherstempel aufgedrückt. An das <STRG> S denkst Du irgendwann nicht mehr, geht instinktiv

Viele Grüße - Axel

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

- HH -
Mitglied
Konstrukteur Automatisierungstechnik


Sehen Sie sich das Profil von - HH - an!   Senden Sie eine Private Message an - HH -  Schreiben Sie einen Gästebucheintrag für - HH -

Beiträge: 169
Registriert: 26.11.2004

SWX 2018 SP5.0
HPZ440 Workstation
Intel Xeon CPU E5-1620 v4 @3,50GHz
32GB RAM
Quadro M4000

erstellt am: 11. Mrz. 2019 15:01    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Maybaum 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von goofy_ac:
Hi Peter

es erfordert Disziplin, aber... wir sind von der Autosicherung komplett weg, haben sie deaktiviert.


Ja das hatte ich auch immer eingestellt, dann plötzlich hat SWX gemeint es speichert die Baugruppe nicht mehr obwohl ich mehrmals speichern gedrückt habe. Es gab aber auch keine Fehlermeldung. Vermutlich lag es daran dass wir alle Daten über das Netzwerk öffnen und speichern. Die SWX Hotline hat gemeint es liegt am Netzwerk, die EDV hat gemeint es liegt am Solidworks.    Da es nicht mehr reproduzierbar ist, kann man es auch nicht mehr sagen. Ich arbeiten auch wieder mit Autosicherung.

mfg

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz