Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  CATIA V5 Infrastruktur
  Windows Script Host, V5R16 auf Vista x64

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Windows Script Host, V5R16 auf Vista x64 (1233 mal gelesen)
  
Die Gewinne der Zukunft werden mit intelligenten, autonomen Elektrofahrzeugen eingefahren. (3DEXPERIENCE)
Didyer
Mitglied



Sehen Sie sich das Profil von Didyer an!   Senden Sie eine Private Message an Didyer  Schreiben Sie einen Gästebucheintrag für Didyer

Beiträge: 34
Registriert: 14.05.2008

HARDWARE:
---------
Intel Xeon X5660
24 GB RAM
Win7 x64
ProE Wildfire 4.0 M190
CATIA V5R19-SP9 x64
Ansys Workbench 14.0.1

erstellt am: 03. Mrz. 2009 16:57    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Fehler_Q-Checker.jpg


wsh_error_2.jpg

 
Liebe Forum-Mitglieder,

ich habe ein Problem mit CATIA V5R16 mit Daimler Zulieferpaket auf Windows Vista x64, SP2.
Prinzipiell funktioniert alles wunderbar, in Kombination mit dem Q-Checker erhalte ich allerdings am Ende die beiden angehängten Fehlermeldungen.
Zuerst funktioniert der Q-Checker ganz normal, alles wird geprüft, angezeigt, gehealt etc. und nach dem abschließen Klick auf "Close" kommen die beiden Fehlermeldungen.

Ich bin auf dem System Administrator, Benutzerkontensteuerung ist deaktiviert.

Vielen Dank im Voraus für Eure Antworten,

Didyer

------------------
Intel Core 2 Duo
E8400 @ 3.00GHz
8 GB RAM

WinXP Pro x64
CATIA V5R17 x64

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Axel.Strasser
Ehrenmitglied V.I.P. h.c.
Selbstständig im Bereich PLM/CAx



Sehen Sie sich das Profil von Axel.Strasser an!   Senden Sie eine Private Message an Axel.Strasser  Schreiben Sie einen Gästebucheintrag für Axel.Strasser

Beiträge: 4107
Registriert: 12.03.2001

Früher war vieles gut, und das wäre es heute immer noch, wenn man die Finger davon gelassen hätte!

erstellt am: 03. Mrz. 2009 17:13    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Didyer 10 Unities + Antwort hilfreich

Hast Du mal versucht ein einfaches vbs zu machen
z.B.
Code:
msgbox "Hallo world"

und dieses auszuführen ?

Axel

------------------
Inoffizielle deutsche CATIA Hilfeseite  Netiquette von cad.de

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Didyer
Mitglied



Sehen Sie sich das Profil von Didyer an!   Senden Sie eine Private Message an Didyer  Schreiben Sie einen Gästebucheintrag für Didyer

Beiträge: 34
Registriert: 14.05.2008

erstellt am: 03. Mrz. 2009 17:25    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

habe das von Dir vorgeschlagene Script erstellt - wird ohne Fehlermeldung oder sonstiges ausgeführt und die Messagebox angezeigt...
Habe das Daimler-Supportpaket neu installiert - hat leider auch nichts gebracht.

So weiß ich jetzt nicht mal, ob es ein Vista- oder ein CATIA-Problem ist.

Hat noch jemand eine Idee?

Danke, Didyer

------------------
Intel Core 2 Duo
E8400 @ 3.00GHz
8 GB RAM

WinXP Pro x64
CATIA V5R17 x64

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Axel.Strasser
Ehrenmitglied V.I.P. h.c.
Selbstständig im Bereich PLM/CAx



Sehen Sie sich das Profil von Axel.Strasser an!   Senden Sie eine Private Message an Axel.Strasser  Schreiben Sie einen Gästebucheintrag für Axel.Strasser

Beiträge: 4107
Registriert: 12.03.2001

Früher war vieles gut, und das wäre es heute immer noch, wenn man die Finger davon gelassen hätte!

erstellt am: 03. Mrz. 2009 18:02    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Didyer 10 Unities + Antwort hilfreich

Hast Du den 64bit Q-Checker ?

Axel

------------------
Inoffizielle deutsche CATIA Hilfeseite  Netiquette von cad.de

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Didyer
Mitglied



Sehen Sie sich das Profil von Didyer an!   Senden Sie eine Private Message an Didyer  Schreiben Sie einen Gästebucheintrag für Didyer

Beiträge: 34
Registriert: 14.05.2008

erstellt am: 03. Mrz. 2009 18:19    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Axel,

der Q-Checker wird mit dem Daimler-Paket mitgeliefert, nur die Lizenz ist separat zu beziehen.
Bei meinem Kollegen funktioniert die gleiche Konfiguration - also Vista x64 mit V5R16 x32 und Daimler-Paket Build10 - allerdings auf anderem Rechner ohne Probleme.

Q-Checker x64 würde mit Daimler x32 sowieso nicht funktionieren, oder???

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Lusilnie
Mitglied



Sehen Sie sich das Profil von Lusilnie an!   Senden Sie eine Private Message an Lusilnie  Schreiben Sie einen Gästebucheintrag für Lusilnie

Beiträge: 1486
Registriert: 13.07.2005

erstellt am: 03. Mrz. 2009 20:55    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Didyer 10 Unities + Antwort hilfreich

Hallo Didyer,

aus der Fehlermeldung Nummer 1 würde ich auf einen Windows-Konfigurationsfehler schließen!

Wie die Fehlermeldung schon sagt, scheint das Ausführen von WindowsScript (.wsh) nicht erlaubt zu sein. Beim QChecker finde ich aber an verschiedenen Stellen die Nutzung von WSH, um diverse Sachen auszuführen, Parameter einzulesen oder ähnliches. (Wozu genau, ob immer und warum die WindowsScripte genutzt werden, weiß ich auch nicht, ich habe sie nur im Installationsumfang von QChecker gefunden!)

Versuche doch mal vom Kommando-Fenster ("cmd" - falls es dies unter VISTA noch gibt!) "wscript.exe" oder "cscript.exe" auszuführen. Wenn Du die Fehlermeldung Nummer 1 bekommst, hast Du den Grund gefunden! Dann musst Du die Sicherheitseinstellungen lockern und das Ausführen von "Windows Script Host" zulassen!


mfg,
Lusilnie

------------------
Alle Aussagen zu DassaultSystemes-Produkten sind sehr optimistisch, selbst diese!!!

frei nach größeren Geistern

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Didyer
Mitglied



Sehen Sie sich das Profil von Didyer an!   Senden Sie eine Private Message an Didyer  Schreiben Sie einen Gästebucheintrag für Didyer

Beiträge: 34
Registriert: 14.05.2008

HARDWARE:
---------
Intel Xeon X5660
24 GB RAM
Win7 x64
ProE Wildfire 4.0 M190
CATIA V5R19-SP9 x64
Ansys Workbench 14.0.1

erstellt am: 04. Mrz. 2009 08:58    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Lusilnie,

wie auch Axels Versuch mit der Message-Box schon gezeigt hat kann der von mir verwendete User Scripte ausführen - es kommt keine Fehlermeldung.
Wenn ich die von Dir beschriebene Vorgehesweise verwende erhalte ich bei "wscript" das Optionenfenster und bei "cscript" eine Übersicht der Optionen im command-screen - beides ohne Fehlermeldung...

Daraus würde ich schlußfolgern, dass es doch ein CATIA-Problem ist, oder???

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Lusilnie
Mitglied



Sehen Sie sich das Profil von Lusilnie an!   Senden Sie eine Private Message an Lusilnie  Schreiben Sie einen Gästebucheintrag für Lusilnie

Beiträge: 1486
Registriert: 13.07.2005

erstellt am: 05. Mrz. 2009 00:20    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Didyer 10 Unities + Antwort hilfreich

Hallo Didyer,

nach "Wissen auskramen" und "QChecker nachschauen" würde ich noch mal eine ganz dumme Frage stellen:
Ist ".html" mit einer Anwendung verknüpft?

Weiterer Ansatz: Kannst Du "wscript.shell" definieren und ein Kommando ausführen? Zum Beispiel:

Code:
set obj.Shell = wscript.createObject("Wscript.shell")
command = """notepad.exex"""
iReturn = objShell.Run(CStr(command),1)
wscript.quit
als "Test.vbs" gespeichert und ausgeführt. Ergebnis?


mfg,
Lusilnie

------------------
Alle Aussagen zu DassaultSystemes-Produkten sind sehr optimistisch, selbst diese!!!

frei nach größeren Geistern

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Didyer
Mitglied



Sehen Sie sich das Profil von Didyer an!   Senden Sie eine Private Message an Didyer  Schreiben Sie einen Gästebucheintrag für Didyer

Beiträge: 34
Registriert: 14.05.2008

HARDWARE:
---------
Intel Xeon X5660
24 GB RAM
Win7 x64
ProE Wildfire 4.0 M190
CATIA V5R19-SP9 x64
Ansys Workbench 14.0.1

erstellt am: 09. Mrz. 2009 21:14    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


VBS_Fehler.jpg

 
Hallo Lusilnie,

ich glaube, Du bist auf der richtigen Spur...
Also, wenn ich das test.vbs mit Deinem Code ausführe, erhalte ich die beigelegte Fehlermeldung.
Ich kann damit nix anfangen, aber vielleicht kannst Du mir noch weiter helfen.

.html und .htm sind mit Firefox verknüpft.

Hast Du einen Lösungsvorschlag???

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Lusilnie
Mitglied



Sehen Sie sich das Profil von Lusilnie an!   Senden Sie eine Private Message an Lusilnie  Schreiben Sie einen Gästebucheintrag für Lusilnie

Beiträge: 1486
Registriert: 13.07.2005

erstellt am: 09. Mrz. 2009 22:46    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Didyer 10 Unities + Antwort hilfreich

Hallo Didyer,

sorry, da war es wohl doch schon etwas spät! Leider sind im Script 2 Fehler, korrekt sollte es so lauten:

Code:
set objShell = wscript.createObject("Wscript.shell")
command = """notepad.exe"""
iReturn = objShell.Run(CStr(command),1)
wscript.quit
Bitte korrigiere dies und teste es danach noch einmal. Wie ist nun das Ergebnis?


mfg,
Lusilnie

------------------
Alle Aussagen zu DassaultSystemes-Produkten sind sehr optimistisch, selbst diese!!!

frei nach größeren Geistern

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Didyer
Mitglied



Sehen Sie sich das Profil von Didyer an!   Senden Sie eine Private Message an Didyer  Schreiben Sie einen Gästebucheintrag für Didyer

Beiträge: 34
Registriert: 14.05.2008

HARDWARE:
---------
Intel Xeon X5660
24 GB RAM
Win7 x64
ProE Wildfire 4.0 M190
CATIA V5R19-SP9 x64
Ansys Workbench 14.0.1

erstellt am: 10. Mrz. 2009 11:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Lusilnie,

danke für Deine Korrekturen, jetzt siehts gleich gaaanz anders aus.

Jetzt gibts keine Fehlermeldung sondern es wird wie gewünscht ein Notepad-Fenster geöffnet - kein Fehler, kein Wiederstand, keine Probleme.

Hilft uns (und mir im Speziellen) das irgendwie weiter???

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Lusilnie
Mitglied



Sehen Sie sich das Profil von Lusilnie an!   Senden Sie eine Private Message an Lusilnie  Schreiben Sie einen Gästebucheintrag für Lusilnie

Beiträge: 1486
Registriert: 13.07.2005

erstellt am: 10. Mrz. 2009 23:46    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Didyer 10 Unities + Antwort hilfreich

Hallo Didyer,

nach diesem Test tippe ich nun auf ein Problem zwischen 64bit- und 32bit-Windows! Entweder, es gibt für beide ein "Windows Script Host" und nur 32bit ist aktiviert, oder im 64bit-CATIA ist der Pfad auf das 32bit-"Windows Script Host" nicht vorhanden.

Allerdings kann ich dies nicht testen, da ich kein 64bit-Windows und auch kein 64bit-CATIA zum Testen habe!


mfg,
Lusilnie

------------------
Alle Aussagen zu DassaultSystemes-Produkten sind sehr optimistisch, selbst diese!!!

frei nach größeren Geistern

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Didyer
Mitglied



Sehen Sie sich das Profil von Didyer an!   Senden Sie eine Private Message an Didyer  Schreiben Sie einen Gästebucheintrag für Didyer

Beiträge: 34
Registriert: 14.05.2008

HARDWARE:
---------
Intel Xeon X5660
24 GB RAM
Win7 x64
ProE Wildfire 4.0 M190
CATIA V5R19-SP9 x64
Ansys Workbench 14.0.1

erstellt am: 11. Mrz. 2009 11:36    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Lusilnie,

Danke auf jeden Fall für Deine Hilfe. Ich recherchiere mal ein bisschen wegen Skripting Host - ob x64 oder x32 - bei Microsoft.

Was ich nicht verstehe ist, warum bei meinem Kollegen mit gleicher Softwarekonfiguration, allerdings anderer Hardware, kein Problem auftritt...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz