Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  CATIA V5 Infrastruktur
  CATIA V5 R13 SP 6 ORACLE-Fehler

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   CATIA V5 R13 SP 6 ORACLE-Fehler (857 mal gelesen)
  
Die Gewinne der Zukunft werden mit intelligenten, autonomen Elektrofahrzeugen eingefahren. (3DEXPERIENCE)
msf_fred
Mitglied


Sehen Sie sich das Profil von msf_fred an!   Senden Sie eine Private Message an msf_fred  Schreiben Sie einen Gästebucheintrag für msf_fred

Beiträge: 6
Registriert: 09.11.2004

Solaris 8;
AIX 5 ML2;
Oracle 8.1.7;
V5 R13 SP 6;
VPM 1.5 PTF24 (PTF 5,9)

erstellt am: 09. Nov. 2004 14:25    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo!

Ich versuche CATIA V5, inkl. DMU-Navigator zu unserer VPM-Datenbank zu verbinden.
Auf SunOS 5.8 stuerzt das Programm CATDBENV ab, wenn ich versuche, die Datenbankverbindung zur ORACLE-Datenbank zu testen.

Fehler:

ld.so.1: CATDBENV: fatal: relocation error: file /net/appl/catsite/sw/B13.06/solaris_a/code/bin/libOracleGLUE.so: symbol OCIInitialize: referenced symbol not found
Killed

Dieser Fehler tritt auf AIX nicht auf!

Hat jemand in der Gemeinde einen Tipp, woran das liegen kann.

Danke im Voraus

  Fred!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Stefan_I
Mitglied
Ing HTL


Sehen Sie sich das Profil von Stefan_I an!   Senden Sie eine Private Message an Stefan_I  Schreiben Sie einen Gästebucheintrag für Stefan_I

Beiträge: 865
Registriert: 04.07.2001

CATIA 422R1
VPM1.6 PTF9
CATIA V5R26SP6
CATIA V6 2014x
AIX5.3-ML06
Windows 7 + 10 64Bit

erstellt am: 10. Nov. 2004 12:53    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für msf_fred 10 Unities + Antwort hilfreich

Hallo Fred,

hast Du schon einmal mit dem PTF-Cover Letter von VPM geschaut ob  alle Softwarestände auf dem richtigen Level sind ?

------------------
Gruss
Stefan Inderbitzin

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

msf_fred
Mitglied


Sehen Sie sich das Profil von msf_fred an!   Senden Sie eine Private Message an msf_fred  Schreiben Sie einen Gästebucheintrag für msf_fred

Beiträge: 6
Registriert: 09.11.2004

Solaris 8;
AIX 5 ML2;
Oracle 8.1.7;
V5 R13 SP 6;
VPM 1.5 PTF24 (PTF 5,9)

erstellt am: 10. Nov. 2004 13:12    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Stefan!

Meinst Du die VPM - PreRequisits?

In der Shell habe ich das V5R13-Environment, sowie die ORACLE-Umgebungsvariablen gesetzt!

Das Programm CATDBENV starte ich dann aus der Shell!

Ich denke fuer diese Operation brauche ich noch keine VPM!

danke vorerst!

Aber was meinst Du!

lg. Fred

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Stefan_I
Mitglied
Ing HTL


Sehen Sie sich das Profil von Stefan_I an!   Senden Sie eine Private Message an Stefan_I  Schreiben Sie einen Gästebucheintrag für Stefan_I

Beiträge: 865
Registriert: 04.07.2001

CATIA 422R1
VPM1.6 PTF9
CATIA V5R26SP6
CATIA V6 2014x
AIX5.3-ML06
Windows 7 + 10 64Bit

erstellt am: 10. Nov. 2004 13:17    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für msf_fred 10 Unities + Antwort hilfreich

Hallo Fred!

ja die meine ich. Vielleicht ist die libOracleGLUE.so Library nicht mit Deiner Umgebung kompatibel.

------------------
Gruss
Stefan Inderbitzin

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

msf_fred
Mitglied


Sehen Sie sich das Profil von msf_fred an!   Senden Sie eine Private Message an msf_fred  Schreiben Sie einen Gästebucheintrag für msf_fred

Beiträge: 6
Registriert: 09.11.2004

Solaris 8;
AIX 5 ML2;
Oracle 8.1.7;
V5 R13 SP 6;
VPM 1.5 PTF24 (PTF 5,9)

erstellt am: 10. Nov. 2004 17:47    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Stefan!

Ja, Danke!

Dann reden wir von dem selben!

Ja habe ich kontrolliert. Die Betriebssystem-Voraussetzungen sind erfuellt!

Zum Test der Datenbankverbindung reicht es aus, wenn in der Shell die DMU-Navigator- und die ORACLE-Umgebungsvariablen gesetzt sind.
Das funktioniert bei uns fuer AIX 5.2 nicht aber auf Solaris 8.
Zum setzen der Umgebungsvariablen verwenden wir das gleiche Skript.

Ich glaube deshalb, das es an der Software fuer  Solaris liegt!

hast Du auch Erfahrung mit Solaris 8?

lg. Fred

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Stefan_I
Mitglied
Ing HTL


Sehen Sie sich das Profil von Stefan_I an!   Senden Sie eine Private Message an Stefan_I  Schreiben Sie einen Gästebucheintrag für Stefan_I

Beiträge: 865
Registriert: 04.07.2001

CATIA 422R1
VPM1.6 PTF9
CATIA V5R26SP6
CATIA V6 2014x
AIX5.3-ML06
Windows 7 + 10 64Bit

erstellt am: 11. Nov. 2004 07:44    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für msf_fred 10 Unities + Antwort hilfreich

Hallo Fred,

nein leider (oder zum Glück ?) nicht. Unsere Hauptplatform ist AIX. Ich hatte früher einmal VPM auf AIX und Irix parallel am laufen. Das war aber eher mühsam. Vor allem bei der Programmiererei bin ich so ziemlich auf die Welt gekommen. Was auf AIX problemlos lief, führte zu ekligen, Problemen auf Irix. Ich war schlussendlich erstaunt, wie gut die DS Leute, den CATIA Code auf den SGI's zum laufen gebracht haben.

Viel Glück noch beim Lösen eures Problems, vielleicht kennt sich ja ein anderer besser aus.

------------------
Gruss
Stefan Inderbitzin

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

msf_fred
Mitglied


Sehen Sie sich das Profil von msf_fred an!   Senden Sie eine Private Message an msf_fred  Schreiben Sie einen Gästebucheintrag für msf_fred

Beiträge: 6
Registriert: 09.11.2004

Solaris 8;
AIX 5 ML2;
Oracle 8.1.7;
V5 R13 SP 6;
VPM 1.5 PTF24 (PTF 5,9)

erstellt am: 11. Nov. 2004 09:50    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke fuer die Bemuehungen!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Sascha_Terlau
Mitglied
Student


Sehen Sie sich das Profil von Sascha_Terlau an!   Senden Sie eine Private Message an Sascha_Terlau  Schreiben Sie einen Gästebucheintrag für Sascha_Terlau

Beiträge: 21
Registriert: 01.02.2002

erstellt am: 04. Apr. 2005 09:54    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für msf_fred 10 Unities + Antwort hilfreich

Hallo,

ich habe auch lange nach einer Lösung gesucht und dann auch gefunden!!
(Das ganze mit Oracle 8.1.7 und CATIA R14 SP3)

Wenn du auf Solaris den Befehl:
    ldd libOracleGLUE.so

ausführst, siehst du einen Eintrag:
    libclntsh.so.9.0 =>      (file not found)

Dann musst du im $ORACLE_HOME/lib einen Link erstellen, denn dort gibt
es nur die Datei libclntsh.so.8.0

    ln -s libclntsh.so.8.0 libclntsh.so.9.0

Danach funktioniert es.

Gruß

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz