Forum:CATIA V5 Infrastruktur
Thema:CATIA V5 R13 SP 6 ORACLE-Fehler
Möchten Sie sich registrieren?
Wer darf antworten? Registrierte Benutzer können Beiträge verfassen.
Hinweise zur Registrierung Sie müssen registriert sein, um Beiträge oder Antworten auf Beiträge schreiben zu können.
Ihr Benutzername:
Ihr Kennwort:   Kennwort vergessen?
Anhang:    Datei(en) anhängen  <?>   Anhänge verwalten  <?>
Grafik für den Beitrag:                                                
                                                       
Ihre Antwort:

Fachbegriff
URL
Email
Fett
Kursiv
Durchgestr.
Liste
*
Bild
Zitat
Code

*HTML ist AUS
*UBB-Code ist AN
Smilies Legende
Netiquette

10 20 40

Optionen Smilies in diesem Beitrag deaktivieren.
Signatur anfügen: die Sie bei den Voreinstellungen angegeben haben.

Wenn Sie bereits registriert sind, aber Ihr Kennwort vergessen haben, klicken Sie bitte hier.

Bitte drücken Sie nicht mehrfach auf "Antwort speichern".

*Ist HTML- und/oder UBB-Code aktiviert, dann können Sie HTML und/oder UBB Code in Ihrem Beitrag verwenden.

T H E M A     A N S E H E N
msf_fred

Beiträge: 6 / 0

Solaris 8;
AIX 5 ML2;
Oracle 8.1.7;
V5 R13 SP 6;
VPM 1.5 PTF24 (PTF 5,9)

Hallo!

Ich versuche CATIA V5, inkl. DMU-Navigator zu unserer VPM-Datenbank zu verbinden.
Auf SunOS 5.8 stuerzt das Programm CATDBENV ab, wenn ich versuche, die Datenbankverbindung zur ORACLE-Datenbank zu testen.

Fehler:

ld.so.1: CATDBENV: fatal: relocation error: file /net/appl/catsite/sw/B13.06/solaris_a/code/bin/libOracleGLUE.so: symbol OCIInitialize: referenced symbol not found
Killed

Dieser Fehler tritt auf AIX nicht auf!

Hat jemand in der Gemeinde einen Tipp, woran das liegen kann.

Danke im Voraus

  Fred!

Stefan_I

Beiträge: 865 / 1

CATIA 422R1
VPM1.6 PTF9
CATIA V5R26SP6
CATIA V6 2014x
AIX5.3-ML06
Windows 7 + 10 64Bit

Hallo Fred,

hast Du schon einmal mit dem PTF-Cover Letter von VPM geschaut ob  alle Softwarestände auf dem richtigen Level sind ?

------------------
Gruss
Stefan Inderbitzin

msf_fred

Beiträge: 6 / 0

Solaris 8;
AIX 5 ML2;
Oracle 8.1.7;
V5 R13 SP 6;
VPM 1.5 PTF24 (PTF 5,9)

Hallo Stefan!

Meinst Du die VPM - PreRequisits?

In der Shell habe ich das V5R13-Environment, sowie die ORACLE-Umgebungsvariablen gesetzt!

Das Programm CATDBENV starte ich dann aus der Shell!

Ich denke fuer diese Operation brauche ich noch keine VPM!

danke vorerst!

Aber was meinst Du!

lg. Fred

Stefan_I

Beiträge: 865 / 1

CATIA 422R1
VPM1.6 PTF9
CATIA V5R26SP6
CATIA V6 2014x
AIX5.3-ML06
Windows 7 + 10 64Bit

Hallo Fred!

ja die meine ich. Vielleicht ist die libOracleGLUE.so Library nicht mit Deiner Umgebung kompatibel.

------------------
Gruss
Stefan Inderbitzin

msf_fred

Beiträge: 6 / 0

Solaris 8;
AIX 5 ML2;
Oracle 8.1.7;
V5 R13 SP 6;
VPM 1.5 PTF24 (PTF 5,9)

Hallo Stefan!

Ja, Danke!

Dann reden wir von dem selben!

Ja habe ich kontrolliert. Die Betriebssystem-Voraussetzungen sind erfuellt!

Zum Test der Datenbankverbindung reicht es aus, wenn in der Shell die DMU-Navigator- und die ORACLE-Umgebungsvariablen gesetzt sind.
Das funktioniert bei uns fuer AIX 5.2 nicht aber auf Solaris 8.
Zum setzen der Umgebungsvariablen verwenden wir das gleiche Skript.

Ich glaube deshalb, das es an der Software fuer  Solaris liegt!

hast Du auch Erfahrung mit Solaris 8?

lg. Fred

Stefan_I

Beiträge: 865 / 1

CATIA 422R1
VPM1.6 PTF9
CATIA V5R26SP6
CATIA V6 2014x
AIX5.3-ML06
Windows 7 + 10 64Bit

Hallo Fred,

nein leider (oder zum Glück ?) nicht. Unsere Hauptplatform ist AIX. Ich hatte früher einmal VPM auf AIX und Irix parallel am laufen. Das war aber eher mühsam. Vor allem bei der Programmiererei bin ich so ziemlich auf die Welt gekommen. Was auf AIX problemlos lief, führte zu ekligen, Problemen auf Irix. Ich war schlussendlich erstaunt, wie gut die DS Leute, den CATIA Code auf den SGI's zum laufen gebracht haben.

Viel Glück noch beim Lösen eures Problems, vielleicht kennt sich ja ein anderer besser aus.

------------------
Gruss
Stefan Inderbitzin

msf_fred

Beiträge: 6 / 0

Solaris 8;
AIX 5 ML2;
Oracle 8.1.7;
V5 R13 SP 6;
VPM 1.5 PTF24 (PTF 5,9)

Danke fuer die Bemuehungen!
Sascha_Terlau

Beiträge: 21 / 0

Hallo,

ich habe auch lange nach einer Lösung gesucht und dann auch gefunden!!
(Das ganze mit Oracle 8.1.7 und CATIA R14 SP3)

Wenn du auf Solaris den Befehl:
    ldd libOracleGLUE.so

ausführst, siehst du einen Eintrag:
    libclntsh.so.9.0 =>      (file not found)

Dann musst du im $ORACLE_HOME/lib einen Link erstellen, denn dort gibt
es nur die Datei libclntsh.so.8.0

    ln -s libclntsh.so.8.0 libclntsh.so.9.0

Danach funktioniert es.

Gruß