Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SolidWorks Simulation
  FlowSimulation Abbruch bei Iteration 50

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:  FlowSimulation Abbruch bei Iteration 50 (1579 mal gelesen)
Stefan Holtmann
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Stefan Holtmann an!   Senden Sie eine Private Message an Stefan Holtmann  Schreiben Sie einen Gästebucheintrag für Stefan Holtmann

Beiträge: 21
Registriert: 30.03.2011

erstellt am: 26. Mrz. 2012 08:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Moin,

ich habe bei mehreren Berechnungen mittlerweile das gleiche Problem. Immer wird nach genau 50 Iterationen abgebrochen. Die Teile welche berechnet werden sollen sind dabei bis auf ein Element immer verschieden. Das Element welches welches in allen Berechnungen vorkommt (auch die, die durchlaufen) würde ich als Fehlerquelle ausschliessen.
Wir setzen noch SW2009 5.1 mit der FlowSimulation ein. Ist jemandem vielleicht ein Problem mit der SW-Version bekannt, welche das Programm während der laufenden Berechnung beendet und dann ein Fehlerprotokoll senden möchte? Also zur Verdeutlichung: Die Berechnung an sich (das Fenster) bleibt auf und SW im Hintergrund wird beendet. Aber immer bei Iteration 50. Habe am Wochenende 3 Berechnungen angeworfen und bei 2 Berechnungen trat dieser Fehler auf. Aber leider nicht das erste Mal.

Kann mir jemand einen Tip geben, was ich ändern muss oder könnte?

Gruß und Danke

PS: Habe schon gehört, dass 2009 5.1 nicht wirklich der beste Patch ist.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

R. Frank
Moderator
Dipl-Ing. (BA) Masch.-Bau


Sehen Sie sich das Profil von R. Frank an!   Senden Sie eine Private Message an R. Frank  Schreiben Sie einen Gästebucheintrag für R. Frank

Beiträge: 1287
Registriert: 11.10.2004

Windows 7 Professional - 8 GB RAM
SWX 2012 SP 4.0 64 bit
PDMWorks 2012
FlowSimulation 2012 SP 4.0 - 64 bit
Simulation 2012 - 64 bit

erstellt am: 26. Mrz. 2012 09:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Stefan Holtmann 10 Unities + Antwort hilfreich

Hallo Stefan.

Aus dem Bauch heraus würde ich vermuten, daß Du (vorausgesetzt Ihr verwendet
ein 32bit-Betriebssystem) die Problematik hast, das Deine Simulation sehr
viel Speicher braucht.
FlowSimulation will zusammenhängende Speicherbereiche haben und wenn Dein
Swapfile fragmentiert ist, kommt es zu Abstürzen.

Hier hab ich mal was zur Abhilfe geschrieben.

Außerdem: Andere (nicht benötigte) Zusatzanwendungen abgeschaltet ?
Mal zur Sicherheit während der Simulation den Windows-Taskmanager öffnen und alles mal kritisch
beobachten.

Als letzte Massnahme könntest Du noch im Verzeichnis Deiner Flow-Simulation im entsprechenden Unterverzeichnis
z.B. \1 bei Projekt Nr. 1 die Datei 1.stdout mit dem Editor (Notepad) betrachten.
Ist zwar relativ viel Text aber vielleicht steht da ja was bei den warnings/errors, was Dir weiter hilft.

Gruß
Roland 

------------------
* Keymaster of the Masterkey *

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Stefan Holtmann
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Stefan Holtmann an!   Senden Sie eine Private Message an Stefan Holtmann  Schreiben Sie einen Gästebucheintrag für Stefan Holtmann

Beiträge: 21
Registriert: 30.03.2011

erstellt am: 26. Mrz. 2012 11:09    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Vielen Dank Roland für die schnelle Antwort.

Als Rechner nutzen wir einen 6Cor mit 16GB RAM auf und einem WinXP64 System.

Der Tip mit dem SwapFile geht nur unter 32Bit?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

R. Frank
Moderator
Dipl-Ing. (BA) Masch.-Bau


Sehen Sie sich das Profil von R. Frank an!   Senden Sie eine Private Message an R. Frank  Schreiben Sie einen Gästebucheintrag für R. Frank

Beiträge: 1287
Registriert: 11.10.2004

Windows 7 Professional - 8 GB RAM
SWX 2012 SP 4.0 64 bit
PDMWorks 2012
FlowSimulation 2012 SP 4.0 - 64 bit
Simulation 2012 - 64 bit

erstellt am: 27. Mrz. 2012 09:10    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Stefan Holtmann 10 Unities + Antwort hilfreich

Hallo Stefan.

Das mit dem Swap-File macht eigentlich nur so richtig Sinn bei 32bit
und hoher Speicherauslastung.
Da Ihr 64bit und 16GB RAM habt, kann ich mir nicht vorstellen, dass
hier der Flaschenhals liegt.

Ich fürchte eher, daß die Kombination 64 bit mit SWXSolidWorks 2009 nicht so optimal
ist.
Soweit ich weiß, wird das nicht offiziell von SWXSolidWorks supportet.

Auch die Simulation-interne Knowledgebase sagt aus, dass erst die Kombination
Win7 X64 mit SWX2010 so richtig funktioniert.

Gruß
Roland 

------------------
* Keymaster of the Masterkey *

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Stefan Holtmann
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Stefan Holtmann an!   Senden Sie eine Private Message an Stefan Holtmann  Schreiben Sie einen Gästebucheintrag für Stefan Holtmann

Beiträge: 21
Registriert: 30.03.2011

erstellt am: 24. Mai. 2012 11:09    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Zusammen,

lange hatten wir, wahrscheinlich wegen kleinerer Simulationen, keinen Ärger mehr mit den Abbrüchen bei der Iteration 50. Komisch ist, dass er immer dort abbricht wenn er mit der Rechnung begonnen hat. Das Problem mit dem Support besteht nicht. Ganz im Gegenteil ist SW2009 sogar nicht für Win7 zu gebrauchen weil es damit zu Konflikten kommt. WinXP64 ist daher von Dassault empfohlen, weshalb unsere CAD-Rechner aktuell auch die einzigsten sind, die noch nicht auf Win7 umgestellt wurden.

Da er immer bei Nr. 50 abbricht, muss ja dort was bestimmtes passieren. Leider kann ich nirgends dazu eine Idee oder Lösung finden. Auch der Support konnte mir da bisher nicht weiterhelfen. Sind wir denn die einzigen Nutzer, die hiermit ein Problem haben?

Gruß
Stefan

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

reflow
Mitglied
Dipl. Ing. Maschinenbau


Sehen Sie sich das Profil von reflow an!   Senden Sie eine Private Message an reflow  Schreiben Sie einen Gästebucheintrag für reflow

Beiträge: 439
Registriert: 27.10.2005

SWX 2013 SP 3.0 mit SolidWorks Flow Simulation, TopsWorks, SPI SheetmetalWorks,
Vista 64 Bit
Intel Q9400, 8GB RAM

erstellt am: 24. Mai. 2012 12:27    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Stefan Holtmann 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Stefan Holtmann:

....


WinXP64 ist daher von Dassault empfohlen, weshalb unsere CAD-Rechner aktuell auch die einzigsten sind, die noch nicht auf Win7 umgestellt wurden.

Da er immer bei Nr. 50 abbricht, muss ja dort was bestimmtes passieren. Leider kann ich nirgends dazu eine Idee oder Lösung finden. Auch der Support konnte mir da bisher nicht weiterhelfen. Sind wir denn die einzigen Nutzer, die hiermit ein Problem haben?

Gruß
Stefan


Moin Stefan,


ja, ich kann mich düster erinnern: lange, lange her, da hatte ich auch solche unerklärlichen Abbrüche, immer an einer bestimmten Iteration. Manchmal habe ich eine Simulation komplett neu definiert (sehr mühselig) und manchmal hat das geholfen.

Lösung hab' ich damals keine gefunden und hinter die Ursache bin ich auch nicht gekommen.

Ich bin dann aber schnellstmöglich von SWXSolidWorks 2009 über 2010 und 2011 auf 2012  und von XP 64 auf Vista 64 bzw W7-64 gewechselt.

Irgendwann hörten die Probleme auf - keine Ahnung mehr, wann.

Mittlerweile kann ich sagen, daß FloWorks akzeptabel stabil läuft.

Mit XP 64 verbinde ich persönlich sehr schlechte Erinnerungen - das vielgescholtene Vista 64 lief und bei läuft noch um Längen stabiler, unproblematischer, und auch komfortabler als XP 64.


Empfehlung hin oder her - mein Eindruck ist, daß mit XP 64 nicht nur ein halbfertiges Produkt auf den Markt geworfen wurde, sondern daß es auch - freundlich ausgedrückt - von Microsoft nur halbherzig supportet wurde.

Nur mal als Beispiel am Rande: Ich konnte für meinen Uraltplotter HP750 keinen brauchbaren Treiber für XP 64 auftreiben - für Vista 64 sehr wohl. Mit vielen anderen Treibern ging's mir genauso.

Wer mag, kann ja mal versuchen, einen deutschsprachigen Internet-Explorer nach IE6 auf XP 64 zu installieren  . Der Internet-Explorer ist ja bekanntlich von Microsoft. Deutlicher kann man als großes Softwarehaus nicht dokumentieren, daß man mit einem Betriebssystem nichts zu tun haben will.

Ich würde als allererstes XP 64 rauswerfen und dann wenn möglich eine aktuelle SWXSolidWorks-Version einspielen.


Gruß

Ron

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2021 CAD.de | Impressum | Datenschutz