Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Rund um AutoCAD
  Bei Doppelklick auf Block wird kein Blockname angezeigt

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Bei Doppelklick auf Block wird kein Blockname angezeigt (1197 mal gelesen)
CharlyB
Mitglied
CAD-Konstrukteur (prozessgesteuerte Anlagentechnik)


Sehen Sie sich das Profil von CharlyB an!   Senden Sie eine Private Message an CharlyB  Schreiben Sie einen Gästebucheintrag für CharlyB

Beiträge: 364
Registriert: 11.09.2007

AutoCAD Mechanical 2016
Inventor Prof. 2016
Windows 8 64Bit
Intel Core i7-4790 4x3.60GHz
32GB RAM
NVIDIA Quadro FX5800 2GB

erstellt am: 01. Feb. 2016 11:03    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


TestBlock.txt


Blockerstellen.jpg


Blockdefinitionbearbeiten.jpg

 
Hallo liebe Experten,

mich plagt seit ca. 2 Wochen folgendes Problem:
beim Doppelklick auf einen x-belibigen Block öffnet sich zwar das Fenster "Blockdefinition bearbeiten",
jedoch wird der Blockname nicht mehr automatisch angezeigt.
   
Statt dessen muss ich manuell den Blocknamen eingeben oder den Blocknamen in der Liste auswählen.
Danach poppt der Blockeditor normal auf.
Dieser "Bock" taucht in JEDER Zeichnung auf. Ich habe zu Testzwecken eine neue Zeichnung erstellt und einen "simplen" Block ohne Attribute erstellt, auch da wird nach Doppelklick der Blockname nicht im Fenster angezeigt.
Die Test-dwg (.txt) und 2 Fotos dazu sind im Anhang.

Merkwürdig in diesem Zusammenhang ist auch, dass ich seit diesem "Bock" auch zuerst Befehle wie Kopieren, Skalieren, usw. auswählen muss und erst dann die Objekte anwählen kann, obwohl ich bei "PICKFIRST (1)" nichts verändert hatte.


Vielen Dank für jeden hilfreichen Tip.

LG Dirk

------------------
Grüße vom Rande des Teutoburger Waldes
Dirk

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 19034
Registriert: 03.06.2002

System: F1
und Google

erstellt am: 01. Feb. 2016 11:16    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CharlyB 10 Unities + Antwort hilfreich

Ich habe nur Standard-AutoCAD, daher kann ich auch nur dafür sprechen:

Der Fehler taucht in meinem 2013er&2016er nicht auf.

Deine andere Problembeschreibung scheint 1:1 damit zutun zu haben, dieses Verhalten ist aber nicht "AutoCAD-Standardverhalten",
du übersiehst also keine Sysvar (so weit mir dies in AutoCAD bekannt ist).

Ich tippe auf ein Zusatzprogramm oder ein Servicepack im Inv/Mech -
irgendetwas was nicht in den AutoCAD-Bereich fällt.

PS: Benenne die Dateinamen auf CAD.de eindeutiger, DU als User hast hier nur einen "Ordner" in dem alle
Uploaddateien gesammelt werden (siehe Profil: FileAttachmentManager), die Chance andere Dateien zu überschreiben ist sehr groß,
zumal es keine Warnung gibt! 160201_Testblock1.dwg <- als Beispiel.
PPS: Man kann hier DWGs direkt hochladen, ein umbenennen als txt ist unnötig und störend - für das nächste Mal.

------------------
CAD on demand GmbH - Beratung und Programmierung rund um AutoCAD

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CharlyB
Mitglied
CAD-Konstrukteur (prozessgesteuerte Anlagentechnik)


Sehen Sie sich das Profil von CharlyB an!   Senden Sie eine Private Message an CharlyB  Schreiben Sie einen Gästebucheintrag für CharlyB

Beiträge: 364
Registriert: 11.09.2007

AutoCAD Mechanical 2016
Inventor Prof. 2016
Windows 8 64Bit
Intel Core i7-4790 4x3.60GHz
32GB RAM
NVIDIA Quadro FX5800 2GB

erstellt am: 01. Feb. 2016 11:35    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke für die Antwort.

Ich habe tatsächlich vor kurzem eine App runtergeladen (EXALL), mit der man auf einen Schlag alle verschachtelten Blöcke auf den Ursprung setzen kann. Vielleicht hängt das damit zusammen.
Fragt sich nur, wie ich diese App wieder sauber entfernt bekomme?

Und danke für die anderen Tips, ich werde sie beherzigen.

------------------
Grüße vom Rande des Teutoburger Waldes
Dirk

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 19034
Registriert: 03.06.2002

System: F1
und Google

erstellt am: 01. Feb. 2016 11:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CharlyB 10 Unities + Antwort hilfreich

Leider hast du keinen Link gepostet, sonst könnte man ja helfen 

Ich habe 2min gegoogelt, alle Treffer waren einfache LISProutinen, welche einfach nur
den AutoCAD-Befegl Ursprung(_explode) mehrfach auf Blockreferenzen loslässt.
zB hier: http://forum.cad.de/foren/ubb/Forum53/HTML/003450.shtml#000009

Diese sind nicht daran schuld und unabhängig von deinem Problem müssen Lisproutinen auch nicht "deinstalliert" werden.

Ich könnte noch mehr schreiben, aber ohne einen Link wäre das unnötiger Aufwand (man müßte ja 10Möglichkeiten abdecken, obwohl nur eine zutrifft)

------------------
CAD on demand GmbH - Beratung und Programmierung rund um AutoCAD

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CharlyB
Mitglied
CAD-Konstrukteur (prozessgesteuerte Anlagentechnik)


Sehen Sie sich das Profil von CharlyB an!   Senden Sie eine Private Message an CharlyB  Schreiben Sie einen Gästebucheintrag für CharlyB

Beiträge: 364
Registriert: 11.09.2007

AutoCAD Mechanical 2016
Inventor Prof. 2016
Windows 8 64Bit
Intel Core i7-4790 4x3.60GHz
32GB RAM
NVIDIA Quadro FX5800 2GB

erstellt am: 02. Feb. 2016 08:55    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Guten Morgen,

sorry für den verspäteten link, ich habe ihn von meinem Arbeitskollegen bekommen, bei dem die app übrigens tadellos läuft.
Wir greifen auf einen gemeinsamen Firmenserver zu. Er kann jedoch problemlos den Block in meiner obigen Test-dwg dopplklicken und der Blockname wird "normal" angezeigt.

Hier der link der app: http://www.cadtutor.net/forum/showthread.php?25303-Explode-all-block s-till-there-are-no-more-blocks


------------------
Grüße vom Rande des Teutoburger Waldes
Dirk

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

runkelruebe
Moderator
Straßen- / Tiefbau




Sehen Sie sich das Profil von runkelruebe an!   Senden Sie eine Private Message an runkelruebe  Schreiben Sie einen Gästebucheintrag für runkelruebe

Beiträge: 7896
Registriert: 09.03.2006

sw:
Win7-x64
Office 365 ProPlus
C3D (& LT )
ET; DACH; Extensions
-------------------
hw:
FX3800
i5 CPU 670
8GB RAM

erstellt am: 02. Feb. 2016 09:14    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CharlyB 10 Unities + Antwort hilfreich

Code:
(setvar "qaflags" 1)
[...]
(setvar "qaflags" 0)

Hast Du die Routine bei Dir mal abgebrochen (angewürgt z.B. mit ESC)?
Oder Ist Dir der Rechner kapital abgeschmiert währenddessen?
Setz mal QAFLAGS wieder auf 0 und berichte.
Hier behebt das zumindest Dein Blocknamenproblem. Das 'beim Schieben/Kopieren' kann ich hier nicht nachvollziehen. Wer weiß, was Du Dir noch so alles verstellt hast...

[rredit] cadffm machte mich darauf aufmerksam, dass Kopieren / Schieben aus der GUI nicht tut. Da ich Tastaturbefehle dafür nutze, fiel es mir nicht auf. Sorry! Und danke an cadffm  [/rredit]

------------------
Gruß,
runkelruebe          Herr Kann-ich-nich wohnt in der Will-ich-nich-Straße...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 19034
Registriert: 03.06.2002

System: F1
und Google

erstellt am: 02. Feb. 2016 09:19    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CharlyB 10 Unities + Antwort hilfreich

In dem Programm wird eine (streng geheime) Systemvariable umgestellt (QAFLAGS auf den Wert1),
am Ende des Programmes wird sie auf 0 gestellt.
Wenn du zwischendrin abbrichst (oder Acad) dann bleibt 1 stehen, ansonsten 0.

Mein Tip: Stelle QAFLAGS einfach mal auf den Wert2 oder 0 und teste erneut.

PS: Das ist halt der Nachteile an so quick,dirty&free, Fehlerkontrolle und Abfangmechanismen sind nicht oder nur ungenügend vorhanden.

So ein Progrämmchen sollte doch etwas "besser" gestaltet werden.

editiert, weil eh zu langsam  I
editiert, weil eh zu langsam II
------------------
CAD on demand GmbH - Beratung und Programmierung rund um AutoCAD

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CharlyB
Mitglied
CAD-Konstrukteur (prozessgesteuerte Anlagentechnik)


Sehen Sie sich das Profil von CharlyB an!   Senden Sie eine Private Message an CharlyB  Schreiben Sie einen Gästebucheintrag für CharlyB

Beiträge: 364
Registriert: 11.09.2007

AutoCAD Mechanical 2016
Inventor Prof. 2016
Windows 8 64Bit
Intel Core i7-4790 4x3.60GHz
32GB RAM
NVIDIA Quadro FX5800 2GB

erstellt am: 02. Feb. 2016 09:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Bingo !!!!

"qaflags" von <1> auf <0> gesetzt:

- Blockname wird wieder angezeigt beim Doppelklick
- ERST Objekte wählen und dann den Befehl geht ebenfalls wieder.

Suuuuuper  

Wie kann sich sowas verstellen? Hab vorher von "qaflags" noch nie was gehört  

    Viiiiielen lieben Dank (U's sind unterwegs) und einen schönen Tag noch  

PS: Hab qaflags auf <2> gesetzt, läuft ebenfalls - Auch die lieben Dank 

------------------
Grüße vom Rande des Teutoburger Waldes
Dirk

[Diese Nachricht wurde von CharlyB am 02. Feb. 2016 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

runkelruebe
Moderator
Straßen- / Tiefbau




Sehen Sie sich das Profil von runkelruebe an!   Senden Sie eine Private Message an runkelruebe  Schreiben Sie einen Gästebucheintrag für runkelruebe

Beiträge: 7896
Registriert: 09.03.2006

sw:
Win7-x64
Office 365 ProPlus
C3D (& LT )
ET; DACH; Extensions
-------------------
hw:
FX3800
i5 CPU 670
8GB RAM

erstellt am: 02. Feb. 2016 09:29    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CharlyB 10 Unities + Antwort hilfreich

>> Wie kann sich sowas verstellen? Hab vorher von "qaflags" noch nie was gehört

Haben wir oben angedeutet: Das ist ein Quick&Dirty-Progrämmle ohne jegliche Fehlerabfangung oder sonstigen Komfort für unbedarfte user.
Die Variable QAFLAGS wird innerhalb des Programms umgestellt. Wenn Du die Routine dann abbrichst und es nicht mehr zum Punkt "(setvar "qaflags" 0)" kommen läßt, bleibt sie eben auf 1 stehen.

Grundsätzlich sollte man Befehle / Routinen in ACAD niemals nie nicht abbrechen (Have a look on MVSETUP...). Besser durchlaufen lassen, danach rückgängig oder eben schließen ohne Speichern.

Ebenso grundsätzlich sollte man zumindest versuchen zu verstehen, was man sich da Lustiges aus dem www zusammen sammelt und auf seinem System ausführt. [erhobener Zeigefingermodus OFF]

------------------
Gruß,
runkelruebe          Herr Kann-ich-nich wohnt in der Will-ich-nich-Straße...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CharlyB
Mitglied
CAD-Konstrukteur (prozessgesteuerte Anlagentechnik)


Sehen Sie sich das Profil von CharlyB an!   Senden Sie eine Private Message an CharlyB  Schreiben Sie einen Gästebucheintrag für CharlyB

Beiträge: 364
Registriert: 11.09.2007

AutoCAD Mechanical 2016
Inventor Prof. 2016
Windows 8 64Bit
Intel Core i7-4790 4x3.60GHz
32GB RAM
NVIDIA Quadro FX5800 2GB

erstellt am: 02. Feb. 2016 09:46    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

@ runkelruebe

Ich habe nicht bewusst den Befehl abgebrochen, kann mich jedoch sehr gut daran erinnern, dass AutoCAD hängen geblieben ist, als ich einen extrem großen verschachtelten Block mit der app auf alle Ursprünge zurücksetzen wollte.
Ich vermute, dass bei dieser Aktion der Wert von qaflags auf <1> stehen geblieben ist.

Nochmals besten Dank für die tolle Hilfe!! 

------------------
Grüße vom Rande des Teutoburger Waldes
Dirk

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz