Hot News:

Unser Angebot:

  Foren auf CAD.de (alle Foren)
  Excel
  Wort in einer Zelle finden

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Wort in einer Zelle finden (47731 mal gelesen)
inv-Kristof
Mitglied
Dipl-- Ing. (FH)


Sehen Sie sich das Profil von inv-Kristof an!   Senden Sie eine Private Message an inv-Kristof  Schreiben Sie einen Gästebucheintrag für inv-Kristof

Beiträge: 1134
Registriert: 01.01.2004

HP 8710w, Win Vista 64x, IV 2009 SP2
Intel® Core™ 2 Duo T9500 2,6 GHz, 4 GB RAM
nVidia® Quadro FX 3600M, 17" 1920x1200
----------------
AMD 64bit 3200+; 2GB DDR400
GeForce 6600GT 128MB
Win Vista 64x
IV 2009 SP2

erstellt am: 25. Mrz. 2006 20:16    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,
welche Formel soll ich verwenden, um in einer Zelle das Wort "Auslauf" herauszufinden. Das Wort Auslauf wird unterchiedlich geschrieben, einmal groß einmal klein. Darüber hinaus steht dieses Wort an verschiedener Stelle in einer Zelle, einmal am Anfang einmal am Ende.
Gruß Kristof

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

rainberg
Mitglied



Sehen Sie sich das Profil von rainberg an!   Senden Sie eine Private Message an rainberg  Schreiben Sie einen Gästebucheintrag für rainberg

Beiträge: 147
Registriert: 14.01.2005

erstellt am: 25. Mrz. 2006 21:20    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für inv-Kristof 10 Unities + Antwort hilfreich

Hallo Kristof,

Fragen stellen ist ok, davon leben die Foren.
Aber auf erhaltene Antworten nicht reagiern, ist schlicht unfair.
Denk mal darüber nach!

Zu deiner Frage:
Wenn dein String in A1 steht, dann erhältst du mit

=SUCHEN("auslauf";A1)

eine Zahl, welche die Position von "auslauf" oder "Auslauf" im String dokumentiert.
Du könntest aber auch folgende Abfrage verwenden:

=WENN(ISTZAHL(SUCHEN("auslauf";A1));"vorhanden";"nicht vorhanden")

------------------
Gruß Rainer


Rückmeldung wäre nett

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

inv-Kristof
Mitglied
Dipl-- Ing. (FH)


Sehen Sie sich das Profil von inv-Kristof an!   Senden Sie eine Private Message an inv-Kristof  Schreiben Sie einen Gästebucheintrag für inv-Kristof

Beiträge: 1134
Registriert: 01.01.2004

HP 8710w, Win Vista 64x, IV 2009 SP2
Intel® Core™ 2 Duo T9500 2,6 GHz, 4 GB RAM
nVidia® Quadro FX 3600M, 17" 1920x1200
----------------
AMD 64bit 3200+; 2GB DDR400
GeForce 6600GT 128MB
Win Vista 64x
IV 2009 SP2

erstellt am: 25. Mrz. 2006 21:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Rainer,
vielen dank für rasche Antwort. Es funktioniert wunderbar und habe ich wieder was gelernt.
Ich weiss es, dass ich dir auf den letzten Beitrag nicht beantwortet habe. Vielen Dank auch für diese Antwort. Was ich noch in dieser Formel nicht so richtig verstanden habe, ist, warum du Matrix 1 in Klammer gesetzt hast und zwar so:
=SUMMENPRODUKT((ISTTEXT(Tabelle1!$A$2:$A$1000))*(Tabelle1!$B$2:$B$1000=Tabelle2!$A3))
und nicht so:
=SUMMENPRODUKT(ISTTEXT(Tabelle1!$A$2:$A$1000)*(Tabelle1!$B$2:$B$1000=Tabelle2!$A3))
Gruß und sorry nochmal für keine Antwort.
Kristof

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

inv-Kristof
Mitglied
Dipl-- Ing. (FH)


Sehen Sie sich das Profil von inv-Kristof an!   Senden Sie eine Private Message an inv-Kristof  Schreiben Sie einen Gästebucheintrag für inv-Kristof

Beiträge: 1134
Registriert: 01.01.2004

HP 8710w, Win Vista 64x, IV 2009 SP2
Intel® Core™ 2 Duo T9500 2,6 GHz, 4 GB RAM
nVidia® Quadro FX 3600M, 17" 1920x1200
----------------
AMD 64bit 3200+; 2GB DDR400
GeForce 6600GT 128MB
Win Vista 64x
IV 2009 SP2

erstellt am: 25. Mrz. 2006 22:18    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

und was soll noch in der Formel geändert werden, um einen bestimmten Bereich nach dem Wort Auslauf zu suchen? z.B. A1 und B1 soll geprüft werden.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

rainberg
Mitglied



Sehen Sie sich das Profil von rainberg an!   Senden Sie eine Private Message an rainberg  Schreiben Sie einen Gästebucheintrag für rainberg

Beiträge: 147
Registriert: 14.01.2005

erstellt am: 25. Mrz. 2006 22:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für inv-Kristof 10 Unities + Antwort hilfreich

Hallo Kristof,

in dieser Formel

=SUMMENPRODUKT((ISTTEXT(Tabelle1!$A$2:$A$1000))*(Tabelle1!$B$2:$B$1000=Tabelle2!$A3))

werden 2 Argumente verwendet und jedes Argument muß in Klammern eingeschlossen sein.

Argument1=(ISTTEXT(Tabelle1!$A$2:$A$1000))
Argument2=(Tabelle1!$B$2:$B$1000=Tabelle2!$A3)

Beide Argumente werden dann in =SUMMENPRODUKT((Argument1)*(Argument2))
eingeschlossen.

------------------
Gruß Rainer


Rückmeldung wäre nett

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

inv-Kristof
Mitglied
Dipl-- Ing. (FH)


Sehen Sie sich das Profil von inv-Kristof an!   Senden Sie eine Private Message an inv-Kristof  Schreiben Sie einen Gästebucheintrag für inv-Kristof

Beiträge: 1134
Registriert: 01.01.2004

HP 8710w, Win Vista 64x, IV 2009 SP2
Intel® Core™ 2 Duo T9500 2,6 GHz, 4 GB RAM
nVidia® Quadro FX 3600M, 17" 1920x1200
----------------
AMD 64bit 3200+; 2GB DDR400
GeForce 6600GT 128MB
Win Vista 64x
IV 2009 SP2

erstellt am: 25. Mrz. 2006 22:34    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Rainberg,
es funktioniert aber auch, wenn ich das erste Argument ohne Klammer schreibe.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

rainberg
Mitglied



Sehen Sie sich das Profil von rainberg an!   Senden Sie eine Private Message an rainberg  Schreiben Sie einen Gästebucheintrag für rainberg

Beiträge: 147
Registriert: 14.01.2005

erstellt am: 25. Mrz. 2006 23:08    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für inv-Kristof 10 Unities + Antwort hilfreich

Hallo Kristof,

stimmt, in einigen Fällen funktioniert auch diese Schreibweise, welche ich mir aber nicht angewöhnen würde.

Deine auslauf-Frage:

wenn Du die Anzahl der Strings, die "auslauf" oder "Auslauf" oder "AUSLAUF" enthalten, in Spalte A, zählen willst dann reicht

=ZÄHLENWENN(A:A;"*auslauf*")

------------------
Gruß Rainer


Rückmeldung wäre nett

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz