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PTC Dokumentationskonventionen
In den PTC Dokumentationen werden folgende Konventionen
verwendet:

Konvention Element Beispiel

Fett Menüpfade, Optionen in
Dialogfenstern sowie
andere wählbare
Elemente der
Benutzeroberfläche.

Wählen Sie die
Befehlsfolge Datei >
Speichern (File >
Save).

Courier Benutzereingaben,
Systemmeldungen,
Dateinamen

Processing completed.

Courier mit
"Größer als"- und
"Kleiner als"-
Symbolen        (< >)

Variablen, die der
Benutzer durch einen
entsprechenden Wert
ersetzt

output=<LOADPOINT>



1-1

1 
Grundfunktionen

Modellerzeugungs-Historie mit dem neuen Modell-
Player wiedergeben

Die Funktion zum Aufrufen von Regenerierungsinformationen wurde
erweitert und vereinfacht. Mit Dienstprogramme > Modell-Player
(Utilities > Model Player) wird das neue Dialogfenster Modell-
Player (Model Player) geöffnet. Mit diesem Dialogfenster können Sie
das Modell KE für KE vorwärts und rückwärts durchlaufen oder einen
Rücklauf an eine beliebige Stelle im Modellerzeugungsprozeß
durchführen. Sie können KEs während des Durchlaufens der
Erzeugungshistorie vorwärts abspielen, ohne sie zu regenerieren. Sie
können die Regenerierung auch beenden und das Menü KE BEHEB
(RESOLVE FEAT) öffnen. Bei Bedarf können Sie im Modus NC-
Bearbeitung für jede NC-Folge CL-Daten berechnen.

Bezugselemente schnell ausblenden
Mit Pro/ENGINEER sparen Sie während der Konstruktion wertvolle
Zeit, wenn Sie einzelne Bezugselemente während der Bearbeitung aus-
oder einblenden. Sie brauchen die Elemente jetzt keiner Folie mehr
zuzuordnen und dann die gesamte Folie auszublenden oder alle
Bezugselemente vom gleichen Typ auszublenden. Verwenden Sie
Editieren > Im Modellbaum auffinden (Edit > Find in Model
Tree), um im Modellbaum nach allen KEs eines bestimmten Typs zu
(z.B. Bezugsachsen) suchen, diese auszuwählen und auszublenden.
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Die folgenden Elemente können während der Bearbeitung
ausgeblendet werden:

� Einzelne Bezugsebenen
� Achsen
� KEs, die Achsen und Koordinatensysteme enthalten
� Analyse-KEs (Punkte und Koordinatensysteme)
� Bezugspunkte (gesamte Arrays)
� Koordinatensysteme
� Bezugskurven (gesamte Kurven, keine einzelnen Kurvensegmente)
� Sammelflächen (gesamte Sammelflächen, keine einzelnen Flächen)
� Baugrupppenkomponenten
Ein während der Bearbeitung aus- oder einzublendendes Element muß
zuerst im Grafikbereich oder Modellbaum gewählt werden. Daraufhin
verwenden Sie den Befehl Ausblenden (Hide), Einblenden
(Unhide) oder Alle einblenden (Unhide All) im Menü Ansicht
(View), die entsprechende Schaltfläche in der Tool-Leiste oder das
Kontextmenü (das angezeigt wird, wenn Sie mit der rechten Maustaste
auf das gewählte Element klicken).

OLE-Objekte in Pro/ENGINEER 2D-Dateien einfügen
Pro/ENGINEER 2001 ermöglicht das Einfügen von OLE (Object
Linking and Embedding)-Objekten in zweidimensionale
Pro/ENGINEER Dateien (hierzu zählen Zeichnungen, Berichte,
Formate, Layouts und Diagramme. Verwenden Sie das Dialogfenster
Objekt einfuegen (Insert Object), das angezeigt wird, wenn Sie auf
Einfuegen > Objekt (Insert > Object) klicken. Sie können OLE-
Objekte als verknüpft oder eingebettet einfügen, und Sie können
Objekte entweder in der Pro/ENGINEER-Umgebung oder in einem
separaten Applikationsfenster außerhalb von Pro/ENGINEER
editieren.

Hinweis: Die Anzahl und Typen unterstützter OLE-Objekte variieren
abhängig von den anderen installierten Applikationen von System zu
System. Das Einfügen und Editieren von OLE-Objekten wird nur auf
Windows-Plattformen unterstützt. Auf UNIX-Systemen werden nur die
Ränder und Berandungsquader angezeigt; die Größe von OLE-
Objekten kann allerdings geändert werden.
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Neue Funktion für den Vergleich von Teilen:
KEs von Teilen oder geometrische Abweichung
zwischen Teilen vergleichen

Pro/ENGINEER 2001 ermöglicht das Analysieren der geometrischen
Abweichung zwischen zwei Teilen oder zwei Versionen eines Teils. Zur
Durchführung eines Geometrievergleichs verwenden Sie die Option
Nach Geometrie (By Geometry) unter Analyse > Teil vergleichen
(Analysis > Compare Part). Die geometrischen Unterschiede
zwischen den Teilen werden schattiert dargestellt.

Verbesserungen im Dialogfenster "Folien" ("Layers")

Verbesserung am Arbeitsablauf
Das Dialogfenster Folien (Layers) ist jetzt modusunabhängig. Nach
dem Öffnen des Dialogfensters bleibt dieses solange geöffnet, bis Sie ein
anderes Modell öffnen oder aktivieren. Während das Dialogfenster
geöffnet ist, können Sie in Pro/ENGINEER jede beliebige Aufgabe
durchführen. Mit Hilfe dieser Verbesserung erhalten Sie leichten
Zugriff auf häufig ausgeführte Aufgaben, wie das Verwalten von KEs
und Komponenten durch Verwendung von Folien und das Steuern der
Darstellung von Elementen. Das Dialogfenster Folien (Layers) wird
nur in den folgenden Situationen geschlossen: wenn Sie es manuell
schließen, ein anderes Pro/ENGINEER Fenster aktivieren oder ein
anderes Modell öffnen.

Darstellungsstatus von Folien auf den gespeicherten Status

zurücksetzen
Über die neue Schaltfläche Zuruecksetzen (Reset) können Sie einen
gespeicherten Folienstatus aufrufen. Wenn Sie durch Klicken auf
Status speichern (Save Status) einen Folienstatus mit dem Modell
gespeichert haben und den Folienstatus etwas später weiter verändern,
können Sie durch Klicken auf Zuruecksetzen (Reset) den
gespeicherten Status wiederherstellen. Alle nicht gespeicherten
Änderungen des Status von Folien im Dialogfenster werden entfernt,
und die gespeicherten Statuseinstellungen werden wiederhergestellt.

Inhalt einer Folie auf eine andere Folie kopieren
Alle Elemente auf einer Folie können jetzt schnell und einfach auf eine
andere Folie kopiert werden. Wählen Sie im Dialogfenster Folien
(Layers) eine Folie, und klicken Sie auf Element > Kopieren (Item >
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Copy). Alle Elemente auf der Folie werden in die Zwischenablage
kopiert. Wählen Sie zum Kopieren der Elemente entweder eine
vorhandene Folie, oder erzeugen Sie eine neue Folie. Klicken Sie dann
auf Element > Einfuegen (Item > Paste).

Hebräischen Text darstellen und eingeben
Pro/ENGINEER 2001 unterstützt die Eingabe und Darstellung von
hebräischem Text nur in begrenztem Umfang. Hebräischer Text kann
in Notizen, im Mitteilungsfenster, in die Eingabefelder von
Dialogfenstern, im Modellbaum und beim Erzeugen von Parametern
eingegeben werden. Englischer und hebräischer Text kann in derselben
Zeichenkette verwendet und hebräischer oder gemischter Text kann
aus anderen Applikationen in Pro/ENGINEER Eingabefelder oder
Dialogfenster eingefügt werden. Hebräischer Text kann in Form von
2D-Notizen, 3D-Notizen, Berichttabellen, Bemaßungen und in
Informationsfenstern (z.B. in einem Stücklistenbericht) dargestellt
werden.

Hinweis: Die Eingabe und Darstellung von hebräischem Text wird in
Pro/INTRALINK nicht unterstützt.

Verbesserungen beim Öffnen und Speichern von
Dateien

Pro/ENGINEER 2001 zeigt im Menü Datei (File) bis zu vier der
zuletzt geöffneten Dateien an. Wie auch in Microsoft Windows
Applikationen können Sie eine zuletzt verwendete Datei schnell öffnen,
indem Sie das Menü Datei (File) öffnen und auf den Dateinamen
klicken.

Erweiterte Länge von Pfadnamen
In früheren Versionen von Pro/ENGINEER konnte ein Pfadname bis zu
256 Zeichen enthalten. Ab Version 2001 dürfen Pfadnamen bis zu 260
Zeichen enthalten.

Verbesserungen bei Familientabellen
Die folgenden Verbesserungen wurden vorgenommen, um den
Arbeitsablauf von Familientabellen zu verbessern:

� Die Spalte mit Variantennamen ist immer gesperrt. Ihre Position
wird beim horizontalen Bildlauf nicht mehr geändert, und sie bleibt
immer sichtbar.
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� Durch Klicken auf die Spaltenüberschrift wird die gesamte Spalte
gewählt.

Verbesserung der Funktion "Benutzerdefiniertes
KE": Beim Umdefinieren/Plazieren eines UDF
austauschbare Referenzen verwenden

Benutzerdefinierte KEs (UDFs) können jetzt flexibler und einfacher
verwendet werden. In Pro/ENGINEER Version 2000i2 mußte das von
Ihnen festgelegte Referenzelement beim Umdefinieren eines UDF dem
Typ entsprechen, der bei der Erzeugung des ursprünglichen KE
angegeben wurde. Wenn Sie z.B. bei der ursprünglichen Erzeugung des
UDF eine Achse als Referenz gewählt hatten, können Sie beim
Umdefinieren der Referenz für das UDF nur eine Achse als neue
Referenz wählen. Punkte, Ebenen oder sonstige Elementtypen können
also nicht gewählt werden.

In Version 2001 können Sie beim Umdefinieren eines UDF jeden
beliebigen Elementtyp angeben, der bei der Erzeugung des
ursprünglichen KE zur Verwendung als Referenz verfügbar war. Wenn
also z.B. bei der Erzeugung des ursprünglichen KE Punkte, Achsen und
Ebenen als Referenzen zulässig waren, dürfen beim Umdefinieren des
UDF ebenfalls Punkte, Achsen und Ebenen als Referenzelemente
gewählt werden.

Zeilen in search.pro-Dateien als Kommentare
festlegen

In 2001 brauchen Sie nicht mehr mehrere search.pro-Dateien zu
erstellen, wenn Sie in verschiedenen Arbeitssitzungen unterschiedliche
Suchpfade verwenden möchten. Sie können jetzt eine einzelne
search.pro-Datei im Handumdrehen Ihren Anforderungen
entsprechend editieren. Genauso wie in anderen Konfigurationsdateien
Zeilen als Kommentare festgelegt werden, werden Zeilen in einer
search.pro-Datei als Kommentar bestimmt, um angegebene
Verzeichnisse in den entsprechenden Zeilen aus dem Pro/ENGINEER
Suchpfad zu entfernen. Genauso wie in Konfigurationsdateien wird
eine Zeile als Kommentar bestimmt, indem Sie ein Ausrufezeichen (!)
hinzufügen. Beim Lesen der search.pro-Datei in der aktuellen
Sitzung werden die als Kommentare festgelegten Zeilen ignoriert.
Wenn Sie eine als Kommentar festgelegte Zeile wieder in den Suchpfad
aufnehmen möchten, löschen Sie einfach das Ausrufezeichen (!). Beim
Lesen der search.pro-Datei wird die Zeile wieder gelesen.
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2 
Benutzeroberfläche

Sie können die Anzeige von Bezugskennzeichen jetzt getrennt von den
bezeichneten Elementen steuern. Diese neue Funktion kann für
Bezugspunkte, Bezugsebenen, Bezugsachsen, Bezugs-
Koordinatensysteme und benannte Bezugskurven verwendet werden.
Sie können z.B. festlegen, Bezugsebenen anzuzeigen und ihre
Kennzeichen nicht anzuzeigen. Verwenden Sie das Dialogfenster
Bezugsdarstellung (Datum Display), das über Ansicht >
Darstellungseinstellungen > Bezugsdarstellung (View > Display
Settings > Datum Display) geöffnet wird, um wichtige grafische
Informationen anzuzeigen, ohne den Bildschirm mit unnötigen
Textbezeichnungen zu füllen.

Menüleisten erweitern und kombinieren
Die Pro/ENGINEER Menüleiste bietet jetzt zusätzlich Zugriff auf
Befehle, die bisher nur im Menü-Manager zur Verfügung standen.
Diese Erweiterung und Feineinstellung der Menüleiste wird in den
nächsten Versionen fortgesetzt und der Menü-Manager somit überholt.
Besonderen Wert wurde auf die Beibehaltung der Integrität von
Mapkeys gelegt. In einigen Fällen funktionieren Mapkeys weiterhin, in
anderen Fällen müssen Mapkeys aufgrund der neuen Position einiger
Optionen aktualisiert werden.

Menü-Zuordnung für Pro/ENGINEER Basismodul
In der folgenden Tabelle sind die neuen Positionen von Werkzeugen
und Befehlen in der Pro/ENGINEER Grundapplikation
zusammengefaßt. Unter "Neue Position" signalisiert ein Sternchen (*)
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neben dem Pfad, daß die Position des Befehls dieselbe ist, und sich nur
der Befehlsname geändert hat.

Hinweis: Die Tabelle enthält keine Befehle, die sich auf einen
bestimmten Objekttyp (z.B. Zeichnung oder Diagramm) oder eine
bestimmte Applikation (z.B. Animation oder Schweißen) beziehen.

Alte Position Neue Position (*nur neue Kennung)

Datei > Arbeitsverzeichnis...
(File > Working Directory...)

Datei > Arbeitsverzeichnis festlegen...
(File > Set Working Directory...)*

Datei > Exportieren > Direkt
VRML...
(File > Export > Direct VRML...)

Datei > VRML-Konvertierer
(File > VRML Converter)

Datei > Topology Bus
(File > Topology Bus)

Datei > Associative Topology Bus
(File > Associative Topology Bus)*

Datei > Topology Bus >
Verifizieren
(File > Topology Bus > Verify)

Datei > Associative Topology Bus > Status
pruefen
(File > Associative Topology Bus > Check
Status)*

Datei > Topology Bus >
Aktualisieren > Auswahl
(File > Topology Bus > Update >
Select)

Datei > Associative Topology Bus >
Aktualisieren
(File > Associative Topology Bus > Update)*

Datei > Topology Bus >
Aktualisieren > Automatisch
(File > Topology Bus > Update >
Automatic)

Datei > Associative Topology Bus > Alle
aktualisieren
(File > Associative Topology Bus > Update
All)*

Datei > Topology Bus > Autom
pruefen
(File > Topology Bus > Auto
Verify)

Datei > Associative Topology Bus > Status
autom pruefen
(File > Associative Topology Bus >
AutoCheck Status)*

Datei > Topology Bus > Protokoll
ansehen
(File > Topology Bus > View Log)

Datei > Associative Topology Bus > Protokoll
zeigen
(File > Associative Topology Bus > Show
Log)*

Editieren > Aendern
(Edit > Modify)

Editieren > Aendern
(Edit > Modify)

Editieren > Neue Referenz Editieren > Referenzen
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Alte Position Neue Position (*nur neue Kennung)

(Edit > Reroute) (Edit > References)*

Editieren > Umdefinieren
(Edit > Redefine)

Editieren > Definition
(Edit > Definition)*

Editieren > Finden...
(Edit > Find...)

Editieren > In Modellbaum auffinden...
(Edit > Find in Model Tree...)*

Ansicht > Standard
(View > Default)

Ansicht > Standardorientierung
(View > Default Orientation)*

Ansicht > 3D-
Drehen/Verschieben/Zoomen...
(View > Spin/Pan/Zoom...)

Dieser Befehl wurde entfernt.

Ansicht > Orientierung...
(View > Orientation...)

Ansicht > Neu orientieren...
(View > Reorient...)*

Ansicht > Modelldarstellung...
(View > Model Display...)

Ansicht > Darstellungseinstellungen >
Modelldarstellung...
(View > Display Settings > Model Display...)

Ansicht > Bezugdarstellung...
(View > Datum Display...)

Ansicht > Darstellungseinstellungen >
Bezugdarstellung...
(View > Display Settings > Datum Display...)

Ansicht > Leistung...
(View > Performance...)

Ansicht > Darstellungseinstellungen >
Leistung...
(View > Display Settings > Performance...)

Ansicht > Spezial > Sichtbarkeit...
(View > Advanced > Visibilities...)

Ansicht > Darstellungseinstellungen >
Sichtbarkeit...
(View > Display Settings > Visibilities...)

Dienstprogramme > Farben >
System...
(Utilities > Colors > System...)

Ansicht > Darstellungseinstellungen >
Systemfarben...
(View > Display Settings > System Colors...)

Dienstprogramme > Farben >
Element...
(Utilities > Colors > Entity...)

Ansicht > Darstellungseinstellungen >
Elementfarben...
(View > Display Settings > Entity Colors...)

Ansicht > Analysendarstellung...
(View > Analysis Display...)

Ansicht > Modell einrichten >
Analysendarstellung...
(View > Model Setup > Analysis Display...)
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Alte Position Neue Position (*nur neue Kennung)

Ansicht > Spezial > Photorender...
(View > Advanced >
Photorender...)

Ansicht > Modell einrichten > Photorender...
(View > Model Setup > Photorender...)

Dienstprogramme > Modellbaum-
Einstellungen > Laden...
(Utilities > Model Tree Settings >
Load...)

Ansicht > Modellbaum einrichten >
Einstellungsdatei oeffnen...
(View > Model Tree Setup > Open Settings
File...)

Dienstprogramme > Modellbaum-
Einstellungen > Speichern...
(Utilities > Model Tree Settings >
Save...

Ansicht > Modellbaum einrichten >
Einstellungsdatei speichern...
(View > Model Tree Setup > Save Settings
File...)

Menü Bezug (Datum)
(in der Menüleiste)

Einfuegen >Bezug
(Insert > Datum)

Dienstprogramme > Teil
vergleichen...
(Utilities > Compare Part...)

Analyse > Teil vergleichen
(Analysis > Compare Part)

Info > Stueckliste
(Info > BOM)

Info > Stueckliste
(Info > Bill of Materials)

Info > Pro/Engineer Objekte
(Info > Pro/Engineer Objects)

Info > Sitzung-Info > Objektliste
(Info > Session Info > Object List)

Info > Mitteilungenprotokoll...
(Info > Message Log...)

Info > Sitzung-Info > Mitteilungenprotokoll
(Info > Session Info > Message Log)

Dienstprogramme > Datum/Zeit
anzeigen
(Utilities > Display Date/Time)

Info > Sitzung-Info > Datum und Uhrzeit
(Info > Session Info > Date and Time)

Info > Regenerierungsinfo...
(Info > Regen Info...)

Dienstprogramme > Modell-Player
(Utilities > Model Player)

Dienstprogramme > Trail-
/Trainingsdatei...
(Utilities > Trail/Training File...)

Dienstprogramme > Trail-/Trainingsdatei
abspielen...
(Utilities > Play Trail/Training File...)

Dienstpogramme > Distributed
Computing...
(Utilities > Distributed
Computing...)

Dienstpogramme > Distributed Computing...
(Utilities > Distributed Computing...)
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Alte Position Neue Position (*nur neue Kennung)

Dienstprogramme >
Voreinstellungen
(Utilities > Preferences)

Dienstprogramme > Optionen
(Utilities > Options)*

Fenster > System oeffnen
(Window > Open System)

Fenster > Systemfenster oeffnen
(Window > Open System Window)*

Hilfe > Pro/E Hilfesystem
(Help > Pro/E Help System)

Hilfe > Inhalt und Index
(Help > Contents and Index)*

Hilfe > Voreinstellungen fuer i-
Site
(Help > I-Site Preferences)

Hilfe > PTC i-Site
(Help > PTC i-Site)*

Hilfe > Rundungen-Tutor
(Help > Round Tutor)

Hilfe > Lernprogramme > Anleitung zur
Rundungserzeugung
(Help > Tutorials > Rounds Creation Guide)

Hilfe > Customer Services Info
(Help > Customer Services Info)

Hilfe > Technical Support Info
(Help > Technical Support Info)

Alte Position Neue Position (*nur mit "Neu"
gekennzeichnete)

Datei > Importieren > Neues
Modell erzeugen
(File > Import > Create New
Model)

Datei > Oeffnen...
(File > Open...)
("Alle Dateien" wählen oder Typenfilter
verwenden)

Datei > Importieren > An Modell
anhaengen...
(File > Import > Append to
Model...)

Einfuegen > Daten aus Datei oder
Komponente > Einbauen
Insert > Data from file or Component >
Assemble
(läßt alle Dateitypen zu)

Datei > Exportieren
(File > Export)

Datei > Kopie speichern...
(File > Save a Copy...)

Konstr Element > Erzeugen >
ICEM In
(Feature > Create > ICEM In)

Datei > Oeffnen, Einfuegen > Daten aus
Datei...
(File > Open, Insert > Data from File...)



2-6 Pro/ENGINEER 2001 Versionshinweise

Alte Position Neue Position (*nur mit "Neu"
gekennzeichnete)

 Konstr Element > Erzeugen >
CDRS In
(Feature > Create > CDRS In)

 Datei > Oeffnen, Einfuegen > Daten aus
Datei...
(File > Open, Insert > Data from File...)

 Konstr Element > Erzeugen >
DESKTOP In
(Feature > Create > DESKTOP
In)

 Datei > Oeffnen, Einfuegen > Daten aus
Datei...
(File > Open, Insert > Data from File...)

Menü-Zuordnung für Pro/SHEETMETAL

Alte Position Icon Neue Position

Konstr Element > Erzeugen > Blech >
Ausklinken
(Feature > Create > Sheetmetal > Notch)

Einfuegen > Form >
Ausklinken
(Insert > Shape > Notch)

Konstr Element > Erzeugen > Blech >
Stanzen
(Feature > Create > Sheetmetal > Punch)

Einfuegen > Form >
Stanzen
(Insert > Shape > Punch)

Konstr Element > Erzeugen > Blech >
Lasche > Flach > Kein Radius
(Feature > Create > Sheetmetal > Wall >
Flat > No Radius)

Einfuegen > Blechlasche >
Flach...
(Insert > Sheetmetal Wall >
Flat...)

Konstr Element > Erzeugen > Blech >
Lasche > Flach > Mit Radius
(Feature > Create > Sheetmetal > Wall >
Flat > Use Radius)

Einfuegen > Blechlasche >
Flach mit Radius...
(Insert > Sheetmetal Wall >
Flat with Radius...)

Konstr Element > Erzeugen > Blech >
Lasche > Profil > Kein Radius
(Feature > Create > Sheetmetal > Wall >
Extruded > No Radius)

Einfuegen > Blechlasche >
Profil...
(Insert > Sheetmetal Wall >
Extrude...)

Konstr Element > Erzeugen > Blech >
Lasche > Profil > Mit Radius
(Feature > Create > Sheetmetal > Wall >
Extruded > Use Radius)

Einfuegen > Blechlasche >
Profil mit Radius...
(Insert > Sheetmetal Wall >
Extrude with Radius...)
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Alte Position Icon Neue Position

Konstr Element > Erzeugen > Blech >
Lasche > Rotation
(Feature > Create > Sheetmetal > Wall >
Revolve)

Einfuegen > Blechlasche >
Nicht-angesetzt > Rotation...
(Insert > Sheetmetal Wall >
Unattached > Revolve...)

Konstr Element > Erzeugen > Blech >
Lasche > Verbinden
(Feature > Create > Sheetmetal > Wall >
Blend)

Einfuegen > Blechlasche >
Nicht-angesetzt >
Verbund...
(Insert > Sheetmetal Wall >
Unattached > Blend...)

Konstr Element > Erzeugen > Blech >
Lasche > Versatz
(Feature > Create > Sheetmetal > Wall >
Offset)

Einfuegen > Blechlasche >
Nicht-angesetzt > Versatz...
(Insert > Sheetmetal Wall >
Unattached > Offset...)

Konstr Element > Erzeugen > Blech >
Lasche > Spezial
(Feature > Create > Sheetmetal > Wall >
Advanced)

Keine Einfuegen > Blechlasche >
Nicht-angesetzt
(Insert > Sheetmetal Wall >
Unattached)

Konstr Element > Erzeugen > Blech >
Lasche > Verdrehen
(Feature > Create > Sheetmetal > Wall >
Twist)

Keine Einfuegen > Blechlasche >
Verdrehen...
(Insert > Sheetmetal Wall >
Twist...)

Konstr Element > Erzeugen > Blech >
Lasche >  Gezogen> Kein Radius
(Feature > Create > Sheetmetal > Wall >
Swept > No Radius)

Einfuegen > Blechlasche >
Ziehen...
(Insert > Sheetmetal Wall >
Sweep...)

Konstr Element > Erzeugen > Blech >
Lasche > Gezogen> Mit Radius
(Feature > Create > Sheetmetal > Wall >
Swept > Use Radius)

Einfuegen > Blechlasche >
Zugkoerper mit Radius...
(Insert > Sheetmetal Wall >
Sweep with Radius...)

Konstr Element > Erzeugen > Blech >
Lasche > Verlaengern
(Feature > Create > Sheetmetal > Wall >
Extend)

Einfuegen > Blechlasche >
Verlaengern...
(Insert > Sheetmetal Wall >
Extend...)

Konstr Element > Erzeugen > Blech >
Lasche > Verschmelzen
(Feature > Create > Sheetmetal > Wall >

Einfuegen > Laschen
verschmelzen...
(Insert > Merge Walls...)
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Alte Position Icon Neue Position

Merge)

Konstr Element > Erzeugen > Blech >
Biegen
(Feature > Create > Sheetmetal > Bend)

Einfuegen > Biegeoperation
> Biegen
(Insert > Bend Operation >
Bend)

Konstr Element > Erzeugen > Blech >
Abwickeln
(Feature > Create > Sheetmetal >
Unbend)

Einfuegen > Biegeoperation
> Abwickeln
(Insert > Bend Operation >
Unbend)

Konstr Element > Erzeugen > Blech >
Rueckbiegen
(Feature > Create > Sheetmetal > Bend
Back)

Einfuegen > Biegeoperation
> Rueckbiegen
(Insert > Bend Operation >
Bend Back)

Konstr Element > Erzeugen > Blech >
Endabwicklung
(Feature > Create > Sheetmetal > > Flat
Pattern)

Einfuegen > Biegeoperation
> Endabwicklung
(Insert > Bend Operation >
Flat Pattern)

Konstr Element > Erzeugen > Blech >
Sicke
(Feature > Create > Sheetmetal > Form)

Einfuegen > Form > Sicke
(Insert > Shape > Form)

Konstr Element > Erzeugen > Blech >
Sicke abflachen
(Feature > Create > Sheetmetal > Flatten
Form)

Einfuegen > Form > Sicke
abflachen
(Insert > Shape > Flatten
Form)

Konstr Element > Erzeugen > Blech >
MatSchnitt
(Feature > Create > Sheetmetal > Cut)

Einfuegen > Blechausbruch
(Insert > Sheetmetal Cut)

Konstr Element > Erzeugen > Blech >
Trennung
(Feature > Create > Sheetmetal > Rip)

Einfuegen > Form >
Trennung
(Insert > Shape > Rip)
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Alte Position Icon Neue Position

Konstr Element > Erzeugen > Blech >
Verformbereich
(Feature > Create > Sheetmetal > Deform
Area)

Einfuegen > Biegeoperation
> Verformbereich
(Insert > Bend Operation >
Deform Area)

Konstr Element > Erzeugen > Blech >
Konvertierung
(Feature > Create > Sheetmetal >
Conversion)

Einfuegen >
Konvertierung...
(Insert > Conversion...)

Konstr Element > Erzeugen > Blech >
Kantenbiegung
(Feature > Create > Sheetmetal > Edge
Bend)

Einfuegen >
Kantenbiegung...
(Insert > Edge Bend...)

Konstr Element > Erzeugen > Blech > Eck
Entlastung
(Feature > Create > Sheetmetal > Corner
Relief)

Einfuegen >
Eckenentlastung...
(Insert > Corner Relief...)

Menü-Zuordnung für Konstruktionsgrundmodul

Alte Position Neue Position

Bezug > Analyse
(Datum > Analysis)

Einfuegen >Bezug > Analyse
(Insert > Datum > Analysis)

Bezug > Achse
(Datum > Axis)

Einfuegen >Bezug > Achse
(Insert > Datum > Axis)

Bezug > KSys...
(Datum > Csys...)

Einfuegen > Bezug >
Koordinatensystem...
(Insert > Datum > Coordinate
System...)

Bezug > Kurve
(Datum > Curve)

Einfuegen > Bezug > Kurve
(Insert > Datum > Curve)

Bezug > Graph
(Datum > Graph)

Einfuegen >Bezug > Graph
(Insert > Datum > Graph)
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Alte Position Neue Position

Bezug > Versatzebenen...
(Datum > Offset Planes...)

Einfuegen > Bezug >
Versatzebenen...
(Insert > Datum > Offset Planes...)

Bezug > Ebene
(Datum > Plane)

Einfuegen > Bezug > Ebene
(Insert > Datum > Plane)

Bezug > Punkt
(Datum > Point)

Einfuegen > Bezug > Punkt
(Insert > Datum > Point)

Mod extrah
(Extract Mdl)

ROHRLEGEN > Montage > Mod
extrah
(PIPING > Fabrication > Extract
Mdl)

Konstr Element > Kopieren
(Feature > Copy)

Menüauswahl existiert nicht mehr

Konstr Element > Erzeugen > Kosmetik >
Skizze
(Feature > Create > Cosmetic > Sketch)

Einfuegen > Kosmetik > Skizze...
(Insert > Cosmetic > Sketch...)

Konstr Element > Erzeugen > Kosmetik >
Gewinde
(Feature > Create > Cosmetic > Thread)

Einfuegen > Kosmetik > Gewinde...
(Insert > Cosmetic > Thread...)

Konstr Element > Erzeugen > Gemeins
DatBenutz
(Feature > Create > Data Sharing)

Einfuegen > Gemeinsam benutzte
Daten
(Insert > Shared Data)

Konstr Element > Erzeugen > Gemeins
DatBenutz > KopieGeom
(Feature > Create > Data Sharing >
CopyGeom)

Einfuegen > Gemeinsam benutzte
Daten > Kopie-Geometrie...
(Insert > Shared Data > Copy
Geometry...)

Konstr Element > Erzeugen > Gemeins
DatBenutz > ExtKopieGeom
(Feature > Create > Data Sharing >
ExtCopyGeom)

Einfuegen > Gemeinsam benutzte
Daten > KopieGeometrie aus
anderem Modell...
(Insert > Shared Data > Copy
Geometry from Other Model...)
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Konstr Element > Erzeugen > Gemeins
DatBenutz > ExtSchrumpfVerpack
(Feature > Create > Data Sharing >
ExtShrinkwrap)

Einfuegen > Gemeinsam benutzte
Daten > Schrumpfverpackung aus
anderem Modell...
(Insert > Shared Data > Shrinkwrap
from Other Model...)

Konstr Element > Erzeugen > Gemeins
DatBenutz > PublizierGeom
(Feature > Create > Data Sharing >
PublishGeom)

Einfuegen > Gemeinsam benutzte
Daten > PublizierGeom...
(Insert > Shared Data > Publish
Geometry...)

Konstr Element > Erzeugen > Gemeins
DatBenutz > SchrumpfVerpack
(Feature > Create > Data Sharing >
Shrinkwrap)

Einfuegen > Gemeinsam benutzte
Daten > SchrumpfVerpack...
(Insert > Shared Data >
Shrinkwrap...)

Konstr Element > Erzeugen >
Volumenkoerper > Fase
(Feature > Create > Solid > Chamfer)

Einfuegen > Fase
(Insert > Chamfer)

Konstr Element > Erzeugen >
Volumenkoerper > Kosmetik > ECAD
Bereiche
(Feature > Create > Solid > Cosmetic >
ECAD Areas)

Einfuegen > Kosmetik > ECAD
Bereich...
(Insert > Cosmetic > ECAD Area...)

Konstr Element > Erzeugen >
Volumenkoerper > Kosmetik > Gravieren
(Feature > Create > Solid > Cosmetic >
Groove)

Einfuegen > Kosmetik > Gravur...
(Insert > Cosmetic > Groove...)

Konstr Element > Erzeugen >
Volumenkoerper > Kosmetik > Skizze
(Feature > Create > Solid > Cosmetic >
Sketch)

Einfuegen > Kosmetik > Skizze...
(Insert > Cosmetic > Sketch...)

Konstr Element > Erzeugen >
Volumenkoerper > Kosmetik > Gewinde
(Feature > Create > Solid > Cosmetic >
Thread)

Einfuegen > Kosmetik > Gewinde...
(Insert > Cosmetic > Thread...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Spezial >
Volumenkoerper > Aus Datei

Einfuegen > MatSchnitt > Verbund
aus Datei...
(Insert > Cut > Blend from File...)
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(Feature > Create > Solid > Cut >
Advanced > Solid > From File)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Spezial >
Volumenkoerper > Spirale ziehen
(Feature > Create > Solid > Cut >
Advanced > Solid > Helical Swp)

Einfuegen > MatSchnitt >
Spiralfoermiger Zugkoerper...
(Insert > Cut > Helical Sweep...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Spezial >
Volumenkoerper > SchnittZuFlaeche
(Feature > Create > Solid > Cut >
Advanced > Solid > Sect to Srfs)

Einfuegen > MatSchnitt > Schnitt
mit Flaechen verbinden...
(Insert > Cut > Blend Section to
Surfaces...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Spezial >
Volumenkoerper > FlaechZuFlaech
(Feature > Create > Solid > Cut >
Advanced > Solid > Srfs to Srfs)

Einfuegen > MatSchnitt > Zwischen
Flaechen verbinden...
(Insert > Cut > Blend Between
Surfaces...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Spezial >
Volumenkoerper > Zug-Verbundkoerper
(Feature > Create > Solid > Cut >
Advanced > Solid > Swept Blend)

Einfuegen > MatSchnitt > Zug-
Verbund-KE...
(Insert > Cut > Swept Blend...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Spezial >
Volumenkoerper > Var Schn Zieh
(Feature > Create > Solid > Cut >
Advanced > Solid > Var Sec Swp)

Einfuegen > MatSchnitt > Zug-KE
mit variablem Schnitt...
(Insert > Cut > Variable Section
Sweep...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Spezial >
Duenn > Aus Datei
(Feature > Create > Solid > Cut >
Advanced > Thin > From File)

Einfuegen > MatSchnitt > Verbund
aus Datei...
(Insert > Cut > Blend from File...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Spezial >
Duenn > Spirale ziehen
(Feature > Create > Solid > Cut >
Advanced > Thin > Helical Swp)

Einfuegen > MatSchnitt >
Spiralfoermiger Zugkoerper...
(Insert > Cut > Helical Sweep...)
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Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Spezial >
Duenn > Zug-Verbundkoerper
(Feature > Create > Solid > Cut >
Advanced > Thin > Swept Blend)

Einfuegen > MatSchnitt > Zug-
Verbund-KE...
(Insert > Cut > Swept Blend...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Spezial >
Duenn > Var Schn Zieh
(Feature > Create > Solid > Cut >
Advanced > Thin > Var Sec Swp)

Einfuegen > MatSchnitt > Zug-KE
mit variablem Schnitt...
(Insert > Cut > Variable Section
Sweep...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt >
Verbinden > Volumenkoerper
(Feature > Create > Solid > Cut > Blend >
Solid)

Einfuegen > MatSchnitt > Verbund...
(Insert > Cut > Blend...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt >
Verbinden > Duenn
(Feature > Create > Solid > Cut > Blend >
Thin)

Einfuegen > Duenner MatSchnitt >
Verbund...
(Insert > Thin Cut > Blend...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Profil >
Volumenkoerper
(Feature > Create > Solid > Cut > Extrude
> Solid)

Einfuegen > MatSchnitt > Profil...
(Insert > Cut > Extrude...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Profil >
Duenn
(Feature > Create > Solid > Cut > Extrude
> Thin)

Einfuegen > Duenner MatSchnitt >
Profil...
(Insert > Thin Cut > Extrude...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Rotation
> Volumenkoerper
(Feature > Create > Solid > Cut > Revolve
> Solid)

Einfuegen > MatSchnitt > Rotation...
(Insert > Cut > Revolve...)
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Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt >
Rotation... > Duenn
(Feature > Create > Solid > Cut > Revolve
> Thin)

Einfuegen > Duenner MatSchnitt >
Rotation...
(Insert > Thin Cut > Revolve...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Ziehen >
Volumenkoerper
(Feature > Create > Solid > Cut > Sweep >
Solid)

Einfuegen > MatSchnitt > Ziehen...
(Insert > Cut > Sweep...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Ziehen >
Duenn
(Feature > Create > Solid > Cut > Sweep >
Thin)

Einfuegen > Duenner MatSchnitt >
Ziehen...
(Insert > Thin Cut > Sweep...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Sammelfl
verwend > Volumenkoerper
(Feature > Create > Solid > Cut > Use
Quilt > Solid)

Einfuegen > MatSchnitt > Sammelfl
verwend...
(Insert > Cut > Use Quilt...)

Konstr Element > Erzeugen >
Volumenkoerper > MatSchnitt > Sammelfl
verwend > Duenn
(Feature > Create > Solid > Cut > Use
Quilt > Thin)

Einfuegen > Duenner MatSchnitt >
Sammelfl verwend...
(Insert > Thin Cut > Use Quilt...)

Konstr Element > Erzeugen >
Volumenkoerper > Bohrung
(Feature > Create > Solid > Hole)

Einfuegen > Bohrung...
(Insert > Hole...)

Konstr Element > Erzeugen >
Volumenkoerper > Rohr
(Feature > Create > Solid > Pipe)

Einfuegen > Spezial > Rohr...
(Insert > Advanced > Pipe...)

Konstr Element > Erzeugen >
Volumenkoerper > Koerper
(Feature > Create > Solid > Protrusion)

Einfuegen > Koerper
(Insert > Protrusion)
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Konstr Element > Erzeugen >
Volumenkoerper > Rippe
(Feature > Create > Solid > Rib)

Einfuegen > Rippe
(Insert > Rib)

Konstr Element > Erzeugen >
Volumenkoerper > Rundung
(Feature > Create > Solid > Round)

Einfuegen > Rundung...
(Insert > Round...)

Konstr Element > Erzeugen >
Volumenkoerper > Schale
(Feature > Create > Solid > Shell)

Einfuegen > Schale
(Insert > Shell)

Konstr Element > Erzeugen >
Volumenkoerper > Verformung > Schraege
(Feature > Create > Solid > Tweak > Draft)

Einfuegen > Schraege...
(Insert > Draft...)

Konstr Element > Erzeugen >
Volumenkoerper > Verformung >
SchraegVersatz
(Feature > Create > Solid > Tweak > Draft
Offset)

Einfuegen > Spezial >
SchraegVersatz...
(Insert > Advanced > Draft Offset...)

Konstr Element > Erzeugen >
Volumenkoerper > Verformung >
SammFlae abfl
(Feature > Create > Solid > Tweak >
Flatten Quilt)

Einfuegen > Spezial > Abgewickelte
Sammelflaeche...
(Insert > Advanced > Flatten Quilt...)

Konstr Element >Erzeugen >
Volumenkoerper > Verformung > Freiform
(Feature > Create > Solid > Tweak > Free
Form)

Einfuegen > Spezial > Freiform...
(Insert > Advanced > Free Form...)

Konstr Element > Erzeugen >
Volumenkoerper > Verformung > Versatz
(Feature > Create > Solid > Tweak >
Offset)

Einfuegen > Spezial >
BereichVersatz...
(Insert > Advanced > Area Offset...)

Konstr Element > Erzeugen >
Volumenkoerper > Verformung >
Einzelflaeche
(Feature > Create > Solid > Tweak >
Patch)

Einfuegen > Spezial >
Einzelflaeche...
(Insert > Advanced > Patch...)
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Konstr Element > Erzeugen >
Volumenkoerper > Verformung > Ersetzen
(Feature > Create > Solid > Tweak >
Replace)

Einfuegen > Spezial >
Flaechenersetzung...
(Insert > Advanced > Replace
Surface...)

Konstr Element > Erzeugen >
Volumenkoerper > Verformung > Vol
biegen
(Feature > Create > Solid > Tweak > >
Solid Bend)

Einfuegen > Spezial > VolKoerper-
Biegung...
(Insert > Advanced > Bend Solid...)

Konstr Element > Erzeugen >
Volumenkoerper > Verformung >
Steuerkrv bieg
(Feature > Create > Solid > Tweak > >
Spinal Bend)

Einfuegen > Spezial >
Steuerkurvenbiegung...
(Insert > Advanced > Spinal Bend...)

Konstr Element > Erzeugen >
Volumenkoerper > Verformung > Ring
biegen
(Feature > Create > Solid > Tweak > >
Toroidal Bend)

Einfuegen > Spezial > Ringbiegung...
(Insert > Advanced > Toroidal
Bend...)

Konstr Element > Erzeugen > Style
(Feature > Create > Style)

Einfuegen > Style
(Insert > Style)

Konstr Element > Erzeugen > Flaeche >
BereichVersatz
(Feature > Create > Surface > Area Offset)

Einfuegen > Flaechenoperation >
SchraegVersatz...
(Insert > Surface Operation> Draft
Offset...)

Konstr Element > Erzeugen > Flaeche >
Schraege
(Feature > Create > Surface > Draft)

Einfuegen > Flaechenoperation >
Schraege...
(Insert > Surface Operation> Draft...)

Konstr Element > Erzeugen > Flaeche >
SchraegVersatz
(Feature > Create > Surface > Draft Offset)

Einfuegen > Flaechenoperation >
BereichVersatz...
(Insert > Surface Operation> Area
Offset...)

Konstr Element > Erzeugen > Flaeche >
Verlaengern
(Feature > Create > Surface > Extend)

Einfuegen > Flaechenoperation >
Verlaengern...
(Insert > Surface Operation>
Extend...)
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Konstr Element > Erzeugen > Flaeche >
Verschmelzen
(Feature > Create > Surface > Merge)

Einfuegen > Flaechenoperation >
Verschmelzen...
(Insert > Surface Operation>
Merge...)

Konstr Element > Erzeugen > Flaeche >
Neu > Spezial > Berandungen
(Feature > Create > Surface > New >
Advanced > Boundaries)

Einfuegen > Flaeche > Aus
Berandungen...
(Insert > Surface > From
Boundaries)

Konstr Element > Erzeugen > Flaeche >
Neu > Spezial > Freiform
(Feature > Create > Surface > New >
Advanced > Free Form)

Einfuegen > Flaeche > Freiform...
(Insert > Surface > Free Form...)

Konstr Element > Erzeugen > Flaeche >
Neu > Spezial > Aus Datei
(Feature > Create > Surface > New >
Advanced > From File)

Einfuegen > Flaeche > Verbund aus
Datei...
(Insert > Surface > Blend from
File...)

Konstr Element > Erzeugen > Flaeche >
Neu > Spezial > Spirale ziehen
(Feature > Create > Surface > New >
Advanced > Helical Swp)

Einfuegen > Flaeche >
Spiralfoermiger Zugkoerper...
(Insert > Surface > Helical Sweep...)

Konstr Element > Erzeugen > Flaeche >
Neu > Spezial > SchnittZuFlaeche
(Feature > Create > Surface > New >
Advanced > Sect to Srfs)

Einfuegen > Flaeche > Schnitt mit
Flaechen verbinden...
(Insert > Surface > Blend Section to
Surfaces...)

Konstr Element > Erzeugen > Flaeche >
Neu > Spezial > FlaechZuFlaech
(Feature > Create > Surface > New >
Advanced > Srfs to Srfs)

Einfuegen > Flaeche > Zwischen
Flaechen verbinden...
(Insert > Surface > Blend Between
Surfaces...)

Konstr Element > Erzeugen > Flaeche >
Neu > Spezial > Zug-Verbundkoerper
(Feature > Create > Surface > New >
Advanced > Swept Blend)

Einfuegen > Flaeche > Zug-Verbund-
KE...
(Insert > Surface > Swept Blend...)

Konstr Element > Erzeugen > Flaeche >
Neu > Spezial > Tang/Flaech
(Feature > Create > Surface > New >
Advanced > TangentToSrf)

Einfuegen > Flaeche > Tangente mit
Flaechen verbinden...
(Insert > Surface > Blend Tangent to
Surfaces...)
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Konstr Element > Erzeugen > Flaeche >
Neu > Spezial > Var Schn Zieh
(Feature > Create > Surface > New >
Advanced > Var Sec Swp)

Einfuegen > Flaeche > Zug-KE mit
variablem Schnitt...
(Insert > Surface > Variable Section
Sweep...)

Konstr Element > Erzeugen > Flaeche >
Neu > Verbinden
(Feature > Create > Surface > New >
Blend)

Einfuegen > Flaeche > Verbund...
(Insert > Surface > Blend...)

Konstr Element > Erzeugen > Flaeche >
Neu > Kopieren
(Feature > Create > Surface > New > Copy)

Einfuegen > Flaeche > Kopieren...
(Insert > Surface > Copy...)

Konstr Element > Erzeugen > Flaeche >
Neu > Trimm kopier
(Feature > Create > Surface > New > Copy
by Trim)

Einfuegen > Flaeche > Kopieren...
(Insert > Surface > Getrimmte
Kopie...)

Konstr Element > Erzeugen > Flaeche >
Neu > Profil
(Feature > Create > Surface > New >
Extrude)

Einfuegen > Flaeche > Profil...
(Insert > Surface > Extrude...)

Konstr Element > Erzeugen > Flaeche >
Neu > Verrundung
(Feature > Create > Surface > New >
Fillet)

Einfuegen > Flaeche > Verrundung...
(Insert > Surface > Fillet...)

Konstr Element > Erzeugen > Flaeche >
Neu > Flach
(Feature > Create > Surface > New > Flat)

Einfuegen > Flaeche > Flach...
(Insert > Surface > Flat...)

Konstr Element > Erzeugen > Flaeche >
Neu > Versatz
(Feature > Create > Surface > New >
Offset)

Einfuegen > Flaeche > Versatz...
(Insert > Surface > Offset...)

Konstr Element > Erzeugen > Flaeche >
Neu > Rotation
(Feature > Create > Surface > New >
Revolve)

Einfuegen > Flaeche > Rotation...
(Insert > Surface > Revolve...)
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Konstr Element > Erzeugen > Flaeche >
Neu > Ziehen
(Feature > Create > Surface > New >
Sweep)

Einfuegen > Flaeche > Ziehen...
(Insert > Surface > Sweep...)

Konstr Element > Erzeugen > Flaeche >
Transformieren
(Feature > Create > Surface > Transform)

Einfuegen > Flaechenoperation >
Transformieren...
(Insert > Surface Operation>
Transform...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Spezial > Volumenkoerper >
Aus Datei
(Feature > Create > Surface > Trim >
Advanced > Solid > From File)

Einfuegen > Flaechentrimmung >
Verbund aus Datei...
(Insert > Surface Trim > Blend from
File...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Spezial > Volumenkoerper >
Aus Datei
(Feature > Create > Surface > Trim >
Advanced > Solid > From File)

Einfuegen > Trimmung an duenner
Flaeche > Verbund aus Datei...
(Insert > Thin Surface Trim > Blend
from File...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Spezial > Volumenkoerper >
Spirale ziehen
(Feature > Create > Surface > Trim >
Advanced > Solid > Helical Swp)

Einfuegen > Flaechentrimmung >
Spiralfoermiger Zugkoerper...
(Insert > Surface Trim > Helical
Sweep...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Spezial > Volumenkoerper >
Spirale ziehen
(Feature > Create > Surface > Trim >
Advanced > Solid > Helical Swp)

Einfuegen > Trimmung an duenner
Flaeche > Spiralfoermiger
Zugkoerper...
(Insert > Thin Surface Trim > Helical
Sweep...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Spezial > Volumenkoerper >
SchnittZuFlaeche
(Feature > Create > Surface > Trim >
Advanced > Solid > Sect to Srfs)

Einfuegen > Flaechentrimmung >
Schnitt mit Flaechen verbinden...
(Insert > Surface Trim > Blend
Section to Surfaces...)
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Konstr Element > Erzeugen > Flaeche >
Trimmen > Spezial > Volumenkoerper >
Zug-Verbundkoerper
(Feature > Create > Surface > Trim >
Advanced > Solid > Swept Blend)

Einfuegen > Flaechentrimmung >
Zug-Verbund-KE...
(Insert > Surface Trim > Swept
Blend...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Spezial > Volumenkoerper >
Zug-Verbundkoerper
(Feature > Create > Surface > Trim >
Advanced > Solid > Swept Blend)

Einfuegen > Trimmung an duenner
Flaeche > Zug-Verbund-KE...
(Insert > Thin Surface Trim > Swept
Blend...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Spezial > Volumenkoerper >
Var Schn Zieh
(Feature > Create > Surface > Trim >
Advanced > Solid > Var Sec Swp)

Einfuegen > Flaechentrimmung >
Zug-KE mit variablem Schnitt...
(Insert > Surface Trim > Variable
Section Sweep...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Spezial > Volumenkoerper >
Var Schn Zieh
(Feature > Create > Surface > Trim >
Advanced > Solid > Var Sec Swp)

Einfuegen > Trimmung an duenner
Flaeche > Zug-KE mit variablem
Schnitt...
(Insert > Thin Surface Trim >
Variable Section Sweep...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Verbinden > Volumenkoerper
(Feature > Create > Surface > Trim >
Blend > Solid)

Einfuegen > Flaechentrimmung >
Verbund...
(Insert > Surface Trim > Blend...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Verbinden > Duenn
(Feature > Create > Surface > Trim >
Blend > Thin)

Einfuegen > Trimmung an duenner
Flaeche > Verbund...
(Insert > Thin Surface Trim >
Blend...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Profil > Volumenkoerper
(Feature > Create > Surface > Trim >
Extrude > Solid)

Einfuegen > Flaechentrimmung >
Profil...
(Insert > Surface Trim> Extrude...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Profil > Duenn
(Feature > Create > Surface > Trim >
Extrude > Thin)

Einfuegen > Trimmung an duenner
Flaeche > Profil...
(Insert > Thin Surface Trim>
Extrude...)
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Konstr Element > Erzeugen > Flaeche >
Trimmen > Rotation > Volumenkoerper
(Feature > Create > Surface > Trim >
Revolve > Solid)

Einfuegen > Flaechentrimmung >
Rotation...
(Insert > Surface Trim > Revolve...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Rotation > Duenn
(Feature > Create > Surface > Trim >
Revolve > Thin)

Einfuegen > Trimmung an duenner
Flaeche> Rotation...
(Insert > Thin Surface Trim >
Revolve...)

Erzeugen > Flaeche > Trimmen >
Silhouette > Volumenkoerper
(Feature > Create > Surface > Trim >
Silhouette > Solid)

Einfuegen > Flaechentrimmung >
Silhouette...
(Insert > Surface Trim >
Silhouette...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Ziehen > Volumenkoerper
(Feature > Create > Surface > Trim >
Sweep > Solid)

Einfuegen > Flaechentrimmung >
Ziehen...
(Insert > Surface Trim > Sweep...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Ziehen > Duenn
(Feature > Create > Surface > Trim >
Sweep > Thin)

Einfuegen > Trimmung an duenner
Flaeche > Ziehen...
(Insert > Thin Surface Trim >
Sweep...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Kurven verwend >
Volumenkoerper
(Feature > Create > Surface > Trim > Use
Curves > Solid)

Einfuegen > Flaechentrimmung >
Kurven verwend...
(Insert > Surface Trim> Use
Curves...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Sammelfl verwend >
Volumenkoerper
(Feature > Create > Surface > Trim > Use
Quilt > Solid)

Einfuegen > Flaechentrimmung >
Sammelfl verwend...
(Insert > Surface Trim> Use Quilt...)

Konstr Element > Erzeugen > Flaeche >
Trimmen > Sammelfl verwend > Duenn
(Feature > Create > Surface > Trim > Use
Quilt > Thin)

Einfuegen > Trimmung an duenner
Flaeche > Sammelfl verwend...
(Insert > Thin Surface Trim> Use
Quilt...)
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Konstr Element > Erzeugen > Flaeche >
Trimmen > EckpktRundung >
Volumenkoerper
(Feature > Create > Surface > Trim >
Vertex Round > Solid)

Einfuegen > Flaechentrimmung >
EckpktRundung...
(Insert > Surface Trim > Vertex
Round...)

Konstr Element > Erzeugen > BenutzerDef
(Feature > Create > User Defined)

Einfuegen > Benutzerdefiniertes
KE...
(Insert > User-Defined Feature)

Konstr Element > Muster loeschen
(Feature > Del Pattern)

Menüauswahl existiert nicht mehr

Konstr Element > Loeschen
(Feature > Delete)

Editieren > Loeschen
(Edit > Delete)

Konstr Element> Gruppe
(Feature > Group)

Menüauswahl existiert nicht mehr.
Alternative: Komponente >
SpezialDienstpr > Gruppe
(Component > Adv Utils > Group)

Konstr Element > Schneiden
(Feature > Intersect)

Menüauswahl existiert nicht mehr

Konstr Element > Muster
(Feature > Pattern)

Editieren > Muster...
(Edit > Pattern...)

Konstr Element > Schreibgeschuetzt
(Feature > Read Only)

Menüauswahl existiert nicht mehr

Konstr Element > Umdefinieren
(Feature > Redefine)

Editieren > Definition
(Edit > Definition)

Konstr Element > Reihenf aend
(Feature > Reorder)

Menüauswahl existiert nicht mehr

Konstr Element> Neue Referenz
(Feature > Reroute)

Editieren > Referenzen
(Edit > References)

Konstr Element > Zurueckholen
(Feature > Resume)

Editieren > Zurueckholen
(Edit > Resume)



Benutzeroberfläche 2-23

Alte Position Neue Position

Konstr Element > Unterdruecken
(Feature > Suppress)

Editieren > Unterdruecken
(Edit > Suppress)

Konstr Element > UDF-Bibliothek
(Feature > UDF Library)

Menüauswahl existiert nicht mehr.
Alternative: Komponente >
SpezialDienstpr > UDF-Bibliothek
(Component > Adv Utils > UDF
Library)

Leitungsdatensatz
(Line Stock)

Einstellung > Leitungsdatensatz
(Setup > Line Stock)

Volumenkoerper
(Make Solid)

Montage > Rohrkoerper
(Fabrication > Pipe Solid)

Darst einst
(Set Display)

Einstellung > Darst einst
(Setup > Set Display)

Menü-Zuordnung für Pro/SURFACE

Alte Position Neue Position

Konstr Element > Erzeugen > Flaeche > Spezial >
Freiform
(Feature > Create > Surface > Advanced > Free
Form)

Einfuegen > Flaeche >
Freiform...
(Insert > Surface > Free Form...)

Konstr Element > Erzeugen > Flaeche > Spezial >
Aus Datei
(Feature > Create > Surface > Advanced > From
File)

Einfuegen > Flaeche > Verbund
aus Datei...
(Insert > Surface > Blend from
File...)

Konstr Element > Erzeugen > Flaeche > Spezial >
Spirale ziehen
(Feature > Create > Surface > Advanced > Helical
Swp)

Einfuegen > Flaeche >
Spiralfoermiger Zugkoerper...
(Insert > Surface > Helical
Sweep...)

Konstr Element > Erzeugen > Flaeche > Spezial >
SchnittZuFlaeche
(Feature > Create > Surface > Advanced > Sect to
Srfs)

Einfuegen > Flaeche > Schnitt
mit Flaechen verbinden...
(Insert > Surface > Blend
Section to Surfaces...)

Konstr Element > Erzeugen > Flaeche > Spezial >
FlaechZuFlaech

Einfuegen > Flaeche > Zwischen
Flaechen verbinden...
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(Feature > Create > Surface > Advanced > Srfs to
Srfs)

(Insert > Surface > Blend
Between Surfaces...)

Konstr Element > Erzeugen > Flaeche > Spezial >
Gezog Verbund
(Feature > Create > Surface > Advanced > Swept
Blend)

Einfuegen > Flaeche > Zug-
Verbund-KE...
(Insert > Surface > Swept
Blend...)

Konstr Element > Erzeugen > Flaeche > Spezial >
Tang/Flaech
(Feature > Create > Surface > Advanced >
TangentToSrf)

Einfuegen > Flaeche > Tangente
mit Flaechen verbinden...
(Insert > Surface > Blend
Tangent to Surfaces...)

Konstr Element > Erzeugen > Flaeche > Spezial >
Var Schn Zieh
(Feature > Create > Surface > Advanced > Var Sec
Swp)

Einfuegen > Flaeche > Zug-KE
mit variablem Schnitt...
(Insert > Surface > Variable
Section Sweep...)

Konstr Element > Erzeugen > Flaeche > Spezial >
Berandungen
(Feature > Create > Surface > Advanced >
Boundaries)

Einfuegen > Flaeche > Aus
Berandungen...
(Insert > Surface > From
Boundaries)

Konstr Element > Erzeugen > Flaeche >
Verbinden
(Feature > Create > Surface > Blend)

Einfuegen > Flaeche >
Verbund...
(Insert > Surface > Blend...)

Konstr Element > Erzeugen > Flaeche > Kopieren
(Feature > Create > Surface > Copy)

Einfuegen > Flaeche >
Kopieren...
(Insert > Surface > Copy...)

Konstr Element > Erzeugen > Flaeche > Trimm
kopier
(Feature > Create > Surface > Copy by Trim)

Einfuegen > Flaeche >
Kopieren...
(Insert > Surface > Getrimmte
Kopie...)

Konstr Element > Erzeugen > Flaeche > Profil
(Feature > Create > Surface > Extrude)

Einfuegen > Flaeche > Profil...
(Insert > Surface > Extrude...)

Konstr Element > Erzeugen > Flaeche >
Verrundung
(Feature > Create > Surface > Fillet)

Einfuegen > Flaeche >
Verrundung...
(Insert > Surface > Fillet...)

Konstr Element > Erzeugen > Flaeche > Flach
(Feature > Create > Surface > Flat)

Einfuegen > Flaeche > Flach...
(Insert > Surface > Flat...)

Konstr Element > Erzeugen > Flaeche > Versatz
(Feature > Create > Surface > Offset)

Einfuegen > Flaeche > Versatz...
(Insert > Surface > Offset...)
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Konstr Element > Erzeugen > Flaeche > Rotation
(Feature > Create > Surface > Revolve)

Einfuegen > Flaeche > Rotation
(Insert > Surface > Revolve)

Konstr Element > Erzeugen > Flaeche > Ziehen
(Feature > Create > Surface > Sweep)

Einfuegen > Flaeche > Ziehen...
(Insert > Surface > Sweep...)

Ansicht > Spezial > Flae vernetzen
(View > Advanced > Mesh Surface)

Ansicht > Modell einrichten >
Flaeche vernetzen...
(View > Model Setup > > Mesh
Surface...)

Menü-Zuordnung für Pro/DETAIL
In der Menü-Zuordnungstabelle für Pro/DETAIL sind in der Spalte
"Neue Position" u.U. mehrere Möglichkeiten des Zugriffs auf die in der
Spalte "Alte Position" beschriebene Funktionalität aufgeführt. Die
Abkürzungsmethoden sind ebenfalls in der Spalte "Neue Position"
aufgeführt.

Alte Position Neue Position

DETAIL > Zeigen/Wegnehm
(DETAIL > Show/Erase)

Ansicht > Zeigen und Wegnehmen...
(View > Show and Erase...)

Wählen Sie Elemente, und klicken Sie mit der
rechten Maustaste, um Wegnehmen (Erase) zu
wählen.

DETAIL > Erzeugen
(DETAIL > Create)

Menüauswahl existiert nicht mehr
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DETAIL > Loeschen
(DETAIL > Delete)

Wählen Sie die Elemente und anschließend
Editieren > Loeschen (Edit > Delete).

Wählen Sie Elemente, und klicken Sie mit der
rechten Maustaste, um Loeschen (Delete) zu
wählen.

Klicken Sie auf  in der Tool-Leiste für
Zeichnungen.

Editieren > Knicke loeschen (Delete Jogs)
(nur für Knicke)

DETAIL > Bewegen
(DETAIL > Move)

Wählen Sie die Elemente, und ziehen Sie sie mit
Hilfe der Ziehgriffe.

Klicken Sie auf  in der Tool-Leiste für die
Zeichnungserstellung.

DETAIL > Text bewegen
(DETAIL > Move Text)

Wählen Sie das Element, und ziehen Sie den
Text mit Hilfe der Ziehgriffe.

DETAIL > Ansatz aendern
(DETAIL > Mod Attach)

Editieren > Ansatz
(Edit > Attachment)

Wählen Sie das Element, und klicken Sie mit der
rechten Maustaste, um Ansatz aendern (Mod
Attach) zu wählen.

DETAIL > Mehrere beweg
(DETAIL > Move Many)

Wählen Sie bei gedrückter UMSCHALT-Taste
mehrere Elemente. Ziehen Sie die Elemente an
die neue Position.

Klicken Sie auf  in der Tool-Leiste für
Zeichnungen und anschließend auf Viel-Auswahl
(Pick Many). Wählen Sie anhand von Auswahl,
Auswahlrahmen, Kette, Polygonzug (Pick, Pick
Box, Pick Chain, Pick Poly). Ziehen Sie die
Elemente an die neue Position.
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DETAIL > Unterbrechen >
Hinzufuegen
(DETAIL >Break > Add)

Einfuegen > Untrbrechen...
(Insert > Break...)

Wählen Sie die Bemassung, und klicken Sie mit
der rechten Maustaste, um Unterbrechen
(Break) zu wählen (nur für Bemaßungen).

DETAIL > Unterbrechen >
Entfernen
(DETAIL >Break > Remove)

Wählen Sie die Elemente und anschließend
Editieren > Alle Unterbrechungen loeschen (Edit
> Delete All Breaks).

Wählen Sie die Bemassung, und klicken Sie mit
der rechten Maustaste, Brueche loesch (Del
Breaks) zu wählen (nur für Bemaßungen).

DETAIL > Verkrz/Verlng
(DETAIL > Clip)

Wählen Sie die Elemente (oder Maßhilfslinien),
und bewegen Sie sie mit Hilfe der Ziehgriffe.

DETAIL > Ansicht wechseln
(DETAIL > Switch View)

Select the item and click Edit > Switch to View.

Wählen Sie das Element, und klicken Sie mit der
rechten Maustaste, um Ansicht wechseln
(Switch View) zu wählen.

Klicken Sie auf  in der Tool-Leiste für die
Zeichnungserstellung.

DETAIL > Pfeile umschalten
(DETAIL > Flip Arrows)

Wählen Sie die Bemaßung und anschließend
Editieren > Eigenschaften (Edit > Properties).

Wählen Sie die Bemaßung, und klicken Sie mit
der rechten Maustaste, um Pfeile umschalten
(Flip Arrows) zu wählen.

DETAIL > Knick erzeugen
(DETAIL > Make Jog)

Einfuegen > Knick...
(Insert > Jog...)

Wählen Sie das Element, und klicken Sie mit der
rechten Maustaste, um Knick erzeugen (Make
Jog) zu wählen.
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DETAIL > Ausrichten
(DETAIL > Align)

Wählen Sie die Elemente (Elemente werden
durch Ziehen ausgerichtet).

Klicken Sie auf  in der Tool-Leiste für
Zeichnungen.

Wählen Sie die Elemente und anschließend
Editieren > Bewegen (Edit > Move).

DETAIL > Skizze
DETAIL > Sketch)

Wählen Sie Skizze (Sketch) in der obersten Tool-
Leiste oder wählen Sie eines der Skizze-Icons in
der rechten Tool-Leiste.

DETAIL > Werkzeuge
(DETAIL > Tools)

Wählen Sie ZEICHNUNG > Werkzeuge
(DRAWING > Tools).

DETAIL > Werkzeuge > Masse
ordnen
(DETAIL > Tools > Clean
Dims)

WERKZEUGE > Masse ordnen
(TOOLS > Clean Dims)

Editieren > Bemassungen ordnen...
(Edit > Cleanup Dimensions...)

Klicken Sie auf  in der Tool-Leiste für die
Zeichnungserstellung.

DETAIL > Werkzeuge >
Kopieren > Andere Zeichnung
(DETAIL >Tools > Copy >
Other Drawing)

WERKZEUGE > Kopieren > Andere Zeichnung
(TOOLS > Copy > Other Drawing)

Editieren > Aus anderer Zeichnung kopieren...
(Edit > Copy from Other Drawing...)

Wählen Sie Editieren > Kopieren (Edit > Copy),
wechseln Sie in ein neues Fenster, und wählen
Sie Editieren > Einfuegen (Edit > Paste).

DETAIL > Aendern
(DETAIL > Modify)

Menüauswahl existiert nicht mehr

DETAIL > Aendern >
Beliebiges Elem
(DETAIL > Modify > Any Item)

Klicken Sie auf  in der rechten Tool-Leiste.
Dies ist die Voreinstellung, und Elemente
können normalerweise jederzeit gewählt werden.
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DETAIL > Aendern > Wert
(DETAIL > Modify > Value)

Editieren > Wert
(Edit > Value)

Wählen Sie die Bemassung, und klicken Sie mit
der rechten Maustaste, um Sollwert (Nominal
Val) zu wählen (nur für Bemaßungen).

DETAIL > Aendern >
Dezimalstellen
(DETAIL > Modify > Num
Digits)

Format > Dezimalstellen...
(Format > Decimal Places...)

Wählen Sie die Bemassung und anschließend
Editieren > Eigenschaften (Edit > Properties)
(nur für Bemaßungen).

DETAIL > Aendern > Text >
Textzeile
(DETAIL > Modify >Text >
Text Line)

Wählen Sie den Text und anschließend Editieren
> Eigenschaften (Edit > Properties).

DETAIL > Aendern > Text >
Gesamte Notiz
(DETAIL > Modify >Text > >
Full Note)

Wählen Sie den Text und anschließend Editieren
> Eigenschaften (Edit > Properties).

Wählen Sie die Notiz und anschließend mit der
rechten Maustaste Text editieren (Edit Text).

DETAIL > Aendern > Text >
Texthoehe
(DETAIL > Modify >Text >
Text Height)

Wählen Sie den Text und anschließend Editieren
> Eigenschaften (Edit > Properties).

DETAIL > Aendern > Text >
Textstil
(DETAIL > Modify >Text >
Text Style)

Wählen Sie den Text und anschließend Editieren
> Eigenschaften (Edit > Properties).

Wählen Sie das Element und anschließend mit
der rechten Maustaste Textstil aend (Mod Text
Style).

DETAIL > Aendern > Text >
Stilbibliothek
(DETAIL > Modify >Text >
Style Lib)

Format > Textstil-Galerie...
(Format > Text Style Gallery...)
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DETAIL > Aendern > Text >
Aktuell Stil
(DETAIL > Modify >Text > Cur
Style)

Format > Standard-Textstil...
(Format > Default Text Style...)

DETAIL > Aendern > Text >
Linientyp
(DETAIL > Modify >Text >
Leader Type)

Wählen Sie das Element und anschließend
Format > Hinweislinientyp umschalten (Format
> Toggle Leader Type).

Wählen Sie das Element und anschließend
Format > Hinweislinientyp umschalten (Format
> Toggle Leader Type).

DETAIL > Aendern > Text >
Pfeilstil
(DETAIL > Modify >Text >
Arrow Style)

Format > Pfeilstil...
(Format > Arrow Style...)

Wählen Sie das Element und anschließend mit
der rechten Maustaste Pfeilstil (Arrow Style).

DETAIL > Aendern > Schraffur
(DETAIL > Modify >
Xhatching)

Wählen Sie die Schraffur und anschließend
Editieren > Eigenschaften (Edit > Properties).

DETAIL > Aendern > Raster >
2D-Raster
(DETAIL > Modify > Grid >
Draft Grid)

Ansicht > 2D-Raster...
(View > Draft Grid...)

DETAIL > Aendern > Raster >
Modellraster
(DETAIL > Modify > Grid >
Model Grid)

Ansicht > Modellraster
(View > Model Grid)

DETAIL > Aendern > Symbol
(DETAIL > Modify > Symbol)

Wählen Sie das Symbol und anschließend
Editieren > Eigenschaften (Edit > Properties).

Wählen Sie das Symbolund anschließend mit der
rechten Maustaste Variante umdef (Redefine
Inst).
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DETAIL > Aendern > Text >
Linienstil > Linien aend
(DETAIL > Modify >Line Style
> Modify Lines)

Format > Linienstil...
(Format > Line Style...)

Wählen Sie die Elemente und anschließend
Editieren > Eigenschaften (Edit > Properties).
(Nur 2D-Elemente.)

DETAIL > Aendern > Text >
Linienstil > Stile editieren
(DETAIL > Modify >Line Style
> Edit Styles)

Format > Linienstil-Galerie...
(Format > Line Style Gallery...)

DETAIL > Aendern > Text >
Linienstil > Aktuell einst
(DETAIL > Modify >Line Style
> Set Current)

Format > Standard-Linienstil...
(Format > Default Line Style...)

DETAIL > Aendern > Text >
Linienstil > LinArten edit
(DETAIL > Modify >Line Style
> Edit Fonts)

Format > Linienart-Galerie...
(Format > Line Font Gallery...)

DETAIL > Aendern > Text >
Linienstil > Stile loeschen
(DETAIL > Modify >Line Style
> Clear Style)

Format > Linienstil...
(Format > Line Style...) Wählen Sie SEL STYLE
> Default.

DETAIL > Aendern >  Geom
Toleranz
(DETAIL > Modify >Geom Tol)

Wählen Sie die Gtol und anschließend Editieren
> Eigenschaften (Edit > Properties).

Wählen Sie die Gtol, und klicken Sie mit der
rechten Maustaste, um Geomtol umdef (Redefine
Gtol) zu wählen.

DETAIL > Aendern >
Bezug/Achse
(DETAIL > Modify >
Datum/Axis)

Wählen Sie den Bezug/die Achse und
anschließend Editieren > Eigenschaften (Edit >
Properties).

DETAIL > Aendern >
Bemassung
(DETAIL > Modify >
Dimension)

Wählen Sie die Bemaßung und anschließend
Editieren > Eigenschaften (Edit > Properties).
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DETAIL > Aendern >
BemassParam > Masstyp
(DETAIL > Modify > Dim
Params > Dim Type)

Menüauswahl existiert nicht mehr
Siehe Einfuegen > Koordinatenbemassung
(Insert > Coordinate Dimension) weiter unten.

DETAIL > Aendern >
BemassParam > Masstyp >
Koordinaten
(DETAIL > Modify > Dim
Params > Dim Type > Coord
Dim)

Einfuegen > Koordinatenbemassung...
(Insert > Coordinate Dimension...)

DETAIL > Aendern >
BemassParam > Masstyp >
Ordinaten
(DETAIL > Modify > Dim
Params > Dim Type > Ordinate
Dim)

Einfuegen > Bemassung > Ordinaten... >
Bemass erzeugen
(Insert > Dimension > Ordinate... > Create
Dims)

DETAIL > BemassParam >
Masstyp > Ordinaten > Basis
erzeugen
(DETAIL > Dim Params > Dim
Type > Ordinate Dim > Create
Base)

Einfuegen > Bemassung > Ordinaten... > Basen
erzeugen
(Insert > Dimension > Ordinate... > Create
Bases)

Editieren > Linear zu Ordinaten... > Basis
erzeugen
(Edit > Linear to Ordinate... > Create Base)

DETAIL > Aendern >
BemassParam > Masstyp >
Ordinaten > Basis einst
(DETAIL > Modify > Dim
Params > Dim Type > Ordinate
Dim > Set Base)

Editieren > Linear zu Ordinaten... > Basis einst
(Edit > Linear to Ordinate... > Set Base)

DETAIL > Aendern >
BemassParam > Masstyp >
Ordinaten > Bezug->Linear
(DETAIL > Modify > Dim
Params > Dim Type > Ordinate
Dim > Ord to Lin)

Editieren > Ordinaten zu Linear
(Edit > Ordinate to Linear)
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DETAIL > Aendern >
BemassParam > Masstyp >
Ordinaten > Linear->Bezug
(DETAIL > Modify > Dim
Params > Dim Type > Ordinate
Dim > Lin to Ord)

Editieren > Linear zu Ordinaten...
(Edit > Linear to Ordinate...)

DETAIL > Aendern >
BemassParam > Schema
(DETAIL > Modify > Dim
Params > Scheme)

Editieren > KE umdefinieren
(Edit > Redefine Feature)

DETAIL > Aendern >
BemassParam > Hilfslinie
(DETAIL > Modify > Dim
Params > Wit Line Disp)

Wählen Sie die Bemaßung und anschließend
Editieren > Eigenschaften (Edit > Properties).

Wählen Sie die Bemaßung, und klicken Sie
anschließend mit der rechten Maustaste auf
Eigenschaften (Properties).

Wählen Sie die Bemaßung, und klicken Sie
anschließend mit der rechten Maustaste auf
Vorgabe-Masshilfslinie (Default Wit Line).

Wählen Sie die Bemaßung, und klicken Sie
anschließend mit der rechten Maustaste auf
Hilfslin wegnehmen (Erase Wit Line).

Wählen Sie die Bemaßung, und klicken Sie
anschließend mit der rechten Maustaste auf
MHilfsLin zeig (Show Wit Line).

DETAIL > Aendern >
BemassParam > Durch Bemass
(DETAIL > Modify > Dim
Params > Diam Dim Type)

Wählen Sie die Bemaßung und anschließend
Editieren > Eigenschaften (Edit > Properties).

Wählen Sie die Bemaßung, und klicken Sie
anschließend mit der rechten Maustaste auf
Eigenschaften (Properties).

DETAIL > Aendern >
FangLinAbstand
(DETAIL > Modify > Snap
Space)

Wählen Sie die Fanglinie und anschließend
Editieren > Eigenschaften (Edit > Properties).

Wählen Sie die Fanglinie, und klicken Sie
anschließend mit der rechten Maustaste auf
FangLinAbst aend (Modify Space).
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DETAIL > Erzeugen >
Standard > Neue Ref
(DETAIL > Create >
Dimension > Standard >New
Ref)

Einfuegen > Bemassung > Neue Referenzen...
(Insert > Dimension > New References...)

DETAIL > Erzeugen >
Standard > Gemeinsame Refer
(DETAIL > Create >
Dimension > Standard
Common Ref)

Einfuegen > Bemassung > Gemeinsame
Referenz...
(Insert > Dimension > Common Reference...)

DETAIL > Erzeugen >
Bemassung > Ordinaten
(DETAIL > Create >
Dimension > Ordinate)

Einfuegen > Bemassung > Ordinaten...
(Insert > Dimension > Ordinate...)

DETAIL > Erzeugen >
Referenzmass > Standard >
Neue Ref
(DETAIL > Create > Ref Dim >
Standard > New Ref)

Einfuegen > Referenzbemassung > Neue
Referenzen...
(Insert > Reference Dimension > New
References...)

DETAIL > Erzeugen >
Referenzmass > Standard >
Gemeinsame Refer
(DETAIL > Create > Ref Dim >
Standard > Common Ref)

Einfuegen > Referenzbemassung > Gemeinsame
Referenzen...
(Insert > Reference Dimension > Common
Reference...)

DETAIL > Erzeugen >
Referenzmass > Ordinaten
(DETAIL > Create > Ref Dim >
Ordinate)

Einfuegen > Referenzbemassung > Ordinaten...
(Insert > Reference Dimension > Ordinate...)

DETAIL > Erzeugen > Notiz
(DETAIL > Create > Note)

Einfuegen > Notiz...
(Insert > Note...)

DETAIL > Erzeugen > Knoten
(DETAIL > Create > Node)

Einfuegen > Knoten
(Insert > Node )
(nur im Symboldefinition-Editiermodus)
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DETAIL > Erzeugen > Symbol
> Variante
(DETAIL > Create > Symbol >
Instance)

Einfuegen > Symbolvariante...
(Insert > Symbol Instance...)

DETAIL > Erzeugen > Symbol
> Definition
(DETAIL > Create > Symbol >
Definition)

Format > Symbolgalerie...
(Format > Symbol Gallery...)

DETAIL > Erzeugen > Geom
Toleranz > Gesetzter Bezug
(DETAIL > Create > Geom Tol
> Set Datum)

Wählen Sie den Bezug und anschließend
Editieren > Eigenschaften (Edit > Properties).

Klicken Sie mit der rechten Maustaste auf
Eigenschaften (Properties).

DETAIL > Erzeugen > Geom
Toleranz > BasisBemass
(DETAIL > Create > Geom Tol
> Basic Dim)

Wählen Sie die Bemaßung und anschließend
Editieren > Eigenschaften (Edit > Properties).

Klicken Sie mit der rechten Maustaste auf
Eigenschaften (Properties).

DETAIL > Erzeugen > Geom
Toleranz > PruefBemass
(DETAIL > Create > Geom Tol
> Inspect Dim)

Wählen Sie die Bemaßung und anschließend
Editieren > Eigenschaften (Edit > Properties).

Klicken Sie mit der rechten Maustaste auf
Eigenschaften (Properties).

DETAIL > Erzeugen > Geom
Toleranz > Tol festlegen
(DETAIL > Create > Geom Tol
> Specify Tol)

Einfuegen > Geometrische Toleranz...
(Insert > Geometric Tolerance...)

DETAIL > Erzeugen > Geom
Toleranz > Loeschen
(DETAIL > Create > Geom Tol
> Clear)

Editieren > Loeschen
(Edit > Clear)

DETAIL > Erzeugen > Geom
Toleranz > Zielpunkt
(DETAIL > Create > Geom Tol
> Make Target)

Einfuegen > Ziel...
(Insert > Target...)
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DETAIL > Erzeugen > Oberfl
Zeichen
(DETAIL > Create > Surf
Finish)

Einfuegen > Oberflaechenzeichen...
(Insert > Surface Finish...)

DETAIL > Erzeugen > Bezug >
3D Bezug
(DETAIL > Create > Datum >
3D Datum)

Einfuegen > Bezug > Ebene
(Insert > Datum > Plane)

DETAIL > Erzeugen > Bezug >
2D Bezug
(DETAIL > Create > Datum >
Draft Datum)

Einfuegen > 2D-Ebene...
(Insert > Draft Plane...)

DETAIL > Erzeugen > Achse >
3D-Achse
(DETAIL > Create > Axis > 3D
3D Axis)

Einfuegen >Bezug > Achse
(Insert > Datum > Axis)

DETAIL > Erzeugen > Achse >
2D hinzufuegen
(DETAIL > Create > Axis >
Draft Add)

Einfuegen > 2D-Achse...
(Insert > Draft Axis...)

DETAIL > Erzeugen > Achse >
Sym Linie
(DETAIL > Create > Axis >
Sym Line)

Einfuegen > Symmetrielinienachse...
(Insert > Symmetry Line Axis)

DETAIL > Erzeugen > Koord
System
(DETAIL > Create > Coord
System)

Einfuegen > Bezug > Koordinatensystem...
(Insert > Datum > Coordinate System...)
(nur Layout)

DETAIL > Erzeugen >
Bezugspunkt
(DETAIL > Create > Datum
Point)

Einfuegen > Bezug > Punkt
(Insert > Datum > Point)
(nur Layout)

DETAIL > Erzeugen > Ballon
(DETAIL > Create > Balloon)

Einfuegen > Ballon...
(Insert > Balloon...)
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DETAIL > Erzeugen > Gefuellt
Bereich > Schraffieren
(DETAIL > Create > Filled
Area > Hatch)

Wählen Sie die Elemente-Schleife und
anschließend Editieren > Fuellen > Schraffiert
(Edit > Fill > Hatched).

DETAIL > Erzeugen > Gefuellt
Bereich > Fuellen
(DETAIL > Create > Filled
Area > Fill)

Wählen Sie die Elemente-Schleife und
anschließend Editieren > Fuellen > Solid (Edit >
Fill > Solid).

DETAIL > Erzeugen >
Fanglinie
(DETAIL > Create > Snap
Line)

Einfuegen > Fanglinie...
(Insert > Snap Line...)

Menü-Zuordnung für Pro/DIAGRAM

Alte Position Neue Position

Einfuegen > Komponente > Eine Ansicht
(Insert >Component > Single View)

Einfuegen > Komponente > Einzelne
Ansicht...
(Insert > Component > Single
View...)

Schaltplan > Erzeugen > Komponente >
Multi-Ansicht > Variante > Erzeugen
(Design > Create > Component > Multi
View > Instance > Create)

Einfuegen > Komponente
Mehrfachansicht...
(Insert > Component > Multi-View...)

Schaltplan > Erzeugen > Komponente >
Multi-Ansicht > Variante > Ansicht hinzuf
(Design > Create >Component > Multi
View > Instance > Add View)

Einfuegen > MAK-Ansicht...
(Insert > MVC View...)

Schaltplan > Erzeugen > Komponente >
Multi-Ansicht > Variante > Info
(Design >Create > Component > Multi
View > Instance > Info)

Info > MAK-Variante...
(Info > MVC Instance...)
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Alte Position Neue Position

Schaltplan > Erzeugen > Komponente >
Multi-Ansicht > Definition
(Design >Create > Component > Multi
View > Definition)

Format > Mehrfachansicht-
Komponenten-Galerie...
(Format > Multi-View Component
Gallery...)

Schaltplan > Erzeugen > Stecker >
NichtAenderbar > Eine Ansicht
(Design >Create >Connector >Fixed >
Single View)

Einfuegen > Stecker > Einzelne
Ansicht...
(Insert > Connector > Single View...)

Schaltplan > Erzeugen > Stecker > Multi-
Ansicht > Variante > Erzeugen
(Design >Create > Connector >Multi View
> Instance >Create)

Einfuegen > Stecker
Mehrfachansicht...
(Insert > Connector > Multi-View...)

Schaltplan > Erzeugen > Stecker > Multi-
Ansicht > Variante > Ansicht hinzuf
(Design >Create > Connector > Multi View
> Instance > Add View)

Einfuegen > MAK-Ansicht...
(Insert > MVC View...)

Schaltplan > Erzeugen > Stecker > Multi-
Ansicht > Variante > Info
(Design >Create > Connector > Multi View
> Instance > Info)

Info > MAK-Variante...
(Info > MVC Instance...)

Schaltplan > Erzeugen > Stecker > Multi-
Ansicht > Definition
(Design >Create > Connector > Multi View
> Definition)

Format > Mehrfachansicht-Stecker-
Galerie...
(Format > Multi-View Connector
Gallery...)

Schaltplan > Erzeugen > Stecker
Parametrisch (> Stift oder Buchse)
(Design >Create > Connector > Parametric
(> Male oder Female)

Einfuegen > Stecker >
Parametrisch...
(Insert > Connector > Parametric...)

Schaltplan > Erzeugen > Stecker >
Parametrisch > Zwischenstecker
(Design >Create >Connector > Parametric
> Inline)

Einfuegen > Stecker >
Verbindungsstecker...
(Insert > Connector > Inline...)
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Alte Position Neue Position

Schaltplan > Erzeugen > KompGruppe >
Definition
(Design >Create > Comp Group >
Definition)

Format > Komponentengruppen-
Gallerie...
(Format > Comp Group Gallery...)

Schaltplan > Erzeugen > KompGruppe >
Variante > Erzeugen
(Design >Create > Comp Group > Instance
> Create)

Einfuegen > Komponentengruppe...
(Insert > Component Group...)

Schaltplan > Erzeugen > KompGruppe >
Variante > Ansicht hinzuf
(Design >Create > Comp Group > Instance
> Add View)

Einfuegen > Komponentengruppen-
Ansicht...
(Insert > Component Group View...)

Schaltplan > Erzeugen > Draht
(Design > Create > Wire)

Einfuegen > Draht...
(Insert > Wire...)

Schaltplan > Erzeugen > Kabelfuehrung
[> Skizze/> Weg folgen/ > Draht
verwenden]
Design >Create >Highway
(> Sketch/> Follow Path/> Use Wire)

Einfuegen > Kabelfuehrung...
(Insert > Highway...)

Schaltplan > Erzeugen > Kabelfuehrung >
Draehte hinzu
(Design > Create > Highway > Add Wires)

Editieren > Kabelfuehrungsdraehte
> Draehte hinzuf...
(Edit > Highway Wires > Add
Wires...)

Schaltplan > Erzeugen > Kabelfuehrung >
Draehte entf
(Design > Create > Highway > Remove
Wires)

Editieren > Kabelfuehrungsdraehte
> Draehte entf...
(Edit > Highway Wires > Remove
Wires...)

Schaltplan > Erzeugen > Kabel > Kabel
erzeugen
(Design >Create > Cable >Make Cable)

Einfuegen > Kabel...
(Insert > Cable...)

Schaltplan > Erzeugen > Kabel > Draehte
hinzu
(Design > Create > Cable > Add Wires)

Editieren > Kabelinhalt > Draehte
hinzuf...
(Edit > Cable Contents > Add
Wires...)
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Alte Position Neue Position

Schaltplan > Erzeugen > Kabel > Draehte
entf
(Design > Create > Cable > Remove Wires)

Editieren > Kabelinhalt > Draehte
entf...
(Edit > Cable Contents > Remove
Wires...)

Schaltplan > Erzeugen > Kabel > Symbol
hinzuf
(Design > Create > Cable > Add Symbol)

Einfuegen > Kabelsymbol...
(Insert > Cable Symbol...)

Schaltplan > Erzeugen > Kabel > Spule
wechseln
(Design > Create > Cable > Change Spool)

Format > Standard-Kabelspule...
(Format > Default Cable Spool...)

Schaltplan > Erzeugen > Kabel > Blatt
wechseln
(Design > Create > Cable > Change Sheet)

(Spinbox in Tool-Leiste für die
Zeichnungserstellung verwenden)

Schaltplan > Erzeugen > Schiene
(Design >Create > Rail)

Einfuegen > Schiene...
(Insert > Rail...)

Schaltplan > Erzeugen > Stoss >
Abzweigung
(Design > Create > Splice > Butt)

Einfuegen > Stoss > Stossnaht...
(Insert > Splice > Butt...)

Schaltplan > Erzeugen > Stoss > Durch
(Design > Create > Splice > Through)

Einfuegen > Stoss > Durchstoss...
(Insert > Splice > Through...)

Schaltplan > Erzeugen > Leiter
[> Leiter erzeug/ > Leiter kopier]
(Design >Create > Ladder
[> Make Ladder/ > Copy Ladder])

Einfuegen > Leiter...
(Insert > Ladder...)

Schaltplan > Erzeugen > Leiter >
Stufenkennung
(Design > Create > Ladder > Rung Label)

Format > Abschnittkennungen...
(Format > Rung Labels...)

Menü-Zuordnung für ModelCHECK

Alte Position Neue Position

Info > ModelCHECK Analyse > ModelCHECK
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Verbesserungen beim Anpassen von Tool-Leisten

Tool-Leisten neu positionieren
Sie können eine Tool-Leiste in Pro/ENGINEER 2001 dynamisch an
eine neue Position am oberen linken oder rechten Fensterrand
verschieben. Klicken Sie hierzu auf einen Ziehgriff der Tool-Leiste, und
verschieben Sie sie an die neue Position. Eine Tool-Leiste kann nicht
als separates Fenster angezeigt werden. Wenn Sie versuchen, die Tool-
Leiste an einer ungültigen Stelle zu positionieren (z.B. in der Mitte des
Pro/ENGINEER Fensters), springt sie zurück an die Ausgangsposition.

Gruppenschaltflächen erzeugen
Pro/ENGINEER 2001 ermöglicht das Erzeugen von
Gruppenschaltflächen in der Tool-Leiste. Eine Gruppenschaltfläche
enthält mehrere Befehlsschaltflächen, die standardmäßig nicht
angezeigt werden. Es werden jeweils nur eine Befehlsschaltfläche (der
zuletzt verwendete Befehl) und ein Pfeil angezeigt. Klicken Sie auf den
Pfeil, um die anderen Schaltflächen anzuzeigen. Die
Gruppenschaltfläche wird geöffnet, und die anderen
Befehlsschaltflächen werden angezeigt. Gruppenschaltflächen sind
dann sinnvoll, wenn Sie im Pro/ENGINEER Fenster auf der Tool-
Leiste Platz sparen und verwandte Befehle zusammenfassen möchten.

Klicken Sie auf Dienstprogramme > Bildschirm anpassen
(Utilities > Customize Screen), um das Dialogfenster Anpassen
(Customize) zu öffnen, in dem Sie eine Gruppenschaltfläche erzeugen
und Befehle hinzufügen können. Klicken Sie in der Liste Kategorien
(Categories) auf Neues Menue (New Menu) und in der Liste
Befehle (Commands) auf Neues Flyout (New Flyout). Ziehen Sie
Neues Flyout (New Flyout) auf die gewünschte Tool-Leiste, und
fügen Sie die Befehle auf gleiche Weise hinzu, wie sie einer Tool-Leiste
hinzugefügt werden.
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3 
Teilemodellierung

Bemaßungen direkt im Arbeitsfenster editieren
Sie können jetzt die Werte von Skizzenbemaßungen über den Absichts-
Manager direkt im Arbeitsfenster ändern und müssen hierzu nicht
mehr so viele Schritte durchführen. Wenn Sie auf die Bemaßung
doppelklicken, wird ein grafisches Eingabefeld geöffnet. Geben Sie den
neuen Wert ein, und klicken Sie auf Eingeben (Enter).

Diese Funktionalität ist auch verfügbar, wenn Sie ein Profil- oder
Rotations-KE wählen. Klicken Sie zum Ändern von KE-Tiefen,
Rotationsbemaßungen und Rundungsradius-Bemaßungen im
Kontextmenü (das durch Klicken mit der rechten Maustaste geöffnet
wird) auf Dynamisch aendern (Dynamic Modify). In diesem Fall
geben Sie entweder einen neuen Wert ein, oder wählen Sie aus der
Liste einen früheren Bemaßungswert.

Schnitte dynamisch ändern
Sie können jetzt KE-Schnitte mit den gleichen Drag-und-Drop-
Funktionen ändern, die auch im Absichts-Manager zur Verfügung
stehen. Diese Drag-und-Drop-Funktionen ermöglichen eine flexiblere
Modellierungsumgebung, in der Änderungen leichter vorgenommen
werden können – insbesondere, wenn die exakten Bemaßungswerte
unbekannt sind.

Nachdem Sie Aendern (Modify) gewählt und den Cursor auf einem
Schnittelemente plaziert haben, ändert sich der Cursor zu einer Hand,
mit der Sie das Element an eine neue Position ziehen können. Klicken
Sie mit der linken Maustaste, um das Element an seiner neuen
Position zu plazieren. Zur Aktualisierung der Geometrie regenerieren
Sie das Modell.
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Neue Auswahlmethode
Wenn Sie in Version 2001 mit einem Modell arbeiten, befindet sich
Pro/ENGINEER immer im Auswahlmodus, sofern Sie nicht ein Tool
aktiviert haben. In Version 2000i2 konnten nur KEs, Komponenten und
3D-Notizen gewählt werden. Jetzt ist es möglich die Auswahl zu filtern
und festzulegen, welche Elemente im voraus hervorgehoben und welche
Elemente gewählt werden können.

Klicken Sie auf Editieren > Auswahl-Voreinstellungen (Edit >
Selection Preferences), um das Dialogfenster Auswahl-
Voreinstellungen (Selection Preferences) zu öffnen. Klicken Sie
auf:

� Bezuege (Datums), um Bezugs-KEs (einschließlich Achsen,
Punkte und Ebenen) zu wählen.

� Primaere Elemente (Primary items), um KEs, Komponenten
und 3D-Notizen zu wählen.

� Geometrische Elemente (Geometric entities), um nur Kanten,
Eckpunkte und Flächen zu wählen.

Nachdem Sie einen Filter gewählt haben, werden die wählbaren
Elemente in Magenta hervorgehoben, wenn Sie den Cursor darauf
plazieren. Klicken Sie mit der linken Maustaste, um ein Element zu
wählen. Drücken Sie die UMSCHALTTASTE, und klicken Sie auf alle
gewünschten Elemente, um mehrere Elemente zu wählen. Sie können
auch die Auswahl-Tool-Leiste verwenden.

Methode "Objekt, Aktion"
Die Methode "Objekt, Aktion" wurde in Version 2000i2 eingeführt. Mit
dieser Methode wählen Sie zuerst das Objekt oder Element und dann
die auszuführende Aktion. Die Methode stand bisher im Absichts-
Manager und zum Ändern von Geometrie zur Verfügung. Diese
Methode wurde in Version 2001 weiter ausgebaut und umfaßt jetzt
folgende Bereiche:

� Profil- und Rotations-KEs
Sie können jetzt mit der Methode "Objekte, Aktion" Profil- und
Rotationsflächen sowie Profil- und Rotationskörper erzeugen, die
Volumenkörper bzw. Materialschnitte sind. Einzelheiten finden Sie
im Abschnitt "Progressive Profil- und Rotations-KEs".

� Skizzierte Bezugskurven
Sie können jetzt mit Hilfe der Methode "Objekt, Aktion" Skizzierte
Bezugskurven erzeugen. Mit der Methode "Objekt, Aktion"
verringert sich die Notwendigkeit, die Orientierung der
Skizzierebene explizit anzugeben.
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Wählen Sie die Skizzierebenenreferenz und dann entweder in der
Tool-Leiste die Schaltfläche Sketched Datum Curve oder
Einfuegen > Bezug > Sketched Datum Curve. Pro/ENGINEER
wählt automatisch eine geeignete Orientierungsansicht und
wechselt zum Skizzieren des Schnitts in den Absichts-Manager.

� Erzeugung einfacher Rundungen
Einfache Rundungen können jetzt mit weniger Menüklicks als
bisher erzeugt werden. Unter Verwendung der Methode "Objekt,
Aktion" wählen Sie zuerst die zu rundenden Kanten, klicken dann
mit der rechten Maustaste und wählen aus dem Kontextmenü den
Befehl Runde Kanten (Round Edges). Die ursprüngliche
Geometrie der Rundung und der dynamischen Ziehgriffe werden
angezeigt. Ändern Sie den Wert für den Radius, indem Sie
entweder die Ziehgriffe verschieben oder auf den Bemaßungswert
doppelklicken und den neuen Wert direkt im Arbeitsfenster
festlegen. Die Rundung wird unter Verwendung folgender
Vorgaben erzeugt:

� Rundungstyp — Einfach

� Attribute — Konstant, Kantenkette

� Referenzen — Tangentenkette
� Bezugsebenen und -achsen

Sie können Bezugsebenen und -achsen jetzt mit der Methode
"Objekt-Aktion" erzeugen und brauchen hierzu nicht mehr so viele
Menüschritte durchzuführen, wodurch Produktivität und Effizienz
gesteigert werden. Wählen Sie eine Referenz (oder mehrere
Referenzen) mit einer vollständigen Definition, und legen Sie den
gewünschten Vorgang fest.

Zum Beispiel genügt die Wahl einer einzelnen Kante als
vollständige Definition einer Bezugsachse (analog zu Durch Kante),
während die Wahl von zwei Kanten oder einer Ebene als
vollständige Definition einer Bezugsebene gilt. Sind die gewählten
Referenzen nicht vollständig definiert, steht die menügesteuerte
Standard-Benutzeroberfläche zur Verfügung, mit der das KE
definiert wird.

Progressive Profil- und Rotations-KEs
Ab Version 2001 enthält Pro/ENGINEER progressive Profil- und
Rotations-KEs. Diese KEs können auf neue und dynamische Arten und
mit einer geringeren Anzahl von Menüaktionen erzeugt werden.

Körper, Schnitte und Flächen-KEs können nach dem Festlegen der
Skizzierebenenreferenz mit der Methode "Objekt, Aktion" erzeugt
werden. Mit der Methode "Objekte, Aktion" gelangen Sie sofort in den
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Absichts-Manager, in dem Sie den Schnitt festlegen und somit Zeit-
und Arbeitsauswand sparen können.

Sie können außerdem eine skizzierte Bezugskurve als Basis für den
Schnitt des neuen KE verwenden, um ein robusteres und flexibleres KE
zu erzeugen. Pro/ENGINEER erzeugt die Geometrie automatisch mit
einem temporären Wert für die Tiefe oder Rotation und fordert Sie vor
dem Fertigstellendes KE auf, die Endergebnisse anzupassen.
Verwenden Sie die Ziehgriffe im Grafikbereich, um die Bemaßungen zu
ändern.

Zum Beispiel: Wählen Sie eine rechteckige skizzierte Bezugskurve, und
klicken Sie auf Einfuegen > Koerper > Profil (Insert >
Protrusion> Extrude). Pro/ENGINEER verwendet den Schnitt der
Kurve als neuen Schnitt und stellt das KE automatisch unter
Verwendung eines temporären Tiefenwertes fertig. Es werden ein
Ziehgriff und eine Tiefenbemaßung angezeigt. Ändern Sie den Wert
dynamisch, und stellen Sie daraufhin das KE fertig, um das Ergebnis
anzuzeigen.

Die Profil- oder Rotationsfläche bzw. der Profil- oder Rotationskörper
wird unter Verwendung folgender Vorgaben erzeugt:

� Attribute — Eine Seite
� Tiefe — Werteingabe

Hinweise:

� Wenn Sie zum Erzeugen eines Rotations-KE diese Methode
verwenden, muß die skizzierte Bezugskurve eine Mittellinie in
ihrem Schnitt enthalten.  Diese Mittellinie wird als Drehachse für
das KE verwendet.  Ist keine Mittellinie enthalten, wird der
Vorgang in der menügesteuerten Standard-Benutzeroberfläche
fortgesetzt.

� Für Trimmflächen-KEs und KEs des Typs "Trimmung an duenner
Flaeche" wird diese Methode nicht unterstützt.

Schrägen schneiden
Beim Erzeugen einer Schräge, die eine Kante schneidet, haben Sie jetzt
mehrere Möglichkeiten, die Überschneidung zu beheben. Wählen Sie
Einfuegen > Schraege... > Neutralebene > Fertig (Insert >
Draft... > Neutral Pln > Done). Wählen Sie anschließend ATRRIBUTE
> Schneiden (ATTRIBUTES > Intersect). Für sich überschneidende
Schrägen sind zwei Optionen verfügbar:

� Verlaengern (Extend) — Erzeugt eine Überschneidung mit einer
vorhandenen Kante des Modells.  Sofern möglich, wird die Schräge
verlängert, so daß sie die benachbarte Fläche des Modells berührt.
Wenn die Schräge nicht bis zur benachbarten Fläche verlängert
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werden kann, wird die Modellfläche bis zur abgeschrägten Fläche
verlängert.

� Keine Verl (No Extend) — Erzeugt eine abgeschrägte Fläche mit
einem Überhang über die Kante des Modells.
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4 
Skizzierer

Bemaßungen direkt im Arbeitsfenster editieren
Sie können jetzt die Werte von Skizzenbemaßungen über den Absichts-
Manager direkt im Arbeitsfenster ändern und müssen hierzu nicht
mehr so viele Schritte durchführen. Wenn Sie auf die Bemaßung
doppelklicken, wird ein grafisches Eingabefeld geöffnet. Geben Sie den
neuen Wert ein, und klicken Sie auf Eingeben (Enter).

Diese Funktionalität ist auch verfügbar, wenn Sie ein Profil- oder
Rotations-KE wählen. Klicken Sie zum Ändern von KE-Tiefen,
Rotationsbemaßungen und Rundungsradius-Bemaßungen im
Kontextmenü (das durch Klicken mit der rechten Maustaste geöffnet
wird) auf Dynamisch aendern (Dynamic Modify). In diesem Fall
geben Sie entweder einen neuen Wert ein, oder wählen Sie aus der
Liste einen früheren Bemaßungswert.

Verbesserung der Funktion "Aufdicken" im Modus
Blech

Version 2001 verfügt über eine verbesserte Aufdickfunktion im Modus
Blech. Sie können einer Kette jetzt Tangentenelemente hinzufügen
oder diese löschen, ohne die aufgedickten Elemente zu verlieren.

Verbesserter Import in den Skizzierer
Zusätzlich zu Schnittdateien können Sie nun auch IGES-Zeichnungen
und DWG-Dateien direkt in einen Skizziererschnitt importieren.  Im
Skizzenmodus erfolgt der Zugriff auf diese Funktion über Skizze >
Daten aus Datei (Sketch > Data from File).
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5 
Baugruppenfunktion (Grundlagen)

Verbesserte Benutzeroberfläche für die
Komponentenplazierung

Das verbesserte Dialogfenster Komponentenplazierung
(Component Placement) ermöglicht jetzt einen leichteren und
effizienteren Arbeitsfluß bei der Komponentenplazierung.
Verbesserungen:

� Eine zusammengefaßte Liste mit Baugruppenbedingungen zur
Vermeidung von Redundanz (wie z.B. Gegengerichtet und Gegen
versetzt) mit einem editierbaren Feld für den Versatzwert.

� Die Option Umschalten (Flip), mit der die Komponente um 180
Grad um den neuen Freiheitsgrad gedreht wird. Mit dieser
Schaltfläche wird die Auswahl von Gelb/Rot-Referenzen auf
Bezugsebenen überflüssig.

� Ein editierbarer Versatzwert in der Bedingungenliste und eine
Option für Zusammenfallend.

� Eine Option für Orientiert in der Spalte Versatz, die sowohl die
Plazierungsbedingung "ausgerichtet-orientiert " als auch die
Plazierungsbedingung "gegengerichtet-orientiert" zuläßt.

� Die Aktivierung/Deaktivierung von
Komponentenplazierungsbedingungen erfolgt anhand von Häkchen
in der Plazierungsbedingungstabelle. Mit diesen Optionen können
Sie mehrere Plazierungsbedingungen angeben und zwischen
aktiven Plazierungsbedingungen hin- und herwechseln, um
verschiedene Komponentenpositionen durchzuspielen.

� Leicht zugängliche Schaltflächen für folgende Operationen:

� Steuern, ob die neue Komponente im Baugruppenfenster oder
in einem neuen Fenster angezeigt wird
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� Komponente an der aktuellen Position fixieren oder
Komponente an der Vorgabeposition einbauen.

� Ändern von Voreinstellungen

Neue Benutzeroberfläche für "Datei" > "Kopie
speichern..." bei Baugruppen

Die neue Benutzeroberfläche vereinfacht die Angabe neuer Namen für
Komponenten nach Verwendung von Datei > Kopie speichern...
(File > Save a Copy...) zur Erzeugung einer Baugruppenkopie. Das
neue Dialogfenster Kopie speichern (Save a Copy) enthält eine
baumähnliche Struktur. Die vorhandene Baugruppe ist in der linken
Spalte, die Namen für die neue Baugruppe werden in der rechten
Spalte aufgelistet. Wählen Sie eine der folgenden drei Optionen, um
einen neuen Namen für die Komponenten anzugeben:

� Die Namen der vorhandenen Komponenten wiederverwenden
� Die Komponentennamen durch Auswahl und Editieren der

einzelnen Komponenten (nacheinander) ändern
� Verwendung des Präfix-/Suffix-Editierfeldes zur Zuweisung neuer

Namen in einem Schritt

Neue Benutzeroberfläche für Baugruppen-KE-
Überschneidung

Die neue Benutzeroberfläche für sich schneidende Komponenten von
Baugruppen-KE enthält das Dialogfenster Geschnittene
Komponenten (Intersected Comps), das folgende Optionen
aufweist:

� Ueberschn autom akt (Auto Update Intrscts) — Bei aktivierter
Option führt das System bei jeder Regenerierung eine
Neubewertung geschnittener Komponenten durch und fügt neue
Komponenten hinzu, die jetzt das KE schneiden.

Hinweis: Die einzigen Komponenten, die berücksichtigt werden,
sind die, die vor den schneidenden KEs erzeugt wurden, wenn
Ueberschn autom akt (Auto Update Intrscts) verwendet wird.
Bei der automatischen Aktualisierung werden keine Komponenten
entfernt, die derzeit als geschnitten markiert sind.

� Model List — Zeigt die Namen von Komponenten an, während
diese manuell oder automatisch, mit der Option AutomHinzuf
(AutoAdd), gewählt werden. In der Spalte SichtbktGrad
(VisLevel) wird der Sichtbarkeitsgrad angegeben, der eingestellt
werden kann, wenn der Modelliste eine Komponente hinzugefügt
wird. Mit der Schaltfläche Entfernen (Remove) können Sie
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hervorgehobene Modelle aus der Modelliste entfernen, und mit der
Schaltfläche Info (Info) wird ein Fenster mit Informationen über
das Modell geöffnet, in dem auch die geschnittenen Komponenten
und die Sichtbarkeitsgrade angegeben sind.

� Grad (Level) — Mit diesen Optionen legen Sie den
Sichtbarkeitsgrad von Modellen fest, die der Modelliste hinzugefügt
werden. Die manuell hinzugefügten Modelle besitzen den aktuellen
Sichtbarkeitsgrad.

� Neue Namen (New names) — Ermöglicht das Kopieren von
Teilen in neue Varianten von vorhandenen Teilen oder
Baugruppen. Ein zur Modelliste hinzugefügter Modellname wird in
diesem Bereich mit einem neuen, editierbaren Namen hinzugefügt.
Das Menü Neue Namen (New names) muß erweitert werden,
bevor die Komponenten der Modelliste hinzugefügt werden und die
neuen Varianten hinzugefügt werden.

Vorgehensweise bei fehlenden Komponenten
während des Aufrufens

Die Vorgehensweise bei fehlenden Objekten oder Komponenten beim
Aufrufen einer Baugruppe wurde verbessert. Fehlende Modelle oder
Unterbaugruppen können mit Kurzreparatur > Komp auffinden
(Quick Fix > Find Component) gesucht werden. Das Dialogfenster
Datei oeffnen (File Open) wird geöffnet, um die Suche in anderen
Verzeichnissen zu ermöglichen.

Unterbaugruppen spiegeln
Sie können jetzt durch Spiegeln von Unterbaugruppen Folien und
Baugruppen-KEs kopieren. Die baumähnliche Struktur der
gespiegelten Unterbaugruppe ermöglicht es, Komponenten zu wählen,
die beim Spiegeln übersprungen werden sollen. Diese Komponenten
werden nicht gespiegelt. Das ursprüngliche Modell kann daher
wiederverwendet werden.

Leistungsverbesserungen
Die Option Abbrechen (Cancel) kann jetzt während der Generierung
von Schrumpfverpackungen verwendet werden.
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Vereinfachte Darstellungen: Standarddarstellung
Sie können jetzt zu der Konfigurationsdatei-Option
open_simplified_rep_by_default einen Darstellungsnamen
hinzufügen. Dieser hinzugefügte Darstellungsname wird bei der
Verwendung von Datei > Oeffnen (File > Open) als Standardname
verwendet. Die Syntax für die Konfigurationsdatei-Option ist jetzt
open_simplified_rep_by_default, No/Yes/<darst_name>. Der
Vorgabewert ist No. Falls sich die benannte Darstellung in einem
Modell befindet, das geöffnet wird, wählt das Modell automatisch diese
Darstellung. Auf diese Weise lassen sich vereinfachte Darstellung
schnell öffnen, ohne zuerst aufgefunden und gewählt werden zu
müssen. Existiert die Darstellung nicht, werden Sie aufgefordert, eine
neue vereinfachte Darstellung mit dem in der Konfigurationsdatei-
Option angegebenen Namen zu erzeugen.

In Pro/ENGINEER Foundation enthaltene
Explosionszustände und Versatzlinien

Explosionszustände sind jetzt im Pro/ENGINEER Foundation Paket
enthalten.

Diese Spezialfunktionalität ermöglicht die Erzeugung mehrerer
benutzerangepaßter explodierter Konfigurationen von Baugruppen, die
im Baugruppenmodus angesehen und bearbeitet und als einmalige
Ansichten in einer Zeichnung plaziert werden können.

Versatzlinien veranschaulichen, wie Komponenten in explodierten
Ansichten eingebaut werden. Sie können zu explodierten Ansichten in
der Baugruppe oder Zeichnung hinzugefügt werden, um die räumliche
Anordnung der Komponenten zueinander in einer Baugruppe zu
verdeutlichen.
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Advanced Assembly Extension

Erbschafts-KE
Ein Erbschafts-KE ermöglicht eine einseitige Zuordnungsverknüpfung
von Geometrie- und KE-Daten von einem Teil mit einem anderen.

Alle KEs aus dem ursprünglichen KE werden ins Ziel-KE kopiert. Sie
können nach dem Verschmelzen Aktionselemente wie z.B. eine
Bemaßungsänderung und die Änderung des KE-Status hinzufügen.
Verschmelzungs-KEs können in der KE-Liste des Zielteils an jeder
Stelle erzeugt werden, einschließlich des ersten KE. Während der
Definition des KE enthält das Dialogfenster die folgenden Optionen:

� Position (Location) � Die Position des KE in Bezug auf die
Koordinatensysteme des Modells wählen.

� Variabl Mass (Var Dims) � Gewählte Bemaßungen bei der
Vererbung in das neue Modell ändern, um sie später leichter
bearbeiten zu können.

� Var KEs (Var Feats) � Erbschafts-KEs durch Unterdrücken oder
Zurückholen steuern.

� Abhaengigkeit (Dependency) � Abhängigkeit bei Bedarf
wechseln.

Ein erzeugtes KE wird im Modellbaum als Erbschafts-KE-Typ
dargestellt. Es kann erweitert werden, um die darin enthaltenen KEs
anzuzeigen.

Erbschafts-KEs besitzen die folgenden Vorteile:

� Verbesserungen können vorgenommen werden, wenn Sie mit
Modellen in unterstützenden Applikationen wie z.B. Analyse oder
NC-Bearbeitung arbeiten. Sie können die einzelnen KEs vom
geerbten Modell aus steuern und ändern.
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� Erbschaft-KEs können als Alternative zu Familientabellen
verwendet werden.

� Änderungen am abgeleiteten Modell haben auf das Elternmodell
keinerlei Auswirkung.

Erbschafts-KEs werden aus vorhandenen Teilen definiert. Zum Öffnen
des Dialogfensters Erbschaft (Inheritance) klicken Sie auf Konstr
Element > Erzeugen > Gemeins DatBenutz > Erbschaft (Feature
> Create > Data Sharing > Inheritance).

Verbesserung der Zonenerzeugung
Das Erzeugen und Verwalten von Zonen wurde durch die neue
Benutzeroberfläche erleichtert. Über das Dialogfenster Zonen-
Manager (Zone Manager) können Sie neue Zonen erzeugen und
bestehende Zonen kopieren, editieren, umbenennen oder löschen.
Zonen können jetzt außerdem Referenzen zu jeder beliebigen Ebene der
aktuellen Baugruppe und folgende neue Referenztypen enthalten:

� Planare Flächen, die nicht Bezugselemente sind
� 2D-Elemente
� Abstandsbereich von einem 2D-Element

Im Dialogfenster Zonendefinition (Zone Definition) können Sie
durch Auswahl von Bedingungen und Einrichten von Beziehungen
zwischen den Bedingungen und der Zone eine bestimmte Zone
festlegen.

Verbesserung der Hüllenerzeugung
Die Erzeugung von Hüllen aus Schrumpfverpackungen kann jetzt
schneller und direkter durchgeführt werden. Im neuen Dialogfenster
Arbeitsraum-Methode (Envelope Method) können vier Arten von
Hüllen erzeugt werden:

� Neue Komponente
� Vorhandene Komponente
� Flächen-Teilmenge einer Schrumpfverpackung
� Schrumpfverpackung aus facettierten Volumenkörpern

Verbesserung des Verschmelzens über Referenz
KEs vom Typ "Verschmelzen über Referenz" enthalten jetzt Folien-,
Farb- und andere Flächendaten. Die Verschmelzfunktion steht jetzt im
Menü GEM DATBENUTZ (DATA SHARING) durch Klicken auf
Konstr Element > Erzeugen > Gemeins DatBenutz (Feature >
Create > Data Sharing) zur Verfügung.
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Verbesserung bei der Kopiegeometrie-Funktionalität
Die in einer Baugruppe auf einer niedrigeren Ebene erzeugten
Kopiegeometrie-KEs können auf eine höhere Ebene umgeleitet werden.

Externe Referenzsteuerung
Das Dialogfenster Externe-Referenzen-Steuerung (External
Reference Control) enthält zwei Registerkarten zur Steuerung
externer Referenzen auf der Modellebene (Teil oder Baugruppe). Auf
der Registerkarte Zugaenglich (Accessible) (Einkommende
Referenzen) können Sie festlegen, welche Referenzen von anderen
Modellen geborgt werden können, wenn Sie im aktuellen Modell
arbeiten. Die Einstellungen für Zugängliche Referenzen sind
folgendermaßen:

� Alle (All) – Läßt externe Referenzen zu jeder beliebigen
Komponente zu.

� Innerhalb der Unterbaugruppe (Inside Subassembly) –
Externe Referenzen dürfen nur zu Komponenten in derselben
Unterbaugruppe erzeugt werden.

� Skelettmodell (Skeleton Model) – Externe Referenzen dürfen
nur zum Skelett von Baugruppen höherer Ebenen erzeugt werden.

� Keine (None) – Läßt keine externen Referenzen zu.

Auf der Registerkarte Gemeinsam verwendet (Shared)
(Ankommende Referenzen) können Sie festlegen, welche Geometrie des
aktuellen Modells von anderen Modellen referenziert werden kann. Die
Einstellungen für Gemeinsam verwendete Referenzen sind
folgendermaßen:

� Alle (All) — Die gesamte Geometrie des aktuellen Modells kann
als externe Referenz von anderen Modellen verwendet werden.
Diese Funktion gleicht der Funktion von Version 2000i2.

� PublizierGeom (Publish Geometry) — Beschränkt externe von
diesem Modell und anderen Modellen gemeinsam verwendete
Referenzen auf Publiziergeometrie-KEs.

� Keine (None) — Verbietet jegliche externen Geometrie- oder
Plazierungsreferenzen von dem anderen Modell auf das aktuelle
Modell.

Sie können die Steuerung externer Referenzen auch auf
Umgebungsebene einstellen. Wählen Sie Dienstprogramme > Ref-
Steuerung (Utilities > Ref Control), um das Dialogfenster
Referenzsteuerung (Reference Control) zu öffnen.
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Benutzerdefinierte KEs zur Erzeugung von
Komponenten

Benutzerdefinierte KEs umfassen Komponenten, die im Kontext einer
Baugruppe erzeugt wurden. Diese Komponenten können externe
Referenzen enthalten. Sie werden über die neue Option Modelle
verkn (Assoc Models) im Dialogfenster UDF Creation zum
benutzerdefinierten KE (UDF) hinzugefügt.

Aufforderungen für alle erforderlichen Referenzen sind notwendig, um
das Erzeugen der neuen Komponente in der neuen Konstruktion zu
ermöglichen. Auf diese Weise wird unter Verwendung von
Konstruktionswissen und -daten eine zusätzliche Anpassung
ermöglicht.

Vereinfachte Skelettdarstellungen
Sie können vereinfachte Darstellungen von Skelettmodellen erzeugen.
Alle bereits im Modus Teil vorhandenen vereinfachten
Darstellungsfunktionen stehen jetzt in einem Skelettmodell zur
Verfügung. Setzen Sie die Konfigurationsdatei-Option
multiple_skeletons_allowed auf yes, um diese Funktion zu
aktivieren.

Referenzweiterleitung für Schrumpfverpackungen
Die Weiterleitung von Referenzen von einem Modell zu einem anderen
wurde implementiert, um den Austausch von
Schrumpfverpackungsmodellen mit ihren vollständigen Darstellungen
und umgekehrt zu ermöglichen. Auf diese Weise wird eine höhere
Flexibilität erzielt und die Handhabung komplexer Konstruktionen
erleichtert. Klicken Sie auf Ersetzen > Ueber Schrumpfverpackung
(Replace > By Shrinkwrap), und suchen Sie nach dem verknüpften
Modell. Pro/ENGINEER ersetzt dann automatisch das Objekt durch
seine verknüpfte Schrumpfverpackung. Die Schrumpfverpackung muß
vor dem Ersetzen erzeugt werden. Pro/ENGINEER erkennt außerdem
die Kinder gewählter Modelle auf gleiche Weise wie bei
Austauschbauteilen.

Betroffene Parameter und Bemaßungen
Sie können jetzt die Hierarchie der Beziehungen zwischen
beziehungsgesteuerten Bemaßungen und Parametern in Ihren
Konstruktionen mit Hilfe des GlobaleRef-Viewer anzeigen. Wählen Sie
die Beziehungsoptionen in der Dropdown-Liste Filtereinstellungen
(Filter Settings), um die Werte anzuzeigen. Erweitern Sie
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anschließend den Zweig, um sich die einzelnen Bemaßungen und
Parameter anzusehen. Wenn Sie in der globalen Referenzenansicht
einen Parameter oder eine Bemaßung wählen, werden in der
Baumstruktur der Referenzansicht alle dazugehörigen
Kindabhängigkeiten angezeigt. Auf diese Weise werden die potentiellen
Auswirkungen der Änderung eines bestimmten Parameters oder einer
bestimmten Bemaßung veranschaulicht.

Regenerierungsdarstellungen
Sie können jetzt eine vereinfachte Darstellung erzeugen, die nur
enthält, was zur Regenerierung notwendig ist. Die neue Option
Beziehung (Relationship) im Dialogfenster Nach Regel (By Rule)
ermöglicht die Auswahl des KE oder der Komponente, das/die
referenziert werden soll. Anhand der Filteroptionen können Sie
festlegen, welche Eltern und/oder Kinder eingeschlossen werden sollen.
Dank dieser Filteroptionen können komplexe Konstruktionen weitaus
leichter geändert werden, da nur betroffene Objekte gewählt und
regeneriert werden.
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Pro/PROCESS for Assemblies

In Pro/PROCESS for Assemblies können Sie Parameter für
Montageeinheiten definieren. Montageeinheiten wurden für den
Schiffsbau implementiert, da Schiffsteile hergestellt und in der Werft
zusammengebaut werden.

Mit der neuen Befehlsfolge Montageeinheit > Parameter (Fab Unit
> Parameters) können Sie vorhandene Informationen über die
Parameter einer aktiven Montageeinheit löschen, ändern und abrufen.
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Optimierungs-KEs aufgrund von
Konstruktionsstudien erzeugen

Beim Durchführen einer Optimierungs- oder Durchführbarkeitsstudie
können Sie diese jetzt in einem Optimierungs-KE erfassen. Sie können
außerdem eine Konstruktionsstudie speichern. Klicken Sie im
Dialogfenster Optimierung/Durchfuehrbarkeit
(Optimization/Feasibility) auf Datei > KE erzeugen (File > Make
Feature), um ein Optimierungs-KE zu erzeugen.

Optimierungs-KEs sind sehr leistungsfähig. Nach dem Hinzufügen
eines Optimierungs-KE wird dieses im Modellbaum angezeigt, und die
Geometrie wird bei jeder Regenerierung des Modells optimiert.

Berücksichtigen Sie die folgenden Aspekte von Optimierungs-KEs:

� Das Hinzufügen eines Optimierungs-KE im Modell kann die zum
Regenerieren benötigte Zeit erheblich verlängern.

� Bei jedem Regenerieren initiiert Pro/ENGINEER die Studie und
wendet die Ergebnisse an. Wenn Sie das Optimierungs-KE-Attribut
RegenAnfrage (RegenRequest) auf Schreibgeschuetzt (Read
only) gesetzt haben, wird keine Optimierung durchgeführt, und die
Dauer des Regenerierungsvorgangs bleibt unverändert.

� Die von den KEs vor dem Optimierungs-KE erzeugte Geometrie
ändert sich eventuell, wenn die Ergebnisse des Optimierungs-KE
angewendet werden.
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� Optimierungen können nicht verschachtelt werden. Dies beinhaltet
die folgenden Einschränkungen:

� Nur Bemaßungen und Parameter, die KEs nach dem
vorhergehenden Optimierungs-KE steuern, können als variable
Bemaßungen für das nächste Optimierungs-KE verwendet
werden.

� Wenn während der Optimierung ein Optimierungs-KE auf Teil-
oder Unterbaugruppenebene regeneriert werden muß, kann
kein Baugruppen-Optimierungs-KE erzeugt werden.

� Sie können keine Optimierungs- oder Durchführbarkeits-
Konstruktionsstudie ausführen, wenn während der
Konstruktionsstudie ein Optimierungs-KE regeneriert werden
muß.

Analyse-KEs im Dialogfenster "Analyse" ("Analysis")
erzeugen

Sie können jetzt die Ergebnisse einer Analyse in einem Analyse-KE
erfassen, während Sie weiterhin im Dialogfenster Analyse (Analysis)
arbeiten. Klicken Sie im Dialogfenster Analyse (Analysis) auf KE
hinzuf (Add Feature), nachdem Sie die Analyse berechnet haben,
und geben Sie den Namen des KE an. Das Analyse-KE wird im
Modellbaum angezeigt und beim Regenerieren des Modells aktualisiert.

Annäherung in Multiziel-Konstruktionsstudien
verwenden

Sie können jetzt in Multiziel-Konstruktionsstudien ungefähre
Bewertungen der Konstruktionsstudienziele an beliebigen Punkten der
Konstruktionsfläche erzeugen. Diese Funktionalität ist besonders dann
von Nutzen, wenn Sie mit geometrisch komplexen Modellen oder
Modellen mit zeitaufwendigen Analyse-KEs arbeiten. Anstatt
zeitaufwendige Regenerierungen durchzuführen, können Sie die Ziele
bewerten und auf Annäherungswerten basierende
Empfindlichkeitsstudien erzeugen. Anhand der Annäherungswerte
können Sie schnell bewerten, wie sich Konstruktionsziele für die
festgelegten Werte von Konstruktionsvariablen ändern.

Pro/ENGINEER verwendet zum Erzeugen von Annäherungswerten das
Konzept einer Reaktionsfläche. Eine Reaktionsfläche nähert die
Zielwerte basierend auf den Ergebnissen aller durchgeführten
Experimente der n-dimensionalen Konstruktionsfläche an.
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Zur Verwendung von Annäherungswerten verwenden Sie Werkzeuge
> Naeherungswert (Tools > Approximation Value) im
Dialogfenster Multiziel-Konstruktionsstudie (Multi-Objective
Design Study).

Sie können eine Näherungswerttabelle außerdem von der Master-
Tabelle ableiten. In der Näherungswerttabelle erhalten Sie
Annäherungswerte von den Konstruktionsstudienzielen für die
gewünschte Anzahl von Experimenten. Zur Erzeugung der
Näherungswerttabelle verwenden Sie Werkzeuge >
Naeherungswerttabelle (Tools > Approximation Table ) im
Dialogfenster Multiziel-Konstruktionsstudie (Multi-Objective
Design Study).

Verbesserungen der Benutzeroberfläche in
Konstruktionsstudien

Die Benutzeroberfläche für Konstruktionsstudien wurde verbessert,
um den Arbeitsablauf zu optimieren. Folgendes wurde verbessert:

� Das Dialogfenster enthält jetzt eine Menüleiste mit Dropdown-
Menüs sowie Symbole für die am häufigsten verwendeten Befehle.

� Sie können jetzt Optionen festlegen, bevor Sie die Analyse
durchführen, indem Sie Optionen > Voreinstellungen (Options
> Preferences) wählen.

� Sie können jetzt den Standardbereich für Konstruktionsvariablen
festlegen, indem Sie Optionen > Standardbereich (Options >
Default Range) wählen.

� Sie stellen in der Multiziel-Konstruktionsstudie zuerst die
Parameter ein, indem Sie Einstellung > Variablen/Ziele (Setup
> Variables/ Goals) wählen und dann die Berechnungen
durchführen.

� Sie können jetzt das Attribut RegenAnfrage (RegenRequest) für
das Analyse-KE auf Immer (Always), Nur
KonstruktionsStudie (Only DesignStudy) oder
Schreibgeschuetzt (Read only) setzen.

� Sie können jetzt die Felder im Dialogfenster für
Konstruktionsstudien direkt editieren, indem Sie auf eine Zelle
klicken und einen neuen Wert eingeben.
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Pro/PIPING

Spezifikationsgesteuerte Rohrkonstruktion
Sie können komplexe Rohrkonstruktionen basierend auf
Projektspezifikationen erzeugen.

Die Pro/PIPING Spezifikationsdatenbank ist das Kernstück der
spezifikationsgesteuerten Rohrkonstruktion. Diese Datenbank enthält
den Master-Katalog, die Formstück-Bibliothek und die
Projektdatendateien. Die Rohrdaten können an diesem leicht
zugänglichen Speicherort problemlos geändert und aktualisiert werden.

Zu Beginn des Modellierens von Rohrleitungen setzen Sie die
Konfigurationsoption piping_design_method auf spec_driven (die
Standardeinstellung ist non_spec_driven), und stellen Sie die
Projektdatendateien in der Spezifikationsdatenbank ein. Das
Einstellen der Projektdatendateien ist kinderleicht. Nachdem Sie in
das neue Dialogfenster Rohrleitungs-Spezifikation definieren
(Define Piping Specification) einfach die Rohrleitungs-, Formstück-,
Isolierungs- und Zubehörteildaten aus den Projektspezifikationen in
die Spezifikationsdatenbank eingegeben haben, können Sie sofort mit
dem Modellieren komplexer Rohrleitungssysteme beginnen.

Mit dem neuen Dialogfenster Leitung erzeugen (Create Pipeline)
können spezifikationsgesteuerte Rohrleitungssysteme mühelos erzeugt
werden. Im Dialogfenster Leitung erzeugen (Create Pipeline)
können Sie folgende Funktionen durchführen:

� Automatisch Rohre, Formstücke, Isolierung und Zubehörteile
gemäß der Spezifikation wählen.

� Eine Rohrformstück-Bibliothek und einen Master-Katalog erstellen
und anpassen, um optimale Flexibilität beim Konstruieren zu
erzielen.
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� Rohrspezifikationen während der Projektkonstruktion erstellen
und ändern. Änderungen aktualisieren und sofort in
Pro/ENGINEER anzeigen.

� Rohrsysteminformationen nach Spezifikationen abrufen und
Zielberichte erzeugen.

� Einer bestimmten Rohrleitung automatisch Farben und Folien
gemäß der Spezifikation zuweisen.

� Alle Spezifikationsdaten an einem leicht zugänglichen Ort
verwalten.

Gruppenformstücke einfügen
Sie können jetzt Gruppenformstücke mit einem einzelnen
Formstückvorgang einfügen. Das neue Dialogfenster
Gruppenformstueck einfuegen (Insert Group Fitting) ermöglicht
das Einfügen einer Gruppe von gegeneinander ausgerichteten
Formstücken in ein Rohrsegment. Mit diesem Dialogfenster können Sie
Formstücke wählen, plazieren, ausrichten und in der Vorschau
anzeigen. Im spezifikationsgesteuerten Modus werden die Formstücke
in einer Formstückdatenbank aufgeführt, auf die Sie über dieses
Dialogfenster zugreifen. Die Formstückdatenbank wird vor ihrer
Verwendung erstellt und kann jederzeit aktualisiert werden.

Sie müssen verschiedene Konfigurationsoptionen einstellen, um das
Einfügen von Formstücken zu aktivieren.

Getrimmte Knicke automatisch einfügen
Über das Dialogfenster Formstueck einfuegen (Insert Fitting)
können Sie an allen Ecken automatisch Knicke oder getrimmte Knicke
einfügen und automatisch den am nächsten liegenden Standardknick
wählen.

Knicke automatisch mit Konstruktionsregelprüfung einfügen
Sie können jetzt die Länge gebogener Spannpratzen von gewählten
Rohrleitungen prüfen. Ist die Länge des gebogenen Spannpratzens
ungültig, können Sie die gewählte Biegung durch einen Knick ersetzen.

Flansche und Dichtungen automatisch einfügen
Während Sie das Dialogfenster Formstueck einfuegen (Insert
Fitting) oder Gruppenformstueck einfuegen (Insert Group
Fitting) zum Einfügen von Formstücken verwenden, können Sie
automatisch die benötigten Flansche und Dichtungen mit geflanschten
Endtypen wählen und einfügen.
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Auslassungsformstücke einfügen
Während Sie das Dialogfenster Formstueck einfuegen (Insert
Fitting) oder Gruppenformstueck einfuegen (Insert Group
Fitting) zum Einfügen von Formstücken verwenden, können Sie jetzt
stumpf geschweißte Auslässe, muffengeschweißte Auslässe,
Gewindeauslässe und Kupplungsflansche einfügen. Bei diesen
Formstücken handelt es sich um spezielle Arten von
Auslassungsformstücken für Abzweigungen, die auf der Oberfläche von
Rohrleitungen zu plazieren sind. Das Symbol für den Formstücktyp
wird im Feld Formstueck-Kategorie waehlen (Select Fitting
Category) festgelegt. Der Name des Formstücks wird im Feld
Auswahlname (Selection Name) angezeigt.

Neue ISOGEN-Zeichnungsfunktion
Pro/PIPING unterstützt jetzt die Erzeugung von isometrischen
Zeichnungen (ISOGEN) für alle spezifikationsgesteuerten
Rohrleitungen und Leitungsspulen. Pro/PIPING speichert die
Rohrleitungsdaten in PCF (Piping Component File)- und MDF
(Material Description File)-Dateien zur Verwendung mit ISOGEN-
Applikationen. Pro/PIPING ISOGEN-Dateien enthalten die folgenden
Funktionen:

� Automatische Stücklisten, basierend auf den Spezifikationen und
der Spezifikationsdatenbank

� Automatische Erzeugung einer isometrischen Zeichnung auf
mehreren Blättern

� Repräsentative Isolierungssymboloption, 2D-Symbolgröße für
Formstückkomponentenoption, automatisches Symbol für die
Markierungsflußrichtung und isometrische Symbole für
Rohrleitungsformstücke

� Automatische Bemaßung, einschließlich Komponente-zu-
Komponente, Ende-zu-Ende, Schnitt-Rohr und Feldbemaßung für
verzogene Rohrleitungssegmente

� Automatische Überlappungsprüfung für Rohrleitungen,
Bemaßungen und Text

Modelle und Bericht für Inter-Unterbaugruppen
Mit Pro/PIPING können Sie jetzt eine Rohrabzweigung in einer aktiven
Baugruppe verlegen, indem Sie eine in einer anderen Baugruppe
vorhandene Rohrleitung referenzieren. Sie können jetzt ein
Zweigformstück an einem Verbindungspunkt von einer Haupt- und
einer Zweigrohrleitung einfügen, die zu verschiedenen Baugruppen
gehören. Der Rohrleitungsbericht enthält jetzt Informationen über
Zweigrohrleitungen in verschiedenen Baugruppen. Wenn Sie eine
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Rohrleitung aus einer anderen Baugruppe öffnen, wird ein neues
Dialogfenster zur Bestätigung geöffnet.

Rohrleitungen in Richtung von und aus Richtung von Zubehör-

Ziehenden verlegen
Wenn Sie mit der Option Von (From) Rohrleitungen ab einem
Ziehende verlegen, wird mit LEITUNG LEGEN > Start einst (ROUTE
PIPE > Set Start) jetzt die Größe des Ziehendeanschlusses gelesen und
das Verlegen der Leitungen basierend auf der zugewiesenen
Anschlußgröße ermöglicht.

Wenn Sie Rohrleitungen mit der Option Zu (to) zu einem Ziehende
verlegen, wird mit LEITUNG LEGEN > Zu Pkt/Anschl (ROUTE PIPE >
To Pnt/Port) und Verbinden (Connect) die aktuelle
Rohrleitungsgröße mit der Größe des Ziehendeanschlusses verglichen.
Stimmen die Größen nicht überein, wird ein Warnhinweis
eingeblendet. Sie können allerdings trotzdem mit dem Verlegen
fortfahren.

Flußrichtung von Rohrerweiterungen
Das Modul Pro/PIPING ordnet jeder beim Modellieren erzeugten
Rohrleitung automatisch eine Standard-Flußrichtung zu. Die
Zuordnung der Flußrichtung basiert auf einem Satz von
Flußrichtungsregeln. Sie können die Flußrichtung mit der Schaltfläche
Umkehren (Reverse) im Bereich Flussrichtung (Flow Direction)
des spezifikationsgesteuerten Dialogfensters Leitung aendern
(Modify Pipeline) auch umkehren.

ANSI- und DIN-Formstück-Bibliothek
Diese erweiterte Bibliothek enthält die ANSI- und DIN-gestützten
Rohrformstück-Bibliotheken. Die Rohrformstück-Bibliothek besteht
jetzt aus ANSI- und DIN-Rohrleitungsformstücken, einschließlich der
generischen Pro/ENGINEER Teile für Formstücke, der Master-
Katalog-Dateien für Rohrleitungen und Formstücke sowie der JIS-
Formstücke.

Die spezifikationsgesteuerte Rohrformstück-Bibliothek wurde erzeugt,
und die Regeln, Vorgehensweisen und Beispiele zur Erzeugung werden
beschrieben. Die Erzeugung von Bibliothekteilen umfaßt folgendes:

� Erzeugung der Formstückgeometrie
� Erzeugung der Formstückanschlüsse
� Festlegen der Einlaßanschlüsse
� Ausrichtung der Systemachsen
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� Zuordnung von Formstückparametern

Aktualisierte JIS-Bibliothek
Die verbesserte JIS-Bibliothek enthält viele neue
Formstückkategorien. Den Master-Katalog-Dateien für JIS-
Formstücke wurden jetzt auch Gewichtsinformationen hinzugefügt.

Weitere Pro/PIPING Verbesserungen

Rohrbaugruppen unter Verwendung des neuen benutzergesteuerten

Rohrleitungs-Konstruktionsmodus konvertieren
Mit dem neuen benutzergesteuerten Modus können Sie den
Rohrleitungs-Konstruktionsmodus wechseln und Baugruppen jederzeit
während der Konstruktion in Pro/PIPING konvertieren. Aktivieren
oder deaktivieren Sie das neue Kontrollkästchen Spez gest (Spec
Driven) im Menü PIPING (ROHRLEGEN), während die
Konfigurationsoption piping_design_method auf user_driven
gesetzt ist (die Vorgabe ist non_spec_driven), um die derzeit aktive
Rohrleitungsbaugruppe auf den spezifikationsgesteuerten oder nicht-
spezifikationsgesteuerten Konstruktionsmodus zu setzen. Alle
Rohrleitungsmenüs werden automatisch aktualisiert.

Das neue Dialogfenster Convert Assembly enthält eine
benutzerfreundliche Schnittstelle für die Konvertierung in den
spezifikationsgesteuerten Konstruktionsmodus.

Neuer Rohrleitungssystembaum
Der neue Rohrleitungssystembaum ermöglicht das Steuern der
Darstellung von Rohrleitungen. Die baumstrukturbasierte Oberfläche
strukturiert alle Leitungen in der aktiven Baugruppe und deren
Unterbaugruppen nach Leitungssystemen und sortiert die Leitungen
nach Namen. Sie definieren das Rohrleitungssystemformat durch
Einstellen der Konfigurationsoption piping_system_tree_format
(die Vorgabe ist mnemonic). Die Möglichkeit zur Aufnahme aller
Unterbaugruppen vereinfacht die Darstellung von Leitungen. Dies ist
besonders dann wichtig, wenn Sie Leitungen nach der
Modellierungsmethode "eine Leitung pro Baugruppe" erzeugen.

Der Rohrleitungssystembaum bietet außerdem flexiblere
Auswahlmöglichkeiten. Sie können eine Leitung, mehrere Leitungen in
einem Rohrleitungssystem oder alle Leitungen in der aktiven
Baugruppe einschließlich deren Unterbaugruppen wählen. Pro/PIPING
hebt Ihre Auswahl hervor. Klicken Sie mit der rechten Maustaste im
Rohrleitungssystembaum, um die Auswahl mit Zeigen/Ausblenden
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(Show/Blank) anzuzeigen oder auszublenden, die
Rohrleitungsmittellinien oder Volumenkörper mit
Mittellinie/Volumenkoerper (Centerline/Solid) anzuzeigen oder
die Anzeige mit Modus zuruecksetzen (Reset Mode)
zurückzusetzen.

Rohrleitungsteilstücke schneiden
Das Schneiden von Rohrleitungsteilstücken ermöglicht das Schneiden
eines langen Rohrsegments in Teilstücke. Über das Dialogfenster Rohr
schneiden (Cut Pipe) können die folgenden Vorgänge ausgeführt
werden:

� Schneiden einer Rohrleitung an einer bestimmten Stelle.
� Schneiden eines geraden Rohrleitungssegments an mehreren

Stellen, durch Angabe der Rohrlänge oder einer
benutzerdefinierten Rohrlänge. Die festgelegte Länge sollte entlang
des geraden Rohrsegments in Form von Intervallen angegeben
werden.

� Legen Sie eine Schnittposition mit Referenz zu anderen Objekten
(z.B. einem benachbarten Rohrsegment, einer strukturellen
Rumpffläche und Bezugsebenen) fest.

� Fügen Sie während des Schneidens von Stücken automatisch
Verbindungsformstücke ein.

� Wählen Sie ein Werkstatt/Baustellen-Attribut wie Werkstatt-
Baustelle (Shop-Field), Werkstatt-Werkstatt (Shop-Shop) und
Baustelle-Werkstatt (Field-Shop).

Gerade Rohrleitungsteilstücke schneiden

Sie können jetzt ein gerades Rohrstück basierend auf der Länge des
Rohmaterials eines Rohrs (z.B. der Standardlänge, in der Rohre
hergestellt und geliefert werden) schneiden. Mit Stueckschneide-
Optionen (Piece Cutting Options) im Dialogfenster Rohr
schneiden (Cut Pipe) können Sie ein gerades Rohrstück wählen und
dieses automatisch in mehrere Teile schneiden [basierend auf der
Länge des unter Rohrlaengen-Spezifikation (Raw Length
Specification) angegebenen Rohmaterials].

Verbindungsformstücke automatisch einfügen (nur spezifikationsgesteuert)

Mit der Funktion Rohrleitungs-Spezifikation definieren (Define
Piping Specification) können Sie Verbindungsformstücke basierend
auf der Rohrleitungs-Spezifikation automatisch an Schnittpositionen
einfügen. Aktivieren Sie das Kontrollkästchen Verbindungsstueck
(Joint Fitting) im Dialogfenster Rohr schneiden (Cut Pipe), um
automatisch Verbindungsformstücke einzufügen.
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� Erlaubt die Rohrleitungs-Spezifikation für einen
Verbindungsstücktyp mehrere Arten von Verbindungsformstücken
(z.B. Kupplungen und Flansche), wird zur Auswahl des
Verbindungsformstücks ein Optionsmenü angezeigt.

� Erlaubt die Rohrleitungs-Spezifikation nur einen
Verbindungsstücktyp, wird dieser automatisch gewählt und
eingefügt.

Rohrstückspulen und automatische Numerierung

Klicken Sie im Dialogfenster Spule generieren (Generate Spool)
auf die Schaltfläche Generieren (Generate), um die automatische
Generierung von Rohrspulstücken (basierend auf den Teileschnitten)
zu aktivieren. Eine Rohrspule wird erzeugt, wenn ein Rohrstückschnitt
mit einem Werkstatt/Baustellen-Attribut oder ein Flansch-Formstück
festgestellt wird. Jeder Rohrspule ist eine eindeutige Spulennummer
zugeordnet, die basierend auf dem mit der Konfigurationsoption
pipeline_spool_label_format festgelegten Format generiert wird.
Klicken Sie im Dialogfenster Spule generieren (Generate Spool) auf
die Schaltfläche Loeschen (Delete), um eine Rohrspule samt
zugeordneter Spulennummer zu löschen.

Biegetabellen für abgeleitete Längen
Pro/PIPING unterstützt jetzt Biegetabellen für abgeleitete Längen für
den nicht-spezifikationsgesteuerten und den spezifikationsgesteuerten
Rohrkonstruktionsmodus. Pro/PIPING verwendet die Biegetabellen
zum Anpassen von Rohrlängen an Biegungen. Hiermit werden
manuelle Berechnungen überflüssig.

Volumenkörperrohre aktualisieren
Pro/ENGINEER erzeugt jetzt automatisch neue Volumenkörperteile
und aktualisiert vorhandene Volumenkörperteile während des
Einfügens, Löschens, Ersetzens und Umdefinierens von Formstücken
sowie beim Einfügen und Löschen von Stückschnitten. Durch diese
neue Funktion fallen wiederholte manuelle Schritte weg. Außerdem
werden Volumenkörperteile standardmäßig automatisch aktualisiert.

Neue Funktionen zur Modellierung der Isolierung und zur

Berichterstellung
Mit Pro/PIPING können Sie die Isolierung für Ihre
Rohrleitungssysteme erzeugen und ändern, Isolierungsvolumenkörper
automatisch erzeugen und ausführliche Isolierungsberichte erstellen.
Verwenden Sie das neue Dialogfenster Isolierung erzeugen (Create
Insulation), um die Isolierung für eine gesamte Rohrleitung oder
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einzelne Rohrleitungssegmente zu erzeugen. Mit dem neuen (nur im
spezifikationsgesteuerten Modus verfügbaren) Dialogfenster Leitung
erzeugen (Create Pipeline) können Sie einer Spezifikation eine
Isolierung zuweisen und automatisch die Volumenkörperdarstellung
der Isolierung erzeugen, wenn die Rohrkörper mit dem neuen
Dialogfenster Rohrkoerper erzeugen (Create Pipe Solid) erzeugt
werden.

In ausführlichen Isolierungsberichten werden das Isolierungsmaterial
sowie Daten über die Dicke und Länge der Isolierung aufgeführt. Die
Berichte können auch Daten zu Isolierungen für Rohrbiegungen und
die Anzahl und den Typ von isolierten Formstücken in der
Rohrleitungsbaugruppe enthalten.
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Pro/DETAIL

Wichtige Verbesserungen der Benutzeroberfläche
und Verwendbarkeit

Die Verbesserungen von Pro/DETAIL umfassen folgendes:

� Die Menübefehle auf der rechten Seite wurden ins Hauptmenü
verlagert und enthalten entsprechende Untermenüs. Da die
Befehle nur ein bis zwei Ebenen tief in der Menühierarchie
enthalten sind, wurde auf diese Weise der Zugriff auf alle Befehle
erleichtert.

� Die mit der rechten Maustaste aufgerufenen Menüs sind
objektbezogen, d.h. die verfügbaren Befehle richten sich nach dem
gewählten Objekt.

� Sie können ein Objekt oder mehrere Objekte (bei gleichzeitigem
Drücken der UMSCHALTTASTE bzw. STRG-Taste) wählen.

� Verwenden Sie den Modellbaum, um 2D-Elemente zu wählen und
kontextbezogene Vorgänge durchzuführen.

Bemaßungen
Sie können folgende Vorgänge ausführen:

� 2D-Elemente können jetzt mit Hilfe der Ziehgriffe von
Maßhilfslinien und Bemaßungen leicht verschoben oder in der
Größe geändert werden.

� Verwenden Sie die neue Schaltfläche WertAendg widerrufen
(Undo Val Chg) im Dialogfenster Bemassungen (Dimensions),
um übernommene Wertänderungen vor dem Regenerieren
rückgängig zu machen.
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� Sie können für ein radiales Muster von KEs (z.B. für einen
Lochkreis) lineare Bemaßungen erzeugen.

� Zur Neuanordnung von Bemaßungen zählen automatische
Unterbrechungen in sich schneidenden Maßhilfslinien.

� Wurde eine gesteuerte Bemaßung nicht regeneriert, da ihre
Referenzen geändert wurden, können Sie die Bemaßung schnell
wählen und eine neue Referenz festlegen.

� Sie können für den Abwicklungszustand eines Blechteils
automatisch Ordinatenbemaßungen erzeugen. Die
Ordinatenbemaßungen für alle Spitzen, Achsen, Biegungslinien,
Bogenmittelpunkte, Stanz- und Formmittelpunkte sowie
Auswerfstifte (einschließlich Eckpunkte, paralleler Kanten, Punkte
und Koordinatensysteme) werden basierend auf dem
Koordinatensystem eines gewählten Modells erzeugt.

� Sie können die Bemaßung beim Bemaßen von zwei konzentrischen
Kreisen radial plazieren.

Ansichten
Folgende Verbesserungen wurden integriert:

� Sie können eine ausführliche Ansicht zu einer allgemeinen,
teilweisen oder skalierten Ansicht ändern, um die
Anzeigeeigenschaften der Ansicht unabhängig von der
Elternansicht zu steuern.

� Sie können die Farbanzeige von gewählten Ansichten im
Zeichnungsmodus wechseln und die zugeordneten
Zeichnungsfarben oder die im Originalmodell verwendeten Farben
anzeigen. Hiermit sparen Sie Zeit, da mit einem einzelnen Befehl
die Modellfarben in der Zeichnung wiederverwendet werden
können.

� Eine neue Option wurde integriert, um einen Detailansichtskreis
basierend auf ASME Y14.5M - 1994 zu erzeugen.

� Schraffuren für Modellquerschnitte können basierend auf dem
Material des Teils zugewiesen werden.

� Detailansichten können jetzt in allgemeine Ansichten konvertiert
werden, wodurch größere Flexibilität erzielt wird. Hiermit können
Sie in der Detailansicht die Kantenanzeige und das Ausblenden
von Komponenten unabhängig von der Elternansicht einstellen.
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Parametrisches Zeichnen
Bei der Zeichnungserstellung gibt es folgende Verbesserungen:

� Die Werkzeuge für 2D-Zeichnungen wurden neu gestaltet und an
den Pro/ENGINEER 3D-Skizzierer angepaßt. Sie ermöglichen jetzt
die automatische Verschiebung, Rotation und Skalierung von
gezeichneten Elementen.

� 2D-Elemente können parametrisch und assoziativ zur
Modellgeometrie (ein Lochkreis oder Schnittpunkt) sein.
Gezeichnete Elemente sind parametrisch an einem Modellpunkt
angesetzt (ähnlich wie Notizlinien an der Geometrie angesetzt
bleiben).

� Gezeichnete 2D-Elemente rasten an anderen gezeichneten
Elementen ein und bleiben verbunden. Zu den beim Skizzieren
angewendeten Bedingungen zählen Horizontal-, Vertikal-,
Mittelpunkt-, Parallel-, Senkrecht- und Tangentenbedingungen.

Wortumbruch in Tabellen und Notizen
Lange Notizen oder Tabelleneinträge können jetzt mit
benutzerdefinierten Wortumbruchfunktionen umbrochen werden. Die
Ränder können jetzt in Notizen an die gewünschte Position verschoben
werden.

Standardinhalt von Detailnotizen festlegen
Verwenden Sie die Konfigurationsoption detail_note_text
<Zeichenkette>, um den Standardtext für Referenznotizen in der
Standardansicht festzulegen.

Benutzerdefinierte Symboldefinitions-Palette
Zum Beschleunigen der Symbolerzeugung und -plazierung können Sie
jetzt beim Erzeugen einer Symbolvariante auf eine Pro/ENGINEER-
Zeichnung zugreifen, die benutzerdefinierte Symboldefinitionen als
Palette enthält. Sie können auf die Palette über das Dialogfenster
Symbolvariante (Symbol Instance) zugreifen
(symbol_instance_palette_file <pfad>).
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Verbesserungen der geometrischen Toleranz
Zu den Verbesserungen der geometrischen Toleranz zählen:

� Die neue Konfigurationsoption restricted_gtol_dialog (y/n)
mit der Sie unabhängig von den standardbezogenen Bedingungen
vollen Zugriff auf die Benutzeroberfläche zur Angabe von
geometrischen Bemaßungen und Toleranzen erhalten.

� Das Rundheitssymbol ist in Teilen und Baugruppen verfügbar.

� Über das Dialogfenster Geometrische Toleranz (Geometric
Tolerance) können Sie einer geometrischen Toleranz die
Berandungskennung hinzufügen, wie mit den ASME Y14.5M –
1994-Standards festgelegt.

� Sie können den Ansatztyp für die geometrische Toleranz
umdefinieren, ohne das Original zu löschen.
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Pro/SHEETMETAL

Verbesserungen am Arbeitsablauf
Die Navigation kann jetzt auf oberster Ebene erfolgen, und es wurde
eine neue Tool-Leiste für alle Blech-KEs hinzugefügt. Einige häufig
verwendete Menübefehle wurden zu einer übersichtlichen
Benutzeroberfläche zusammengefaßt. Aufgrund neuer verfügbarer
Standardwerte stehen effizientere Dialogfenster zur Verfügung. Für die
Erzeugung von Blech-KEs stehen fortschrittliche Werkzeuge bereit. Es
wurden in verschiedenen Bereichen des Moduls erhebliche Änderungen
an der Oberfläche vorgenommen, um den Arbeitsablauf für
Konstrukteure zu vereinfachen. Aufgrund dieser Verbesserungen
erhalten Sie erforderliche Informationen schneller und reduzieren so
die Konstruktionszeit.

Parameter für Blechteile
Die Menübefehle zum Hinzufügen und Ändern von Blechparametern
wurden zu einer übersichtlichen Benutzeroberfläche zusammengefaßt.
Neue Parameterfunktionen ermöglichen Ihnen das Vordefinieren von
einigen Schritten für das Festlegen von KEs. Diese Schritte werden bei
der KE-Erzeugung automatisch mit einem Vorgabewert aus Setup
übersprungen. Die benutzerdefinierten Standardwerte werden beim
Erzeugen von Laschen-KEs verwendet;  Sie brauchen daher nicht mehr
für jede einzelne Lasche die gleichen Eingaben vorzunehmen (z.B.
Innenradius, Außenradius usw.). Mit einem einzigen Mausklick können
Sie die Standardwerte und automatischen Attribute für alle Parameter
leicht einstellen.
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Neue Parameterfunktionen ermöglichen die Beziehungssteuerung und
das Einstellen der Blechparameter in einer empfangenen Datei sowie
das Regenerieren des Modells mit globalen Parametern.

Die neuen Funktionen zum Steuern der Blechparameter verbessern
den Konstruktionsarbeitsfluß beträchtlich.

Umschlagfunktion
Sie können auf ausgewählten geraden, gebogenen oder gezogenen
Blechkanten Umschläge erzeugen. Abhängig von der gewünschten
Naht stehen die folgenden Arten von Umschlägen zur Verfügung:

� Offener Umschlag
� Bündiger Umschlag
� Entenschnabel-Umschlag
� C-Umschlag
� Z-Umschlag

Spitze Ecken zu Biegungen konvertieren
Auf Profillaschen skizzierte scharfe Ecken können automatisch zu
Biegungen konvertiert werden. Scharfe Kanten, die mit der
vorhandenen Geometrie verbunden sind, können konvertiert werden.

Diese neue KE-Definition kann vor oder nach dem Erzeugen von
Profillaschen mit scharfen Ecken eingerichtet werden.

Pro Schnitt wird zusammen mit mehreren Längenbemaßungen
automatisch eine Radiusbemaßung erzeugt.

Tiefenwertoptionen für Blechteile
Die Tiefenwertoption steht jetzt für Blechschnitte zur Verfügung. Sie
können Materialschnitte mit der Tiefenwertoption erzeugen, deren
angegebene Tiefe gleich oder größer als die Blechdicke ist. Dank diesem
zusätzlichen Materialschnitt-KE wird die Flexibilität beim
Konstruieren erhöht.

Freischnittlinien in Blechendabwicklungen
ausblenden

Beim Erzeugen einer Endabwicklung werden alle Freischnittlinien mit
Breite 0 entfernt. Trennungen mit Breite 0 müssen beim Anfertigen
von Zeichnungen oder Weiterreichen von Teilen zur Fertigung nicht
mehr entfernt werden.
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Automatische Ordinatenbemaßung von
Blechendabwicklungen

In Zeichnungsansichten werden automatisch Ordinatenbemaßungen
für Blechendabwicklungen erzeugt. Die Ordinatenbemaßungen werden
aus einem Koordinatensystem für scharfe Ecken, Achsen,
Biegungsbogen-Mittelpunkten, Stanzungen und Formmittelpunkten
erzeugt.
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Geometrieloses Schweißen
Sie können jetzt Schweißnähte erzeugen, die aus weniger Referenzen
und Geometrie als Volumenkörper-Schweißnähte bestehen.
Geometrielose Schweißnähte sind leicht zu erzeugen, da sie schnell zu
plazieren sind und die Leistung der Baugruppe nur minimal
beeinflussen.

Geometrielose Schweißnähte werden über ein informatives grafisches
Dialogfenster definiert, das auf Schweißsymbolstandards der
International Organization for Standardization (ISO), dem American
National Standards Institute (ANSI) und der American Welding
Society (AWS) basiert. Geometrielose Schweißnähte werden durch
Auswahl der Kanten von Teilen integriert. Schweißnähte können nach
ihrer Entwicklung mit Volumenkörpergeometrie oder geometrielos
erzeugt werden.

Neuer vereinfachter Arbeitsfluß für das Zuweisen
von Schweißprozeß- und Schweißdraht-Dateien

Die Schweißprozeß- und Schweißdraht-Dateien wurden überarbeitet
und bieten jetzt einen effizienteren und realistischeren Arbeitsfluß für
das Festlegen von Bearbeitungsparametern. Es wird jetzt zwischen
Bearbeitungs- und Konstruktionsparametern unterschieden, um eine
von der Definition des Bearbeitungsprozesses unabhängige
Entwicklung der Konstruktion zu ermöglichen. Die Schweißprozeß-
und Schweißdraht-Dateien werden jetzt unabhängig voneinander
erzeugt und werden nicht mehr in jedem Schweiß-KE definiert.
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Die Schweißprozeß- und Schweißdraht-Dateien werden Schweiß-KEs
bei oder nach ihrer Erzeugung zugeordnet. Schweiß-KEs verweisen
jetzt auf die Schweißprozeß- und Schweißdraht-Dateien, wodurch
Schweißprozeß- und Schweißdraht-Änderungen in allen Schweiß-KEs,
die diese Parameterdateien referenzieren, integriert werden können.

Zur Definition von Schweißprozeß- und Schweißdraht-Dateien wurden
neue grafische Dialogfenster integriert. Einer der wesentlichen Vorteile
dieser neuen Dialogfenster ist die Funktion zur Zuordnung von
Schweißprozeß- und Schweißdraht-Dateien zu vielen Schweiß-KEs in
einem einzigen Schritt. Außerdem können Schweißparameter jetzt im
Modellbaum dargestellt werden.
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Automatischer Import von Baugruppen
Sie können jetzt eine Platine und Komponenten automatisch in einem
Schritt in eine Pro/ENGINEER Baugruppe importieren, ohne zuerst
die Platine als separates Teil zu erzeugen und einzubauen.

IDF-kompatible Verbesserungen
Notizen werden als Pro/ENGINEER 3-D-Notizen in den Modus Teil
importiert. Wenn Sie im Modus Teil den Export auf die Platine
durchführen, werden alle passenden 3D-Notizen in den IDF3.0-
Notizenabschnitt exportiert. Schalttafeln werden durch den Import in
ein Teil und eine Baugruppe unterstützt. Der Schalttafelexport ist
sowohl im Modus Teil als auch im Modus Baugruppe möglich.

Beim Importieren in den Modus Baugruppe bzw. beim Importieren
einer Komponenten-Bibliothek wird festgestellt, ob die gewünschten
Komponenten im Arbeitsspeicher, in der Zuordnung oder im
INTRALINK-Suchpfad enthalten sind. Abhängig vom Ergebnis dieser
Prüfung wird von Pro/ECAD entweder eine Bibliotheksdatei
angefordert. Es werden nur die relevanten Komponenten importiert.

Schablonenfunktion
Sie können jetzt über zwei neue Konfigurationsoptionen
(template_ecadpart und template_ecadasm) eine
Standardschablone ausweisen, die für den Import von Teilen oder
Baugruppen verwendet wird. Wenn Sie sich während des Importierens
dazu entscheiden, nicht die Standardschablone zu verwenden, können
Sie eine Schablone aus der Liste wählen.
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Folien automatisch erzeugen und plazieren
Ist die neue Konfigurationsoption ecad_comp_layer_map auf yes
gesetzt, wird für jeden importierten Komponententyp eine separate
Folie erzeugt. Jede Folie wird nach dem Komponententyp benannt, und
alle Komponenten mit diesem Namen werden auf dieser Folie plaziert.
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Pro/DIAGRAM

Verbesserungen der Benutzeroberfläche und Menüs
Das neue Menü Einfuegen (Insert) ermöglicht das schnelle
Hinzufügen von Datenbankobjekten. Mit dem neuen Menü Format
(Format) können Sie Komponenten- und Symboldefinitionen schnell
definieren und aufrufen. Das neue Menü Skizze (Sketch) bietet
intelligente und benutzerfreundliche Werkzeuge für die 2D-
Zeichnungserstellung.

Drahtlistenausgabe nach Folien filtern
Sie können eine Drahtliste erzeugen, die speziell auf die Objekte
abgestimmt ist, die einer gewählten Folie zugewiesen sind.

Weitere Optionen für neue Referenzen
Wenn Sie einen Stecker durch einen anderen ersetzen, oder wenn im
bestehenden Objekt Drähte zu einem Stift verlegt werden, für den im
neuen Objekt kein entsprechender Stift vorhanden ist, können Sie die
Drähte im Raum verlegen.

Wenn beim erneuten Verlegen Drähte im ersten Referenzobjekt zu
einem Stift geleitet werden und im zweiten Objekt kein entsprechender
Stift vorhanden ist, können Sie im zweiten Objekt einen Stift festlegen,
zu dem die Drähte verlegt werden.

Erhöhte Benutzerfreundlichkeit
� Alphanumerisches Sortieren � Falls zutreffend, wird ein Objekt in

der Liste alphanumerisch eingeordnet.
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� Auswahl mehrerer Spulen � Sie können jetzt die Parameter für
mehrere Spulen gleichzeitig ändern.

� Viel-Auswahl für Mehrfachansichts-Komponenten � Sie können
jetzt in Ansichten für Mehrfachansichts-Komponenten die
Werkzeuge für die Viel-Auswahl verwenden.
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Pro/HARNESS-MFG und

Pro/CABLING

Pro/CABLING

Kabelleiter automatisch verlegen
Interne Kabelleiter werden jetzt automatisch zu bestimmten Stiften
verlegt, die über eine logische Referenz zugewiesen wurden.

Verbessertes T-Bündel-KE
Eine neue Kabelbündelroutine ermöglicht das schnelle Erzeugen
gebündelter T-Schnitte, in denen die Verbindungen aus
unterschiedlichen Richtungen im T verschmelzen.

Pfad in einem Netzwerk festlegen und ihm automatisch zu verlegende

Kabel zuweisen
Sie erhalten zusätzliche Steuermöglichkeiten für das automatische
Verlegen, wenn Sie ein Pfad-KE zwischen zwei Speicherorten in einem
Netzwerk festlegen und den Parameter use_path <pfadname> in der
Verbindung verwenden, die zugewiesen wird.  Anhand des Parameters
autoroute_path_param_name können Sie selbst einen Namen für
den Parameter festlegen.
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Drähte, Kabel oder Kabelbäume kopieren und wiederverwenden
Sie können Drähte, Kabel oder auch ganze Kabelbäume kopieren und
wiederverwenden. Jedes zum Verlegen gewählte Kabel wird entlang
eines Pfads von der Form des Quellkabels kopiert. Besitzt das
Quellkabel eine feste Länge, erhalten die neu verlegten Kabel die
gleiche feste Länge (besitzt nur ein Abschnitt des Quellkabels eine feste
Länge, erhält der entsprechende Abschnitt der neu verlegten Kabel
ebenfalls diese feste Länge).

Neue Benutzeroberfläche für Aderendhülsen-Tabellen
Zum Festlegen der Regeln für die Ausführung von Aderendhülsen-
Tabellen steht jetzt eine neue tabellenartige Benutzeroberfläche zur
Verfügung.

Draht- und Kabel-Flächengeometrie exportieren
Neben Mittellinien können Sie jetzt auch die Flächengeometrie von
Kabeln in alle Exportformate exportieren, die in Pro/ENGINEER zur
Verfügung stehen.

Alle logischen Informationen nach logischen Referenzen aktualisieren
Das Aktualisieren einer Kabelbaugruppe über eine logische Referenz
zu einer Pro/DIAGRAM Datei ist jetzt unbeschränkt möglich. Zum
Beispiel kann ein Kabelkomponenten-Referenzdesignator jetzt über
eine logische Referenz aktualisiert werden, wenn das Quelldiagramm
geändert und neu referenziert wurde.

Pro/HARNESS-MFG

Verbesserung des Autofan-Algorithmus
Der Algorithmus für die automatische Abwicklung in Pro/HARNESS-
MFG wurde erheblich verbessert. Er generiert jetzt ein deutlicheres
Ergebnis, und die Notwendigkeit für manuelle Nachbesserung wurde
reduziert.   



16-1

16 
Interactive Surface Design

Extension

Interactive Surface Design Extension ist ein neues Pro/ENGINEER
Modul, mit dem das Style-KE zur Verfügung gestellt wird. Dieses neue
Modul verfügt über einmalige Funktionen zur Erzeugung von Freiform-
Flächen und ermöglicht ein höheres Maß an Interaktion und
Kreativität. Interactive Surface Design Extension ergänzt das
Advanced Surface Extension Paket.

Style (Style) bietet eine neue Konstruktionsumgebung mit folgenden
Eigenschaften:

� Die Möglichkeit einer vierfachen Ansichtsdarstellung, die das
gleichzeitige Arbeiten in mehreren Modellansichten erlaubt.

� Soft Point-Technologie
� Direkte Steuerung der Kurven- und Flächenkontinuität

Mit Style (Style) können Sie 2D- (die 3. Dimension wird nach der 2D-
Form festgelegt) oder auch 3D-Kurven erzeugen. Die Soft Point-
Technologie ermöglicht geometrieärmere und flexiblere Kurven,
wodurch die Beziehungen zwischen Kurvenpunkten leichter hergestellt
werden können.

Der Grad der Kontinuität zwischen der gesamten Geometrie kann mit
Reglern direkt auf dem Bildschirm gesteuert werden, womit andere
Beziehungen zwischen Kurven und Flächen verwaltet werden.
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Diese intuitive und interaktive Funktion ermöglicht das Erstellen
neuer KEs auf der Teileebene und das Modellieren von Kurven und
Flächen mit beliebig vielen Bedingungen. Style (Style) nutzt die
gesamte Leistung der parametrischen Pro/ENGINEER Umgebung, um
das Freiform-Modellieren und parametrische Modellieren zu
integrieren.
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Neue Benutzeroberfläche für Scantools
Die neue Benutzeroberfläche für Scantools vereinfacht das Importieren
von Rohdaten und das Erzeugen von Kurven und Flächen. Kurven und
Flächen können jetzt über das Dialogfenster Kurve aendern (Modify
Curve) bzw. Flaeche aendern (Modify Surface) interaktiv geändert
werden.
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Bandflächen
Bei einer Bandfläche handelt es sich um einen Bezug, der ein
Tangentenfeld darstellt, das entlang einer Basiskurve verläuft. Die
Bandfläche verläuft tangential zu den Bezugskurven, die die
Basiskurve schneiden.

Verwenden Sie die Bandfläche, um die Tangentialbedingungen
zwischen zwei Flächen-KEs zu integrieren. Mit der Bandfläche können
Sie die Einzelflächenstruktur so definieren, daß benachbarte Flächen
tangential zueinander verlaufen, ohne daß eine dieser Flächen als
Tangentenreferenz verwendet wird. Auf diese Weise fungiert die
Bandfläche als Tangentenreferenz. Wenn Sie diese Methode verwenden
möchten, erzeugen Sie zuerst die Bandfläche. Als nächstes erstellen Sie
die einzelnen Flächen so, daß sie tangential zur Bandfläche verlaufen.
Nachdem Sie die Tangentialität zwischen zwei benachbarten Flächen
hergestellt haben, können Sie die mit der Bandfläche assoziierte Folie
ausblenden.

Die Folie für Bandflächen kann auch vordefiniert werden. Hierzu legen
Sie den Namen der Folie über die Konfigurationsoption def_layer
(LAYER_RIBBON_FEAT) fest. Dadurch werden alle erzeugten
Bandflächen automatisch dieser Folie hinzugefügt.
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Verbundfläche mit zusätzlichen Kurven
Das KE Annaeher-Verbund (Approximate Blend) wurde durch das
KE Verbundflaeche (Blended Surface) ersetzt. Wenn Sie jetzt eine
Verbundfläche erzeugen, können Sie weitere Kurven wählen, denen
sich die neue Fläche anzunähern versucht. Nachdem Sie weitere
Kurven gewählt haben, können Sie die Flächenglätte und die Anzahl
von u- und v-Einzelflächen festlegen.
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Pro/CASTING

Benutzeroberfläche für Werkzeugbau-Applikationen
Die Benutzeroberfläche ermöglicht jetzt einen effizienteren
Arbeitsablauf. Pro/MOLDESIGN ist in die Modi Spritzguß-Kavität und
SpritzgußLayout untergliedert.  Bei Pro/MOLDESIGN ist Spritzguß-
Kavität ein neuer Untertyp im Modus NC-Bearbeitung und
SpritzgußLayout ein neuer Untertyp im Modus Baugruppe.  Bei
Pro/CASTING ist Guß-Kavität ein neuer Untertyp im Modus NC-
Bearbeitung.

Die Modi Spritzguß-Kavität und Guß-Kavität umfassen alle
Funktionen, die normalerweise mit der Erzeugung der
Eindruckgeometrie verbunden sind.  Eine Tool-Leiste, die Icons für die
gebräuchlichsten Funktionen enthält, leitet den Benutzer durch die
Erzeugung von Kavitätsgeometrie. Die Anordnung der Icons entspricht
dem Arbeitsablauf beim Konstruieren. Über ein Icon am unteren Ende
der Tool-Leiste für Spritzguß-Kavität können Sie schnell in den Modus
SpritzgußLayout wechseln, um die Ausarbeitung der gesamten
Spritzgußbaugruppe zu vervollständigen.

Der Modus SpritzgußLayout umfaßt alle Funktionen, die
normalerweise mit dem Definieren von Detailelementen der
Spritzgußbaugruppe der obersten Ebene verbunden sind. Wie der
Modus Spritzguß-Kavität bietet auch der Modus SpritzgußLayout eine
bestimmte Tool-Leiste für die wichtigsten Operationen. Über ein Icon
am unteren Ende der Tool-Leiste können Sie in den Modus Spritzguß-
Kavität zurückwechseln, um Kavitäten zu erzeugen und Änderungen
vorzunehmen.
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Sie können die Reihenfolge der Icons anpassen, so daß sie Ihrem
Konstruktionsablauf entspricht.

Standard-Öffnungsrichtung für den Spritzguß und
Guß

Sie können jetzt im Spritzgußmodell eine globale Öffnungsrichtung
festlegen, die grafisch dargestellt wird.  Diese Richtung wird in
spritzgußspezifischen KEs wie Silhouettenkurven und
Rocktrennflächen als Standard-Öffnungsrichtung verwendet. Sie
können auch für jedes beliebige KE (z.B. Schiebeteil) eine lokale
Öffnungsrichtung festlegen.

Mold Catalog Composer
Der Catalog Composer hilft Ihnen bei der Erzeugung
benutzerangepaßter Spritzgußkatalog-Komponenten.  Diese
Funktionalität ist im Modus Teil verfügbar, wenn Sie Applikationen
> Spritzguss/Guss und anschließend Dienstprogramme > Catalog
Composer wählen. Das Dialogfenster Katalogbaum (Catalog Tree)
hilft bei der Erzeugung der benutzerangepaßten Katalog-Komponente.
Sie können den Katalog von Grund auf erstellen oder einen bereits
vorhandenen Katalog ändern. Catalog Composer ist mit allen
Katalogkonventionen und -regeln vertraut und kann überprüfen, ob
Ihre Katalog-Komponente gültig ist.

Volumenkörpertrennung
Volumenkörpertrennung ist eine Alternative zum Trennen des
Spritzguß- /Gußvolumens.  Mit dieser Methode können Sie ein Teil, z.B.
ein Werkstück, direkt trennen und dadurch die Erzeugung eines
Spritzgußvolumens umgehen.  Diese Funktionalität ist nützlich, wenn
Sie das eigentliche Werkstück ändern und die wahren Bemaßungs- und
Mustermerkmale beibehalten möchten. Mit Volumenkörpertrennung
können Sie ein Teil trennen und dann das Restmaterial entweder
entfernen, anhand des Restmaterials eine Komponente oder ein
Spritzgußvolumen erzeugen oder das Restmaterial zu einem
vorhandenen Teil hinzufügen.

Verbesserungen für Tangentenschrägen
Das Tangentenschrägen-KE bietet jetzt zusätzliche Optionen für das
Erzeugen von Schrägengeometrie. Sie können Querschnitt-
Tangentialität (neue Option) oder vollständige Tangentialität (alte
Option) verwenden. Sie können eine ein- oder zweiseitige Schräge mit
einer Volumenkörper- oder Flächengeometrie erzeugen. Sie können
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außerdem eine Steuerkurvenkontur festlegen, um den Vorgang
robuster zu gestalten, und Abschlußebenen und Abschlußwinkel für
Abschlußebenen erzeugen.

Rockverlängerungssteuerung Tangente zu Teil
Die Funktionalität für automatische Trennflächen (Rock) bietet jetzt
Verlängerungssteuerung, wodurch sichergestellt wird, daß die
Trennfläche, die verlängert wird, tangential zu einer Teilefläche bleibt.
Dadurch kann die Bearbeitung der Einsätze beträchtlich vereinfacht
werden.  Gehört ein Trennkurvensegment vollständig zur unteren
Fläche eines Referenzteils, können Sie das neue Dialogfenster
Verlaengerungssteuerung (Extension Control) verwenden, um die
Verlängerung einer Rocktrennfläche zu erzeugen, die tangential zur
unteren Fläche verläuft.

Verbesserungen des Rockflächen-
Schleifenverschlusses

Zum Schließen von Schleifen in einer Rockfläche stehen jetzt zwei
Optionen zur Verfügung: Mittlere Fläche und Mittlere Ebene. Die
mittlere Fläche oder Ebene wird durch Versatz einer gewählten Fläche
und Verbinden dieser Einzelfläche mit der Schleifenberandung erzeugt.

Verformungs-/Ersatz-Funktion für Spritzguß-
/Gußvolumina

Die Operation zum Verformen/Ersetzen der Geometrie kann direkt an
Spritzgußvolumina ausgeführt werden. Die Option zum Ersetzen von
Flächen (Flaeche ersetzen) ist in den Menüs WKZGVOL (MOLD
VOL) und DIE VOL verfügbar; der Zugriff erfolgt über WKZG
VOLUMEN > Aendern bzw. GUSSVOLUMEN > Aendern (CAST
VOLUME > Modify).

Benennung von Komponenten in Dialogen
Sie können jetzt ein Werkstück im Dialogfenster Automatisches
Werkstueck (Automatic Workpiece) benennen, anstatt nach dem
vollständigen Definieren der Rohlingsgeometrie.
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Keine Rohlingsbearbeitung
Sie können ein Referenzmodell bearbeiten, ohne einen entsprechenden
Rohling zu erzeugen. Diese Methode eignet sich insbesondere beim
Bearbeiten eines komplexen Referenzteils (z.B. ein Guß), bei dem Sie
einige einfache KEs bearbeiten müssen. Anstatt einen ebenso
komplexen Rohling zu definieren und diesen zum Referenzguß
zusammenzubauen, ist es evtl. effizienter, ein NC-Modell ohne Rohling
zu erzeugen und daraufhin einige Schritte zum Definieren der
Bearbeitungs-KEs auszuführen.

Um ein NC-Modell für die Bearbeitung ohne Rohling zu erzeugen,
rufen Sie das Referenzmodell auf, und klicken Sie im Menü NC-
MODELL (NC MODEL) auf Fertig (Done), anstatt einen Rohling zu
definieren. Es erscheint eine Mitteilung mit dem Hinweis, daß ein
Modell ohne Rohling erzeugt wird.

Steht für ein NC-Modell kein Rohling zur Verfügung, müssen Sie die
notwendigen Werte angeben, um die Dicke des zu entfernenden
Materials festzulegen. Aus diesem Grund enthält das Dialogfenster für
das KE, abhängig von dem erstellten KE, ein oder mehrere zusätzliche
Elemente, wenn Sie ein Bearbeitungs-KE für ein NC-Modell ohne
Rohling erzeugen.

Spannelemente
Vor der Benutzung von Spannelementen in einem NC-
Bearbeitungsprozeß müssen Sie erst die Einstellung der
Spannelemente für das NC-Bearbeitungsmodell definieren. Jede
Einstellung von Spannelementen hat einen Namen und enthält
Informationen über die Spannelemente, die im Modell vorhanden sein
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müssen, wenn die Einstellung aktiv ist. Spannmitteleinstellungen
können beim Einstellen einer Operation oder zwischen dem Erzeugen
von KEs und Werkzeugwegen definiert werden.

Spannmitteleinstellungen gehören zu Operationen. Wenn Sie eine
Operation erzeugen, wird automatisch eine leere
Spannmitteleinstellung für diese Operation erzeugt. Diese erste
Spannmitteleinstellung wird im Modellbaum oberhalb der Operation
eingefügt, so daß Sie die Spannmittelgeometrie zum Definieren des
Programm-Nullpunkts für die Operation verwenden können. Sie
können diese Einstellung ändern, indem Sie ihr Komponenten
hinzufügen.  Sie können auch weitere Spannmitteleinstellungen für
dieselbe Operation erzeugen (diese Einstellungen werden im
Modellbaum unter der Operation eingefügt). Beachten Sie, daß eine
Operation zwar mehrere zugeordnete Spannmitteleinstellungen
besitzen, jedoch nur jeweils eine Spannmitteleinstellung aktiv sein
kann. Wenn Sie ein Bearbeitungs-KE erzeugen, wird es im Modellbaum
automatisch unter der derzeit aktiven Spannmitteleinstellung
eingefügt. Das System berücksichtigt ggf. Spannmittelkomponenten,
wenn es die Geometrie für Bearbeitungs-KEs und die entsprechenden
Hartwände erzeugt.

Rotationssicherheitsabstand für
Werkzeugmaschinen mit 4 Achsen

Mit der Option Rotationssicherheitsabstand verwenden (Use
Rotary Clearance) im Dialogfenster Operationseinstellung
(Operation Setup) können Sie für Werkzeuge eine sichere
Rückzugshöhe auf Z-Ebene definieren, um die Sicherheit von
Maschinentischdrehungen zu gewährleisten. Der Wert unter
Rotationssicherheitsabstand (Rotation Clearance) legt den
Mindestabstand fest, bei dem das NC-Modell und die
Spannelementkomponenten während Maschinentischdrehungen
deaktiviert werden. Außerdem können Sie für Werkzeuge, die für einen
Rückzug auf den Rotationssicherheitsabstand zu lang sind, einen
Rotations-Sicherheitspunkt angeben. Geben Sie in die Textfelder
Rotations-Sicherheitspunkt (Safe Rotary Point) Werte für die x-,
y- und z-Koordinate ein. Damit für ein Werkzeug der Rotations-
Sicherheitspunkt anstatt des Rotationssicherheitsabstandes verwendet
wird, müssen Sie es im Werkzeug-Manager als "lang" kennzeichnen.
Aktivieren Sie hierzu im Dialogfenster Wkzg Einst (Tool Setup) auf
der Registerkarte Einstellungen (Settings) das Kontrollkästchen
Langes Wkzg (Long Tool).
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Stücklisten für ein Werkzeug
Auf der neuen Registerkarte Stueckliste (BOM) im Dialogfenster
Wkzg-Einstellung (Tool Setup) können Sie die
Stücklisteninformationen für das Werkzeug angeben.

Wenn Sie ein Volumen-Werkzeugmodell aufrufen, werden automatisch
alle im Werkzeugmodell verwendeten Teile und Baugruppen in die
Stückliste für das Werkzeug eingeschlossen. Bei allen anderen
Werkzeugtypen können Sie Stücklisteninformationen angeben, indem
Sie die Namen der Komponenten eingeben und ihren Typ und ihre
Menge angeben.

Automatische Plazierung von CL-Befehlen
Mit der Funktion Automatische Befehlsplazierung (Automatic
Command Placement) können Sie vor oder nach einem bestimmten
Ereignis im Werkzeugweg (z.B. vor jedem Lauf oder nach der letzten
Rückzugsbewegung) einen CL-Befehl oder einen Befehlssatz einfügen,
ohne daß sich dessen Position bei späteren Werkzeugweg-Änderungen
verschiebt.

Die Registerkarte CL-Befehle (CL Commands) des Dialogfensters
Werkzeugweg-Eigenschaften (Tool Path Properties) enthält acht
typische Positionen in einer CL-Datei, an denen Sie einen angepaßten
CL-Befehl einfügen können.

� Vor LOADTL (Before LOADTL) – Vor der LOADTL-Anweisung.

� Nach LOADTL (After LOADTL) – Nach der LOADTL-
Anweisung.

� Nach SPINDL (After SPINDL) – Nach der SPINDL-Anweisung.

� Nach FROM (After FROM) – Nach der FROM-Anweisung. Diese
Option ist nur dann verfügbar, wenn Sie das Kontrollkästchen
FROM verwenden (USE FROM) im Abschnitt FROM-/HOME-
Anweisungen (FROM/HOME Statements) gleich über dem
Abschnitt Automatische Befehlsplazierung (Automatic
Command Placement) aktivieren.

� Vor jedem Lauf (Before Each Pass) – Vor der Anfahrbewegung
zu jedem Schnittlauf im Werkzeugweg.

� Nach jedem Lauf (After Each Pass) – Nach der
Rückzugbewegung von jedem Schnittlauf im Werkzeugweg.
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� Nach endgueltigem Rueckzug (After Final Retract) – Nach
der endgültigen Rückzugbewegung im Werkzeugweg. Diese Option
ist nicht verfügbar, wenn im Dialogfenster WkzgWeg-
Eigenschaften (Tool Path Properties) auf der Registerkarte
Zwischenraum (Clearance) für die Option Endgueltiger
Rueckzug (Final Withdrawal) der Wert Keine (None) aktiviert
ist.

� Nach GOHOME (After GOHOME) – Nach der GOHOME-
Anweisung. Diese Option ist nur dann verfügbar, wenn Sie das
Kontrollkästchen GOHOME verwenden (USE GOHOME) im
Abschnitt FROM-/HOME-Anweisungen (FROM/HOME
Statements) gleich über dem Abschnitt Automatische
Befehlsplazierung (Automatic Command Placement)
aktivieren.

Rippenoberseiten-KE und Werkzeugweg
Mit dem Rippenoberseiten-KE können Sie Material von der
Rippenoberseite entfernen. Die Rippenoberseite ist der Boden des KE.
Er muß horizontal sein.

Zur effektiven Bearbeitung dieser KEs steht ein neuer Werkzeugweg-
Algorithmus zur Verfügung. Das Material wird nur über der Rippe
entfernt, d.h. das KE reicht nicht bis an die Materialberandung. Auf
diese Weise erhalten Sie mehr Flexibilität für die Reihenfolge der
Bearbeitung: Sie können das Rippenoberseiten-KE entweder vor oder
nach dem Entfernen des Materials auf einer der Rippenseiten
bearbeiten.

Hinterschneidung-KE und Werkzeugweg
Ein Hinterschneidung-KE ist ein offenes Volumen mit einer Hartdecke,
das von einem Scheibenfräswerkzeug zu bearbeiten ist. Nachdem Sie
eine Decke festgelegt haben, werden die Wände und der Boden
automatisch erkannt. Sie können die KE-Tiefe ändern.

Beim Bearbeiten einer Hinterschneidung können Sie entweder mehrere
Schnittläufe oder einen einzelnen Mittelschnitt durchführen, wobei auf
der Decken- und Bodenfläche die gleiche Menge an Material
beibehalten wird.

Außenfasen-KE und Werkzeugweg
Das Außenfasen-KE ermöglicht das Entfernen des Materials entlang
einer Kette aus horizontal gefasten Kanten. Die Fasenflächen bilden
den Boden des KE.
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Zur effektiven Bearbeitung dieser KEs steht ein neuer Werkzeugweg-
Algorithmus zur Verfügung. Zum Bearbeiten eines Außenfasen-KE
müssen Sie ein Werkzeug zum Entgraten oder Kegelsenken
verwenden, wobei der Parameter Spitzenwinkel (Point Angle) des
Werkzeugs auf den Fasenwinkel abgestimmt werden muß (z.B. bei
einer Fase mit 45 Grad müssen Sie das Werkzeug mit einem
Spitzenwinkel von 90 Grad verwenden). Das auf den Bodenflächen
verbleibende Material wird in der Richtung gemessen, die für die
Fläche der Fase normal ist.

Außenverrundungs-KE und Werkzeugweg
Das Außenverrundungs-KE ermöglicht das Entfernen des Materials
entlang einer Kette aus horizontal verrundeten Kanten. Die
verrundeten Flächen bilden den Boden des KE.

Zur effektiven Bearbeitung dieser KEs steht ein neuer Werkzeugweg-
Algorithmus zur Verfügung. Zur Bearbeitung eines Außenrundungs-
KE müssen Sie entweder ein Werkzeug des Typs Eckenrunden
(Corner Rounding), bei dem der Parameter Radius mit dem Radius
der Außenrundung übereinstimmt, oder ein skizziertes Werkzeug
verwenden. Das auf den Bodenflächen verbleibende Material wird in
der Richtung gemessen, die für die Fläche der Rundung normal ist.
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Änderungen im Werkzeug-Manager
Der Werkzeug-Manager enthält die folgenden Verbesserungen:

� Die Möglichkeit zur Angabe von Schnittdaten für die Werkzeuge
(abhängig vom Rohlingsmaterial).

� Die Möglichkeit zur Angabe von Stücklisteninformationen für die
Werkzeuge.

Schnittdaten für ein Werkzeug angeben
Im Register Drehzahlen & Vorschuebe (Speeds & Feeds) können
Sie Schnittdaten (Vorschub, Drehzahl, axiale und radiale Tiefe) für das
Schruppen und Schlichten mit diesem Werkzeug angeben, abhängig
vom Typ und vom Zustand des Rohlingsmaterials. Zur Festlegung der
Schnittdaten für ein Werkzeug muß zunächst die Material-
Verzeichnisstruktur eingerichtet werden. Daraufhin geben Sie im
Dialogfenster Operationseinstellung (Operation Setup) in der
Dropdown-Liste Rohlingsmaterial (Stock Material) das
Rohlingsmateial an.

Sie können die für das Werkzeug bereitgestellten Schnittdaten
verwenden, um die Werte für die NC-Bearbeitungsparameter
festzulegen, und zwar entweder über Beziehungen oder durch Auswahl
von Editieren > Aus Wkzg kopieren (Edit > Copy From Tool) in
der Menüleiste am oberen Ende des Dialogfensters Parameter-Baum
(Param Tree).
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Stücklisten für ein Werkzeug
Auf der neuen Registerkarte Stueckliste (BOM) im Dialogfenster
Wkzg-Einstellung (Tool Setup) können Sie die
Stücklisteninformationen für das Werkzeug angeben.

Wenn Sie ein Volumen-Werkzeugmodell aufrufen, werden automatisch
alle im Werkzeugmodell verwendeten Teile und Baugruppen in die
Stückliste für das Werkzeug eingeschlossen. Bei allen anderen
Werkzeugtypen können Sie Stücklisteninformationen angeben, indem
Sie die Namen der Komponenten eingeben und ihren Typ und ihre
Menge angeben.

Angepaßte Zyklen
Sie können an eine Werkzeugmaschine angepaßte Bohrzyklen
erzeugen. Geben Sie hierzu ein Schlüsselwort für den Zyklentyp ein,
legen Sie die Tiefe fest, und geben Sie für jedes Tiefeninkrement ein
Standard- oder benutzerdefiniertes Schlüsselwort an. Angepaßte
Zyklen werden mit der Werkzeugmaschine gespeichert (Arbeitszelle).
Sie können allerdings auch separat in XML-Dateien gespeichert
werden.

Um einen angepaßten Zyklus in einer NC-Folge zu plazieren, geben Sie
die Löcher (Bohrsätze) an, die mit dem Zyklus zu bohren sind, und
definieren Sie die geometrischen Referenzen (Flächen, Bezugsebenen,
Bezugspunkte), die laut Zyklussyntax benötigt werden. Sie können
einen angepaßten Zyklus nur dann in einer NC-Folge verwenden, wenn
er in der aktuellen Arbeitszelle vorhanden ist.

Rotationssicherheitsabstand für
Werkzeugmaschinen mit 4 Achsen

Mit der Option Rotationssicherheitsabstand verwenden (Use
Rotary Clearance) im Dialogfenster Operationseinstellung
(Operation Setup) können Sie für Werkzeuge eine sichere
Rückzugshöhe auf Z-Ebene definieren, um die Sicherheit von
Maschinentischdrehungen zu gewährleisten. Der Wert unter
Rotationssicherheitsabstand (Rotation Clearance) legt den
Mindestabstand fest, bei dem das Referenzteil, das Werkstück und die
Spannelementkomponenten während der Maschinentischdrehungen
deaktiviert werden. Außerdem können Sie für Werkzeuge, die für einen
Rückzug auf den Rotationssicherheitsabstand zu lang sind, einen
Rotations-Sicherheitspunkt angeben. Geben Sie in die Textfelder
Rotations-Sicherheitspunkt (Safe Rotary Point) Werte für die x-,
y- und z-Koordinate ein. Damit für ein Werkzeug der Rotations-
Sicherheitspunkt anstatt des Rotationssicherheitsabstandes verwendet
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wird, müssen Sie es im Werkzeug-Manager als "lang" kennzeichnen.
Aktivieren Sie hierzu im Dialogfenster Wkzg Einst (Tool Setup) auf
der Registerkarte Einstellungen (Settings) das Kontrollkästchen
Langes Wkzg (Long Tool).

Intelligenter Werkzeug-Rückzug beim Volumenfräsen
Beim Volumenfräsen können Sie die Gesamt-Schnittzeit auf ein
Minimum beschränken, indem Sie die Höhe des Werkzeug-Rückzugs
am Ende eines Schnitts minimieren, bevor sich das Werkzeug zum
Anfang des neuen Schnitts bewegt.

Beim Volumenfräsen können Sie die Höhe des Werkzeug-Rückzugs am
Ende eines Schnitts auf zwei Arten steuern, bevor sich das Werkzeug
an den Anfang des neuen Schnitts zurückbewegt.

� Sie können das Dialogfenster Rueckzug-Auswahl (Retract
Selection) verwenden, um eine Zwischen-Rückzugsebene, die
sogenannte Traversenebene, festzulegen. Wenn Sie eine
Traversenebene angeben, verwendet das Werkzeug diese Ebene für
die Bewegung zwischen den Schnitten beim Bearbeiten eines
Volumens. Am Ende der NC-Folge wird das Werkzeug vollständig
zur Rückzugsebene zurückgezogen.

� Sie können den Parameter RUECKZUGS_MODUS
(RETRACT_OPTION) auf SMART (SMART) stellen. Das System
berechnet für jeden Zwischenrückzug in der NC-Folge eine
minimale Sicherheitsebene für den Rückzug des Werkzeugs an die
neue Position. Diese Sicherheitsebene wird als die Ebene der
niedrigsten Schicht bestimmt, die keine Behinderungen für den
Werkzeugweg besitzt (plus den RUECKZUGS_ABSTAND
(PULLOUT_DIST)-Wert, falls dieser festgelegt wurde). Am Ende
der NC-Folge wird das Werkzeug vollständig zur Rückzugsebene
zurückgezogen.

Durch dieses Beschränken der Höhe der Zwischen-Werkzeugrückzüge
wird die Schnittzeit auf eine geringere Gesamtzeit reduziert.

Verbesserungen beim Hochgeschwindigkeits-
Volumenfräsen

Verschiedene Verbesserungen beim Hochgeschwindigkeits-
Volumenfräsen minimieren die Rückzüge und ermöglichen glatte
Übergänge zwischen den Werkzeugbewegungen.
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Neue Verfahrtwerttypen
Für das Volumenfräsen wurden zwei neue Hochgeschwindigkeits-
Verfahrtwerttypen implementiert. Setzen Sie den Parameter
VERFAHRWEG_TYP (SCAN_TYPE) auf einen der folgenden Werte:

� SPIRAL_SCHNITTYP_BEIBEH
(SPIRAL_MAINTAIN_CUT_TYPE) — Generiert einen
spiralförmigen Werkzeugweg, der die Wände zuerst bearbeitet.
Nach Abschluß des ersten Schnitts entlang der Wände bewegt sich
das Werkzeug bogenförmig in den nächsten Schnitt. Hierbei wird
die Schnittrichtung umgekehrt, um den Schnittyp in Bezug auf das
verbleibende Material beizubehalten [GLEICHLAUF (CLIMB) oder
GEGENLAUF (CONVENTIONAL)]. Das Werkzeug bewegt sich
dann entlang des spiralförmigen Wegs mit S-förmigen
Verbindungen in die nachfolgenden Schnitte.

� SPIRAL_SCHNITTRCHTNG_BEIBEH
(SPIRAL_MAINTAIN_CUT_DIRECTION) — Generiert einen
spiralförmigen Werkzeugweg, der die Wände zuerst bearbeitet.
Nach Abschluß des ersten Schnitts bewegt sich das Werkzeug S-
förmig in den nächsten Schnitt. Hierbei wird die Schnittrichtung
beibehalten und der Schnittyp in Bezug auf das verbleibende
Material geändert [z.B. von GLEICHLAUF (CLIMB) zu
GEGENLAUF (CONVENTIONAL)]. Das Werkzeug bewegt sich
dann entlang des spiralförmigen Wegs mit S-förmigen
Verbindungen in die nachfolgenden Schnitte.

Für diese zwei Verfahrwegtypen können Sie anhand der zwei neuen
Parameter LASCH_PROF_SCHNEID_VORSCH
(WALL_PROFILE_CUT_FEED) und
LASCH_PROF_SPIND_DREHZAHL
(WALL_PROFILE_SPINDLE_SPEED) für den ersten Schnitt eine
niedrigere Vorschubrate und Spindelgeschwindigkeit einstellen, wenn
das Werkzeug das Material auf beiden Seiten schneidet.

Glatte Übergänge zwischen Werkzeugbewegungen
Der für das Hochgeschwindigkeits-Volumenfräsen verfügbare
Parameter RUECKZUGS_UEBERGANG (RETRACT_TRANSITION)
legt zuerst den Übergang des Werkzeugs zwischen einer vertikalen
Rückzugbewegung und einer horizontalen Bewegung auf der
Rückzugsebene oder Zwischen-Traversenebene fest. Daraufhin legt er
den Übergang zwischen der Traversenbewegung und einer vertikalen
Eintauchbewegung fest.

Wenn Sie RUECKZUGS_UEBERGANG (RETRACT_TRANSITION)
auf BOGEN_UEBERGANG (ARC_TRANSITION) setzen, werden die
vertikalen und horizontalen Bewegungen durch einen tangentialen
Bogen verbunden. Auf diese Weise muß das Werkzeug bei der
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Hochgeschwindigkeits-Bearbeitung beim Richtungswechsel nicht
verlangsamt oder angehalten werden. Der Radius des
Übergangsbogens wird durch den Parameter RUECKZUGS_RADIUS
(RETRACT_RADIUS) definiert. Der Bogen beginnt über der
Sicherheits-Traversenebene. Daher finden die horizontalen
Traversenbewegungen [es gilt der Parameter RUECKZUGS_RADIUS
(RETRACT_RADIUS)] über der Rückzugsebene oder Zwischen-
Traversenebene statt.

Schnitte beim Volumenfräsen können der Form von
Wänden folgen

Wenn VERFAHRWEG_TYP (SCAN_TYPE) beim Volumenfräsen auf
HARTWAENDEN_FOLGEN (FOLLOW_HARDWALLS) gesetzt ist,
folgt jeder Schnitt unter Beibehaltung des festen Versatzes zwischen
den festgelegten Punkten der zwei aufeinanderfolgenden Schnitte der
Form der Wände des Volumens. Sind die Schnitte geschlossen, befinden
sich S-förmige Verbindungen zwischen den Schnitten.

Neuer Parameter zur Steuerung des
Werkzeugeintauchens beim Volumenfräsen

Ist beim Volumenfräsen VERFAHRWEG_TYP (SCAN_TYPE) auf
TYP_3 (TYPE_3) gesetzt, legt der Parameter EINTAUCH_VORIG
(PLUNGE_PREVIOUS) fest, an welcher Stelle das Werkzeug
eintaucht, wenn eine neue Zone bearbeitet wird:

� JA (YES) — Das Werkzeug taucht an einer bereits bearbeiteten
Zone ein und bewegt sich dann in die neue Zone.

� NEIN (NO) (Standard) — Das Werkzeug taucht in der neuen Zone
ein.

Verbesserungen beim Restvolumenfräsen mit
vorherigem Werkzeug

Die folgenden neuen Parameter ermöglichen eine verbesserte
Steuerung beim Restvolumenfräsen mit dem vorherigen Werkzeug.

Der Parameter BEARB_REIHENF (MACHINING_ORDER) legt fest,
in welcher Reihenfolge in den Ecken und auf den Flächen das restliche
Material entfernt wird. Die Werte lauten:

� ECKEN_ZUERST (CORNERS_FIRST) (Vorgabe) — Entfernt das
restliche Material zuerst in den Ecken und dann auf den Flächen.

� FLAECHEN_ZUERST (SURFACES_FIRST) — Entfernt das
restliche Material zuerst auf den Flächen und dann in den Ecken.
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� NUR_ECKEN (CORNERS_ONLY) — Entfernt das restliche
Material in den Ecken und bearbeitet keine Flächen.

� NUR_FLAECHEN (SURFACES_ONLY) — Säubert die Flächen
und bearbeitet keine Ecken.

Der Parameter FLAE_SAEUBERUNG (SURFACE_CLEANUP) legt
fest, ob das Säubern der Flächen in einem Durchlauf oder in mehreren
Schritten erfolgt. Die Werte lauten:

� EINZELNE_TIEFE (SINGLE_DEPTH) (Standard) — Das
Werkzeug führt am Boden der Fläche einen Schnittlauf durch.

� MULTI_TIEFE (MULTI_DEPTH) — Das Werkzeug führt mehrere
Schnittläufe durch und entfernt das Material in schrittweisen
Inkrementen. Sie müssen für den Parameter ZUSTELLUNG
(STEP_DEPTH) einen Wert festlegen.

Der Parameter ECKEN_SAEUBERUNG (CORNER_CLEANUP) legt
fest, wie die Ecken bearbeitet werden. Die Werte lauten:

� Z_EBENE_SCHNITTE (Z_PLANE_CUTS) (Standard) — Entfernt
das Material in den Ecken mittels 2,5-Achsen-Bearbeitung.

� KONTUR (CONTOUR) — Entfernt das Material in den Ecken mit
einer Reihe von vertikalen Schritten.
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Pro/NC-SHEETMETAL

Automatisches Nibbeln
Das automatische Nibbeln ist ein spezielles Verfahren des
Blechnibbelns. Das automatische Nibbeln ermöglicht die automatische
Auswahl aller Kanten für Nibbel-NC-Folgen. Sie können das
Multiwerkzeug-Nibbeln einrichten und einzelne Nibbel-NC-Folgen
ändern, die aus der Folgengruppe erzeugt wurden.

Verbesserung der Verschachtelung

Reihenfolge der Teile steuern
Die Steuerung der Reihenfolge von Teilen ist ein ausschließlicher
Bestandteil der Funktion zur automatischen Verschachtelung. Sie
können die Reihenfolge der Verschachtelung von gewählten Teilen in
der Reihenfolgen-Liste festlegen. Die Steuerung der Teilereihenfolge ist
insbesondere von Nutzen, wenn bei der Produktion von hohen
Stückzahlen große Mengen davon betroffen sind. Die Reihenfolge
festgelegter Mengen von bestimmten Teilen wird festgelegt, um die
Verschachtelung aller Teile zu steuern. Ordnen Sie demselben Teil
verschiedene Prioritäten zu, um die Verschachtelung auf ein Minimum
zu beschränken oder ganz zu vermeiden.
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Verwendung von Rohmaterial
Sie können unvollständige Verschachtelungen erzeugen, die ein
brauchbares rechteckiges Segment für den verbleibenden
ungeschnittenen Bereich ergeben. Der Umfang der verschachtelten
Teile wird automatisch mit gleichmäßigen rechteckigen Formen
ausgefüllt. Diese Verschachtelungstechnik spart Kosten durch die
Verwendung des übrigbleibenden Blechabfalls.

Doppelt vorhandene Punkte und Schnittlinien
entfernen

Zu den Optimierungsverbesserungen zählt die Funktion zum
Entfernen von doppelt vorhandenen Schnittlinien. Die Methode für das
Entfernen doppelt vorhandener Punkte wurde ebenfalls deutlich
verbessert.
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Pro/VERIFY

Mehrere Formate für das Exportieren von
berechneten Abweichungsergebnissen

Sie können berechnete Abweichungsergebnisse in einem der folgenden
Formate exportieren:

� Abweichung (Deviation) — Nur Punktabweichungen in eine
Textdatei.

� Pkte Abweichung (Pts & Deviation) — Die xyz-Koordinaten
und die Abweichung für jeden Punkt in eine Textdatei.

� Pkte & Abw Vektor (Pts & Dev Vector) — Die xyz-Koordinaten
und den Abweichungsvektor für jeden Punkt in eine Textdatei.

Wählen Sie ERGEB PRUEF > Exportieren (VER RESULTS >
Export) und anschließend das gewünschte Format.
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Datenaustausch

Änderungen an der Benutzeroberfläche für
Importieren/Exportieren

Die Befehle Importieren (Import) und Exportieren (Export) sind
nicht mehr im Menü Datei (File) von Pro/ENGINEER enthalten. Die
folgende Tabelle enthält eine Zusammenfassung der Änderungen der
Pro/ENGINEER Benutzeroberfläche für das Importieren und
Exportieren.

2000i2 Benutzeroberfläche Neue 2001 Benutzeroberfläche

Datei > Importieren >
Erzeugen
(File > Import > Create)

Datei > Oeffnen
(File > Open)

Datei > Importieren >
Anhaengen
(File > Import > Append)

Einfuegen > Daten aus Datei...
(Insert > Data From File...)

Datei > Exportieren
(File > Export)

Datei > Kopie speichern...
(File > Save a Copy...)

Konstr Element > Erzeugen >
ICEM In
(Feature > Create > ICEM In)

Datei > Oeffnen, Einfuegen > Daten aus Datei...
(File > Open, Insert > Data from File...)

Konstr Element > Erzeugen >
CDRS In
(Feature > Create > CDRS In)

Datei > Oeffnen, Einfuegen > Daten aus Datei...
(File > Open, Insert > Data from File...)
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2000i2 Benutzeroberfläche Neue 2001 Benutzeroberfläche

Konstr Element > Erzeugen >
DESKTOP In
(Feature > Create >
DESKTOP In)

Datei > Oeffnen, Einfuegen > Daten aus Datei...
(File > Open, Insert > Data from File...)

Statusanzeige
Im Pro/ENGINEER Fenster befindet sich jetzt unterhalb der Tool-
Leiste eine Anzeige für den Importstatus (in %).

Associative Topology Bus

Kurven, Flächen und Bögen in CADDS übertragen
Die von Pro/ENGINEER zu CADDS übertragenen Kurven, Flächen
und Bögen werden jetzt mit aktiviertem oder deaktiviertem Associative
Topology Bus in ihrem exakten mathematischen Format übertragen.
Die Übertragung aus Pro/ENGINEER in CADDS hat eine exakte
Repräsentation der ursprünglichen Geometrie zur Folge.

CADDS CVPATH
Sie können der Umgebungsvariable CVPATH jetzt ein Verzeichnis
hinzufügen, während Pro/ENGINEER ausgeführt wird. Verwenden Sie
die Konfigurationsoption extend_cvpath, um der Umgebungsvariable
CVPATH während der Pro/ENGINEER Sitzung Pfade hinzuzufügen.
Dies ermöglicht das Importieren, Überprüfen und Aktualisieren von
CADDS-Modellen von Verzeichnissen aus, die im CVPATH
ursprünglich nicht angegeben wurden.

CATIA Direct Translator
Mit einer Lizenz für die "Schnittstelle für CATIA II mit ATB" können
Sie jetzt Modelle direkt aus CATIA übertragen und die Assoziativität
beibehalten, ohne die CATIA-Software auf der Pro/ENGINEER
Workstation auszuführen. Modelle können unter Beibehaltung ihrer
Assoziativität nur auf diese Weise aus CATIA übertragen werden.

Konfiguration Ergebnis:

topobus_enable yes

catia_translator catii (Standard)

Direkte assoziative Übertragung.
In diesem Fall müssen Sie die
Konfigurationsoption
catia_translator nicht einstellen.
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Konfiguration Ergebnis:

CATIA mit aktiver oder nicht aktiver
"Schnittstelle für CATIA II mit ATB"-
Lizenz

Die Standardeinstellung catii wird
automatisch verwendet.

topobus_enable no

catia_translator catii (Standard)

CATIA mit aktiver oder nicht aktiver
"Schnittstelle für CATIA II mit ATB"-
Lizenz

Direkte nicht assoziative Übertragung.

topobus_enable no

catia_translator pro_cat

CATIA mit aktiver "Schnittstelle für
CATIA II mit ATB"-Lizenz

Abhängig von der Verfügbarkeit einer
CATIA-Softwarelizenz wird entweder
eine .ct- oder eine .model-Datei erstellt.

Änderungen an der Benutzeroberfläche für Associative Topology Bus
Die folgende Tabelle enthält eine Zusammenfassung der Änderungen
der Pro/ENGINEER Benutzeroberfläche für Associative Topology Bus.

2000i2 Benutzeroberfläche Neue 2001 Benutzeroberfläche

Datei > Topology Bus >
Verifizieren
(File > Topology Bus > Verify)

Datei > Associative Topology Bus > Status
pruefen
(File > Associative Topology Bus > Check
Status)

Datei > Topology Bus >
Aktualisieren > Auswahl
(File > Topology Bus > Update >
Select)

Datei > Associative Topology Bus >
Aktualisieren
(File > Associative Topology Bus > Update)

Datei > Topology Bus >
Aktualisieren > Automatisch
(File > Topology Bus > Update >
Automatic)

Datei > Associative Topology Bus > Alle
aktualisieren
(File > Associative Topology Bus > Update All)*
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2000i2 Benutzeroberfläche Neue 2001 Benutzeroberfläche

Datei > Topology Bus > Autom
pruefen
(File > Topology Bus > Auto
Verify)

Datei > Associative Topology Bus > Status autom
pruefen
(File > Associative Topology Bus > AutoCheck
Status)

Datei > Topology Bus > Protokoll
ansehen
(File > Topology Bus > View Log)

Datei > Associative Topology Bus > Protokoll
zeigen
(File > Associative Topology Bus > Show Log)

Direkt- und Standardübersetzer

Pro/DETAIL zu MEDUSA
Sie können aus Pro/ENGINEER Pro/DETAIL Zeichnungen in
MEDUSA exportieren. Pro/DETAIL Zeichnungen werden als
MEDUSA-Blätter exportiert.

AutoCAD 2000-Erweiterung
Der Import aus dem Drawing Exchange Format (DXF) und DWG und
der Export in DXF und DWG wurde verbessert. Für AutoCAD 2000
wird die Übertragung der meisten Elemente jetzt unterstützt.

IGES-Ansichtslayout importieren
Wenn Sie durch Importieren einer Initial Graphics Exchange
Specification (IGES)-2D-Datei eine neue Pro/ENGINEER Zeichnung
mit 3D-Ansicht und 3D-Modellinformationen erzeugen, erstellt
Pro/ENGINEER ein Modell und eine Zeichnung in der Sitzung. Die
Zeichnung verwendet das Modell zur Anzeige der zutreffenden
Ansichten. Dies ist nur beim Erzeugen eines neuen Modells und nicht
beim Anhängen eines existierenden Modells der Fall.

Direct Open DWG- und DXF-Export
Sie können jetzt eine DXF- und DWG-Datei mit Datei > Oeffnen (File
> Open) direkt in den Zeichnungsmodus importieren. Sie müssen sich
nicht mehr in einer aktiven Zeichnung befinden, um diesen Vorgang
auszuführen.
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Profilimport
Beim Importieren einer IGES-, STEP-, CATIA- oder einer anderen
Datenaustauschdatei mit planaren Kurvenzügen nach Pro/ENGINEER
können Sie die planaren Kurvenzüge zu Bezugskurven konvertieren,
um diese bei der Erzeugung von KEs zu verwenden. Zur Steuerung
dieser Funktion setzen Sie die Konfigurationsoption
intf_in_extract_profiles auf:

� None � (Vorgabe) Profilkurven werden beim Importieren nicht
extrahiert.

� Comp � Alle planaren und nicht mit einer Fläche assoziierten
Bezugskurvenzüge werden konvertiert (keine Berandungskanten
für eine getrimmte Fläche).

� All � Alle planaren Kurven werden in skizzierte Bezugskurven
konvertiert.

Hinweis: Diese Option kann die Erzeugung eines umfangreichen
Bezugskurvensatzes zur Folge haben.

ACIS
Das Importieren von .sat-Dateien, die nach dem American Committee
for Interoperable Systems (ACIS) formatiert sind, wird jetzt
unterstützt.

STEP-Bestätigungseigenschaften unterstützen Varianten von

Komponenten
Standard for the Exchange of Product Model Data (STEP)-
Bestätigungseigenschaften unterstützen jetzt mehrere Varianten einer
Komponente in einer Baugruppe für CENTROID. Dieser Centroid-Wert
ist der Ort einer Variante in Bezug auf ihre Elternbaugruppe.
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GeomIntegrityCHECK
Mit GeomIntegrityCHECK kann sichergestellt werden, daß die
Benutzermodelle den VDA 4955 Version 2
Konstruktionsspezifikationen entsprechen. (VDA 4955 ist eine
deutsche Norm. Ziel dieser Norm ist es, die Effizienz bei der
Datenumwandlung zwischen CAD-Systemen zu erhöhen).
GeomIntegrityCHECK ist eine neue Komponente von ModelCHECK
und enthält 42 Prüfungen, die in ModelCHECK vorher nicht verfügbar
waren. Mit den Prüfungen wird die Geometrie in einem Modell geprüft.
Es werden die Bereiche identifiziert, die beim Verwenden eines Modells
in einer Downstream-Applikation oder einem anderen CAD-System
Probleme verursachen könnten.

GeomIntegrityCHECK analysiert unter Verwendung einer
konfigurierbaren Liste von Prüfungen die Kurven eines Modells,
Flächen, Berandungsflächen, Topologien, Volumenkörper und
Zeichnungstext und identifiziert Problembereiche.

Die neue Konfigurationsdatei für GeomIntegrityCHECK config.gmc
befindet sich im ModelCHECK-Verzeichnis config. Sie legt die
Standardwerte für die Prüfungen fest.

Beim Ausführen von GeomIntegrityCHECK wird vor der Analyse ein
Konfigurationsfenster angezeigt. In diesem Fenster können Sie wählen,
welche Prüfungen ausgeführt werden.

Auf ModelCHECK zugreifen
Klicken Sie auf Analyse > ModelCHECK (Analysis >
ModelCHECK), um auf ModelCHECK zuzugreifen.
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Berichte ändern
Die zur Anzeige der ModelCHECK-Berichte verwendeten Applets sind
jetzt leichter zu handhaben. Sie können schneller geladen werden und
nehmen weniger Platz auf dem Desktop ein.

Zu den Berichtverbesserungen zählen:

� Die Größenänderung von Spalten, indem Sie den Cursor auf der
Spaltenberandung plazieren und diese verschieben.

� Das Sortieren von Spalten in alphabetischer Reihenfolge durch
Klicken auf die Spaltenüberschrift.

� Die Angabe der Größe des Web-Browsers, der zum Anzeigen von
Berichten verwendet wird.  Die Datei config_init.mc enthält
zwei neue Optionen, WINDOW_WIDTH und WINDOW_HEIGHT.  Die
Werte für diese Optionen werden in Pixel angegeben, und der
Vorgabewert ist 500 bzw. 700.

Hervorhebungsfarben
Sie können die Farben ändern, die Sie in Pro/ENGINEER zum
Hervorheben von Elementen verwenden, indem Sie in der
ModelCHECK-Benutzeroberfläche mit der rechten Maustaste auf die
Schaltfläche für das Hervorheben klicken.

Leerstellen in Verzeichnisnamen
Die in den Konfigurationsdateien angegebenen Verzeichnispfade
können Leerzeichen enthalten.

Beispiel:

c:-\- Programme

Neue Prüfkonfigurationen
� PARAM_UNUSED (Nicht verwendete Parameter)

Optionen: Y/N/E/W

Meldet Modellparameter, die nicht in Beziehungen und in
Familientabellen verwendet werden.

� RENAMED_SYMBOLS (Umbenannte Symbole)
Optionen: (Y/N)

Meldet Bemaßungssymbole, deren Vorgabewert geändert wurden
(z.B. wenn d0 in Laenge umbenannt wird).
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� SKETCH_ITEMS (Anzahl von Elementen pro Skizze)
Optionen: Y/N/E/W

Analysiert die zum Erzeugen von Modell-KEs verwendeten Skizzen
und führt alle Skizzen im Bericht auf, die mehr Elemente pro
Skizze enthalten, als maximal zulässig sind. Verwenden Sie
MAX_SKETCH_ITEMS in der Konstanten-Konfigurationsdatei (.mcn),
um die maximale Anzahl von Elementen festzulegen.

� DEFAULT_VIEWS (Zeichnungsansichten mit Standardanzeige)

Optionen: Y/N/E/W

Meldet Zeichnungsansichten, bei denen die Anzeigeeinstellung die
Vorgabe ist und nicht Drahtmodell, Verdeckte Kante oder
Sichtbare Kanten.

� DRAWING_PARAMS (Modellparameter im Modus Zeichnung)
Optionen: Y/N/E/W

Fügt die gesamte Parameterfunktionalität im Modus Zeichnung
hinzu, die bisher nur in den Modi Teil und Baugruppe verfügbar
war.  Verwenden Sie zum Konfigurieren der Parameter, die geprüft
werden müssen, DRW_PARAMETER in der Start-Konfigurationsdatei
(.mcs).

� RELATION_UPDATE (Beziehungen aktualisieren)
Optionen: Y/N/E/W

Bringt alte Beziehungen auf den Stand von neuen.  Verwenden Sie
RELATION_UPDATE_FILE in der Start-Konfigurationsdatei (.mcs),
um eine Textdatei (rel_update.txt) anzugeben, in der die alten
und neuen Werte für die Beziehungen aufgelistet sind.  Beispiel:
Zum Aktualisieren der Beziehung MASS=MP_MASS(“”) auf
MY_MASS=MP_MASS(“”) fügen Sie zwei Zeilen in der Datei
rel_update.txt hinzu, und zwar folgendermaßen:

MASS=MP_MASS(“”)
MY_MASS=MP_MASS(“”)

Wenn ModelCHECK die Beziehung MASS=MP_MASS(“”) findet,
wird der Benutzer aufgefordert, die Beziehung auf den Stand der
neuen zu aktualisieren.
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Pro/ENGINEER Schiffsbau-

Lösungen

Pro/ENGINEER Schiffsbau-Lösungen ist ein umfassendes Paket von
Applikationen die Konzeptionierung von Schiffen bis hin zu deren
Fertigung. Pro/ENGINEER Schiffsbau-Lösungen bietet Funktionen für
die Rumpfkonstruktion, die konzeptionelle Unterteilung eines Schiffs,
die strukturelle Stahlkonstruktion, die Einzelteilfertigung sowie die
Blockfertigung. Die Ausstattungsfunktionalität bietet für die
spezifikationsgesteuerte Rohrverlegung, parametrisch und assoziativ
verlegte Systeme und eine Kabel- und Rohrverlegen unterstützende
Konstruktion, Heizungs-, Ventilations- und Klimaanlagen-
Konstruktion und die Definition von Prozeß- und
Instrumentierungsdiagrammen. Dieses Werkzeug bietet weiterhin ein
Lösungspaket für die Konstruktion von Wohnbereichen und
Maschinenräumen sowie Lösungen für die strukturelle Ausstattung für
die Konstruktion von Ausrüstung für die Schiffsstruktur.

Neben den anderen PTC-Produkten für die vollständige Produkt- und
Verfahrensdefinition zählen zu den Grundkomponenten für den
Schiffsbau von Pro/ENGINEER Version 2001:

� Basic Hull Design
� Structural Hull Design
� Piping
Die Komponenten Ship Electric, HVAC, Routed Systems, Supports
Machinery und Structural Outfitting Accommodations sind für
zukünftige Pro/ENGINEER Versionen geplant.
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Arbeiten Sie mit dem Reeder und den
Konstruktionsteams zusammen

Windchill, das PTC-Produkt für die webgestützte Zusammenarbeit, die
Collaborative Product Commerce (CPC)-Lösung, ist vollständig in
Pro/ENGINEER Schiffsbau-Lösungen integriert. Dies ermöglicht die
vollständige Nutzung der CPC-Lösung ab den Konzeptideen, über die
Angebotserstellung, zum Vertragsentwurf, die ausführliche
Konstruktion, die Herstellung, bis zur Unterstützung während des
Einsatzes. Mit Pro/ENGINEER Schiffsbau-Lösungen und Windchill
werden Konstruktionsdaten leicht erfaßt. Sie stehen jedem beteiligten
Team, dem Kunden und Zulieferer – innerhalb und außerhalb des
Unternehmens - jederzeit zur Verfügung. Die Konstruktionsdaten sind
sicher, jederzeit verfügbar und können von jedem Teammitglied im
Web-Browser angezeigt werden.

Beginnen Sie mit Schiffskonzepten
Unter Verwendung der einzigartigen Top-Down-
Konstruktionsverfahren der Pro/ENGINEER Architektur bzw.
Technologie zur Flächenerzeugung können Schiffsbauarchitekten und
Schiffskonstrukteure Rumpfformdaten aus Legacy-Systemen
importieren oder parametergesteuerte Rumpfflächen konstruieren. Als
globale Referenz wird ein Schiffsspantensystem verwendet, das aus
änderbaren Parametern für den Spantenabstand erzeugt wird. Decks
und Schotts können leicht erzeugt werden. Schiffsbauarchitekten
können verschiedene Anordnungsstudien erstellen, indem Sie einfach
die Parameter von Decks und Schotts ändern und das gesamte
Schiffsmodell mit einem Mausklick aktualisieren. Sie definieren
Komparts und vollständige Tanktabellenanalysen mit vollständiger
Assoziativität zu Kompart- und allgemeinen Anordnungszeichnungen.
Sie konstruieren einen vollständigen Landekurvenplan und erzeugen
automatisch Plattenabwicklungsmodelle und -zeichnungen. Verwenden
Sie das vollständige Skelett des Schiffsmodells für alle folgenden
Konstruktionsaufgaben und -produkte ohne Datenverlust oder erneute
Durchführung von Arbeitsschritten und mit vollständiger
Datenintegrität.

Detaillierte Ausgabe von Strukturkonstruktion und
Bearbeitung

Mit Pro/ENGINEER Schiffsbau-Lösungen können Sie:

� Daten des konzeptuellen Schiffsmodells gemeinsam nutzen.
� Konstruktionsbereiche, Arbeitszonen und Bearbeitungsblöcke

erstellen.
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� Vollständig parametrische strukturelle Bauteile wie Platten,
Versteifungen, Balken, Träger und Pfeiler konstruieren.

� Vollständig anpaßbare Bibliotheken als Grundlage zur schnellen
und leichten Auswahl von Materialstärken verwenden.

� Vollständig parametrische und von Elternbauteilen abhängige
Freischnitte, Ausschnitte, Kniebleche und Riegelbleche
konstruieren.

� Strukturbauteile entweder abhängig (Aktualisierung findet statt,
wenn das Basisobjekt geändert wird) oder unabhängig kopieren,
um strukturelle Objekte schnell und intelligent zu duplizieren.

� Bearbeitungsaufmaße für Platten definieren und überprüfen,
indem Sie Typen und Werte von überschüssigem Material,
fehlerhaftem überschüssigem Material oder von
Schwindungsänderungen festlegen.

� Assoziative Versteifungs- und Plattenausdehnungszeichnungen
erzeugen sowie NC-Verschachtelungs- und Einbrenndaten.

Ausstattungsvoraussetzungen gleichzeitig
konstruieren

In einer integrierten Schiffsbauumgebung beginnen Leitungs- und
Ausstattungstechniker mit ihrer Arbeit, sobald mit dem konzeptuellen
Modellieren begonnen wurde. Rohrsysteme sind vollständig
spezifikationsgesteuert, und das Verlegen wird mit
benutzerfreundlichen und intuitiven Werkzeugen durchgeführt.
Verlege-Referenzen können zu Strukturobjekten, Komponenten, Decks,
Komparts und Schotten erzeugt werden, um bei Änderungen des
konzeptuellen Modells alle Rohrsysteme automatisch zu aktualisieren.
Hierzu dienen die Top-Down-Konstruktionsmethoden von
Pro/ENGINEER.

Auf Grundlage der preisgekrönten Pro/ENGINEER
Architektur

Das Applikationspaket für den Schiffsbau von PTC ist auf der
Pro/ENGINEER Architektur aufgebaut. Pro/ENGINEER ist weltweit
führend im Bereich CAD/CAM/CAE. Die einmalige Architektur von
Pro/ENGINEER ermöglicht Schiffskonstrukteuren das Erzeugen von
dreidimensionalen Entwürfen höchst komplexer Schiffe. Der Benutzer
definiert intelligente parametrische KEs mit intuitiven
Konstruktionsmethoden. Die Geometrie des Schiffs und der
Komponenten wird von Bemaßungen (Parametern) gesteuert.
Modellobjekte sind assoziativ verknüpft, d.h., wenn ein Parameter
geändert wird, wird das gesamte Modell aktualisiert. Auf diese Weise
bleibt die Konstruktionsabsicht erhalten. Es wird eine Architektur mit
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einer einzelnen Datenbank eingesetzt, in der für alle Komponenten
dieselben Grundinformationen angewendet werden. Der
Schiffskonstrukteur kann jede beliebige Geometrie jederzeit und auf
allen Konstruktionsebenen — Zeichnung, Baugruppe und
Bearbeitungsmodell — automatisch aktualisieren. Natürlich stehen
neben der Autorisierungs- und Zugriffssteuerung des Windchill PDM-
Systems auch Werkzeuge zum Steuern der Auswirkungen von
Änderungen zur Verfügung.

Mit den leistungsfähigen Schiffsbau-Applikationen von
Pro/ENGINEER kann keine andere Schiffskonstruktion-Software
verglichen werden.

Erstklassige Schiffskonstruktionen sind heute auf dem
Schiffsbaumarkt kein Luxus mehr. Reeder fordern erstklassige
Schiffskonstruktionen. Schiffskonstrukteure müssen in entsprechende
Technologie und Werkzeuge zur Schiffskonstruktion investieren, um
die höchste Produktivität zu erzielen, Kosten zu minimieren und die
zur Konstruktion und den Bau erforderliche Zeit möglichst gering zu
halten. Die Werkzeuge, die die Schiffskonstruktion vom anfänglichen
Konzept bis zum Endprodukt begleiten, bestimmen die letztendliche
Qualität des daraus hervorgehenden Schiffs. Durch das
Implementieren von Pro/ENGINEER Schiffsbau-Lösungen sind Sie der
Konkurrenz einen Schritt voraus.

Hauptstärken und -vorteile
Pro/ENGINEER Schiffsbau-Lösungen:

� Enthält PTC Windchill, ein Unternehmensinformationssystem
(Collaborative Product Commerce), mit dem Produktinformationen
dem gesamten Unternehmen zur Verfügung gestellt werden.

� Ist eine Modellierlösung der nächsten Generation für den
Schiffsbau, mit einer KE-gestützten, assoziativen, parametrischen
Architektur.

� Verfügt über eine moderne, für den Schiffsbau maßgeschneiderte
Microsoft Windows-zertifizierte grafische Benutzeroberfläche
(GUI).

� Ist plattformunabhängig und ermöglicht den Benutzern z.B. die
Verwendung unter Windows NT, Windows 2000 oder UNIX.

� Besteht aus einem vollständigen Applikationspaket, das auf der
preisgekrönten Architektur des Pro/ENGINEER Systems basiert.

� Wird in Zusammenarbeit mit einigen der wichtigsten
Schiffskonstrukteure entwickelt.

� Wird von PTC, einem der weltweit 10 größten Softwarehäuser mit
zahlreichen Ressourcen zur Produktunterstützung entwickelt.
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� Verwendet Behavioral Modeling, ein neues Paradigma im Bereich
der MCAD-Technologie, mit dem die objektgesteuerte Konstruktion
und Optimierung ermöglicht wird.

� Nutzt die Funktionen für den Datenaustausch des Associative
Topology Bus (ATB), mit dem automatische Aktualisierungen
zwischen ungleichen CAD-Applikationen ermöglicht werden.

Dies sind nur einige der Merkmale, durch die sich PTC als führender
Anbieter von Softwarelösungen für den Schiffsbau von anderen
Anbietern abhebt. PTC blickt mit Spannung in die Zukunft von
Pro/ENGINEER Schiffsbau-Lösungen. Wir möchten Ihnen auch
weiterhin die besten Lösungen zur Steigerung der Produktivität,
Verbesserung der Qualität und Verkürzung der Konstruktionszeiten
anbieten. Überzeugen Sie sich selbst davon, was dieses Produkt der
nächsten Generation alles zu bieten hat.

Pro/ENGINEER Schiffsbau-Lösungen
Die folgende Funktionalität ist für die im Handel erhältliche Version
von Pro/ENGINEER Schiffsbau-Lösungen geplant:

� Rumpfformen

� Erzeugung parametrischer Rumpfformen unter Verwendung
der Pro/ENGINEER Technologie zur Flächenerzeugung

� Import von Rumpfformdaten über Standardschnittstellen-
Dateien wie IGES, STEP, SET, VDA, Neutral, ACIS, STL,
VRML oder direkte Schnittstellen wie Associative Topology
Bus, CADDS 5i, ICEM, CATIA

� Spanten

� Globales Schiffsreferenz-Spantensystem

� Benutzerdefinierte oder dateigestützte Spantenabstand-
Tabellen (mit verschiedenen und variablen Abständen)

� Benutzerdefinierte Rahmenbezugsbenennung

� Spantensystemversatz

� Option zur Bestimmung der Spantenrichtung [von hinterem
Lot (HL) zu vorderem Lot (VL) und umgekehrt]

� Automatische Erzeugung von Spantenlandekurven
� Landekurven

� Vollständige Erzeugung von Landekurvenoptionen unter
Verwendung von Skizzen, Projektionen, Stilen usw.

� Benutzerdefinierte Schrift- und Farbdefinition für Stoß-, Naht-,
Geradschnittnaht-, Versteifungslandungs-, Knick-, Öffnungs-,
Markierungs-, Grobblechberandungs-, Decküberschneidungs-,
Durchschweißloch-, Schraffur-, Tür- und Lochkurven
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� Rumpf-KEs

� Quer- und Längsschotterzeugung

� Erzeugung von planaren Schotten, Sickenschotten, gewellten
Schotten mit oberen und unteren Böcken und Stufenschotten

� Vollständige Definition von Deck- und Schottenlängen

� Lineare, parabolische, bogenförmige Decks

� Lukensüll-Erzeugung mit skizzierten, gewählten oder
standardmäßigen Öffnungsoptionen

� KE-, Flächen- und Kurvenklassifikation, mit wählbaren und
anpaßbaren und mehreren Unterklassen, Klassenwerten und -
namen (Deckflächenklasse mit den Unterklassen Hauptdeck,
Tankdecke usw.)

� Abwechselnde Anzeige von Modellbaum-Rumpfelementen
(Spantensysteme, Flächen, Komparts, Platten, Versteifungen,
Säulen/Balken, geschweißte Flansche, Kniebleche, Bünde,
Ausschnitte, Öffnungen und Freischnitte)

� Komparts

� Definieren von Primär- und Sekundärkomparts mit Typ,
relativer Dichte, Füllverhältnis und Permeabilität, Kompart-
ID, Serie, Zeichenkette und Name

� Vollständige Definition von geschlossenen
Kompartberandungen

� Vollständig anpaßbare Komparttyp-Bibliothek

� Schiffsbaukompart-Tanktabellen-Analyseergebnisse und
Zeichnungsbericht-Parameter für Kompart-Typ, ID-Nummer,
Spantposition, vollständige Volumen- und Gewichtkapazität,
LCG, VCG, TCG und Übersichtsberechnungen

� Platten

� Dicken- und Materialdefinition mit Versatzfunktion der
geformten Fläche

� Berandungs- und Kantenerweiterung

� Standardbund-Auswahl

� Plattenbenennung und -klassifikation

� Definition und Überprüfung des Aufmaßes für die Bearbeitung
von überschüssigem Plattenmaterial (Plattengruppe oder
Einzelplatte), verzerrtem überschüssigen Material (mit
Richtung des Verzerrbereichs und Skopus des Verzerrabstands)
und einer durch einen Winkel, Wert, absoluten oder skalierten
Typ definierten Schwindungsänderung (wahlweise anwendbar
auf Außen- und Innenplatte und Markierungen der Platte)

� Automatische Plattenerweiterungszeichnungen mit Präfix- und
Suffixnamen für Zeichnung
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� Anpaßbare Parameterdatei für Schiffszeichnungen
� Versteifungen

� Versteifungsgeometrie-Schnittypen für I-, Kanal-,
Gleichmäßiger Winkel-, Ungleichmäßiger Winkel-,
Umgekehrter Winkel-, T-, Leitungs, Quadratstab-, Rundstab-,
Halbrund, Glühbirnen, Versatz-T-, Versatz-L-Schnitt und
vorgefertigte Schnitte

� Vollständig anpaßbare Materialstärken-Bibliotheken

� Benutzerdefinierte Versteifungs-Endbedingungen, Setback-
und Schnittaufmaße

� Wählbare Versteifungsstegrichtung, senkrecht zur
Fläche/Platte oder parallel zur orthogonalen Schiffsebene

� Definierbarer Versatz für Versteifungssteg und -flansch

� Verdrehte Versteifungen mit konstanter oder variabler
Rotation

� Definierbare Namen für den Standard-Ausschnittyp,
Ausschnitt und das Riegelblech

� Vollständige Freischnittdefinition

� Versteifungsklassifikation (keine Durchdringung,
Durchdringung, durchdringendes Objekt)

� Automatische Erzeugung von Versteifungszeichnungen mit
definierbaren Präfix- und Suffixnamen

� Anpaßbare Parameterdatei für Versteifungszeichnungen mit
Symboldefinition für inverse Biegungskurvenrichtung

� Erzeugung von Stützen und Balken

� Erzeugung von geschweißten Flanschen und Knickflanschen

� Berichte mit strukturellen Objekten für den Schiffsbau
enthalten Einheiten, Objektnamen, Typen, Klassifikationen,
Schnittdaten, Schnittnamen, Schnittypen, Montagedaten,
Material, Positionierung, Leitkurven- und Objektlängen,
Schnittaufmaße, Setbacks und Versätze

� Abhängiges oder unabhängiges Kopieren von Strukturobjekten
� Kniebleche

� Automatische Erzeugung von intelligenten Knieblechen mit
Geometrie, die von verbundenen Objekten abgeleitet ist.

� Vollständig anpaßbare Knieblechtyp-Bibliotheken vom Typ A,
B, C, D, E, F, K und L

� Benutzerdefinierte(r) Knieblecheinfügeebenen-Definition und -
Versatz

� Während der Erzeugung änderbare Knieblechdicke
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� Ausschnitte

� Vollständig anpaßbare Schnittbibliothek

� Explizite Methoden und Autoauswahlmethoden für Schnitte

� Verzerrte Schnitte für Objekte mit schiefen Winkeln

� Automatische Aktualisierung von Schnitten bei Änderungen
der Versteifungsmaterialstärke

� Riegelbleche

� Vollständig anpaßbare Riegelblech-Bibliothek (Halb, Voll,
Versatz und Eingeschlossen)

� Option zur NC-Bearbeitung in einem Stück oder in zwei
Stücken

� Optionen zur Erzeugung von Versteifungs- und
Plattenriegelblechen

� Automatische Riegelblech-Aktualisierung bei
Schnittänderungen

� Rumpföffnungen

� Vollständig anpaßbare Öffnungsbibliothek (Rechteck, Oval,
Kreis und Ellipse)

� Parametrische Aktualisierung beim Änderung der
Strukturbauteile

� Freischnitte

� Vollständig anpaßbare Freischnitt-Bibliothek

� Automatische Erzeugung von verschiedenen Freischnittypen
wie Ausklinkung, Fase, Allgemein, Flanschschnitt und
Mehrstufenschnitt

� Rumpfschalenabwicklung

� Automatische Erzeugung der Schalenabwicklungszeichnung

� Benutzerdefinierte Präfix- und Suffixnamen für Zeichnungen

� Teilweise oder vollständige Rumpfabwicklung

� Standard- oder gewählte Kurvenzuordnung

� Beibehalten oder Löschen des abgewickelten Rumpfmodells
� Piping

� Intelligente und intuitive Verlegebefehle mit Steuerung durch
externe Referenzen

� Mehrere Rohrleitungsstile und -formen

� Prüfung der Kontinuität und Vollständigkeit von
Rohrleitungen

� Bibliotheken mit leicht zu verwendenden Formstücken,
Zubehörteilen, Ventilen, P&ID

� Erzeugung von Rohrspezifikationen (ANSI, DIN, ISO)
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� Automatisches Einfügen von Flanschen, Knicken, Dichtungen
und Bolzen

� Automatische Größenänderung und Orientierung von
Formstücken und Rohrkomponenten

� Vollständige Prüfung von Massenwerten sowie Zusammenstoß-
und Kollisionsprüfung

� Werkzeuge zur Rohrleitungsänderung

� Modellierung der Rohrleitungsisolierung

� Automatische Aktualisierung aller Rohrleitungskomponenten
nach Komponenten- und Spezifikationsänderungen

� Spulenzeichnungsdefinition mit automatischer Erzeugung von
Biegungsnotizen und Stücklisten

� Automatische Biegemaschinenausgabe

� Direkte Ausgabe in ISOGEN-Software zur Erzeugung von
isometrischen Rohrleitungen

� Automatische Erzeugung von Leitungsspulen

Hinweise zu Lösungen
Die hier beschriebene Funktionalität von Pro/ENGINEER Schiffsbau-
Lösungen ist nur ein Teil des umfassenden Funktionsangebots von
PTC. Lösungen in den Bereichen Diagrammerstellung, Verkabelung,
Schweißen, NC-Bearbeitung, Simulation, Visualisierung, Zeichnungen,
Verwaltung komplexer Baugruppen und Datenaustausch werden
ebenfalls für die komplexe Modellierung von Schiffskonstruktionen
angeboten. Wenden Sie sich an PTC, wenn Sie hierzu nähere
Informationen wünschen.
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27 
Pro/TOOLKIT

SUN C++-Plattform

user_initialize
Wenn Sie eine Pro/TOOLKIT-Applikation in C++ codieren, müssen Sie
user_initialize() als C-Funktion kennzeichnen, indem Sie vor der
Funktionsbeschreibung ein extern "C" angeben.

Version 5 C++-Compiler
Wenn Sie eine Pro/TOOLKIT-Applikation auf SUN-Systemen unter
Verwendung von SUN C++ Version 5 kompilieren, müssen Sie das
Compiler-Flag –compat=4 verwenden.

Begrenzungszeichen in der Registrierungsdatei protk.dat
Verwenden Sie in der Datei protk.dat bei Verwendung von UNIX-
Plattformen einen Schrägstrich (/) und bei Verwendung von Windows-
Plattformen einen umgekehrten Schrägstrich (\) als
Begrenzungszeichen.

Online-Dokumentation —Pro/TOOLKIT APIWizard
Pro/TOOLKIT verfügt über einen Online-Browser namens APIWizard,
der ausführliche Dokumentationsdaten anzeigt. Dieser Browser zeigt
Informationen aus dem Pro/TOOLKIT User's Guide und aus der
Pro/TOOLKIT Headerdatei abgeleitete API-Daten in einer einfachen
Benutzeroberfläche an.
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Der Pro/TOOLKIT APIWizard enthält folgendes:

� Definitionen von Pro/TOOLKIT Objekten und ihre hierarchischen
Beziehungen

� Definitionen von Pro/TOOLKIT Funktionen
� Deklarationen der Datentypen, die von Pro/TOOLKIT Funktionen

verwendet werden
� Das Handbuch Pro/TOOLKIT User’s Guide, in dem Sie

Informationen nach Themen oder Objekten nachschlagen können
� Codebeispiele für Pro/TOOLKIT Funktionen (aus Applikationen,

die im Rahmen der Pro/TOOLKIT-Installation bereitgestellt
werden)

APIWizard installieren
Beim Installieren von Pro/ENGINEER wird der Pro/TOOLKIT
APIWizard automatisch installiert. Die APIWizard Dateien befinden
sich im Pro/ENGINEER Installationsverzeichnis unter:

<proe_installationspfad>/jlink

APIWizard starten
Zum Starten des Pro/TOOLKIT APIWizard richten Sie Ihren Browser
auf:

<proe_installationspfad>/jlink/jlinkwizard.htm

Ihr Webbrowser zeigt die Pro/TOOLKIT APIWizard Daten in einem
neuen Fenster an.

Webbrowser-Umgebungen
Der APIWizard unterstützt Netscape Navigator Version 4 und höher
sowie Internet Explorer Version 5 und höher.

Bei der Verwendung von APIWizard mit Internet Explorer ist die
Installation des Java2-Plugins erforderlich.

Bei der Verwendung von Netscape Navigator ist die Installation der
Java Swing Foundation Class erforderlich. Ist diese Klasse nicht auf
Ihrem Computer installiert, kann sie vom APIWizard geladen werden.
Dieser Vorgang dauert einige Minuten und wird zwischen Sitzungen
nicht fortgesetzt.

Benutzer der SGI-Hardware-Plattform müssen die Swing-Klasse
installieren.
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Swing-Klassenbibliothek laden
Wenn Sie auf den APIWizard mit Internet Explorer zugreifen, laden
Sie das Internet Explorer-Java2-Plugin herunter und installieren es.
Dieser Vorgang ist der Installation des Swing-Archivs vorzuziehen, da
Swing die Zugriffszeit der APIWizard Suchfunktion verlängert.

Wenn Sie auf den APIWizard mit Netscape Navigator zugreifen, laden
Sie das Java Foundation Class (Swing)-Archiv herunter.

Pro/PIPING API Funktionen
Mit den folgenden Funktionen kann eine Pro/TOOLKIT Applikation
Rohrleitungsdatensatz-Informationen erzeugen, lesen und schreiben
und die Verbindung der mit dem Pro/ENGINEER Modul Pro/PIPING
erzeugten Rohrleitungen analysieren.

Funktionen zur Leitungsdatensatzverwaltung

Leitungsdatensätze

Funktion Definition

ProAssemblyLnstksCollect() Sucht alle für eine bestimmte Baugruppe
definierten Leitungsdatensätze.

ProPipelineLnstkGet() Ruft den Standard-Leitungsdatensatz für ein
bestimmtes Rohrleitungs-KE ab.

ProPipelineLnstkSet() Legt den Standard-Leitungsdatensatz für ein
bestimmtes Rohrleitungs-KE fest.

ProLnstkCreate() Erzeugt in der angegebenen Baugruppe einen
neuen Leitungsdatensatz. Erzeugt außerdem
Standard-Leitungsdatensatzparameter.

Leitungsdatensatzparameter
Funktion Definition

ProLnstkParametersCollect() Sucht alle Parameter für einen bestimmten
Leitungsdatensatz.

ProLnstkParametersSet() Setzt die Parameter eines angegebenen
Leitungsdatensatzes.
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Funktion Definition

ProLnstkParameterAdd() Fügt der Parameterliste neue Parameter zum
festgelegten Leitungsdatensatz zu.

ProLnstkParameterDelete() Löscht festgelegte Parameter aus einem
Leitungsdatensatz.

Rohrleitungsverbindung analysieren

Netzwerke

Funktion Definition

ProPipelineNetworkEval() Analysiert die KEs und Komponenten einer
Rohrleitung (durch Rohrleitungs-KE angegeben)
und erstellt eine Netzwerkdatenstruktur.

ProPnetworkFree() Gibt die Netzwerkdatenstruktur nach der Analyse
frei.

ProPnetworkLabelGet() Ruft die von einem festgelegten Netzwerk
beschriebene Rohrleitungskennung ab.

ProPnetworkSizeGet() Ruft die von einem festgelegten Netzwerk
beschriebene Rohrleitungsgröße ab.

ProPnetworkSpecGet() Ruft die von einem festgelegten Netzwerk
beschriebene Rohrleitungsspezifikation ab.

Verlängerungen

Funktion Definition

ProPnetworkExtensionVisit() Besucht alle Verlängerungen in einem Netzwerk.

ProPextensionFlowGet() Teilt Ihnen die Flußrichtung in Bezug auf die
Reihenfolge der Bauteile der Verlängerung mit.
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Bauteile

Funktion Definition

ProPextensionMemberVisit() Besucht alle Mitglieder in einer Verlängerung.

ProPmemberTypeGet() Gibt an, welche drei Typen das Bauteil darstellt.

Abschlüsse

Funktion Definition

ProPmemberTerminatorGet() Gibt das Objekt Pterminator zurück, das den
Abschluß im angegebenen Bauteil angibt.

ProPterminatorTypeGet() Teilt Ihnen mit, ob es sich bei einem Abschluß um
einen Eingang oder einen Ausgang handelt.

Verbindungen

Funktion Definition

ProPmemberJunctionGet() Gibt das Objekt Pjunction zurück, das die
Verbindung im angegebenen Bauteil angibt.

Serien

Funktion Definition

ProPmemberSeriesGet() Gibt das Objekt Pseries zurück, das die Serie im
angegebenen Bauteil angibt.

ProPseriesIdGet() Ergibt die Ganzzahl-ID der festgelegten Serie.
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Objekte

Funktion Definition

ProPterminatorObjectGet() Gibt ein einzelnes Objekt zurück, das einen
Abschluß angibt.

ProPjunctionObjectGet() Gibt ein einzelnes Objekt zurück, das eine
Verbindung angibt.

ProPseriesObjectVisit() Besucht alle Objekte, die den Inhalt einer Serie
angeben.

ProPobjectTypeGet() Ergibt einen der folgenden Typen:

Segment — Ein einzelnes Rohrsegment,
entweder eine Biegung oder eine Gerade. Kann
nur zu einer Serie gehören.

Formstueck (Fitting) — Eine
Baugruppenkomponente, die zwei oder mehrere
Rohrleitungssegmente verbindet. Kann zu einer
Serie (wenn zwei Segmente verbunden werden)
oder einer Verbindung (wenn mehr als zwei
Segmente verbunden werden) gehören.

Stubin — Ein Bezugspunkt, der die Stelle
festlegt, an der zwei oder mehrere Rohrsegmente
direkt, ohne ein Formstück verbunden werden.
Kann nur zu einer Verbindung gehören.

Auswahl (Selection) — Ein Objekt, das eine
ProSelection mit einer Beschreibug des
Elements, mit dem ein Rohrabschluß verbunden
wird, enthält. Kann nur zu einem Abschluß
gehören.

ProPobjectPipelineGet() Gibt das Rohrleitungs-KE zurück, zu dem das
angegebene Objekt gehört.

ProPobjectSegmentGet() Gibt das Segment zurück, das in einem Objekt
des entsprechenden Typs enthalten ist.

ProPobjectFittingGet() Gibt das Formstück zurück, das in einem Objekt
des entsprechenden Typs enthalten ist. Das
Formstück wird vom Objekt ProPfitting
angegeben.

ProPfittingAsmcompGet() Gibt die Baugruppenkomponente zurück, die das
Formstück darstellt.
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Funktion Definition

ProPobjectStubinGet() Gibt den Stuin zurück, der in einem Objekt des
entsprechenden Typs enthalten ist. Der Stubin
wird vom Zeiger ProPstubin angegeben.

ProPstubinPointGet() Ergibt die 3D-Stelle des Stubin.

ProPobjectSelectionGet() Gibt die Auswahl zurück, die in einem Objekt
des Typs Abschluß enthalten ist.

ProPselectionSelectionGet() Stellt das Objekt ProSelection bereit, das in der
Auswahl enthalten ist, und identifiziert das
Element außerhalb der Rohrleitung, mit der der
Abschluß verbunden ist.

Segmente

Funktion Definition

ProPsegmentTypeGet() Teilt Ihnen mit, ob das Segment gerade oder gebogen
ist.

ProPsegmentLinestockGet() Gibt den Leitungsdatensatz zurück, der für dieses
Segment verwendet wurde.

ProPsegmentLengthGet() Gibt die physische Länge des Segments zurück.

ProPsegmentCurvesGet() Gibt ein Array eines ProCurve-Objekts zurück, das
die Geometrie der Mittellinie des Segments
beschreibt. Die Kurven werden immer in
Flußrichtung aufgelistet.

Rohrleitungsterminologie
Beim Arbeiten mit Pro/PIPING sollten Sie mit den folgenden Begriffen
vertraut sein:

� Rohrleitung — Eine Reihe von verbundenen Leitungen und
Formstücken. Eine Rohrleitung besteht aus mindestens einem
Leitungsdatensatzsegment, das abgeschlossen ist:

� Offene Enden — Enden ohne angeschlossene(s) Leitungen,
Formstücke oder Zubehör.
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� Geschlossene Enden — Enden, die durch Leitungen,
Formstücke oder Zubehör geschlossen sind.

� Verbindungen — Mindestens zwei Enden, die zu einem Rohr
zusammenlaufen.

Rohrleitungen können ebenfalls angeschlossene Verzweigungen
enthalten.

� Rohrverlängerung � Eine nicht abzweigende Folge von
Rohrleitungselementen.

� Rohrleitungs-KE � Ein KE zur Benennung der Rohrleitung, um
deren Gruppierung darzustellen. Alle anderen KEs in der
Rohrleitung verweisen auf dieses KE. Ein Rohrleitungs-KE besitzt
keine eigene Geometrie.

� Zweig oder Verzweigung — Ein Zweig, an dem sich eine
Rohrleitung in zwei oder mehrere Rohrleitungen aufteilt, oder eine
Verbindung, an der mehrere Rohrleitungen verschmolzen werden.
Eine Rohrleitung, die über eine Verzweigung verläuft, besitzt eine
fortlaufende Flußrichtung. Trifft diese fortlaufende Flußrichtung
auf mehrere Öffnungen, bewegt sich der Hauptteil des Flusses
entlang des Pfads mit dem geringsten Widerstands.

� Bauteil einer Verlängerung � Ein Abschluß, eine Serie oder eine
Verbindung.

� Serie �  Eine nicht abzweigende Folge von Rohrleitungsobjekten.

� Verbindung � Eine Baugruppenkomponente oder ein
Bezugspunkt, die/der ein Teil darstellt, das mit mindestens drei
Rohrsegmenten verbunden ist.

� Abschluß — Das Ende der Rohrleitung, das offen oder geschlossen
sein kann.

� Stubin � Ein Bezugspunkt, der mit mindestens drei Serien
verbunden ist.

� Segment � Ein Rohrabschnitt, der gerade oder gebogen sein kann.
Für ein gebogenes Segment wird ein gerades Rohrsegment
verwendet, das gebogen wird.

� Formstück � Eine Komponente, die zwei Rohrsegmente
miteinander verbindet, um z.B. eine Ecke zu bilden, in der aus
Platzgründen kein gebogenes Rohrsegment verwendet werden
kann. Ein Formstück wäre z.B. auch ein Ventil.

� Objekt � Ein Segment, ein Formstück oder ein Stubin.

� Netzwerk � Eine Datenstruktur, die Referenzen zu
Rohrleitungsobjekten enthält. Die Objekte sind strukturiert und
ihre Verbindung und Reihenfolge basiert auf dem Fluß.
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Maximale Länge von Verzeichnisnamen
In der Version 2001 von Pro/ENGINEER wurde die Länge eines
Verzeichnispfads von 256 Zeichen (einschließlich des Abschlußzeichens)
auf 260 Zeichen erhöht. Auf diese Weise wird eine höhere
Kompatibilität zu Microsoft Windows erzielt. In Pro/TOOLKIT wurde
der Wert des Makros PRO_PATH_SIZE, der u.a. zum Definieren des
Typs ProPath verwendet wird, entsprechend geändert. Wenn Sie den
Vorteil dieser Verbesserung sofort nutzen möchten, sollten Sie alle mit
früheren Versionen von Pro/ENGINEER entwickelten Pro/TOOLKIT
Applikationen neu kompilieren und verknüpfen. Wenn Sie diesen
Schritt nicht durchführen, werden alle Verzeichnispfade mit mehr als
256 Zeichen, die an die Pro/TOOLKIT Applikation von Pro/ENGINEER
geleitet werden, abgeschnitten. Pro/ENGINEER wurde so geändert,
daß alle zu langen Pfade abgeschnitten werden, um das Risiko der
Datenbeschädigung durch einen Überlauf des Arrays zu vermeiden.
Dies trifft auch auf Fälle zu, in denen der Pfad ein Ausgabeargument
einer Pro/TOOLKIT Bibliotheksfunktion wie z.B.
ProDirectoryCurrentGet() und ProMdldataGet() oder die
Eingabe in ein Callback wie der Benachrichtigung für
PRO_DIRECTORY_CHANGE_POST ist.

Benutzerdefinierte Konstruktionselemente (UDF)
Pro/TOOLKIT Version 2001 verfügt über eine vielseitigere
Unterstützung von: erfaßten UDF-Informationen, Erzeugung,
Datenstrukturfunktion, variablen Bemaßungen und Mustern, UDF-
Referenzen, Baugruppenschnitten und Komponentenmodellnamen.

Hinweis: Diese neuen Funktionen gelten anstelle vieler Funktionen
des Typs Pro/Develop.

Gruppeninformationen
ProUdfNameGet()
ProUdfDimensionVisit()
ProUdfDimensionsCollect()
ProUdfDimensionNameGet()

Gruppen erzeugen
ProUdfCreate()
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Datenstruktur für UDF-Eingaben
ProUdfdataAlloc()
ProUdfdataFree()
ProUdfdataNameSet()
ProUdfdataDependencySet()
ProUdfdataScaleSet()
ProUdfdataDimdisplaySet()
ProUdfdataOrientationAdd()
ProUdfdataQuadrantAdd()

Variable Bemaßungen und Muster
ProUdfvardimAlloc()
ProUdfdataVardimAdd()

UDF-Referenzen
ProUdfreferenceAlloc()
ProUdfdataReferenceAdd()

Baugruppenschnitte
ProUdfintersectionAlloc()
ProUdfdataIntersectionAdd()

Namen von Komponentenmodellen
ProUdfmdlNamesAlloc()
ProUdfmdlNamesSet()

Zeichnungen aus Schablonen erzeugen
Pro/TOOLKIT unterstützt jetzt das Erzeugen einer neuen Zeichnung
aus einer Zeichnungsvorlage.

ProDrawingFromTmpltCreate()

Angepaßte Erzeugung von Modellen mit Startteilen
Die Callback-Funktion ProMdlStartAction() und der
Benachrichtigungstyp ProMdlStart ermöglichen die angepaßte
Erzeugung von Modellen mit Startteilen.
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Blech
Blechfunktionen wurden überarbeitet und unterstützen jetzt die
geometrische Analyse, Biegungstabellen und Bemaßungsfunktionen.

Geometrieanalyse
ProSmtPartThicknessGet()
ProSmtedgeContourGet()
ProSmtOppsurfGet()
ProSmtOppedgeGet()
ProSmtBendsrfParentGet()
ProSmtBendsrfChildGet()
ProSmtBendedgeChildGet()
ProSmtBendedgeParentGet()
ProSmtSurfaceTypeGet()

Biegetabellen
ProSmtPartBendtableApply()
ProSmtPartBendtableRemove()
ProSmtFeatureBendtableApply()
ProSmtFeatureBendtableRemove()
ProSmtFeatureDevldimsGet()

Bemaßungen
ProSmtDevldimIsDriven()
ProSmtDevldimDrivenSet()




