
Sequences 
 

Sequences have been enhanced: we recommend you to read the Sequence section in its
overall to discover more about:

scheduling actions: "iterative create last step and add" mode
interface change for action duration
Delay option
Color and transparency actions 
To have a look, please click on the appropriate keyword in the What's New section
(items under Sequences)

About sequence capabilities: provides background information about sequence capabilities.
Sequence editor: provides information about the sequence editor
Display Gantt chart: provides background information about the Sequence Gantt Chart.

Define a sequence: Click the Edit Sequence icon, add actions, sequence them, modify the
actions duration if necessary. Click the Edit Analysis tab and add interferences and distances.
When satisfied click OK.
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http://nypddsy/fbpdocr10/FitEnglish/fitug.doc/src/fitugbt0700.htm


About Sequence Capabilities
A sequence is a way to put together and schedule actions to perform simulations.

Sequences are persistent and can be stored in your document. 

What is an action?

Actions are entities of different nature organized within the sequence.
They can be objects from the following list:

tracks (camera tracks, product tracks, shuttle tracks, section plane tracks, light tracks) please refer to About
Tracks Capabilities

color and transparency actions  ( )

visibility actions i.e. Show/Hide (
simulations (R6 simulations)

sequences ( )

FEA Analysis 

Please read "DMU Engineering Analysis Review"- Animating Images
mechanisms which can be simulated with laws

Please read "Running Mechanisms within a Sequence" in the DMU Kinematics Simulator User's Guide
About actions duration:

Actions are characterized by a duration:

i.e. Track duration is linked to the trajectory length
About  Visibility and color actions

Using a a color/transparency action, you could only define an initial and a final state. This highlight aims at offering
more capabilities for Color/Transparency actions based on the track model:

recording of multiple states for the same action using the standard graphic properties toolbar.
possibility to change the object on which is applied the action
recording capabilities using the same Recorder tool than the track
time edition of the action (possibility to change the duration of each segment).
VB exposition
The visibility or color actions are created in sequence context and their effects are seen only when you use the
Player (in the sequence for instance)
color and transparency actions have now a duration
Visibility actions are instantaneous (duration=0) 
For more information, please refer to Defining a Sequence

Initially the product looks like this: 

when creating a color action in the sequence, it becomes:

http://nypddsy/fbpdocr10/FitEnglish/fitug.doc/src/fitugbt0501.htm
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Make sure though, you schedule this action properly using the Action Delay parameter (i.e. depending on the effect you
want to obtain)

The picture below gives you the various results after action creation according to the option set:

This duration is recovered in the sequence but you can also apply a specific duration in sequence context.

Example:

Duration in the player of a sequence comprising two tracks:
The two actions are scheduled to start one after the other (see: sequencing modes)

Beginning End

About Action Modification
You can modify the action duration, all you need to do is:

select the action in the Actions in Sequence list
Enter the new value in the action duration (i.e. 200)
If you need a delay, enter a value in the Action delay field (i.e. 400)
You can use the Reset button to swap to the default action value (intrinsic duration) 

 



 

About sequencing

Sequencing aims at defining a time frame within which the actions are scheduled. 

Two sequencing modes are available:
actions start together (simultaneous mode)
actions start right one after the other (consecutive mode)

 

Simultaneous mode

Beginning Middle  End 

Consecutive mode
              Beginning Middle End



You can combine the two modes and modify the scheduling at any time.

Sequences lets you put together existing actions, anyway, you can easily create a new action on the fly and add it in
the current sequence. This capability lets you edit actions in context and synchronize meeting points in different
actions.

The example below illustrates the two modes combination:

Simultaneous mode

Consecutive mode

About Journaling/automation

Sequences are journalized. You can generate a macro using Tools->Macro->Record... (see the Infrastructure user's
Guide)

Sequence creation:
3 methods are available to create sequences:

There are existing actions in your document (actions in session list), 

Click the Sequence icon , and add them using the arrow into the Action in sequence list and schedule them,
using the sequencing tools (Refer to: Sequence editor)

1.  

Open an empty sequence and create actions on the fly (the sequence editor remains opened)2.  
Combine the two methods (1. and 2.) 3.  

Sequences created in this manner are persistent and can be stored in the document. They are listed as separate
entities in the specification tree and can be selected at any time and modified.



Sequence Editor
The sequence editor lets you manage and simulate actions from the following:

moving objects (part, camera, ...) 
graphic attributes ( show/hide, colors, transparency)

you can also manage time with Gantt chart 

Let's look at it more carefully:

The Edit Sequence dialog box comprises of two tabs:
Edit Action tab
Edit Analysis tab

The Edit Action tab lets you perform the following operations:

Add/remove actions using the green arrows 

1. Select an action in the "Action in session" list and click .  The action is added in the sequence list.
See example below:



2. Select an action and click . The action is removed from the "Action in Sequence" list

Note: If you multi-select actions in the session list and click the Add button, the actions are added in
simultaneous mode.

Customize the add mode settings:
(1) Create last step and add option: creates a last step and add the selected action into it
.(default mode) (in consecutive mode)
(2) Add in last step option: lets you add an action in last step (in simultaneous mode)



a new add mode appears
(3) Iterative create last step and add option: lets you add the actions in consecutive steps
(1-2-3...)

 
(1)

(2)

(3)

Sequence actions using:

if working in consecutive mode
Move up:  moves up a selected action 
Move down: moves down a selected action

if working in simultaneous mode
Merge up: merges the selected action up
Merge down: merges the selected action down

 
Note: remember you can combine the two modes within the same sequence.
Please read About Sequence Capabilities

Customize the action duration
action duration: the numerical field lets you enter a specific duration for an action (this capability
enables to simulate the same action with a different time scaling)
reset duration: lets you reset the selected action to its intrinsic duration

 

 

  Note: you can enter a specific duration for all action types except visibility actions which are instantaneous
(duration=0)

 



   
A new option is available :

action delay: lets you delay the starting time of an action (i.e. it is now possible to overlap two
actions)

For instance, two tracks within the same sequence step can be synchronized, in order to achieve passing by
specific waypoints simultaneously.

For all actions contained in the sequence, the delay is a time attribute, just like their duration. It means the
action will start with respect to the specified delay with the theoretical beginning of the step, which the action
belongs to. Valid delay values are zero or positive.

  The actions appear in the "Action in sequence" list, they are scheduled in steps and their duration and delays
are displayed. 

Note: To apply a delay to an action or modify it, all you need to do is select the required action in the Action in
session list and enter a value in the Action delay field:

 

Also read : About actions duration
Now click the Edit Analysis tab:



The Edit Analysis tab lets you perform the following operations:
Add/remove interferences or distances using the green arrows

1. Select an analysis in the "Analyses in session" list and click add. 
 The action is added in the sequence list.
2. Select an analysis in the "Analyses in Sequence" list and click remove

Note: you can add existing interferences or distances or create them on the fly ( in this case they are
automatically displayed in the "Analyses in session "list

Set the clash detection mode
Set all inactive option: (default mode) as you simulate your sequence, the detection is set to off,
the interferences and/or distances defined in your sequence are not taken into account
Set all active option: as you simulate your sequence the detection is set to on, the interferences
and/or distances defined in your sequence are taken into account
Set all stop option: as you simulate your sequence, the detection is set to stop (on collision), the
simulation stops when an interference defined in your sequence is detected. The distances
defined remain active.

About Editing an action and analysis

Double-click actions, interferences, distances to display the dedicated editor. Perform the required
modifications, the modifications are automatically taken into account in the Edit Sequence dialog box.

 



Displaying Gantt Chart
This task shows you how to display the Gantt Chart viewer.
A Gantt chart allows users to do a basic, overall cycle-time analysis for a set of actions.
The Gantt chart visualization is based on the cycle time parameter defined in each
action. 
About Gantt Chart:

The Gantt chart is another way to visualize your sequence. Note that you cannot modify
the action duration using the Gantt window.

A Gantt chart is bar graph of a sequence.  It shows start and stop times as well as
dependencies.  The Gantt chart is a 2D view of the sequence process.  
Open the CHAINSAWAT.CATProduct document 

A sequence is defined
1. Select a sequence in the specification tree:

for instance Sequence.4

Gantt Chart for multiple sequences in a single Gantt Chart are not supported

2. Select Window->New Gantt Chart Window

http://nypddsy/fbpdocr10/CfyEnglish/cfyug.doc/src/samples/CHAINSAWAT.CATProduct


The Gantt chart window is displayed:

Let's describe it more carefully:
The left frame of the Gantt chart lists each of the individual actions and /or
analyses that exist in your document, displaying the duration, start time and end
time for each. 
The right frame provides a graphical representation of each action or analysis
(along the line of time) which also indicates the start, duration and end of each.
A dashed vertical line in the right window (called the Time Line), provides a visual
indication of the current time during the execution.
 



You can easily modify the action duration within the Gantt Chart, stretching the action
graphical representation, the Gantt Chart as well as the Edit sequence dialog box are
automatically updated.

For instance, double-click a sequence in the specification tree. You are in the sequence
command. 

Then select Window->New Gantt Chart Window:



It does work, the other way round: modifying the action duration within the Edit
Sequence updates the Gantt Chart window automatically



Defining a Sequence
This task shows you how to define a sequence

Open the DEFINE_SEQUENCE.CATProduct document.
Tracks are already defined 

1. Click the Edit Sequence icon  in the DMU Simulation toolbar

The Edit Sequence dialog box is displayed

2. Select Track.1 (Track.1) in the action in session list and click .

3. Select Track.1 (Track.2) in the action in session list and click .

The Sequence.1 is identified in the specification tree

http://nypddsy/fbpdocr10/FitEnglish/fitug.doc/src/samples/DEFINE_SEQUENCE.CATProduct


you want them to start together
4. Click Merge Up button 

The two actions will start together
Note: you could have selected both (simultaneous mode) in the action in session list.

5. Check the "Add in last step" option in the Edit Sequence dialog box
(Create last step and add  option is set by default)



6. Add a color action (you are going to create it on the fly), for this

Click the Color action icon  in the DMU Simulation toolbar
  The Color Action edition dialog box appears
 

  7. Select Handle.1 either in the specification tree or in the geometry area
 

  The Graphic Properties toolbar appears 
  8. Select a color of your choice using the arrow and combo list. For instance blue
 

  9.
Click Record 

  10. Set the transparency, for this: 

click the Edit button  in the color action dialog box
select the Graphic tab in the Properties dialog box displayed
check the transparency option if needed, and move the slider as desired

Note: you can access the Properties dialog box at any time to change color, transparency. The
Graphic Properties toolbar a quicker way to modify graphic properties. 



 

 
  11. Click Apply, when done, click close to exit the Properties dialog box
  12.

Click Record  
  13. Click Ok in the Edit Color Action dialog box when you are satisfied.

The color action is automatically added in the action in the sequence and identified in the
specification tree



14. Modify the action duration if necessary 
For more detailed information, please read: About Action Modification

Enter 200 in the Action duration field

15. Select the Color Action.1 in the action list and modify its delay:
enter 400 in the Action delay field

 

16 Play your sequence if needed using the Player
Now add analyses in your sequence for validation purposes

17. Click the Edit Analysis tab



18. Multi-select the existing analyses (i.e. Distance.1 and Interference.1) and click .
Note: you can create and add analysis specifications on the fly. You can also edit existing
analysis specifications, double-clicking them in the "Analyses in sequence" list

19. Click Set all active button

2 0 . Click Ok in the Edit Sequence dialog box when satisfied.

21. Select your sequence in the specification tree and click the player icon .
22. Simulate your sequence using the DMU Player buttons.

23. If you need to restore the initial positions, click the Reset icon .
24. Open the DEFINE_SEQUENCE_RESULT.CATProduct to check your result
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