
PRINT ORGANIZER 101 

MICROSTATION V8i 

WHAT IS IT?  
Print Organizer has replaced Batch Plot. Go to File > Print Organizer. 
 
Open Print Organizer and you will see that an untitled.pset dialog has opened. Files are added to the 
set via the Add Files to Set button or by dragging and dropping via Windows Explorer. 
 

 
 
You will see on the left an untitled folder. This is the first default Print Set.  
 
By default, the root folder gets its name from the print set name. When you save the print set with a 
different name, the root folder name changes accordingly. 
 
SETTING THE DRIVER 
The first thing you should do is set the print driver (File > Printer setup). 
 

 
 
The printer driver being used is shown in the bottom of the Print Organizer dialog box. 
 

 
 
You can only have one driver per pset. 
 
SAVING THE PSET 
In the dialog box, File>Save As and save your .pset with a name.  
 
To add a subfolder to your new set click on the Add Folder to Set tool  
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Use the Add Files button to add your files or drag and drop into the dialog from Windows Explorer.  
 

 
 
APPLYING PRE-DEFINED PRINT STYLES 
To avoid the complications and to be sure your get the settings you expect, you should always pick 
the Print Style when creating new Print Definitions*. 
Click on the magnifying glass in this dialog to select a Print Style from any of your company dgnlibs 
or the active file. You should always pick the Print Style here to be sure you get the settings you 
expect.  
 
You can override any of the print style’s settings for an individual drawing by applying some Manually 
Specified Options in this dialog box.  
Note: If you want to change the settings later, you can do so by double-clicking in the relevant 
column of the Print Organizer dialog. 
 
CREATING DEFINITIONS FROM DEFAULT SETTINGS 
If at this stage you choose to ignore the Print definition creation options and click ok. MicroStation 
loads the files with print definitions created from what it can find:  
 
If you are using Sheets it looks at the sheet properties.  

1. It gets the paper size from the Sheet Layout. 
2. Units (mm/in) are defined from the paper size definition (typically from sheetsizes.def) 

regardless of the paper size. (i.e. if the Sheet Layout is 10.5 x 8", the paper size will still be 
A3 if that is the default paper size of the current driver. The units, however, will be set to 
inches.) 

 
 If you are using Models it will look at the last saved active view.   

3. It uses the last paper size selected in Print Organiser. This can either be from the last file 
that was loaded in or the last manually chosen paper size (whichever was done last). 
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4. If one has not been selected it takes the default paper size from the current driver. 
5. If that driver doesn’t have a default paper size it uses the first in the list (of the .pltcfg). 
6. If it doesn’t have any paper sizes defined (i.e. printer.pltcfg) it uses the default paper size 

from the Windows printer that it loads. 
 
For every file loaded after your first one: 

1. The definitions are applied from the sheet,  
2. If it can’t find a sheet then the definitions are taken from the model and the default print 

driver (.pltcfg) 
3. If it can’t find the default print driver then it takes the same settings as the first model in the 

list (if adding a model) or the first sheet in the list (if adding a sheet).  
 
The first added set of files takes a while to convert to Definitions. The next are considerably quicker.  
 

 
 

 
 
To change the view to show the folder headings go to View>Show in Groups 
 

 
 
You can open multiple instances of the same print set file (in other instances of MicroStation), but 
only the first instance has write access. Subsequent instances of the print set will open in read-only 
mode. Read-only mode allows you to preview and print the files, but if you make changes you will 
need to save the print set with a different name. 
 
DEFINING A PRINT SET STYLE 
Each print definition consists of properties, like size, scale, and colour that determine how the DGN 
file will be print. This allows you to specify a different pen table or print area for each print definition 
in the print set. 
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GO TO TOOLS>DEFINE PRINT STYLES 
 

 
 
Click the New button to create a new Print Style and click on the name to change it.  
Edit the settings in the right hand side of the dialog to suit. 
 

 
 
Tick boxes are preset with a blue square – this means “as-is”. A tick = on and a blank square =  off. 
 
You can set the default print style by highlighting and clicking on the black tick icon. It seems that 
you can set more than one style to be your default at this point! Click the icon again to remove the 
default tick.  
 
NOTE: If you have a default Print Style defined, MicroStation will load this every time a model is 
opened. The default Print Style will override your print settings, meaning that you may end up with 
incorrect paper sizes. For example, if you have an A1 Print Style as default, an A0 drawing will be 
reset to use A1 paper. For this reason, until Bentley provide the ability to choose whether or not the 
default Print Style applies (or print settings can be saved in the file), we recommend NOT setting any 
default Print Styles. 
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The Print Style is set by the Tools>Apply Print Style name  
 

 
 
 

 
 
Any Print Styles defined in a file that you add are ignored e.g. In file 101.dgn you create a print style 
called 101. If you open another file and add 101.dgn into your pset, it ignores the print style called 
101 (hmmm..daft?). You can only apply Print Styles found in any configured dgnlibs (usually office-
wide or project-wide standards) or in the active file.  
 
*BEWARE: If the Print Style changes the driver (.pltcfg), all paper sizes will be reset according to the 
following: 
 

1. It gets the paper size from the Sheet Layout (if one exists) UNLESS the default paper size is 
bigger. 

2. If a Sheet Layout doesn’t exist, it uses the last paper size selected in Print Organiser. This 
can either be from the last Sheet that was loaded in or the last manually chosen paper size 
(whichever was done last). 

3. If one has not been selected it takes the default paper size from the current driver. 
4. If that driver doesn’t have a default paper size it uses the first in the list (.pltcfg). 
5. If it doesn’t have any paper sizes defined (i.e. printer.pltcfg) it uses the default paper size 

from the Windows printer that it loads. 
 
 
MANUALLY EDITING PRINT SETTINGS 
When adding a new drawing to the Print Organiser, you can choose to edit any settings either by 
selecting a different Print style or by specifying manual overrides.  
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If you change an attribute by double-clicking in a column, only that attribute is changed. 
 
You can edit multiple definitions by Ctrl+Select. Double-clicking in a column to change an attribute 
will affect all the selected definitions.  
 
PRINT OUTPUT NAMES 
These are set from the Print Organiser File > Output File Names... menu. 
 

 
 
This will open the Output File Name Expression box that gives you a series of pre-defined 
expressions you can use to set the print name. Most every day options are provided, including 
<design name>, <sheet name>, <date> etc. 
 

 
 
Should you wish to create one that isn’t provided, you can select “Custom” and enter your own text in 
the Specify Expression box. This requires a detailed knowledge of Named Expressions, so in most 
cases it is safer to cut and paste text from an existing Expression. 
 
This Output File Name Expression is saved with any .pset you create, but it is not remembered if you 
quit and restart Print Organiser. Print Organiser always defaults to the first Output File Name 
Expression in its pre-defined list: <print counter>-<print set name>. 
 
COMPATABILITY WITH OLD .JOB SETTINGS 
Print Organizer's File > Open menu item can open a print set (.pset) file or a job set (.job) file. When 
Print Organizer opens a job set file, each corresponding model in the job set is converted to a print 
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definition. The print definition properties are obtained from the print specifications stored in Batch 
Print's batchplt.spc file. Therefore, it is necessary to have access to the batchplt.spc file when initially 
opening a job set file in Print Organizer. 
 
SINGLE FILE PRINTING 
Print definition files have replaced print setup (.ini) files. A print definition (.pset) file has the same file 
format as Print Organizer's print set file, but it contains only a single print definition.  
 
The Configuration pull-down menu on the Print dialog, with its Open, Save, and Save As items, has 
been removed. The menu has been replaced with File>Save Print Definition File and File>Open Print 
Definition File. 
 

 
 
Print Styles can also be applied to a single print under the Settings>Apply Print Style pull down. 
(Note: you can only define them from Print Organiser.) Applying a Print Style will change the settings 
in the Print dialogue, but it will not load a different driver. The driver specified in the Print Style only 
works in Print Organiser. You should select your driver before applying a Print Style. 
 

 
 
A .pltcfg can have a default print style attached (Base Properties > General > Print Style Name) – 
most of which it could do anyway. 
 
 
FOR THE CAD MANAGER 
You can define Print Styles in your office dgnlib. 
Note: If you are printing from a file which is also in the dgnlib search path, the Print Styles are loaded 
twice. 
 
The new configs: 
 
MS_PRINTDEF_PATH specifies the search path for your print definition (.pset) files. This variable 
replaces MS_PLOTINI, which is no longer supported. 
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MS_PLTCFG_PATH specifies the search path for pltcfg or .plt files.  
If this configuration variable is defined, the first directory in its value is used as the initial directory in 
the Select Printer Driver Configuration File dialogue. If this variable is not defined the most recently 
used directory for printer driver configuration files is used.  
 
MS_DEFAULT_PLTCFG_FILE — specifies a default printer driver configuration file. If it is set to a 
printer driver configuration filename, that file (instead of the most recently used one) is selected 
when you open the print dialog. The value of this variable may be either a .pltcfg or .plt file. This 
variable replaces the old variable MS_PLOTDLG_DEF_PLTFILE, which is still honoured if 
MS_DEFAULT_PLTCFG_FILE is not defined. 
 
The MS_PLTFILES configuration variable behavior has changed. The print output directory specified 
by the MS_PLTFILES configuration variable is now given priority over the most recently used print 
output directory. If this configuration variable is defined, the most recently used directory is always 
ignored when the Print dialog brings up the Save Print As dialog for saving a print output file. 
 
You’ll need to keep MS_BATCHPLT_SPECS defined as Print Organiser uses this if you load in an 
old .job file. It uses the Batch Plot specs to set the correct print properties. 
 
If you have any of the MS_BATCHPRINT configs defined, such as 
MS_BATCHPRINT_ADD_ONLY_SHEET_MODELS = 1, these will still affect the addition of new 
files. When adding a new file, you have an option in the Fences tab to select which type of models to 
add: 
 

 
 
This will only take effect if MS_BATCHPRINT_ADD_ONLY_SHEET_MODELS is not defined. The 
configs takes precedence over the Print Organiser option. 
 
If you want to specify a default Output File Name, there is a undefined config variable 
MS_PLT_DEFAULT_OUTPUT_FILENAME_EXPRESSION. You can set this to any Named 
Expression, either created in the Named Expressions dialogue or by specifying the full text string. 
You cannot use the same syntax to specify the Print Organiser Output File Name, i.e. 
MS_PLT_DEFAULT_OUTPUT_FILENAME_EXPRESSION = <design name>. Yeah we know, that’s 
absolute nuts, but there you have it.  
 
 


