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> General Information

Message From Editor

The GTAC Quarterly newsletter is a collection of technical articles written by your Support team at the Global
Technical Access Center (GTAC). Articles span our product line and are grouped into product areas for your
convenience.

This issue includes valuable information on the new plotting package included with the NX 3 release. We
recommend all who are installing and running NX 3 to read these articles carefully. They are intended to help you
prepare for the changes to plotting setup and operation and ease the transition to this improved feature.

Please direct any comments on the newsletter to gtac_quarterly@ugs.com. We are always interested in hearing
your comments and suggestions. Also remember, you must subscribe to the Newsletter Electronic Mailing List
to receive a notification of when the newsletter is available.

To Subscribe:  Send an e-mail message to: newsletter-subscribe@support.ugs.com.
Or you can go to http://[support.ugs.com/mailmanl/listinfo for information and instructions on
how to subscribe to this or any of our other electronic mailing lists.

Enjoy the issue!

Blended Training Solutions — One Size Does Not Fit All
UGS Education Services continues to offer many training choices:

e Web based self paced training (E-learning)
e E-learning provides more than 100 self paced training courses
e Free introductory courses and assessments
e Tracking and reporting of training progress and assessments
e Automatic, adaptive training recommendations based upon user assessment scores
e All self-paced training can be customized to fit your needs

e LIVE! Online (distance learning) training with a live instructor via the World Wide Web
e Fully collaborative training with hands-on workshops
e Application demonstration and sharing
e Screen sharing technology that connects instructor to students
e Half-day events to allow students to remain productive at work

e Center based instructor led training
e North American training center locations
State of the art classrooms providing individual workstations to maximize your learning experience
All course content is UGS certified
Available for Unigraphics NX 2, I-deas, Imageware, Teamcenter and E-factory applications
¢ Client-Site Training
e Take advantage of our expert instructors and courses, but with the convenience of your site.

e Training can be tailored to include a specialized mix of topics from our standard classes to address
specific training objectives at no extra cost to you!
e Our custom courseware services can be leveraged to focus training on your company’s specific
learning objectives.
e Mobile classrooms are available to equip any customer facility (or possibly your local UGS sales
office) with all the necessary hardware for a successful training class.
On the Web

e Finding the Unigraphics NX 2, |-deas, Imageware, Teamcenter and E-factory training solutions you need is
as simple as following these steps:

Visit http://training.ugs.com

Choose class finder

Choose the options that match your training requirements and select GO
Review the classes categorized by delivery format

Select Register to sign up for a course

abhwbd=
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New Printing and Plotting in NX 3

NX 3 will provide users with a state-of-the-art printing and plotting system as part of the Gateway module. This is
another step in our ongoing initiative to bring stronger production functionality to NX users. This new plotting system
will provide users with flexibility and control through a comprehensive user interface, and provide many new
capabilities. Nearly 300 Enhancement Requests (ER) have been resolved and fulfilled as a result. These include
numerous requests for color and width controls, and more flexibility for the end user.

A new NX plotting system was needed because the legacy plotting functionality was outdated and inadequate. The
legacy system was designed more than a decade ago, and it had not been updated to support newer printers or
contemporary printing concepts. It also lacked an easy-to-use graphical user interface. NX users had requested
many enhancements that could not be effectively implemented in the context of the legacy plotting system. It was
essential to replace the legacy system with a new plotting system that provides modern printing features commonly
available with other applications. The powerful features of the new system can significantly enhance the
effectiveness and productivity of NX users.

The new plotting system replaces the legacy plotting system. Legacy NX plotting functionality is not supported by NX
3 or later NX releases. You cannot use legacy plot queues with these releases. If you run NX 2 or an earlier NX
release concurrently with NX 3 or a later NX release, then two different plotting systems are in use. The earlier
release uses the legacy plotting system, and the later release uses the new plotting system. The two plotting
systems are independent and do not interact or interfere with one another.

The new plotting system is based on powerful commercial printing software developed by SDI (www.sdicgm.com), a
UGS strategic partner. Basing the new system on commercial printing software provides NX users with capable,
flexible, and up-to-date printing functionality. SDI is in the business of plotting, and also has extensive expertise in
CGM (Computer Graphics Metafile), a graphics file format that NX produces for the new plotting system. Major NX
customers already use SDI products, and SDI provides the printing/plotting capability in I-deas. The UGS
partnership with SDI means that NX customers can install other useful SDI products to obtain optional enhancements
to printing and CGM functionality.

The new plotting system has a large number of enhancements and benefits for users. Among the key features are:

e The new system uses standard plot file formats (CGM and TIFF) that are supported by a wide variety of
commercial applications, so the new plotting system can be readily extended and integrated with other
customer processes.

e All aspects of the new plotting system are controlled by intuitive, easy to use graphical user interfaces.

e |tis much easier to control printer settings than in the legacy system. Many settings can be easily set by an
NX user in the NX Print dialog instead of by a system administrator in a plot queue definition.

e Many more printers are now supported, including devices that do not support PostScript or HP-GL/2.
Defining a queue for a printer device is easier than in the legacy system. It can be as simple as entering a
name for the queue, and then choosing the operating system print queue and the printer model. Easy printer
definition means greater productivity for both end users and system administrators.

e The new system permits system administrators and ordinary users to define "profiles" to encapsulate
commonly used printer option settings (scale, portrait/landscape, color/monochrome) for fast and easy
preparation of plot jobs.

e CGM files produced for plotting support a generous variety of color and width settings. It is much easier to
set color and width attributes than in the legacy system. It is now possible to plot by both color and width.

e The NX Print dialog displays a preview of the plot layout on paper, and also provides a CGM Viewer function
that displays the contents of the CGM file to be printed.

e The new system permits the user to save print-ready CGM files on disk that can be directed to any plotter at
a later time without starting NX or loading a part.

e The new system permits the user to convert wireframe CGM output to raster images (e.g. JPEG) of arbitrary
resolution.

e The new system provides an easy-to-use visual interface for arranging plots on a layout.

e® P " Go to Table of Contents
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Continued from previous

e The new system provides effective user interfaces for operating on multiple drawing sheets at once, both for
plotting and CGM export.

e The new system provides powerful NX Open API access, and also includes updated GRIP commands. The
nxplot command-line program provides some programming options even to customers without GRIP and NX
Open API licenses.

e The new plotting system supports plotting of raster image annotations on drawing sheets.

The new NX 3 plotting system makes it easy for a large number of users to share the same printer definitions.
Printer definitions are stored in a directory called a printer group directory, and any NX user who can access the
directory (i.e., who has "read permissions" for the directory) can use the printers in the printer group. These printer
group directories contain file specifications, so if you have both UNIX and Windows workstations, you will need one
printer group directory for your UNIX systems, and a separate printer group directory for your Windows systems.

If a single printer group directory is all that is needed, then it can be easily specified by an environment variable,
UGII_SDI_SERVER_CFG_DIR. If multiple printer groups are desired, they can be used by pointing a customer
default to the location of a text file that describes the supported plotter groups. The printer groups will then display in
the plotting user interface as a drop down menu of choices for the user. Multiple printer groups are useful when you
have a large variety of printers configured, and you want to place them into logical groups to make it easier for users
to find them.

The new plotting system has a completely new NX Open API interface defined in uf_plot.h. The interface is
extensive, and includes access to all aspects of the new plotting system. GRIP has also been updated, and the
GRIP plotting commands have been redesigned to allow GRIP programs to interface with the new plotting system.
This does mean that customized programs that have been written to automate plotting will need to be re-written.
Although older GRIP plotting programs will run, you will need to define a text file that maps from older queue names
to the newer printer group structure. These older GRIP programs will not have access to much of the new printer
functionality. Once you recompile a GRIP plotting program, you will need to update to the NX 3 GRIP command
syntax for the plotting commands. Older NX Open API plotting programs will not run at all. These plotting API
programs will have to be rewritten with the new interface. There are additional NX Open API functions for generating
CGM files. These new routines are defined in uf_cgm.h and are in addition to the older CGM functions that will
continue to work in the new system.

The new plotting system is a powerful tool for producing hard copy output, but it will require some planning to
integrate it into a production system. The system manager will have to understand the new plotting system, and how
printer queues are defined. You will want to consider which printer queues will need to be set up for users, and
whether these will be set up in one printer group (which requires configuring an environment variable), or multiple
printer groups (which requires setting a customer default, and creating a printer group definition file). How users will
share these printer groups needs to be considered, typically printer groups will be on a shared file server that all
users have access to. If you have to support both Windows and UNIX users, you will need to define the printer
groups twice, once for each platform. In addition any automated programs that deal with plotting will need to be
rewritten before you can deploy NX 3. NX Open API programs that automate plotting will definitely need to be
rewritten, and GRIP programs should be rewritten to gain access to the new plotting features. Finally you will want
the users to try the new plotting functionality, so that they can see how it will meet their needs, and to become familiar
with all the new functionality.

This new printing and plotting system will provide NX users with new functionality and greater flexibility through a
modern user interface. As stated previously, this new capability is part of our ongoing initiative to bring stronger
production functionality to NX users. The new printing/plotting system User Interface (Ul) is rich with options and
visual feedback.

Keith Hafen and Doug Korneffel
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NX 3 Plottting - Frequently Asked Questions

General
How can | get the latest information on the NX plotting system?

The latest information on the NX plotting system is available at the UGS GTAC Support page (http://
support.ugs.com). Search the UGSolutions Database for the exact phrase “NX Plotting System Information.”

Why does NX 3 provide a new plotting system?

A new NX plotting system was needed because legacy plotting functionality was outdated and inadequate. The

legacy system was designed more than a decade ago, and it had not been updated to support newer printers or

contemporary printing concepts or an easy-to-use graphical user interface. NX users had requested many
enhancements that could not be effectively implemented in the context of the legacy plotting system.

It was essential to replace the legacy system with a new plotting system that provides modern printing features
commonly available with other applications. The powerful features of the new system can significantly enhance the
effectiveness and productivity of NX users.

Why does the new plotting system use commercial printing software provided by SDI?

The new plotting system is based on powerful commercial printing software developed by SDI (www.sdicgm.com), a
UGS strategic partner. Basing the new system on commercial printing software provides NX users with capable,
flexible, and up-to-date printing functionality.

SDl is in the business of and plotting, and also has extensive expertise in CGM (Computer Graphics Metafile), a
graphics file format that NX produces for the new plotting system. Major NX customers already use SDI products,
and SDI provides the printing/plotting capability in I-DEAS.

The UGS partnership with SDI means that NX customers can install other useful SDI products to obtain optional
enhancements to printing and CGM functionality.

Can | still use the legacy plotting system?

No. The new plotting system replaces the legacy plotting system. Legacy NX plotting functionality is not supported
by NX 3 or later NX releases. You cannot use legacy plot queues with these releases.

If you run NX 2 or an earlier NX release concurrently with NX 3 or a later NX release, then two different plotting
systems are in use. The earlier release uses the legacy plotting system, and the later release uses the new plotting
system. The two plotting systems are independent and do not interact with one another.

Banner
How has banner functionality changed in the new plotting system?

In the new plotting system, plot banner functionality (appends an informative text block to plots) is enhanced to
support additional content elements, including elements to display the full path of the part, the Teamcenter revision of
the part, whether the drawing sheet is out of date, etc.

Plot banner functionality is also enhanced to permit the location of the banner text block to be defined relative to the
bounds of the plot, so it is no longer necessary to specify the location in absolute plot coordinates. For example, the
banner location might be specified relative to the lower-right corner of the plot.

In addition, for printers that use RTL printer models, you can set header and trailer options to display an alternate
form of banner. If enabled, the header is printed on the leading edge of the output, and the trailer is printed on the
trailing edge of the output. The content of the header and trailer are the same: date and time, user account name,
CGM file name, SDI job number (a number referenced on the Queue page of the NX Print dialog), and an optional
text message that you are prompted to enter when you click Print.

e You can enable headers or trailers for individual plot jobs on an RTL printer. Click Advanced Settings
on the Print Setup tab of the NX Print dialog. When the Advanced Settings dialog is displayed turn on
Headers or Trailers as desired.

e You can enable headers or trailers by default for all plot jobs printed on an RTL printer. Select the printer
on the Printers tab of the Printer Administrator dialog, and click System Profile. When the System
Profile dialog is displayed, click Advanced Settings on the Printer Setup tab. \When the Advanced

Settings dialog is displayed turn on Headers or Trailers as desired. .
Continued Next +" _"s Go to Table of Contents
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Continued from previous

Colors and Widths
How are colors and widths used in the new plotting system?

The new plotting system supports easy specification of colors for plotting, including use of as-displayed (WYSIWYG)
colors, part colors, custom color palettes, and black-on-white. All 216 object colors can be used. Custom color
palettes are easy to create and edit, and can be readily stored and shared via color definition files (CDFs).

The new plotting system also supports easy specification of widths for plotting, including use of standard widths, an
arbitrary single width, custom widths assigned according to object width index, and custom widths assigned

according to object color index. Custom widths are easy to create and edit, and can be readily stored and shared

via width definition files (WDFs).

Color customizations are independent of width customizations, and can be used in mix and match fashion. You can
save custom color and width settings with an individual drawing sheet, so the same colors and widths can be used
each time you plot the sheet.

Features of the NX Plotting System
What are key enhancements in the new plotting system introduced in NX 3?7

e The new system uses standard plot file formats (CGM and TIFF) that are supported by a wide variety of
commercial applications, so the new plotting system can be readily extended and integrated with other
customer processes.

e All aspects of the new plotting system are controlled by intuitive, easy to use graphical user interfaces.

e |tis much easier to control printer settings than in the legacy system. Many settings can be easily set by
an NX user in the NX Print dialog instead of by a system administrator in a plot queue definition.

e Itis much easier to define printer queues. An ordinary user can readily define printers and profiles for the
plotter devices and plotting tasks that are most important to him. Easy printer definition means greater
productivity for both end users and system administrators.

e The new system permits system administrators and ordinary users to define "profiles" to encapsulate
commonly used printer option settings (scale, portrait/landscape, color/monochrome) for fast and easy
preparation of plot jobs.

e CGM files produced for plotting support a generous variety of color and width settings. It is much easier
to set color and width attributes than in the legacy system.

e The NX Print dialog displays a preview of the plot layout on paper, and also provides a CGM Viewer
function that displays the contents of the CGM file to be printed. The CGM Viewer function can also be
used to select a rectangular subregion of the plot for printing.

e The new system permits the user to save print-ready CGM files on disk that can be directed to any plotter
at a later time without starting NX or loading a part.

e The new system permits the user to convert wireframe CGM output to raster images (e.g., JPEG) of
arbitrary resolution.

e The new system provides an easy-to-use visual interface for arranging plots on a layout.

e The new system provides effective user interfaces for operating on multiple drawing sheets at once, both
for plotting and CGM export.

e The new system provides powerful programmability, and the nxplot command-line program provides
some programming options even to customers without GRIP and UFUNC licenses.

e The new plotting system supports plotting of raster image annotations on drawing sheets.
How can | combine multiple plots in one plot file?

The new plotting system provides Plot Layout functionality for arranging multiple plots in one plot file for printing or
for saving to disk in CGM format. This functionality permits you to layout multiple plots for efficient printing on roll-
feed paper, or to overlay plot jobs so they are printed on top of one another, or to collect plots in a single file for
publishing.

Plot Layout functionality includes an intuitive, easy to use, graphical user interface that permits you to see the current
arrangement of plots and to manipulate each new plot as it is added to the layout. Optionally, the functionality can
compute a default, initial location for each new plot in a manner &

designed to conserve roll-feed media. Continued Next «" "% Go to Table of Contents
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Continued from previous You can add any number of plots to the plot layout over the course of the session, but you
can still plot individual jobs at any time without disturbing the contents of the layout.

To add a plot to the plot layout, click Add to Plot Layout in the File-=> Plot dialog.

NX Open
How can | convert legacy NX Open API programs for the new plotting system?

An extensive collection of NX Open API functions provides comprehensive access to NX plotting functionality
introduced in NX 3.

For an example of how to plot all drawing sheets in the current part, refer to sample program ufd_plot_drawings.c
in the NX Open kit.

For an example of how to create HP-GL/2 output files for all drawing sheets in the current part, perhaps for purposes
of comparing plots in HP-GL/2 format, refer to sample program ufd_plot_drawings_hpgl.c and script move_hpgl.pl
in the NX Open Kkit.

e Command-line program nxplot provides programmatic access to some plotting functionality without
using an NX Open license. You can automate common plotting tasks by implementing scripts or
programs that invoke nxplot.

How can | convert legacy NX Open GRIP programs for the new plotting system?

Beginning with NX 3, GRIP plotting statements are redefined to utilize the many features of the new plotting system.
Plotting statements PLOT, PLTSAV, PLTSUB, and PLTDEL have new parameters and new behaviors. Also,
statement PLTUPD and plotting-related parameters of statement DRAWV are now obsolete and have no effect.

If you have legacy GRIP plotting programs written for releases before NX 3, you can modify them to use the
redefined statements with their new parameters. If you do not modify or recompile your legacy GRIP plotting
programs, you can continue to use them with the new plotting system, provided you create a mapping file that maps
legacy statement parameters to values that are meaningful in the new system.

e Only limited features of the new plotting system are available with this mapping technique. To fully
exploit the capabilities of the new system, you must modify GRIP plotting programs to use the
updated statement parameters.

You can find instructions for using the mapping technique in a sample mapping file provided with NX. The sample file
is ${UGII_BASE_DIR}/nxplot/sample_plotter_mapping.txt.

Plot Layout
How can | save plot output to disk in the new system?

The NX plotting system supports various strategies for saving plot files on disk. Choosing an approach depends on
how you intend to use the files.

e You can save plot files on disk in printer-independent CGM format by selecting Save CGM File in the
File-=> Plot dialog. You can later use the NX Print dialog to print the saved CGM files on any printer, or
you can use various applications to import or otherwise process the files. For example, Microsoft Office
applications support importing of CGM files. Note that you can view any CGM file with the CGM Viewer
function of the NX Print dialog, but you can also install a CGM viewer application or browser plug-in so
that you can easily view the CGM files you save on disk.

e You also can save plot files on disk in the printer output format (e.g. RTL, PostScript, HP-GL/2).
If you save a plot output file on disk only occasionally, then use the Output Options setting in the NX Print
dialog.
1. Inthe File => Plot dialog, click Plot to display the NX Print dialog.
2. Choose a printer and then set Output Options to Print to File or Print to File and Printer.
3. When you click Print, the system prompts you to specify a path for the plot output file.
e If you routinely save plot output files as part of some defined process, then you might prefer to invoke the

process automatically whenever a plot output file is produced. To accomplish this, you can use the
Printer Administrator dialog to set the Render File then Execute Program option for your printer.

) o
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Continued from previous

1. Select File => Utilities-=> Printer Administration
2. Specify the printer group for the printer of interest.

3. When you click OK, the Printer Administrator dialog displays. In the Printer Administrator dialog,
select your printer

4. Click Setup.
5. Turn on the Render File then Execute Program option.

6. Enter the full path of a command (including switches) to invoke your process. After SDI software
generates each plot output file, it automatically invokes your command, specifying the plot file
name as the last parameter. In a simple case, your command might simply copy the plot output
file to a particular directory.

e You can generally retain plot output files so you can later access them on disk. In the
Printer Administrator dialog, click the BPS Settings tab, and turn on the Save Input/
Output Files option. The setting affects all plot jobs printed on all printers in the printer
group.

You can find retained files under the "jobs™ directory. (Search for UGII_SDI_BPS_JOBS_DIR in the ugii_env file.)
By default, the jobs directory is ${UGII_TMP_DIR}/bps, and you can find all files for a particular plot job in one of the
subdirectories of ${UGII_TMP_DIR}/bps/<user_name>/<node_name>, where <user_name> represents the user
account name, and <node_name> represents the system node name.

Retained input/output files can consume large amounts of disk space, so delete the files promptly when they are no
longer needed.

Plot Queues
Can all users at my site share the same printer definitions?

Yes. Printer definitions are stored in a directory called a printer group directory, and any NX user who can access the
directory (i.e., who has "read permissions" for the directory) can use the printers in the printer group.

¢ Printer definitions are platform-specific, so if both Windows and UNIX workstations are used at the site,
you must create a printer group with printer definitions for Windows and a printer group with printer
definitions for UNIX.

Also, any printer devices or files specified by printer definitions must be visible to the operating system of each user
workstation. When defining a printer for Windows, for example, the printer must have been added on each user
workstation (via Add Printer), or you can use the LPR/Queue option to identify the printer in Uniform Naming
Convention (UNC) format. \\server_name\share_name to permit access by all user nodes. On the Printers tab of
the Printer Administration dialog, select the printer of interest, and click Setup. When the Printer Setup dialog
is displayed, set the Printer option to LPR/Queue and enter the UNC name of the printer.

If all users at the site share only a single printer group per UNIX or Windows platform, then the system administrator
sets environment variable UGII_SDI_SERVER_CFG_DIR in the ugii_env file to identify the printer group directory.

Users also can share multiple printer groups per platform. In this case, the system administrator enumerates the
printer groups in a printer group list file, and he sets a customer default to identify this file.

Printer Queues and Printer Groups

Is there a way to automatically convert legacy plot queues for use with the new plotting system?

No. You must manually define new printers for the new plotting system, but defining a printer in the new system is
generally easier than defining a queue in the legacy system. The process of defining a printer is similar to using the
Add Printer function on Windows systems. It can be as simple as entering a name for the printer, and then using the
mouse to choose the operating system print queue from one list and the printer model from another list.

You might define fewer printers for the new plotting system because the new system permits you to directly control
more options than did the legacy system. For example, some options controlled by plot queue switches in the legacy
system (switches /AS (auto-scale), /D (DPI), /SP (set palette), etc.) can be conveniently controlled by you in the new
system. Therefore, you might prefer not to define extra printers to handle the various option choices.

. o
Continued Next s? %,

e® %

Go to Table of Contents



GTAC QUARTERLY Third Quarter 2004

>»> NX
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e Printer definitions are platform-specific, so if you use both Windows and UNIX workstations, you will
create a printer group with printer definitions for Windows and a printer group with printer definitions for
UNIX.

Use File => Utilities-=> Printer Administration to define printers.
In the new plotting system, how can | obtain the behaviors produced by legacy plot queue switches?

In the legacy plotting system, you set plotting options by specifying switches (codes) in plot queue definitions. The
new plotting system supports comparable features, but you enable the features in other ways. For some common
legacy plot queue switches, the following table indicates how to produce comparable results in the new plotting

system.
/2 (HP-GL/2 switch) When using the Printer Administrator dialog to create the printer, choose an HP-
GL/2 printer model. (See also "How can | produce plot output in HP-GL/2
format?")

/AR (Auto-run switch) You need not perform any steps to obtain this behavior. The new plotting system
automatically processes all ready plot jobs.

IAS (Auto-scaling

switch) In the new plotting system, you can obtain auto-scaling behavior by enabling the

Best Fit to Page option as follows:

e You can enable Best Fit to Page for an individual plot job, or you can
save the setting in a user profile. Set the Scaling option to Best Fit to
Page on the Print Layout tab of the NX Print dialog. Click Save Profile
As in the NX Print dialog to save the setting in a user profile.

e You can enable Best Fit to Page as the default scaling setting for a
printer. Select the printer on the Printers tab of the Printer Administrator
dialog, and click System Profile. When the System Profile dialog is
displayed, click the Print Layout tab, and turn on Best Fit to Page.

IDJ (DesignJet switch) | When using the Printer Administrator dialog to create the printer, choose the
/LJ (LaserJet switch) appropriate DesignJet or LaserJet model from the list of printer models.

/D (DPI or dots-per-inch) | In the new plotting system, you can set the DPI or resolution as follows:

e You can choose the resolution for an individual plot job, or you can
save the resolution in a user profile. Set the Resolution option to the
desired value on the Print Setup tab of the NX Print dialog. Click Save
Profile As in the NX Print dialog to save the setting in a user profile.

e You can set the default resolution for a printer. Select the printer on
the Printers tab of the Printer Administrator dialog, and click System
Profile. When the System Profile dialog is displayed, choose the default
resolution on the Print Setup tab.

e You can set the resolutions supported by a custom printer model.
Select a custom printer model on the Models tab of the Printer
Administrator dialog, and click Properties. When the Properties - Printer
Model dialog is displayed, use the Resolutions option to customize
resolutions supported by the printer model. Note that you cannot modify
the properties of a predefined printer model. First use Save As to save a
custom copy of a predefined printer model, and then modify the
properties of the custom copy.
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/MO (Monochrome

switch) In the new plotting system, you can enable monochrome output in the following

ways:

e You can enable monochrome output for individual plot jobs. In the
File-=> Plot dialog, set the Colors option to Black on White, or instead,
set the Colors option to Monochrome on the Print Setup tab of the NX
Print dialog. Click Save Profile As in the NX Print dialog to save the NX
Print Monochrome setting in a user profile.

e You can choose monochrome as the default color setting for a |E|
printer. Select the printer on the Printers tab of the Printer Administrator
dialog, and click System Profile. When the System Profile dialog is
displayed, set the Colors option to Monochrome on the Print Setup tab.

e You can specify whether a printer model supports color or
monochrome output. Select a custom printer model on the Models tab
of the Printer Administrator dialog, and click Properties. When the
Properties - Printer Model dialog is displayed, set the Colors option to
Color, Monochrome, or Both. Note that you cannot modify the properties
of a predefined printer model. First use Save As to save a custom copy
of a predefined printer model, and then modify the properties of the
custom copy.

ISP (Set palette switch) |In the new plotting system, you can set the Colors and Widths options in the
File => Plot dialog to reproduce the behavior of any of the many possible
settings of the legacy /SP switch.

You can set the Colors option to any of the following values:

o As Displayed: The colors used to display the geometry on screen are
also used in printing.

e Part Color: The colors of the part color table are used in printing.

e Custom Palette: An alternate set of 216 colors is used for printed
output.

e Legacy Colors: Geometry is printed using 15 fixed colors supported by
NX releases before NX 3, and each of the 216 colors in the part color
table is mapped to the most similar of the 15 fixed colors.

e Black on White: Geometry is printed in black. You can set the Widths
option to any of the following values.

e Standard Widths: Three fixed line widths are used in printed output.

e Single Width: A single line width is used. You can choose one of the
standard widths, one of the custom 3 widths, or a user-defined width.

e Custom 3 Widths: You specify three custom lines widths that are used
in printed output.

e Custom Palette: You specify custom line widths per color (for 216
colors).

e /11/14 /17 /A3 /A4 (Tray selection switches)
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In the new plotting system, you can select a paper tray by using an initialization file containing tray selection
commands that are inserted at the beginning of each output file dispatched to the printer.

When you define a printer, you can specify an initialization file to be used for all jobs printed on this printer.

1. On the Printers tab of the Printer Administration dialog, select the printer of interest.

2. Click Setup.

3. When the Printer Setup dialog displays, enter the path of an initialization file in the Initialization File entry
field or click the Browse button to search for the file.

When you define a paper size for a custom printer model, you can specify an initialization file to be used for all jobs
printed on paper of this size by all printers that share the custom printer model. Use this second approach if you wish
to define a printer that supports printing to multiple paper trays.

On the Models tab of the Printer Administration dialog, select the custom model of interest.
Click Properties.

When the Properties - Printer Model Dialog displays, selectthe paper size of interest.
Click Edit Paper Size.

When the Paper Size Properties dialog displays, enter the path of an initialization file in the Initialization
File entry field, or click the Browse button to search for the file.

o w0bd-=

What are some reasons for using multiple printer groups?

You can create multiple printer groups as a strategy for organizing printers, so that an individual printer group might
represent just the printers at a particular location or just the printers belonging to a particular department or work
group. This provides the following benefits:

1. When you invoke the File-=> Plot dialog to prepare a plot job, it is easy to choose the appropriate printer
group by its descriptive name, and the NX Print dialog lists only the printers in this printer group. This
approach can make it easier for you to select the printers you use most often, because printer lists are
uncluttered by printers you rarely use.

2. Use of multiple printer groups means that printer definition can be a distributed responsibility. The
system administrator might create a printer group to represent printers that are shared by all users at the
site. Others might create printer groups for printers used only by users in a particular workgroup at a
particular location. An individual NX user might create a printer group to manage printers and printing
options that he uses most often.

3. Because it is easy to define printers in the NX plotting system, each individual NX user can readily define
printers for his particular printing needs in his own printer group. (Defining a printer is similar to using
Add Printer on Windows.)

To use multiple printer groups:

1. List the printer groups of interest in a printergroup list file.

2. Set acustomer default to identify the file. NX reads the printer group list file to display an option menu of
printer groups in the File-=> Plot dialog and other plotting dialogs.

3. Specify a special entry in a printer group list file to automatically include the contents of some other
printer group list file, so an individual user can create a file that includes the contents of the printer group
list file defined by a system administrator for the site or workgroup.

A template version of the printer group list file is provided with NX. The template file contains instructions and
samples to explain file syntax. When creating a printer group list file, you can copy this template file and add your
printer group information to the copied file. The template file is ${UGII_BASE_DIR}/nxplot/
printer_group_list_file.txt.

How can | produce plot output in HP-GL/2 format?

To produce plot output in HP-GL/2 format, plot the job on a printer defined to use an HP-GL/2 printer model.

Continued Next +%s
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1. First you must define a printer that uses an HP-GL/2 printer model. By default, the SDI plotting software
integrated with NX uses RTL (HP Raster Transfer Language, a subset of HP PCL) for many printer
models. To produce HP-GL/2 output, you can choose an existing printer model that uses HP-GL/2, or you
can create a new printer model that uses HP-GL/2.

In either case, use the Printer Administrator dialog to define printers and printer models. Select File-=>
Utilities-=> Printer Administration, and specify the printer group for which you wish to define printers
and models. When you click OK, the Printer Administrator dialog is displayed.

To use an existing printer model, add a new printer and choose printer model GEN:Generic HPGL/2.

If you have an actual printer device in mind (e.g., HP DesignJet), then you can create a HP-GL/2 model
for this printer by copying an existing model. In the Printer Administrator dialog, click the Models tab
and select the model of interest. Click Save As, and specify a unique name for your new model, possibly
including some reference to HP-GL/2. Then click Properties, set the Class to HPGL/2, and click OK.
Then return to the Printers tab and add a new printer using your new model.

2. After you add the new printer on the Printers tab, click System Profile and specify default options for
the new printer.

3. Click Cancel or Close to dismiss the Printer Administrator program. You will be able use your new printer
the next time you invoke File-=> Plot.

If you wish to save HP-GL/2 plot output files on disk, see question "How can | save plot files on disk?"

Maggie Bourguet and Keith Hafen

Enabling FLEXIm with Windows XP Service Pack 2

Windows XP Service Pack 2, by default, adds a firewall. If you have this firewall enabled, you will need to configure
your server to allow incoming requests to communicate with FLEXIm.
To enable communication with FLEXIm perform the following steps:

e Start => All Programs => Accessories => Security Center. This will open the Windows Security
Center window.

e Select Windows Firewall.

e Inthe Windows Firewall window, select the Exceptions button.

e Select the Add Program button.

e Select Browse... from the Add Program window.

e Locate the Imgrd.exe file which should be in your UGNXFLEXIm directory.

e Select Open to add it to your list of exceptions.
Repeat this process to add the uglmd.exe file.

Jamie Goggin

Export a Specific, User-defined View to IGES
Suppose you have a user-defined view that depicts the model in its position where it fits on a vehicle. How do you
export the 3D model only in that specific view?

From the IGES Export inside a Unigraphics’ sessions (GUI), go to Modify Settings => Choose Views, turn off the
All User Defined switch and choose the view to export.

Using the external translator interface (xlatorui) perform the normal file selection steps. Go to Edit => Settings. On
the General page, find Views to Export, turn off Standard Views and in the User Views - all or Just Names
Entered, type the name of the desired view. (Avoid misspellings that will cause no data to export.)

Keith Powell
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Allow User Input in Post Processing Using a TK

The following describes the process to create a TK window for user input. The variable created in the user input can
then be used by the post processor. Begin by copying the following into a text file named your_tk_dialog.tcl:

set frm [frame .f -relief flat]
pack $frm -side top -fill x -padx 3 -pady 3
label $frm.Ibl -text "Parameter" -justify left
entry $frm.ent -width 25 -relief sunken -textvar ent_var
$frm.ent delete 0 end
grid $frm.Ibl $frm.ent - - - -sticky ew -padx 3 -pady 3
set butt [frame .b -relief sunken -bd 1]
pack $butt -side bottom -fill x
button $butt.ok -text "OK"  -width 10 -command "OkButtonCallBack $frm"
button $butt.ca -text "Cancel" -width 10 -command "destroy ."
grid $butt.ok $butt.ca -sticky ew -padx 3 -pady 3
proc OkButtonCallBack { frm args } {
puts [$frm.ent get]
destroy .

}

Next, in the Post Builder post processor, add the following to the Program Start in a custom command. This custom
command will reference the text file created in the preceding step. Then copy ugwish.exe from the \mach\auxiliary
directory to the directory where the file your_tk_dialog.tcl is located.

set var [exec c:\\yourdir\ugwish.exec c:\\yourdir\\your_tk_dialog.tcl]
MOM_output_literal $var

When the user post processes this program a dialog will appear for the input. The value of $var will be output to the
post processed data.

Gale Palmer

How to Place a Parts List at an Exact Location

Suppose you want to position the lower left corner of a parts list to the upper right corner of a Title block.

—

Place the parts list on drawing sheet.
Place mouse cursor on upper left corner of the parts list and left click to select it.
With out moving the mouse, click MB3 (mouse button 3) and select Style from the list.
From the Annotation Style dialog select the Sections tab.
Set Alignment Position to Lower Left and choose OK.
On the Selection toolbar check General Objects and set the selection filter to Any.
Place mouse cursor on upper left corner of the parts list and left click to select it.
With out moving the mouse, click MB3 and select Origin from list.
From the Origin tool select the Point Constructor icon (top row far right).

. Click on the upper left corner of Title block.

. OK.

220N~ ®DN
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Ron Zinn

Export Sketch Curves to IGES

You may have a need to export sketch geometry for use in another application. If you attempt to export these curves
to IGES from your Displayed Part you will encounter an Object Dependency error. This occurs because the IGES
specification does not support the sketch concept.

As a workaround, create model curves from the sketch curves for export to IGES. One method is to use Insert =>
Curve Operation and offset the sketch curves as either associative or non-associative geometry at a distance of
zero.

Keith Powell _._
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Entity Pruning From the Hierarchy Form

Entity pruning is defined as the ability to prune a part from a model file so that it is no longer in that model file.
Instance pruning is defined as pruning an instance from an assembly only in the context of that assembly. The part
has never been removed from the model file. Before I-deas 11 NX Series, entity pruning could not be accomplished
from the Hierarchy form. Only instance pruning was available on the Hierarchy form. Beginning with I-deas 11 NX
Series, an instance can be selected on the Hierarchy form in order to perform entity pruning on that part so that it is
truly removed from the model file.

Prior to I-deas 11 NX Series, there were two ways to accomplish entity pruning once a part was in a model file. The

first way involved bringing every assembly to the workbench, selecting every instance of the part to prune at every

level of that assembly, and selecting Prune. This was a very tedious, error-prone process. A second way was to
select the part on the Manage Bins form and select Delete. If the part was used in the definition of an assembly in

that model file, the part could not really be deleted from the assembly, however, it could be pruned from the model

file. |-deas would prompt the user for what was desired.

If an instance is selected on the Hierarchy form to be pruned,
I-deas will now ask if it is OK to prune this part in all
assemblies in the model file.

@ Hherarchy
il | |l P P
top{H1l)

lo_wer(HiE)
box{H13}

-
;@'I-I!En\ Question Q’y
?) Prune part(s) in all assemblies?

lower2(Hi5)
;yl}ndgr(H}&)

Yes Mo | Cancell

If Yes is selected, the part will be entity pruned and will be
removed from the model file. If No is selected, just the
selected instance will be pruned-local (instance pruning) and
the part will remain in the model file. Pruned-local means that
Master Assembly is going to behave like the item is pruned
only in the context of the assembly on the workbench.

ol Gl = =\ Selected ~ ER
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e e | top(Hil) . n -

lo_wer(HiE)
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Note: The software will always prune the following lower2 (Hi5)

instances locally: sriindexiMie]l (Fowed)

e asubassembly.

e a part that was checked out of the library and
has been modified.

Also note that there is no Unprune All. In order to
unprune all the entity pruned instances, they will each
have to be selected and unpruned in each assembly in
which they appear. For further information regarding
pruning, see the UGSolutions article entitled "Pruned,”
"Pruned-Local", and "New Pruned" defined.

Doug Penick DeselecﬂDismis_sl A3 | Dismiss
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