Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  CATIA V4 Administration
  Lösung: Catia V4 Remot auf AIX im Shadet Modus

  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Lösung: Catia V4 Remot auf AIX im Shadet Modus (2939 mal gelesen)
catz
Mitglied



Sehen Sie sich das Profil von catz an!   Senden Sie eine Private Message an catz  Schreiben Sie einen Gästebucheintrag für catz

Beiträge: 733
Registriert: 26.02.2003

V4
V5
VPM
W2k

erstellt am: 23. Mrz. 2004 14:48    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo allerseits,

sollte schon jemand damit herumexperimentiert haben V4 remote von einem AIX Rechner auf einem anderen Rechner im Schattierten Modus laufen zu lassen und daran verzweifelt ist, gibt es eine Lösung.
Auch auf Exceed sollte sich dies Änderung positiv auswirken.

Eind Datei anlegen z.B /tmp/PROFILE mit dem Inhalt:
*---------------------------------------
* For CATIA:
AFMMNICK TOCONNID=*,
          TOWSTYPE=XSOFT,
          PROCOPT=((STRDEVS,16),(LOCDEVS,2),(VWTBLSZ,64),(ECHOMETH,2),
          (XWINDASP,1,1),(XNAME,CATIA),(MODFYOCT),(LSTES,32))
*

vor dem Starten von Catia die Var. gPPROFILE exportieren:
export gPPROFILE=/tmp/PROFILE

dann Catia starten:
catini -XM -cs


Gruß
Stefan


IP

Helmut Zoellner
Mitglied
CAD-Systembetreuer


Sehen Sie sich das Profil von Helmut Zoellner an!   Senden Sie eine Private Message an Helmut Zoellner  Schreiben Sie einen Gästebucheintrag für Helmut Zoellner

Beiträge: 167
Registriert: 04.12.2000

Catia V4/V5
HP-UX, AIX, IRIX, Win2000;

erstellt am: 24. Mrz. 2004 08:51    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für catz 10 Unities + Antwort hilfreich

Hi Stefan,

hast Du es doch noch geschafft, was?
Ist der remote Rechner auch ein AIX, oder kann das ein beliebiges Unix sein?

Gruss aus RV  Helmut 

IP

catz
Mitglied



Sehen Sie sich das Profil von catz an!   Senden Sie eine Private Message an catz  Schreiben Sie einen Gästebucheintrag für catz

Beiträge: 733
Registriert: 26.02.2003

V4
V5
VPM
W2k

erstellt am: 24. Mrz. 2004 09:17    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Helmut,

ich hab nur nur AIX Rechner zur Verfügung.
Server: AIX
Client: AIX
Probierst Du's mit nem Linux Client? Würd mich grad interessieren.

Grüße
Stefan

IP

kjung
Mitglied
Administrator


Sehen Sie sich das Profil von kjung an!   Senden Sie eine Private Message an kjung  Schreiben Sie einen Gästebucheintrag für kjung

Beiträge: 399
Registriert: 17.03.2003

CATIA V4.2.4
CATIA V5R9SP4, V5R10SP5,
VPM 1.5 PTF11/12
AIX 4.3.3 ML10
WIN2K

erstellt am: 24. Mrz. 2004 10:02    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für catz 10 Unities + Antwort hilfreich

Hallo Stefan,
prinzipiell funktioniert Deine Lösung, aber sie scheint Grafikkartenabhängig zu sein. Ich habe mal Dein gProfile angelegt und auch die Environvariable definiert, aber beim Start sagt er :
AFM1059 DEFAULTS ERROR. LABEL 'TOWSTYPE=XSOFT,' IN SOURCE UDS TOO LONG

Welche(n) Grafikadapter verwendest Du ?

------------------
Klaus   

IP

catz
Mitglied



Sehen Sie sich das Profil von catz an!   Senden Sie eine Private Message an catz  Schreiben Sie einen Gästebucheintrag für catz

Beiträge: 733
Registriert: 26.02.2003

V4
V5
VPM
W2k

erstellt am: 24. Mrz. 2004 11:54    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


PROFILE_remote_catia_aix.txt

 
Hallo Klaus,

als Client verwende ich eine 43P140 mit GXT2000P
als Server funktionieren  44P170 mit GXT2000P, GXT4000P
                          Power265 mit GXT6500P, GXT4500P

Ich denke eher es liegt an dem Profile File.
Ich hänge meins mit an.

Gruß
Stefan

IP

kjung
Mitglied
Administrator


Sehen Sie sich das Profil von kjung an!   Senden Sie eine Private Message an kjung  Schreiben Sie einen Gästebucheintrag für kjung

Beiträge: 399
Registriert: 17.03.2003

CATIA V4.2.4
CATIA V5R9SP4, V5R10SP5,
VPM 1.5 PTF11/12
AIX 4.3.3 ML10
WIN2K

erstellt am: 24. Mrz. 2004 13:19    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für catz 10 Unities + Antwort hilfreich

Hallo Stefan,
das AFMMNICK muß an 2. Position beginnen !
Es funktioniert sowohl für V4 als auch für V5. Sehr interessant.

------------------
Klaus   

IP

Detritus
Mitglied


Sehen Sie sich das Profil von Detritus an!   Senden Sie eine Private Message an Detritus  Schreiben Sie einen Gästebucheintrag für Detritus

Beiträge: 3
Registriert: 19.01.2005

erstellt am: 20. Jan. 2005 08:41    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für catz 10 Unities + Antwort hilfreich

Hm, toller Lösungsansatz.
Also, bei mir funktioniert dann der shaded-Modus von V4 nicht; dafür wird der Drahtmodus richtig dargestellt. Der Bildaufbau ist allerdings mies...
Liegt das vielleicht an einer falschen exceed-Einstellung?
Brauche ich Exceed 3D um das ganze richtig machen zu können (hab nur normales Exceed zur Verfügung)?

Wäre nett wenn mir jemand helfen kann.
Gruss und Dank
Chris

IP

catz
Mitglied



Sehen Sie sich das Profil von catz an!   Senden Sie eine Private Message an catz  Schreiben Sie einen Gästebucheintrag für catz

Beiträge: 733
Registriert: 26.02.2003

V4
V5
VPM
W2k

erstellt am: 20. Jan. 2005 09:18    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hi Chris,

es sollte auch ohne Exceed3D schattiert laufen.
Aber eben ohne OpenGL unterstützung. -> in dem Fall auch langsam.
Von OpenGL profitierst Du auch nur, wenn Du eine ordentlichen 3D Grafikkarte hast.

Verwende mal die Textdate, welche ich weiter oben angehängt habe als /tmp/PROFILE.

Klaus hat ja auch geschrieben, daß es auf jedes _blank_ in der Datei ankommt.
export gPPROFILE=/tmp/PROFILE nicht vergessen.
Diese Variabel in der $HOME/.dtprofile und sicherheitshalber in der $HOME/.profile deines AIX Users setzen.

Gruß
Stefan

IP

Detritus
Mitglied


Sehen Sie sich das Profil von Detritus an!   Senden Sie eine Private Message an Detritus  Schreiben Sie einen Gästebucheintrag für Detritus

Beiträge: 3
Registriert: 19.01.2005

erstellt am: 20. Jan. 2005 10:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für catz 10 Unities + Antwort hilfreich

Danke Stefan!

Jetzt funktionierts geshaded. Aber die performance ist unter aller Kanone.
Blöd ist auch, dass wir standardmässig die tcsh statt ksh haben und beim manuellen wechsel auf die ksh meine .(dt)profile nicht laden will...naja, exportier ich halt von Hand.

WENN ich Exceed3D hätte, würden dann die OpenGL-berechnungen anstelle von meiner GXT6500P ordnungsgemäss von meiner Quadro3400 gemacht werden? Mit niedrigerer Netzlast und Quadro-Performance?
Geht das nur mit Exceed3D?

Gruss und Dank
Chris

IP

catz
Mitglied



Sehen Sie sich das Profil von catz an!   Senden Sie eine Private Message an catz  Schreiben Sie einen Gästebucheintrag für catz

Beiträge: 733
Registriert: 26.02.2003

V4
V5
VPM
W2k

erstellt am: 20. Jan. 2005 10:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Chris,

Ja.
Genau so wurde mir das mündlich vom Hersteller versprochen.
Ich konnte das allerdings nicht nachprüfen, da wir nicht einen 3D beschleunigten Windows Rechner im Standort haben.
Aber fordere doch die kostenlose Exceed Testversion an.
Die läuft incl. Exceed3D 30 Tage.

Gruß
Stefan

IP

Detritus
Mitglied


Sehen Sie sich das Profil von Detritus an!   Senden Sie eine Private Message an Detritus  Schreiben Sie einen Gästebucheintrag für Detritus

Beiträge: 3
Registriert: 19.01.2005

erstellt am: 20. Jan. 2005 12:47    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für catz 10 Unities + Antwort hilfreich

Mittlerweile gibts die Testversion für 60Tage.

Hab' mal die neueste Version (10) und Exceed 3D geholt und muss echt sagen, dass es genauso aussieht wie ohne Exceed 3D. *grml* Das Logfile sagt zwar
"Direct Rendering: Enabled.
Hardware Acceleration: Enabled." aber ein performance-boost ist nicht spürbar.

Catia sagt mir beim Start:
"* X-Resources: not active for remote display <ip>"

Muss ich vielleicht auf AIX noch irgendwas einstellen?

IP

catz
Mitglied



Sehen Sie sich das Profil von catz an!   Senden Sie eine Private Message an catz  Schreiben Sie einen Gästebucheintrag für catz

Beiträge: 733
Registriert: 26.02.2003

V4
V5
VPM
W2k

erstellt am: 20. Jan. 2005 14:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hi,

technisch weiß ich nun auch nicht weiter.
Ich hab Dir ne PM geschrieben.

Gruß
Stefan

IP

klassefotos
Mitglied
Systembetreuer

Sehen Sie sich das Profil von klassefotos an!   Senden Sie eine Private Message an klassefotos  Schreiben Sie einen Gästebucheintrag für klassefotos

Beiträge: 2
Registriert: 04.04.2005

erstellt am: 02. Jan. 2008 12:55    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für catz 10 Unities + Antwort hilfreich

Hallo Zusammen,
Ich wünsche allen ein gesundes und frohes neues Jahr 2008!

Hat schon jemand mehr Erfahrung mit dem Exceed 3D machen können?
Bei läuft es aber echt krotten langsam ich glaube ich habe hier keine OpenGL unterstützung!

Gruß
Joachim

IP

choppIX
Mitglied


Sehen Sie sich das Profil von choppIX an!   Senden Sie eine Private Message an choppIX  Schreiben Sie einen Gästebucheintrag für choppIX

Beiträge: 1
Registriert: 24.10.2008

erstellt am: 24. Okt. 2008 09:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für catz 10 Unities + Antwort hilfreich

Hallo zusammen,

wir haben hier Exceed/Exceed3D V13 auf XP-Rechnern mit Nvidia QuadroFX 3500  Grafikadaptern im Einsatz.
Klar, dass V4 im schattierten Modus nicht berauschend aussieht bzw. langsam ist. Das liegt jedoch am V4 selbst, da es keine OpenGL-Anwendung ist sondern auf graPHIGS basiert. Die Darstellung von
schattierten Flächen wird auf eine max. Farbenanzahl von 4096 beschränkt. Das liegt, laut IBMs "graPHIGS Programming Interface", an der Einstellung in der gPROFILE "TOWSTYPE=XSOFT".

Wenn wir mit V5  über Exceed arbeiten, gibt es keine Darstellungsprobleme und in annehmbarer Performance. Darstellung und Geschwindigkeit sind i.O.

Gruß
choppIX

IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz