Hot News aus dem CAD.de-Newsletter:

Unser Angebot:

  Foren auf CAD.de (alle Foren)
  QGIS
  Attribute nach Postion zusammenfügen - Verarbeitungsmodellierung

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Attribute nach Postion zusammenfügen - Verarbeitungsmodellierung (119 mal gelesen)
ISpeech
Mitglied
Flurbereiniger


Sehen Sie sich das Profil von ISpeech an!   Senden Sie eine Private Message an ISpeech  Schreiben Sie einen Gästebucheintrag für ISpeech

Beiträge: 34
Registriert: 25.01.2018

QGIS 2.18.15, Windows 10 Home; i3-4030U, 1,9 GHz, 4 GB RAM

erstellt am: 15. Apr. 2019 21:53    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Wenn ich die Funktion "Attribute nach Postion zusammenfügen" aufrufe kann ich unter dem Parameter "Hinzuzufügende Felder", die Felder auswählen die ich nur hinzufügen will. Ich wähle diese in der Mehrfachauswahl einfach aus. In meinem Fall will ich die Felder AREA_m2 und test hinzufügen. Starte ich die Prozedur steht im Protokoll

'JOIN_FIELDS' : ['AREA_m2','test'],

und alles funktioniert.

Jetzt will ich aber die Prozedur über die Verarbeitungsmodellierung (Grafische Modellierung) einbinden und kann logischerweise unter "Hinzuzufügende Felder" nichts auswählen, sondern muss es direkt reinschreiben. Ich weiß nicht, wie ich die Felder richtig reinschreibe.

Schreibe ich
AREA_m2, test
steht im Protokoll
JOIN_FIELDS: 'AREA_m2, test'
und die Prozedur bricht ab.

Schreibe ich
'AREA_m2','test'
steht im Protokoll
JOIN_FIELDS: '\'AREA_m2\',\'test\'',
und die Prozedur bricht auch ab.

Ich habe noch weiter Schreibweisen versucht, aber die nie Richtige gefunden.

Kann mir jemand sagen, wie ich die Felder richtig benennen muss?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ISpeech
Mitglied
Flurbereiniger


Sehen Sie sich das Profil von ISpeech an!   Senden Sie eine Private Message an ISpeech  Schreiben Sie einen Gästebucheintrag für ISpeech

Beiträge: 34
Registriert: 25.01.2018

QGIS 2.18.15, Windows 10 Home; i3-4030U, 1,9 GHz, 4 GB RAM

erstellt am: 16. Apr. 2019 13:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Der richtige Eintrag muss

AREA_m2;test

lauten. Also mit Semikolon und ohne Leerzeichen.
Danke an R.U. ;-)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz