Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  PTC Creo Allgemein
  Familientabellen Problem beim umbenennen im Commonspace (Windchill)

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
  
Gut zu wissen: Hilfreiche Tipps und Tricks aus der Praxis prägnant, und auf den Punkt gebracht für PTC CREO
Autor Thema:  Familientabellen Problem beim umbenennen im Commonspace (Windchill) (433 mal gelesen)
Hias1986
Mitglied
CAD-Admin


Sehen Sie sich das Profil von Hias1986 an!   Senden Sie eine Private Message an Hias1986  Schreiben Sie einen Gästebucheintrag für Hias1986

Beiträge: 66
Registriert: 20.12.2010

Z-Book

erstellt am: 16. Nov. 2022 07:02    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Servus zusammen,

ich habe aktuell folgendes Problem.
In der Baugruppen Familientabelle "Tab_1" sind die Komponenten "Teil_1", "Teil_2" und "Teil_3" verbaut.
"Teil_1", "Teil_2" und "Teil_3" sind ebenfalls Varianten aus einer anderen Tabelle "Teil_Generic".
Die Tabelle sowie die verbauten Teile sind im Commonspace eingecheckt.

Ich erstelle einen neuen Workspace und lade mir die Tabelle inkl. alles Abhängigkeiten herunter.
Ich öffne die Tabelle und alles ist richtig.
Ich schließe die Tabelle wieder und lösche den Arbeitsspeicher.

Jetzt suche ich im Commonspace das "Teil_1" und benenne dieses um zu "Teil_1_test"
Ich gehe zurück in meinen oben erstellten Workspace.
Führe die Schritte WS-synchronisieren und WS-aktualisieren aus.
Der Workspace erkennt die Änderung von "Teil_1" zu "Teil_1_test".

Ich öffne die Familientabelle "Tab_1" aus dem Workspace.
Die Tabelle hat immer noch den Namen von "Teil_1" in der Zeile. Somit findet die Tabelle das "Teil_1" nicht und verbaut dafür das "Teil_Generic".

Hat jemand eine Idee warum die Tabelle den Namen nicht richtig erkennt? Leider kann ich nicht nachvollziehen seit wann das Problem besteht.

Die letzten Config Anpassungen waren:
dm_cache_limit 0 -> 8000
retrieve_merge_ref_parts  yes
retrieve_data_sharing_ref_parts  yes

Wobei ich nicht weiß ob es einen Zusammenhang zu diesen Config Anpassungen gibt?

Creo 4 M150
WC 11.1


[Diese Nachricht wurde von Hias1986 am 16. Nov. 2022 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

tarsobar
Mitglied
Konstrukteur


Sehen Sie sich das Profil von tarsobar an!   Senden Sie eine Private Message an tarsobar  Schreiben Sie einen Gästebucheintrag für tarsobar

Beiträge: 235
Registriert: 04.02.2002

WIN 10; DELL Precision 5820
Creo Parametric 4, SUP 2020

erstellt am: 16. Nov. 2022 12:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Hias1986 10 Unities + Antwort hilfreich

Hi!

Name und Dateiname geändert?

Gruß

T.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Hias1986
Mitglied
CAD-Admin


Sehen Sie sich das Profil von Hias1986 an!   Senden Sie eine Private Message an Hias1986  Schreiben Sie einen Gästebucheintrag für Hias1986

Beiträge: 66
Registriert: 20.12.2010

Z-Book

erstellt am: 16. Nov. 2022 16:17    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Ja, Name und Dateiname gleich geändert.
Name und Dateiname ist also bei uns immer gleich.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Hias1986
Mitglied
CAD-Admin


Sehen Sie sich das Profil von Hias1986 an!   Senden Sie eine Private Message an Hias1986  Schreiben Sie einen Gästebucheintrag für Hias1986

Beiträge: 66
Registriert: 20.12.2010

Z-Book

erstellt am: 17. Nov. 2022 09:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hier noch das selbe Problem aus der PTC Community.

https://community.ptc.com/t5/3D-Part-Assembly-Design/PTC-COMMON-NAME-is-not-changing-after-rename-and-stays-same-as/td-p/823295?q=Rename%20a%20family%20table%20is%20not%20updating

Wer Zeit hat kann es bei sich testen. Vielleicht ist gemeinsam eine Lösung zu finden.

Wichtig für den Test ist, dass man nach erfolgreichem Test (ohne Fehler) in der selben Creo Sitzung den Test mit dem Umbenennen nochmal in einem neuen Workspace macht.
Komischerweise tickt Creo nämlich 1x richtig und dann immer falsch               

[Diese Nachricht wurde von Hias1986 am 17. Nov. 2022 editiert.]

[Diese Nachricht wurde von Hias1986 am 17. Nov. 2022 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Experiment1
Mitglied
CAD-/ Windchill Admin // F&E


Sehen Sie sich das Profil von Experiment1 an!   Senden Sie eine Private Message an Experiment1  Schreiben Sie einen Gästebucheintrag für Experiment1

Beiträge: 63
Registriert: 01.04.2021

Creo Parametric 8.0.5.0 (ehemals Creo 4 M100)
Windchill PDMLink 12.0.2.6 (ehemals 11.0 M030)
Virtueller CAD-Desktop (Citrix + NVidia Grid M60-2Q)

erstellt am: 18. Nov. 2022 12:00    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Hias1986 10 Unities + Antwort hilfreich

Moin,

ich hab's getestet, konnte keine Probleme feststellen.
Creo 8.0.5.0 und Windchill 12.0.2.6

Mir ist aufgefallen, dass der Parameter PTC_COMMON_NAME gar nicht mehr auswählbar ist, man sich aber noch drauf in Beziehungen referenzieren kann. Wie sieht es denn mit PTC_WM_NAME aus, ist der auch falsch?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Hias1986
Mitglied
CAD-Admin


Sehen Sie sich das Profil von Hias1986 an!   Senden Sie eine Private Message an Hias1986  Schreiben Sie einen Gästebucheintrag für Hias1986

Beiträge: 66
Registriert: 20.12.2010

Z-Book

erstellt am: 18. Nov. 2022 12:53    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Kannst du den Test bitte mit den selben Daten in einem neuen Workspace durchführen?
Im 1. Workspace funktioniert es. Sobald man die Daten in einen 2 oder ff Workspace lädt tritt der Fehler erst auf.

Grüße

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Experiment1
Mitglied
CAD-/ Windchill Admin // F&E


Sehen Sie sich das Profil von Experiment1 an!   Senden Sie eine Private Message an Experiment1  Schreiben Sie einen Gästebucheintrag für Experiment1

Beiträge: 63
Registriert: 01.04.2021

Creo Parametric 8.0.5.0 (ehemals Creo 4 M100)
Windchill PDMLink 12.0.2.6 (ehemals 11.0 M030)
Virtueller CAD-Desktop (Citrix + NVidia Grid M60-2Q)

erstellt am: 18. Nov. 2022 14:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Hias1986 10 Unities + Antwort hilfreich

Auch da keine Probleme!
Die im Commonspace umbenannten Familientabelleninstanzen bekommen jede Namensänderung mit. Ebenso die Baugruppen, in denen sie eingebaut sind.
Wir verwenden PTC_COMMON_NAME nicht direkt, sondern immer einen weiteren Parameter, der dann in den Beziehungen damit verknüpft wird.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Hias1986
Mitglied
CAD-Admin


Sehen Sie sich das Profil von Hias1986 an!   Senden Sie eine Private Message an Hias1986  Schreiben Sie einen Gästebucheintrag für Hias1986

Beiträge: 66
Registriert: 20.12.2010

Z-Book

erstellt am: 18. Nov. 2022 15:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Ich versuche das Thema nochmal verständlicher zu erklären.
1.
Ein neues Prt  Teil_1 erstellen (es kann ohne Inhalt sein)
2.
In diesem Teil_1 eine Familientabelle mit einer Zeile erstellen Teil_1_Instance
3.
Eine Baugruppe erstellen Baugruppe_1
4.
In dieser Baugruppe das Teil_1 einbauen(Platzierung egal)
5.
In der Baugruppe_1 eine Familientabelle mit einer Zeile erstellen Baugruppe_1_Instance
6.
In der Familientabelle der Baugruppe_1 eine Spalte hinzufügen und die Komponente Teil_1 auswählen
7.
In der soeben hinzugefügten Spalte bei der  Baugruppe_1_Instance über ersetzen durch das Teil_1_Instance verbauen.
8.
Alles speichern und einchecken.
9.
Speicher leeren
10.
Neuen Workspace erstellen
11.
Baugruppe_1 mit allen Abhängigkeiten und Varianten herunterladen.
12.
Teil_1_Instance im Commonspace suchen und umbenennen zu Teil_1_Instance_Test
13.
Baugruppe_1 öffnen und in der Familientabelle checken ob das Teil_1_Instance_Test in der Zeile Baugruppe_1_Instance verbaut ist

Sollte eigentlich passen, da es beim ersten umbenennen funktioniert.

14.
Alles schließen, Speicher leeren und im Commonspace das Teil_1_Instance_Test wieder umbenennen auf Teil_1_Instance
15.
Neuen Workspace erstellen und Baugruppe_1 mit allen Abhängigkeiten und Varianten Downloaden
16.
Baugruppe_1 öffnen und den Namen des Teil_1_Instance in der Spalte Baugruppe_1_Instance überprüfen

Der Name sollte jetzt noch passen.

17.
Im Commonspace das Teil_1_Instance suche und wieder umbenennen zu Teil_1_Instance_Test
18.
In der Baugruppe_1 Familientabelle jetzt wieder checken ob der Name Teil_1_Instance_Test richtig dargestellt ist

Jetzt tritt der Fehler auf und die Tabelle baut das Generic Teil_1 ein.

Es sind viele Schritte und man muss warum auch immer alle Schritte verfolgen bzw. den Versuch 2x machen damit der Fehler auftritt, ich wäre aber dankbar wenn ihr euch die Zeit nehmt und mir bestätigt, dass der Fehler reproduzierbar ist.
Es wurde von mir bereits mit sämtlichen Creo Versionen getestet.

Wünsche euch viel Spaß beim testen und ein schönes Wochenende!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ChriHo
Mitglied


Sehen Sie sich das Profil von ChriHo an!   Senden Sie eine Private Message an ChriHo  Schreiben Sie einen Gästebucheintrag für ChriHo

Beiträge: 3
Registriert: 06.11.2019

Creo 8
Windchill 12.0

erstellt am: 24. Nov. 2022 10:22    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Hias1986 10 Unities + Antwort hilfreich

Hallo Hias1986,

ich habe die Punkte ausgetestet und folgendes festgestellt:
- Beim 1. Versuch wird der neue umbenannte Name erkannt
- Beim 2. Versuch & auch bei weiteren Versuchen wird leider der neue Name in der Familientabelle nicht erkannt und es wird das Generic verbaut   Dadurch tritt bei uns leider der gleiche, fehlerhafte Effekt auf.

Haben Sie hierzu schon eine Lösung?

VG

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Hias1986
Mitglied
CAD-Admin


Sehen Sie sich das Profil von Hias1986 an!   Senden Sie eine Private Message an Hias1986  Schreiben Sie einen Gästebucheintrag für Hias1986

Beiträge: 66
Registriert: 20.12.2010

Z-Book

erstellt am: 25. Nov. 2022 07:02    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo ChriHo,

leider habe ich noch keine Lösung.
Aktuell liegt der Fehler bereits direkt bei PTC. Es ist aber leider noch keine Lösung vorhanden.

Gruß

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Hias1986
Mitglied
CAD-Admin


Sehen Sie sich das Profil von Hias1986 an!   Senden Sie eine Private Message an Hias1986  Schreiben Sie einen Gästebucheintrag für Hias1986

Beiträge: 66
Registriert: 20.12.2010

Z-Book

erstellt am: 29. Nov. 2022 06:27    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Servus,

der Beitrag hat jetzt schon einige Views jedoch leider wenig Antworten.

Es wäre hilfreich wenn alle mit der Kombi Creo-Windchill den Test durchführen können und kommentieren, ob der Fehler reproduzierbar ist. Bitte unter Angabe der Softwareversionen.

Wichtig ist, dass ihr nach dem 1. Test, der normal keinen Fehler verursacht, das gleiche in einem 2. Workspace wiederholt.

Ich wäre dankbar über eine Info mit einer Creo und Windchill Version in welcher der Fehler nicht auftritt.

Aktuell scheint es so, als wäre der Fehler in allen Versionen der Software vorhanden. Wer viel mit Familientabellen arbeitet erzeugt somit ständig kaputte Tabellen und Datensätze.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

EWcadmin
Moderator
Konstrukteur (Dipl.-Ing. Maschinenbau), CAD-/PDM-Admin.




Sehen Sie sich das Profil von EWcadmin an!   Senden Sie eine Private Message an EWcadmin  Schreiben Sie einen Gästebucheintrag für EWcadmin

Beiträge: 3176
Registriert: 27.10.2005

Creo 4.0 Parametric M150
Windchill 12.0.2.3
HP Z4 G4 mit 32GB RAM
NVIDIA Quadro P4000
Windows 10 Enterprise

erstellt am: 29. Nov. 2022 10:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Hias1986 10 Unities + Antwort hilfreich

Hallo Hias1986,

wir setzen hier Creo in Kombination mit Windchill ein. Gelegentlich arbeiten wir auch mit Familientabellen, versuchen aber, das nach Möglichkeit zu vermeiden. Falls doch, dann mit restriktiven Regeln um Probleme im Windchill zu vermeiden.
Was wir überhaupt nicht machen, ist so ein Umbenennungsmarathon von Nummer und Name von Objekten. Zum einen arbeiten wir mit automatischer Nummernvergabe und zum anderen erschließt sich uns der Sinn von so vielen Nacheinander-Umbenennungen nicht. Daher und auch aus zeitlichen Gründen (schließlich bezahlt mein Arbeitgeber unter gewissen Anforderungen meine Arbeitszeit  ) werde ich den Test hier nicht durchführen.
Du sagst selbst, dass das Problem mittlerweile bei PTC liegt. Ich nehme an, als Call mit entsprechender Nummer. Sollte das für PTC ein schwerwiegendes Problem sein, wird sicherlich auch bereits ein SPR vorliegen. Warten wir also das Ergebnis ab.

BTW: Nach jedem Umbenennen sollte eine FamTab in Creo korrekt verifiziert werden. Das dient nicht nur der korrekten Regenerierung sondern auch der internen Prüfung aller Referenzen usw. . Danach natürlich speichern und einchecken. Und erst danach im CS nochmals umbenennen, wenn es denn wirklich sein muss. Hast Du das auch so gemacht?

------------------
Grüße aus OWL, Thomas

ProE macht Spaß - viel ProE macht viel Spaß !  (Zitat, frei nach meinem ProE-Beibringer)

Neu auf CAD.de? Diese Infos werden Dir den Einstieg erleichtern: Willkommen auf CAD.de
Auch sehr hilfreich für ProE-/Creo-Neulinge: ProE konfigurieren

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2022 CAD.de | Impressum | Datenschutz