Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  PTC Creo Allgemein
  Regenerierung von Teile-KEs in Baugruppe

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
  
Gut zu wissen: Hilfreiche Tipps und Tricks aus der Praxis prägnant, und auf den Punkt gebracht für PTC CREO
Autor Thema:  Regenerierung von Teile-KEs in Baugruppe (999 / mal gelesen)
Tingeltangel-Bob
Mitglied
Feinwerktechnik Konstrukteur


Sehen Sie sich das Profil von Tingeltangel-Bob an!   Senden Sie eine Private Message an Tingeltangel-Bob  Schreiben Sie einen Gästebucheintrag für Tingeltangel-Bob

Beiträge: 116
Registriert: 07.09.2009

Creo 5.0.6.0
Intel(R)Xeon(R) W-2255 CPU @ 3.70GHz
NVIDIA Quadro RTX 4000
Windows 10 Pro

erstellt am: 17. Nov. 2020 09:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen,

ich habe öfter das Problem, dass KEs von Teilen, welche Baugruppen-Referenzen besitzen, nicht automatisch regeneriert werden.

Ein Beispiel hierfür ist ein Strahlengang, den wir zur Verdeutlichung und Kontrolle in der Baugruppe darstellen, wobei die Spiegelflächen, -achsen und -punkte als Referenzen dienen. Nach der Verschiebung von Spiegeln und der Regenerierung der Baugruppe verschiebt sich jedoch der Strahlengang nicht. Wenn ich mir die Referenzen des Strahlengangs über "Referenzen editieren" anzeige lasse, dann sehe ich die Referenz an der korrekten neuen Position    Erst nachdem ich in die Definition des betreffenden Strahlengang-KEs gehe, aktualisiert es sich

An einem aktuellen Beispiel habe ich herausgefunden, dass sich eine von Teil A in der Baugruppe in Teil B projizierte Fläche nur dann automatisch aktualisiert, wenn ich mir bspw. ein Abstandsmaß von Teil A anzeigen lasse und ändere. Wenn ich aber in die Platzierungsdefinition von Teil A gehe und hier das Abstandsmaß ändere, dann bleibt die projizierte Fläche im Teil B nach dem Regenerieren an alter Stelle.

Selbes Problem tritt auch bei üblichen Platzierungen von Teilen auf, also bspw. wird ein Spiegelhalter verrutscht, aber der SPiegel kommt nicht hinterher.

Gefühlt habe ich das Problem erst seit dem Umstieg auf CREO 5.

Gibt es config-Einstellungen, die ich überprüfen kann? Habe bereits nach möglichen config-Einträgen gesucht, aber nichts passendes gefunden.

Oder könnte es evtl an Eigenheiten verschiedener Platzierungs- bzw. Änderungsmethoden liegen, wie man an meinem zweiten Beispiel sieht?

Vielleicht ist jemandem was ähnliches begegnet und kann mir ein paar Tipps geben.

------------------
Gruß
Tobi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

SmilingDevil
Mitglied
Dipl. Ing.


Sehen Sie sich das Profil von SmilingDevil an!   Senden Sie eine Private Message an SmilingDevil  Schreiben Sie einen Gästebucheintrag für SmilingDevil

Beiträge: 445
Registriert: 02.09.2005

Creo Elements 5

erstellt am: 13. Nov. 2023 11:03    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Tingeltangel-Bob 10 Unities + Antwort hilfreich

Moin,
ich habe auch das Problem das sich KE's nicht wie gewünscht/erwartet regenerieren.

Eine Gespiegelte Gruppe von Bohrlöcher im jünsten Fall, ich habe die "Originale" geändert (von einfachem Sackloch auf Senkloch) und lustigerweise bleiben die Spiegelungen davon unbeeindruckt.

ist die Gruppierung das Problem?

Gruß, Axel

------------------
In übereinstimmung mit der Prophezeiung!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

BergMax
Ehrenmitglied V.I.P. h.c.
Dipl.-Ing. (FH)



Sehen Sie sich das Profil von BergMax an!   Senden Sie eine Private Message an BergMax  Schreiben Sie einen Gästebucheintrag für BergMax

Beiträge: 2293
Registriert: 23.08.2005

Creo 4.0 M130
Creo 8.0.3.0
GT/SUT 8.0.0.0
HP z440, Quadro K2200, Win10 Enterp.
DualView

erstellt am: 14. Nov. 2023 12:29    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Tingeltangel-Bob 10 Unities + Antwort hilfreich

Moin,

ob die Gruppierung das Problem ist kann man doch einfach mal testen. Dann wirst du vermutlich zu der Erkenntnis kommen, dass die Gruppierung unschuldig ist (Zumindest bei Creo 8 so, CE5 habe ich schon lange nicht mehr).

Das Problem scheint mir der komplette Umbau der Bohrungsform zu sein, was ja auch neue, vorher nicht vorhandene Maße bedeutet. Diese können scheinbar nicht direkt nachgezogen werden.
In Creo 8 gibt es im Spiegeln-Tool einen Knopf "Spiegelung erneut anwenden" womit die Spiegelung nicht nur regeneriert (sprich vorhandene KE/Maße werden neu berechnet), sondern komplett neu aufgebaut wird. Dann ändert sich alles wie es soll. Ob es den Knopf in CE5 schon gab/gibt - keine Ahnung.

------------------
Beste Grüße
Max

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

PRO-sbehr
Mitglied
Dipl.-Ing. Konstruktion


Sehen Sie sich das Profil von PRO-sbehr an!   Senden Sie eine Private Message an PRO-sbehr  Schreiben Sie einen Gästebucheintrag für PRO-sbehr

Beiträge: 1144
Registriert: 05.07.2002

VDI
Intel Xeon Gold 6244 CPU
Laptop
DELL Precision M6800
Intel Core I7-4810MQ
Grafik: Nvidia Quadro K4100M
Windows 10 Enterprise 64bit
Creo Parametric 7.0.9.0

erstellt am: 15. Nov. 2023 06:50    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Tingeltangel-Bob 10 Unities + Antwort hilfreich

Hallo Axel,

sprechen wir bei Deinem Problem tatsächlich von CREO Parametrics oder wie in Deiner Info angegeben von CREO Elements (anderes Forum auf CAD.de) ?

Gruß Stefan

------------------
Pro/bleme sind endlich in der Unendlichkeit der Hoffnung.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

BergMax
Ehrenmitglied V.I.P. h.c.
Dipl.-Ing. (FH)



Sehen Sie sich das Profil von BergMax an!   Senden Sie eine Private Message an BergMax  Schreiben Sie einen Gästebucheintrag für BergMax

Beiträge: 2293
Registriert: 23.08.2005

Creo 4.0 M130
Creo 8.0.3.0
GT/SUT 8.0.0.0
HP z440, Quadro K2200, Win10 Enterp.
DualView

erstellt am: 16. Nov. 2023 13:41    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Tingeltangel-Bob 10 Unities + Antwort hilfreich

Moin Stefan,

Creo Elements/Pro 5 war der direkte Nachfolger, bzw. einfach ein umbenanntes Pro/E Wildfire 5.
Wildfire 5 wurde zu Creo Elements/Pro 5 und dann zu Creo 1/2/3...

Du verwechselst das vermutlich mit Creo Elements/Direct.

------------------
Beste Grüße
Max

[Diese Nachricht wurde von BergMax am 16. Nov. 2023 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

PRO-sbehr
Mitglied
Dipl.-Ing. Konstruktion


Sehen Sie sich das Profil von PRO-sbehr an!   Senden Sie eine Private Message an PRO-sbehr  Schreiben Sie einen Gästebucheintrag für PRO-sbehr

Beiträge: 1144
Registriert: 05.07.2002

VDI
Intel Xeon Gold 6244 CPU
Laptop
DELL Precision M6800
Intel Core I7-4810MQ
Grafik: Nvidia Quadro K4100M
Windows 10 Enterprise 64bit
Creo Parametric 7.0.9.0

erstellt am: 16. Nov. 2023 14:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Tingeltangel-Bob 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von BergMax:
Moin Stefan,

Creo Elements/Pro 5 war der direkte Nachfolger, bzw. einfach ein umbenanntes Pro/E Wildfire 5.
Wildfire 5 wurde zu Creo Elements/Pro 5 und dann zu Creo 1/2/3...

Du verwechselst das vermutlich mit Creo Elements/Direct.


Hallo Max,

genauso wie nur "CREO" ist auch nur "CREO Elements" nicht sehr aussagekräftig um zu erkennen um welches Programm es sich handelt, daher habe ich vorsichtshalber nachgefragt. Übrigens hatte CREO Elements/Pro soweit ich mich erinnere im Gegensatz zu Pro/E Wildfire 5 keine Versionsnummer 5 hintendran, so daß durchaus auch hierdurch die irrige Meinung aufkommen kann, daß es sich vielleicht um Creo Elements/Direct handeln könnte. Hiervon kenne ich die Versionshistorie nicht.

Aber danke Dir Max für den Hinweis.

Gruß Stefan

------------------
Pro/bleme sind endlich in der Unendlichkeit der Hoffnung.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

SmilingDevil
Mitglied
Dipl. Ing.


Sehen Sie sich das Profil von SmilingDevil an!   Senden Sie eine Private Message an SmilingDevil  Schreiben Sie einen Gästebucheintrag für SmilingDevil

Beiträge: 445
Registriert: 02.09.2005

Creo Elements 5

erstellt am: 05. Dez. 2023 12:11    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Tingeltangel-Bob 10 Unities + Antwort hilfreich

...leider benehmen sich auch gespiegelte Bohrungen so, bei denen ich nur einen Abstand ändere.. die Spiegelung bleibt eingefroren und muß jedesmal (meine einzige Lösung dezeit) gelöscht und neu erstellt werden.. wirkt unintuitiv. Noch jemand mit einer Idee? ich finde keinen "spiegeln regenerieren"-Knopf

------------------
In übereinstimmung mit der Prophezeiung!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

arni1
Ehrenmitglied V.I.P. h.c.



Sehen Sie sich das Profil von arni1 an!   Senden Sie eine Private Message an arni1  Schreiben Sie einen Gästebucheintrag für arni1

Beiträge: 3943
Registriert: 17.12.2002

Pro/E seit Version 11
Creo6
HP Z210
Intel Xeon 3.3GHz; 20 GB RAM
NVIDIA Quadro 2000
HP ZR30w
Win10 64bit

erstellt am: 05. Dez. 2023 12:53    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Tingeltangel-Bob 10 Unities + Antwort hilfreich

Eine Abstandänderung wird in der Spiegelung übernommen.
Eine Änderung der Bohrungsart (Sackloch auf Senkloch) wird nicht übernommen.
Neu erzeugt werden muß die Spigeleung trotzdem nicht,
Spiegel-Ke umdefinieren
Haken setzen bei #Spiegelung_erneut_anwenden
So können nachträglich auch zusätzliche KE's in die Gruppe aufgenommen werden und gespiegelt werden.

Gruß
Arni

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2023 CAD.de | Impressum | Datenschutz