Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  PTC Creo Allgemein
  Beziehung

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Beziehung (199 mal gelesen)
Redifiner
Mitglied



Sehen Sie sich das Profil von Redifiner an!   Senden Sie eine Private Message an Redifiner  Schreiben Sie einen Gästebucheintrag für Redifiner

Beiträge: 280
Registriert: 01.10.2002

Creo 4.0

erstellt am: 15. Jan. 2020 09:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Zusammen,

ich habe mit in einem 3D Modell eine Beziehung erstellt:

weight=mp_mass("")/1000

wenn bei den Parametern schaue, wird ein Parameter namens weight erstellt und der korrekte Wert wird angezeigt.

Das gleiche habe ich in einer Baugruppe gemacht, hier habe ich allerdings das Problem, das der Paramater der Wert 0 eingetragen wird. Wenn ich unter Beziehungen schaue steht zwar kein Fehler, aber folgender Eintrag:

weight=mp_mass("")/1000
warning Model changed since mass props calculated. May need to recalculate.

Wenn ich aber mit Masseneigenschaften prüfe, wird das richtige Gewicht angezeigt, ich habe den Eindruck, dass in der Baugruppe irgendetwas gesperrt ist. Aber was?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Tingeltangel-Bob
Mitglied
Feinwerktechnik Konstrukteur


Sehen Sie sich das Profil von Tingeltangel-Bob an!   Senden Sie eine Private Message an Tingeltangel-Bob  Schreiben Sie einen Gästebucheintrag für Tingeltangel-Bob

Beiträge: 51
Registriert: 07.09.2009

Creo 4 M030
Windows 10 Pro
Intel Core i7-4712HQ

erstellt am: 15. Jan. 2020 10:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Redifiner 10 Unities + Antwort hilfreich

Moin,

während das unter Analyse -> Masseneigenschaften angezeigte Gewicht immer dem aktuellen Gewicht entspricht, muss das in einem Parameter angezeigte Gewicht immer neu berechnet werden: Modelleigenschaften -> Masseneigenschaften -> Ändern -> OK. Danach nochmal regenerieren und fertsch. So ist das jedenfalls bei mir.

------------------
Gruß
Tobi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

der berater
Mitglied
Anwendungsberater


Sehen Sie sich das Profil von der berater an!   Senden Sie eine Private Message an der berater  Schreiben Sie einen Gästebucheintrag für der berater

Beiträge: 318
Registriert: 07.12.2000

PTC Creo Parametric
PTC Windchill PDMLink
Mathcad Prime

erstellt am: 15. Jan. 2020 10:58    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Redifiner 10 Unities + Antwort hilfreich

trag mal folgende zeile in die config.pro ein:
mass_property_calculate automatic

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Redifiner
Mitglied



Sehen Sie sich das Profil von Redifiner an!   Senden Sie eine Private Message an Redifiner  Schreiben Sie einen Gästebucheintrag für Redifiner

Beiträge: 280
Registriert: 01.10.2002

Creo 4.0

erstellt am: 15. Jan. 2020 11:29    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

genau das wars. Ohne dem config.pro Eintrag hat es sich genau so verhalten, wie Tobi es beschrieben hat. Mit dem config.pro Eintrag verhält es sich in der Baugruppe jetzt genau so wie auch im Einzelteil. Vielen lieben Dank, Berater :-)

[Diese Nachricht wurde von Redifiner am 15. Jan. 2020 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz