Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Rund um AutoCAD
  MTEXT - Tiefstellung

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   MTEXT - Tiefstellung (348 mal gelesen)
Bernhard GSD
Mitglied



Sehen Sie sich das Profil von Bernhard GSD an!   Senden Sie eine Private Message an Bernhard GSD  Schreiben Sie einen Gästebucheintrag für Bernhard GSD

Beiträge: 436
Registriert: 29.08.2002

AutoCAD 2019(Deu); Windows 10 PRO x64(Deu)

erstellt am: 06. Mrz. 2019 07:59    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Ich habe ein seltsames Phänomen:

MTEXT mit Tiefgestellten Zeichen bei NICHT-Linksbündiger Ausrichtung verschwindet ins Irgendwo in der Zeichnung.

Das Problem tritt ursächlich nur auf meinem PC auf (siehe unten), bleibt aber auf Rechnern, die dieses Problem nicht verursachen, bestehen.

(NOT-)LÖSUNG zur Behebung:

Ich kann diese Texte nur mit [STRG]+[A] und folgendem Entfernen der Elemente im normalen Zeichenbereich auswählen und dann die Ausrichtung auf eine der Linksbündigen Ausrichtungen wieder in den den normalen Zeichenbereich zurück bringen.

AutoCAD 2019 - Windows 10 Pro (Allerdings habe ich das Win 10 über das Windows 7 drüberinstalliert)

Wer kennt dieses Problem?
Und wer kennt die tiefere Ursache dieses Problems?

------------------
Gruß aus Wien
Bernhard

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Ingo Struck
Mitglied
Holztechniker


Sehen Sie sich das Profil von Ingo Struck an!   Senden Sie eine Private Message an Ingo Struck  Schreiben Sie einen Gästebucheintrag für Ingo Struck

Beiträge: 448
Registriert: 08.01.2010

Intel Core i7-3770
16 GB RAM
AMD FirePro V3900 (FireGL V)
Windows 7 Pro SP1
AutoCAD 2017 SP1 - deutsch

erstellt am: 06. Mrz. 2019 08:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bernhard GSD 10 Unities + Antwort hilfreich

Hallo Bernhard,

vielleicht kannst Du ja eine Beispiel-dwg hier hochladen. Wenn wir das Verhalten nachvollziehen können fällt bestimmt auch jemand dazu etwas ein.

Was meinst Du mit "normaler Zeichenbereich"? Tritt das Verhalten nur im Modellbereich und nicht in den Layouts auf? Tritt es innerhalb des Texteditors (mit blinkendem Cursor im Text) oder außerhalb auf? Markierst Du mit [STRG]+[A] den gesamten Text innerhalb des Texteditors? Benutzt Du den Schalter "Tiefgestellt" in der Gruppe Formatierung des Texteditors? Bei aktivierter Eigenschaftenpalette [Strg + 1] gibt es in der Kategorie "Text" die "papierdefinierte Breite" und die "modelldefinierte Breite", was steht dort?

mfg, Ingo 

------------------
"Umwege erhöhen die Ortskenntnisse!"

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Bernhard GSD
Mitglied



Sehen Sie sich das Profil von Bernhard GSD an!   Senden Sie eine Private Message an Bernhard GSD  Schreiben Sie einen Gästebucheintrag für Bernhard GSD

Beiträge: 436
Registriert: 29.08.2002

AutoCAD 2019(Deu); Windows 10 PRO x64(Deu)

erstellt am: 06. Mrz. 2019 09:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo, Eine Beispielzeichnung hochzuladen bringt hier wenig, das der Fehler erst beim Laden der Zeichnung mit meiner Autocad-Installation auftritt - und ich kann auch keine saubere Zeichnung, die den Fehler verursachen würde, erstellen.

[STRG]+[A] verwende ich nicht im Texteditor, sondern im Zeichnungseditor um alle Zeichnungselement auszuwählen. Dann entferne ich mit [Shift]+Auswahl die normalen Zeichnungselemente. Es bleiben die Elemente ausgewählt, die weit außerhalb meiner Zeichnung liegen.

------------------
Gruß aus Wien
Bernhard

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Bernhard GSD
Mitglied



Sehen Sie sich das Profil von Bernhard GSD an!   Senden Sie eine Private Message an Bernhard GSD  Schreiben Sie einen Gästebucheintrag für Bernhard GSD

Beiträge: 436
Registriert: 29.08.2002

AutoCAD 2019(Deu); Windows 10 PRO x64(Deu)

erstellt am: 06. Mrz. 2019 10:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Die Verschiebung beträgt übrigens 5.00000000E+09 Zeichnungseinheiten.

------------------
Gruß aus Wien
Bernhard

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Ingo Struck
Mitglied
Holztechniker


Sehen Sie sich das Profil von Ingo Struck an!   Senden Sie eine Private Message an Ingo Struck  Schreiben Sie einen Gästebucheintrag für Ingo Struck

Beiträge: 448
Registriert: 08.01.2010

Intel Core i7-3770
16 GB RAM
AMD FirePro V3900 (FireGL V)
Windows 7 Pro SP1
AutoCAD 2017 SP1 - deutsch

erstellt am: 06. Mrz. 2019 11:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bernhard GSD 10 Unities + Antwort hilfreich

Was meinst Du mit Zeichnungseditor? Vermutlich befindest Du Dich im Modellbereich? Hast Du die anderen Fragen schon durchprobiert?

Wenn Du Dir sicher bist, das es an Deiner AutoCAD Installation liegt, könntest Du die Zeichnung mit einem anderem Profil laden und schauen, ob es dann funktioniert.

mfg, Ingo 

------------------
"Umwege erhöhen die Ortskenntnisse!"

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Bernhard GSD
Mitglied



Sehen Sie sich das Profil von Bernhard GSD an!   Senden Sie eine Private Message an Bernhard GSD  Schreiben Sie einen Gästebucheintrag für Bernhard GSD

Beiträge: 436
Registriert: 29.08.2002

AutoCAD 2019(Deu); Windows 10 PRO x64(Deu)

erstellt am: 06. Mrz. 2019 11:16    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


MTEXT-Test.dwg

 
Nein, das Profil zu wechseln (von einem Rechner, der das Problem nicht hat) hat leider nichts gebracht.

Ich befinde mich im Modellbereich, im Papierbereich tritt das Problem genauso auf. Es betrifft sowohl besteht sowohl bei alten und neuen Zeichnungen.

Ich habe jetzt eine Zeichnung angehängt, in der das Problem bereits existiert: Die Zeichnung enthält einen Kreis auf 0,0 und Radius 1.0 sowie ein MTEXT-Element, dessen Basis ebenfalls auf 0,0 liegt (bzw. liegen solle).

Zu finden ist der Text selbst jedoch auf X = 5.00000000E+09 Y = 0.00000000 Z = 0.00000000

------------------
Gruß aus Wien
Bernhard

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Kuschelfee
Mitglied
Bauzeichnerin


Sehen Sie sich das Profil von Kuschelfee an!   Senden Sie eine Private Message an Kuschelfee  Schreiben Sie einen Gästebucheintrag für Kuschelfee

Beiträge: 121
Registriert: 07.05.2007

Soficad 2018-7
AutoCAD 2019.1.2
Windows 7 Professional

erstellt am: 06. Mrz. 2019 13:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bernhard GSD 10 Unities + Antwort hilfreich

Dein Mtext beinhaltet Dynamische Spalten.
Wenn du diese deaktivierst (Spalten von Dynamisch auf keine Spalten)und deinem Text im Eingenschaftenfenster die Definierte Breite auf 0 (zur Zeit 133.43) stellst ist er wieder an der Richtigen stellen.

Ursächlich sind die dynamischen Spalten im MText
Stell doch mal MTEXTCOLUMN auf 0
Natürlich kannst du auch Alternnativ die Breite der Dynamischen Spalten ändern.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Bernhard GSD
Mitglied



Sehen Sie sich das Profil von Bernhard GSD an!   Senden Sie eine Private Message an Bernhard GSD  Schreiben Sie einen Gästebucheintrag für Bernhard GSD

Beiträge: 436
Registriert: 29.08.2002

AutoCAD 2019(Deu); Windows 10 PRO x64(Deu)

erstellt am: 06. Mrz. 2019 13:44    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Zitat:
Original erstellt von Kuschelfee:
Dein Mtext beinhaltet Dynamische Spalten.
Wenn du diese deaktivierst (Spalten von Dynamisch auf keine Spalten)und deinem Text im Eingenschaftenfenster die Definierte Breite auf 0 (zur Zeit 133.43) stellst ist er wieder an der Richtigen stellen.

Das hilft bei mir leider nicht. 

Aber wenigstens kann ich den anderen jetzt sagen, wie sie den Fehler, den mein Rechner verursacht, wieder reparieren können.

Offensichtlich hat mein Rechner ein Problem mit der Autocad-Installation.

Danke Trotzdem an alle.

------------------
Gruß aus Wien
Bernhard

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Ingo Struck
Mitglied
Holztechniker


Sehen Sie sich das Profil von Ingo Struck an!   Senden Sie eine Private Message an Ingo Struck  Schreiben Sie einen Gästebucheintrag für Ingo Struck

Beiträge: 448
Registriert: 08.01.2010

Intel Core i7-3770
16 GB RAM
AMD FirePro V3900 (FireGL V)
Windows 7 Pro SP1
AutoCAD 2017 SP1 - deutsch

erstellt am: 06. Mrz. 2019 13:57    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Bernhard GSD 10 Unities + Antwort hilfreich


MText-Test.png

 
Leider kann ich das Problem nicht nachvollziehen. Im Anhang ist ein Screenshot der geöffneten Zeichnung. Der Text ist markiert und befindet sich etwa auf X = 67 , Y = 0. Die Basis des Textes befindet sich bei 0,0 und der MText besitzt laut Eigenschaftenpalette eine definierte Breite von 133,4303 Einheiten. Merkwürdig ist die augenscheinlich mittige Position trotz Ausrichtung oben links. Auch der Eintrag unter Text > Inhalt "\A1;\pxqc;H{\H0.7x;\S^2;}O" erschließt sich mir nur teilweise. Evtl. kann jemand etwas zu diesen Formatierungscodes sagen?

mfg Ingo 

------------------
"Umwege erhöhen die Ortskenntnisse!"

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Bernhard GSD
Mitglied



Sehen Sie sich das Profil von Bernhard GSD an!   Senden Sie eine Private Message an Bernhard GSD  Schreiben Sie einen Gästebucheintrag für Bernhard GSD

Beiträge: 436
Registriert: 29.08.2002

AutoCAD 2019(Deu); Windows 10 PRO x64(Deu)

erstellt am: 06. Mrz. 2019 14:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Zitat:
Original erstellt von Kuschelfee:
Dein Mtext beinhaltet Dynamische Spalten.
Wenn du diese deaktivierst (Spalten von Dynamisch auf keine Spalten)und deinem Text im Eingenschaftenfenster die Definierte Breite auf 0 (zur Zeit 133.43) stellst ist er wieder an der Richtigen stellen.

Nach nochmaligen Test:
Die Dynamischen Spalten sind nicht das Problem, aber wenn ich Definierte Breite auf 0 stelle (und die Spalten auf "keine"), ist es bei mir zwar immer noch falsch, aber auf anderen Rechnern ist es dann trotzdem wieder richtig.

Normalerweise sollte es aber auch so nicht sein, dass der eigentliche Text 5.0000000E+09 Zeichnungeinheiten daneben liegt - trotz der im hochgeladenen Beispiel falschen Breite und Spaltenanzahl (das hat im eigentlichen Anlassfall nämlich gepasst - Nur die Breite war da auf 1.0)

Aber offensichtlich ist der Fehler nur teilweise reproduzierbar.

------------------
Gruß aus Wien
Bernhard

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz