Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Rund um AutoCAD
  Keine Fangpunkte an Blöcken beim Kopieren

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Keine Fangpunkte an Blöcken beim Kopieren (768 mal gelesen)
Dunkelelf
Mitglied
CAD-Konstrukteur


Sehen Sie sich das Profil von Dunkelelf an!   Senden Sie eine Private Message an Dunkelelf  Schreiben Sie einen Gästebucheintrag für Dunkelelf

Beiträge: 70
Registriert: 10.02.2017

Windows 7
Prozessor: I7-4810, 2,8 GHz mit 32GB RAM
Grafikkarte: NVIDIA Quadro K1100M
AutoCAD 2017, SP1

erstellt am: 10. Jan. 2019 11:38    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen und frohe neues Jahr.
Ich habe seit kurzem Acad2019 und habe jetzt folgendes Problem: Ich arbeite mit zwei Bildschirmen. Auf jedem Bildschirm ein AutoCAD-Fenster (AutoCAD nur einmal geöffnet).
Wenn ich mit dem Kopieren-Befehl ein Element von einem Fenster in das andere kopieren möchte, findet AutoCAD keinen Fangpunkt an Blöcken. Das heißt, ich klicke in dem ersten Fenster den Anfangspunkt und im zweiten Fenster möchte ich, dass der zweite Punkt ein Endpunkt an einem Block ist.
Wenn ich das gleiche Element mit einem Hotgrip-Punkt von Fenster zu Fenster kopiere funktioniert es komischerweise. Da kann ich alle Fangpunkte des Blocks anwählen.
Wäre schön wenn es eine Lösung für das Problem gäbe da man nun mal nicht immer mit einem Hotgrip-Punkten arbeiten kann.
Danke im Voraus für evtl. Hilfe

------------------
freundlich grüßt der Dunkelelf

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CADmium
Moderator
Maschinenbaukonstrukteur




Sehen Sie sich das Profil von CADmium an!   Senden Sie eine Private Message an CADmium  Schreiben Sie einen Gästebucheintrag für CADmium

Beiträge: 13413
Registriert: 30.11.2003

Hinweis: Meine Mitarbeit auf CAD.DE ist fakultativ, unentgeltlich und beruht nur auf einem ausgeprägtem Helfersyndrom.

erstellt am: 10. Jan. 2019 11:43    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Dunkelelf 10 Unities + Antwort hilfreich

welchen Wert hat denn die Autocadvariable OSMODE ?

------------------
Also ich finde Unities gut ... und andere sicher auch
---------------------------------------
  - Thomas -          
"Bei 99% aller Probleme ist die umfassende Beschreibung des Problems bereits mehr als die Hälfte der Lösung desselben."

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

runkelruebe
Moderator
Straßen- / Tiefbau




Sehen Sie sich das Profil von runkelruebe an!   Senden Sie eine Private Message an runkelruebe  Schreiben Sie einen Gästebucheintrag für runkelruebe

Beiträge: 7935
Registriert: 09.03.2006

sw:
Win7-x64
Office 365 ProPlus
C3D (& LT )
ET; DACH; Extensions
-------------------
hw:
FX3800
i5 CPU 670
8GB RAM

erstellt am: 10. Jan. 2019 11:58    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Dunkelelf 10 Unities + Antwort hilfreich

Was meinst Du denn mit "Fenster"?
(Modell)Ansichtsfensterkonfiguration? Dann würd ich das Verhalten teilweise bestätigen: Die Darstellung des OF erscheint nicht vorher, sondern erst genau beim Klick >> es wird trotzdem (oft) richtig gefangen.

Um den Einfügepunkt des Blocks im zweiten Fenster zu erwischen, schränk den OFang temporär ein und klick auf einen Teil der Blockgeometrie. Mit ein wenig Übung, kannst Du diesen bug[*] so umgehen. (Klappt natürlich auch mit jedem beliebigen anderen OF, mußt nur mit der (ebenfalls nicht sichtbaren) Pickbox treffen)

Bug weil: hotgrip tut, ist IMHO ein Grafikproblemchen, ACAD kommt da irgendwo nicht ganz mit.


------------------
Gruß,
runkelruebe          Herr Kann-ich-nich wohnt in der Will-ich-nich-Straße...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 19237
Registriert: 03.06.2002

System: F1
und Google

erstellt am: 10. Jan. 2019 12:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Dunkelelf 10 Unities + Antwort hilfreich


190110-1.jpg

 
Hi Dunkelelf,

seit 2015 ist die Datei- und ProgrammFENSTERwelt für mich untergegangen.
Mit Version 2015 verzichtete man auf Ur-alte Technik, was leider so einige
Verschlechterungen mit sich brachte.
(Auf der Positiv-Seite wird nur Performance stehen und die nur für Bestimmte Dateiinhalte/Einstellungen)

Zuerst konnte ich deiner Beschreibung zu 100% folgen,
danach ein Test mit Schieben anstatt Kopieren: AHA, mit Schieben ging es wunderbar.
Fazit: Es liegt nicht an den neumodischen Icons des aktiven Befehls (was man bei Kopieren und Schieben am Cursor sieht).
Nun wollte ich es umgekehr testen, alles wieder zurück auf Anfang und zuerst mit Schieben testen (funktionierte),
danach mit Kopieren: Funktionierte auch!
Kurz: Bis auf wenige Ausnahmen klappt es jetzt mit beiden Befehlen wie gewünscht.

Vorschlag: Teste mal etwas hin und her -
Aktiviere zunächst beide Fenster (wenn kein Befehl aktiv ist die Fenster aktuell schalten)
Teste erneut..

Falls es nicht hilft fallen dir sicher noch andere Dinge ein:

Dateifenster nicht vollbold - Wechseln zwischen den Fenstern,
auf Vollbild, wechseln zwischen den Fenster,
testen beide Befehle aus und dann erneut.

Di Logik habe ich da noch nicht erkannt, aber immerhin kann ich sagen:
a) Es liegt nicht an mehreren Monitoren
b) es ist nicht generell so
c) das Verhalten konnte ich ab 2017 nachvollziehen (da gibt es diese kopiern/schieben/Befehlsicon am Cursor auch nicht)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Dunkelelf
Mitglied
CAD-Konstrukteur


Sehen Sie sich das Profil von Dunkelelf an!   Senden Sie eine Private Message an Dunkelelf  Schreiben Sie einen Gästebucheintrag für Dunkelelf

Beiträge: 70
Registriert: 10.02.2017

Windows 7
Prozessor: I7-4810, 2,8 GHz mit 32GB RAM
Grafikkarte: NVIDIA Quadro K1100M
AutoCAD 2017, SP1

erstellt am: 10. Jan. 2019 13:58    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo
Zu CADmium:
OSMODE liegt auf 4197. Es sollten also Endpunkte gefangen werden.

Zu runkelruebe:
Zwei Ansichtsfenster im Modell. Je eins auf jedem Bildschirm. Es stimmt das Autocad den Punkt tatsächlich fängt. Aber da der Fangpunkt nicht angezeigt wird möchte ich mich lieber nicht darauf verlassen das der Punkt auch tatsächlich richtig gefangen wurde. Und ständig nachmessen will ich natürlich auch nicht.
OFang einschränken? Verstehe ich erst mal nicht. Den Block kann ich anklicken wo ich will es wird kein Fangpunkt angezeigt. Erst wenn ich in die Nähe eines z.B. Endpunktes komme sieht man, das Autocad den Punkt, wahrscheinlich auch genau, fängt (ohne Anzeige des Fangpunktes).
Ich denke das du recht hast mit dem Grafikproblem welches beim Hotgrip komischerweise nicht auftaucht.

Zu Cadffm:
Ich habe jetzt etliches getestet, komme aber immer zum gleichen Ergebnis. Es wird beim zweiten Fangpunkt nichts angezeigt. Es tritt immer nur der Effekt auf den ich bei der Antwort auf "runkelruebe" beschrieben habe.

Fazit:
Ich denke ihr habt alle Recht mit euren Antworten. Zum Glück gibt es ja immer mehrere Wege die nach Rom führen. Muss ich halt meine gewohnte Arbeitsweise ein wenig umstellen. Danke für die schnellen Bemühungen. Units folgen.

------------------
freundlich grüßt der Dunkelelf

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

runkelruebe
Moderator
Straßen- / Tiefbau




Sehen Sie sich das Profil von runkelruebe an!   Senden Sie eine Private Message an runkelruebe  Schreiben Sie einen Gästebucheintrag für runkelruebe

Beiträge: 7935
Registriert: 09.03.2006

sw:
Win7-x64
Office 365 ProPlus
C3D (& LT )
ET; DACH; Extensions
-------------------
hw:
FX3800
i5 CPU 670
8GB RAM

erstellt am: 10. Jan. 2019 18:00    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Dunkelelf 10 Unities + Antwort hilfreich

Nur der Vollständigkeit halber:

>> OFang einschränken? Verstehe ich erst mal nicht.

Zitat:
>> so meinte ich das << (ACAD-Hilfe "Verwendung des Objektfangs")

Klicken Sie bei gedrückter UMSCHALT-Taste mit der rechten Taste des Zeigegeräts, um das Kontextmenü Objektfang aufzurufen.


Damit erhälst Du einen temporären (gilt nur für den nächsten Klick) Objektfang NUR auf die gewünschte Punktart.

Dein derzeitiger OSMODE 4197 hat ja mehr als den Endpunkt drin (nur Endpunkte wäre 1) und mit der temp. Überschreibung gewährleistest Du, dass nicht irgendwas anderes gefangen wird, denn Du siehst es ja nicht vorher. Und wer guckt schon so genau hin, ob im Moment des Klicks auch wirklich ein Quadrat aufblitzt und nicht etwa ein Dreick ("Mittelpunkt") oder gar die böse Linie mit dem Punkt drunter ("Nächster").
Wie gesagt, gefangen wurde bei meinen kurzen Tests vorhin ebenso zuverlässig wie sonst auch, man sieht es halt nur nicht vorher.

Weiß Autodesk schon von Deinem Unmut?    Grüß schön! 

------------------
Gruß,
runkelruebe          Herr Kann-ich-nich wohnt in der Will-ich-nich-Straße...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Dunkelelf
Mitglied
CAD-Konstrukteur


Sehen Sie sich das Profil von Dunkelelf an!   Senden Sie eine Private Message an Dunkelelf  Schreiben Sie einen Gästebucheintrag für Dunkelelf

Beiträge: 70
Registriert: 10.02.2017

Windows 7
Prozessor: I7-4810, 2,8 GHz mit 32GB RAM
Grafikkarte: NVIDIA Quadro K1100M
AutoCAD 2017, SP1

erstellt am: 11. Jan. 2019 08:48    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo runkelruebe
Alles verstanden. Autodesk werde ich heute mal kontaktieren.
Happy weekend

------------------
freundlich grüßt der Dunkelelf

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Dunkelelf
Mitglied
CAD-Konstrukteur


Sehen Sie sich das Profil von Dunkelelf an!   Senden Sie eine Private Message an Dunkelelf  Schreiben Sie einen Gästebucheintrag für Dunkelelf

Beiträge: 70
Registriert: 10.02.2017

Windows 7
Prozessor: I7-4810, 2,8 GHz mit 32GB RAM
Grafikkarte: NVIDIA Quadro K1100M
AutoCAD 2017, SP1

erstellt am: 14. Jan. 2019 14:28    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo
Habe das Problem an Autodesk weitergeleitet und auch eine Antwort bekommen.

Der Autodesk-Mitarbeiter teilte mir mit das das Verhalten in der Version 2019 und ebenfalls in der Version 2018 reproduzierbar ist (und auch in 2017, wie ich gerade herausgefunden habe).
Aufgrund dessen wird der Fall an die Entwicklung von Autodesk weitergeleitet.
Mal sehen was dabei herauskommt. Werde mich dann mit einem etwaigen Ergebnis wieder melden.

------------------
freundlich grüßt der Dunkelelf

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 19237
Registriert: 03.06.2002

System: F1
und Google

erstellt am: 14. Jan. 2019 14:35    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Dunkelelf 10 Unities + Antwort hilfreich

Mehr lesen = früher wissen (17er) 
Danke für die Meldung beim Support
(nur so besteht überhaupt Hoffnung auf positiver Veränderung, wenn auch dieses Problem hier sicher keine Priorität bekommt)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz