Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Rund um AutoCAD
  AutoCAD (nicht ACADM) mit eigenem Profil?

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   AutoCAD (nicht ACADM) mit eigenem Profil? (995 mal gelesen)
Alexander Doppler
Mitglied
Konstrukteur / CAD-Administrator / CAD-Verantwortlicher


Sehen Sie sich das Profil von Alexander Doppler an!   Senden Sie eine Private Message an Alexander Doppler  Schreiben Sie einen Gästebucheintrag für Alexander Doppler

Beiträge: 145
Registriert: 15.09.2003

Dell Precision 4700 (i7) mit 16GB RAM
NVidia K1000
WIN 7/64Bit / Inventor 2012 / AutoCAD 2012

erstellt am: 29. Mrz. 2016 10:19    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Leute

Ich habe ein kleines Problem und steh grad auf dem Schlauch: Wir sind gerade daran auf die Product Design Suite 2016 zu updaten (ich bereite das Deployment vor). Als Bestandteil davon wird bei uns auch AutoCAD Mechaical installiert. Nun gibt es ja die Möglichkeit, AudoCAD pur (Vanilla) oder eben Mechanical zu starten. Wir haben bei uns im Betrieb immer mit einem eigenen Firmenprofil (.arg) gearbeitet, da wir noch einige Firmenspezifische Pfade und Einstellungen einbringen wollen. Nun hab' ich das Problem, dass mit unserem Profil immer AutoCAD Mechanical gestartet wird (statt das pure AutoCAD) und auch entsprechend eine Fehlermeldung über fehlende Pfadinformationen erscheint.
Ich weiss von früher (2012 und vorher) dass die Info, welche Erweiterungen geladen werden über eine .RX datei gesteuert wird (oder wurde). Irgendwie ist das aber schon sehr lange her und ich bekomm's nicht mehr hin, dass ich AutoCAD pur mit meinem Profil geladen bekomme.

Hier ist was ich in meiner Verknüpfung aufrufe:

"C:\Program Files\Autodesk\AutoCAD 2016\acad.exe" /t "g:\cad\templates\acad 2016\acadm\templates\mc-acad2016.dwt" /product ACADM /p "g:\cad\templates\acad 2016\acadm\profiles\mc-acad2016.arg" /language "de-DE"

Ich habe auch schon versucht den Parameter "/product ACADM" durch "/product ACAD" zu ersetzen, aber erstens funktioniert das nicht und zweitens sehe ich im Aufruf für das Vanilla Profil (im Startmenü), dass auch dort "/product ACADM" hinterlegt ist...

Hat mir irgendjemand von Euch einen guten Hinweis, wie ich das machen kann?

Vielen Dank für Eure Hilfe

Alexander

------------------
«There are two means of refuge from the miseries of life: music and cats.» (Albert Schweitzer)
«The smallest feline is a master piece» (Leonardo Da Vinci)
«Man kann die Menschheit in zwei Gruppen unterteilen: In Katzenliebhaber und solche, die vom Leben benachteiligt sind» (Francesco Petrarca)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Peter2
Ehrenmitglied V.I.P. h.c.




Sehen Sie sich das Profil von Peter2 an!   Senden Sie eine Private Message an Peter2  Schreiben Sie einen Gästebucheintrag für Peter2

Beiträge: 3299
Registriert: 15.10.2003

Win 10/64 Pro
AutoCAD MAP 3D 2018

erstellt am: 30. Mrz. 2016 11:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Alexander Doppler 10 Unities + Antwort hilfreich

Der Parameter "/product .." müsste eigentlich schon der richtige sein. Eventuell als ersten Parameter in der Zeile nach vorne schieben? Kein Tippfehler? Und ev. auch das laden der Profile und des Template anpassen.

------------------
Für jedes Problem gibt es eine einfache Lösung.
Die ist aber meistens falsch. ;-)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Iris2
Mitglied
CAD-Admin


Sehen Sie sich das Profil von Iris2 an!   Senden Sie eine Private Message an Iris2  Schreiben Sie einen Gästebucheintrag für Iris2

Beiträge: 1162
Registriert: 17.02.2004

REVIT 2014/2015/2016
TEKLA Structures
liNear
AutoCAD 2014 / Soficad
ACA 2014
Microstation V8i

erstellt am: 30. Mrz. 2016 11:56    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Alexander Doppler 10 Unities + Antwort hilfreich

Hallo Alexander,

ich hab zwar kein Mechanical am Start aber "meine" Programmaufrufe für "nacktes AutoCAD und AutoCAD Architecture sehen so aus:

"D:\Programme\.....\AutoCAD 2014\acad.exe" /ld "D:\Programme\.....\AutoCAD 2014\AecBase.dbx" /p "V1-2-0" /product "ACA" /language "de-DE"
"D:\Programme\.....\AutoCAD 2014\acad.exe" /p "D:\Programme\.......\V1-1-0.arg"

Vielleicht hilft Dir das etwas weiter.

(Die dwt hab ich im Profil hinterlegt, nicht im Programmaufruf)

------------------
Liebe Grüße
Iris

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CADchup
Ehrenmitglied V.I.P. h.c.




Sehen Sie sich das Profil von CADchup an!   Senden Sie eine Private Message an CADchup  Schreiben Sie einen Gästebucheintrag für CADchup

Beiträge: 3307
Registriert: 14.03.2001

Sicher ist, dass nichts sicher ist. Selbst das nicht.
Joachim Ringelnatz

erstellt am: 30. Mrz. 2016 13:31    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Alexander Doppler 10 Unities + Antwort hilfreich

Hi,

IMHO ist der Schalter /product optional und wird für nacktes AutoCAD nicht benötigt. Weg damit.

Vermutlich fällst du aber auf den Mechanismus herein, wie Acad sein Profil lädt. Du verwendest eine ARG-Datei zum Laden des Profils. Das funktioniert nur so lange, wie es noch kein Profil gleichen Namens gibt. Wenn das Profil schon vorhanden ist, werden die ARG-Einstellungen ignoriert und das bestehende Profil aktiviert.


Gruß
CADchup

------------------
CADmaro.de

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Alexander Doppler
Mitglied
Konstrukteur / CAD-Administrator / CAD-Verantwortlicher


Sehen Sie sich das Profil von Alexander Doppler an!   Senden Sie eine Private Message an Alexander Doppler  Schreiben Sie einen Gästebucheintrag für Alexander Doppler

Beiträge: 145
Registriert: 15.09.2003

Dell Precision 4700 (i7) mit 16GB RAM
NVidia K1000
WIN 7/64Bit / Inventor 2012 / AutoCAD 2012

erstellt am: 31. Mrz. 2016 08:21    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Vielen Dank für die vielen Anregungen

Im Grunde genommen hab' ich das selbe geschrieben wie beim Programmlink für "vanilla" welches sich im Startmenü befindet - einfach erweitert. Interessant ist, dass wenn ich mein "/p ..." Schalter auf /p <<VANILLA>> setze, klappt's 

Wie gesagt, ich habe von früher irgend wie im Kopf gehabt, dass das Zuladen von Modulen (.ARX) über eine Datei mit Endung .RX gesteuert wird. Ich weiss einfach nicht ob das immer noch so ist. Zumindest für den Splashscreen (welcher ja schon andeutet ob Mechanical oder AutoCAD pur geladen wird) scheint das nicht relevant zu sein, denn der kommt so brutal schnell, dass der in dieser Zeit unmöglich alle ARX-Erweiterungen nachgeladen haben kann.

Was ich gemerkt habe, ist dass wenn ich meine zusätzlichen Supportpfadangaben im Profil nicht an oberste Stelle setze sondern zuunterst, meckert er wenigstens nicht von wegen "fehlenden Pfadinformationen".

@ CADchup: Hmm... Da sagt aber AutoDesk was anderes: https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/Startup-switches-for-AutoCAD.html

Gruss
Alexander

------------------
«There are two means of refuge from the miseries of life: music and cats.» (Albert Schweitzer)
«The smallest feline is a master piece» (Leonardo Da Vinci)
«Man kann die Menschheit in zwei Gruppen unterteilen: In Katzenliebhaber und solche, die vom Leben benachteiligt sind» (Francesco Petrarca)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CADchup
Ehrenmitglied V.I.P. h.c.




Sehen Sie sich das Profil von CADchup an!   Senden Sie eine Private Message an CADchup  Schreiben Sie einen Gästebucheintrag für CADchup

Beiträge: 3307
Registriert: 14.03.2001

Sicher ist, dass nichts sicher ist. Selbst das nicht.
Joachim Ringelnatz

erstellt am: 31. Mrz. 2016 10:34    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Alexander Doppler 10 Unities + Antwort hilfreich

Hi,

was meinst du?
Den /product-Schalter? Dann formuliere ich um: Der Schalter wird benötigt, wenn eine bestimmte Ausprägung von AutoCAD gestartet werden soll. Wenn der Schalter fehlt, wird IMHO ACAD gestartet.
Was an ARXen oder zusätzlichen Tools geladen wird, bestimmen beim Start der Schalter /ld (und z.Bsp. /b), das Profil, die acad.rx, wenn es sie gibt/für Acad greifbar ist (und die zu finden sein sollte, wenn es sie denn gibt) und diverse andere kleine Hebelchen.

Keine Ahnung, wie Mechanical sich lädt, aber ich denke nach wie vor, dass du zuerst mal die ARG-Geschichte ausschließen solltest.


Gruß
CADchup

------------------
CADmaro.de

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Peter2
Ehrenmitglied V.I.P. h.c.




Sehen Sie sich das Profil von Peter2 an!   Senden Sie eine Private Message an Peter2  Schreiben Sie einen Gästebucheintrag für Peter2

Beiträge: 3299
Registriert: 15.10.2003

Win 10/64 Pro
AutoCAD MAP 3D 2018

erstellt am: 31. Mrz. 2016 11:56    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Alexander Doppler 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Alexander Doppler:
...Interessant ist, dass wenn ich mein "/p ..." Schalter auf /p <<VANILLA>> setze, klappt's   ...

Ich denke, das ist das gleiche, was CADchup sagt - das Profil setzt irgendwelche Pfade und/oder Startgruppen, in den Pfaden werden irgendwelche MNL/acad.rx oder was auch immer gefunden und abgearbeitet, und dann kommt eine Mischung zwischen Pur und MEP heraus. Durch "/p <<Vanilla>>" oder "/p frznpf" oder ... wird die Grundeinstellung geladen, und dann scheint es zu klappen.

------------------
Für jedes Problem gibt es eine einfache Lösung.
Die ist aber meistens falsch. ;-)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Alexander Doppler
Mitglied
Konstrukteur / CAD-Administrator / CAD-Verantwortlicher


Sehen Sie sich das Profil von Alexander Doppler an!   Senden Sie eine Private Message an Alexander Doppler  Schreiben Sie einen Gästebucheintrag für Alexander Doppler

Beiträge: 145
Registriert: 15.09.2003

Dell Precision 4700 (i7) mit 16GB RAM
NVidia K1000
WIN 7/64Bit / Inventor 2012 / AutoCAD 2012

erstellt am: 31. Mrz. 2016 16:04    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Also, ich hab jetzt einfach mal das <<VANILLA>> Profil genommen und auf meine Bedürfnisse angepasst und unter neuem Namen gespeichert (und das in allen 3 Sprachen, da wir im Konzern mit DE, EN und FR arbeiten). Nun bringt AutoCAD zwar immer noch (oder wieder) den Mechanical-Splashscreen, aber zumindest scheint es keine Mechanical-Module nachzuladen, da im Optionen Dialog nach dem Tab "Profil" keine weiteren Tabs mehr erscheinen.
Somit scheint's einigermassen geklappt zu haben, aber die Lösung dünkt mich ein bisschen "Von Hinten durch die Brust in's Auge" und das Wie und Warum ist mir damit auch nicht klar.  Also kann ich nur hoffen, dass es so bleibt, wie's im Moment ist.

Danke trotzdem an alle für alle wertvollen Hinweise

Gruss
Alexander

------------------
«There are two means of refuge from the miseries of life: music and cats.» (Albert Schweitzer)
«The smallest feline is a master piece» (Leonardo Da Vinci)
«Man kann die Menschheit in zwei Gruppen unterteilen: In Katzenliebhaber und solche, die vom Leben benachteiligt sind» (Francesco Petrarca)

[Diese Nachricht wurde von Alexander Doppler am 31. Mrz. 2016 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz