Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Rund um AutoCAD
  Layer-Eigenschaftsfilter - Filterdefinitionen

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Layer-Eigenschaftsfilter - Filterdefinitionen (1292 mal gelesen)
CSchubert
Mitglied
Ausgrabungsingenieur


Sehen Sie sich das Profil von CSchubert an!   Senden Sie eine Private Message an CSchubert  Schreiben Sie einen Gästebucheintrag für CSchubert

Beiträge: 42
Registriert: 10.05.2005

Windows 7
ACAD 2010
TachyCAD, PhoToPlan

erstellt am: 05. Mai. 2015 16:07    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,
wir haben hier ein Problem mit den Filterdefinitionen der Layer-Eigenschaftsfilter. Die Anzahl der für einen Filter möglichen Definitionen scheint begrenzt zu sein. Wir können zwar bei der Erstellung eines Filters beliebig viele Filterdefinitionen angeben, es werden jedoch nicht alle übernommen. Merkwürdigerweise variiert die Zahl der Definitionen, die übernommen werden aus nicht nachvollziehbarem Grund so zwischen 12 und 16.
An der Datei selbst scheint es nicht zu liegen (kopieren des gesamten Dateiinhalts in eine leere Zeichnung und speichern als .dxf haben nicht geholfen). Gibt es evtl. doch eine Systemvariable dazu?
Hat jemand eine Idee dazu?

Grüße,
Christof

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 19237
Registriert: 03.06.2002

System: F1
und Google

erstellt am: 05. Mai. 2015 16:32    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CSchubert 10 Unities + Antwort hilfreich

Sei doch so gütig und lade den Helfern eine entsprechende DWG (mit definierten Layern und Filter(n) hoch,
dann testet man auch gerne (mehr Leute = mehr Power) und deine Chancen auf Lösungen oder wenigstens Hintergrundinformationen wächst!

Wenn ich eine Datei habe, dann sehe ich gerne nach..
Am besten natürlich mit Angabe eines konkreten Beispieles:
FilterXXX müßte Layer XY ausblenden, macht das aber nicht..

Zur Zeit könnte es vieles sein, selbst ein Anwenderfehler (Erwartungshaltung anders wie das Programm tickt),
mit DWG siht das dann schon anders aus   

------------------
CAD on demand GmbH - Beratung und Programmierung rund um AutoCAD

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Entsorger01
Moderator
Techniker




Sehen Sie sich das Profil von Entsorger01 an!   Senden Sie eine Private Message an Entsorger01  Schreiben Sie einen Gästebucheintrag für Entsorger01

Beiträge: 3165
Registriert: 07.07.2006

ACAD 2014 - SP1
VPstudio (Raster)
Acrobat Prof. X
Photoshop CS6
Win7

erstellt am: 06. Mai. 2015 07:14    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CSchubert 10 Unities + Antwort hilfreich

  Hatten wir schon, leider ohne "richtige" Lösung. Aber mal schauen, vielleicht kommt dieses mal mehr rum?!

Damals kam die TH zumindest auf einen Workarround --> Filtererstellung per KLASSLAYER

------------------
Gruß

Michi

"Es ist schon alles gesagt, nur noch nicht von allen." (Karl Valentin)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CSchubert
Mitglied
Ausgrabungsingenieur


Sehen Sie sich das Profil von CSchubert an!   Senden Sie eine Private Message an CSchubert  Schreiben Sie einen Gästebucheintrag für CSchubert

Beiträge: 42
Registriert: 10.05.2005

Windows 7
ACAD 2010
TachyCAD, PhoToPlan

erstellt am: 06. Mai. 2015 07:34    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke für den Hinweis auf den anderen Thread, den muss ich mir mal in Ruhe anschauen. Ich hatte zwar selbst schon gesucht, aber den muss ich wohl übersehen haben.
Die Datei wird von einem Kollegen bearbeitet, ich muss erst mal nachfragen ob ich die hier hochladen darf.

Grüße,
Christof

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 19237
Registriert: 03.06.2002

System: F1
und Google

erstellt am: 06. Mai. 2015 07:48    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CSchubert 10 Unities + Antwort hilfreich

Super Link, man was für ein Patient.
Aber mit dem Unterschied das damals Filter verschwanden / nicht vorhanden und ignoriert wurden.

Die Workaround Ansätze wären auch hier passend, nur die DWG um das Problem nachvollziehen zu können wäre noch hilfreich.

Edit: Wir brauchen Layer&Layerfilter, das kann wohl kaum ein riesen Geheimnis sein 
------------------
CAD on demand GmbH - Beratung und Programmierung rund um AutoCAD

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Entsorger01
Moderator
Techniker




Sehen Sie sich das Profil von Entsorger01 an!   Senden Sie eine Private Message an Entsorger01  Schreiben Sie einen Gästebucheintrag für Entsorger01

Beiträge: 3165
Registriert: 07.07.2006

ACAD 2014 - SP1
VPstudio (Raster)
Acrobat Prof. X
Photoshop CS6
Win7

erstellt am: 06. Mai. 2015 08:08    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CSchubert 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von cadffm:

Aber mit dem Unterschied das damals Filter verschwanden / nicht vorhanden und ignoriert wurden.


Stellt sich die Frage, ob die Filterkriterien wirklich nur ignoriert werden, oder Christof nur noch nicht bemerkt hat, dass sie garnicht mehr vorhanden sind? ;)
Zitat:
Original erstellt von cadffm:

[...] nur die DWG um das Problem nachvollziehen zu können wäre noch hilfreich.


Ein Versuch wäre es wert, wobei ich allerdings befürchte, dass wie beim anderen Thread das Problem an anderen Rechnern nicht auftritt (siehe Beitrage von ruebe)

------------------
Gruß

Michi

"Es ist schon alles gesagt, nur noch nicht von allen." (Karl Valentin)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CSchubert
Mitglied
Ausgrabungsingenieur


Sehen Sie sich das Profil von CSchubert an!   Senden Sie eine Private Message an CSchubert  Schreiben Sie einen Gästebucheintrag für CSchubert

Beiträge: 42
Registriert: 10.05.2005

Windows 7
ACAD 2010
TachyCAD, PhoToPlan

erstellt am: 06. Mai. 2015 16:35    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


PL-72_Gesamtplan.txt

 
So, hier die leere Datei mit den Filtern. Das Problem ist genau das gleiche wie in dem anderen Thread beschrieben. In dem in der angehängten Datei angelegten Filter "Eigenschaftsfilter1" sollen eigentlich noch weitere Definitionen rein, die zwar hinzugefügt werden können, dann aber nicht übernommen werden. Beim Schließen des Dialogfelds für die Layerfiltereigenschaften ertönt dann eine akustische Fehlermeldung ("pling"). So lange der Layereigenschaften-Manager geöffnet ist, sind die hinzugefügten Definitionen bei erneutem Öffnen des Layerfilters noch vorhanden. Wird der Manager geschlossen und anschließend wieder geöffnet fehlen die Definitionen. Das Problem tritt bei uns auf unterschiedlichen Rechnern auf.

Gruß,
Christof

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 19237
Registriert: 03.06.2002

System: F1
und Google

erstellt am: 06. Mai. 2015 17:08    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CSchubert 10 Unities + Antwort hilfreich


1_Layerfiltertest_150506.dwg

 
PS: DWG kann (und sollte) man direkt anhängen, eine Änderung der Dateierweiterung(auf zB. TXT) ist nicht nötig und nicht gewünscht, fürs nächste Mal, danke.

Zum Problem: Super, wenn es also so ist wie im anderen Thread, wie sieht es dann mit der dortigen Lösung aus?

PS: Danke für die DWG, aber schade das du dort auch die Layer gelöscht hast, ich werde jetzt aber keine 20 Layer anlegen um testen zu können  

Kurzer Test meinerseits: Über die Layerpalette (in Acad2013) habe ich jetzt deinem Filter einige Zeilen hinzugefügt,
ich habe jetzt 30 Einträge/Zeilen und diese bleiben auch erhalten (nach speichern,schließen,öffnen der Datei).

Ob die Filter funktionieren kann ich nicht restlos klären, dafür müßte ich ja enstprechend die Layer anlegen  

Also bei mir funktioniert es (wenn ich jetzt das vorgehen nicht falsch verstanden hatte).
Davon unabhängig kannst du ja mal, wie im anderen Thread angesprochen, die Layerfilter über KLASSLAYER erweitern und testen!?

komische Sache.

------------------
CAD on demand GmbH - Beratung und Programmierung rund um AutoCAD

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

mcap
Mitglied
CAD-Supporter


Sehen Sie sich das Profil von mcap an!   Senden Sie eine Private Message an mcap  Schreiben Sie einen Gästebucheintrag für mcap

Beiträge: 75
Registriert: 13.11.2014

erstellt am: 06. Mai. 2015 17:28    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CSchubert 10 Unities + Antwort hilfreich


PL-72_Gesamtplan_mc.dwg

 
Hallo Christof

Habe in deiner Zeichnung 20 zusätzliche Zeilen zum Filter Eigenschaftsfilter1 hinzugefügt und entsprechende Layer erzeugt.
Der Filter arbeitet m.E. tadellos (AutoCAD 2014).

------------------
Gruss Marco

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Entsorger01
Moderator
Techniker




Sehen Sie sich das Profil von Entsorger01 an!   Senden Sie eine Private Message an Entsorger01  Schreiben Sie einen Gästebucheintrag für Entsorger01

Beiträge: 3165
Registriert: 07.07.2006

ACAD 2014 - SP1
VPstudio (Raster)
Acrobat Prof. X
Photoshop CS6
Win7

erstellt am: 07. Mai. 2015 07:04    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CSchubert 10 Unities + Antwort hilfreich

Na, da bin ich ja mit meiner Befürchtung richtig gelegen. Wie im anderen Thread - nicht nachvollziehbar. Ich hab's mit ACAD2012 getestet.

Wenn ich mir allerdings das Datum des anderen Threads anschaue, tendiere ich in die Richtung "ACAD-2010-Bug".

@Christof: Laufen alle Rechner, bei denen der Fehler auftritt mit ACAD2010?

Vielleicht kann's ja hier auch nochmal einer mit dieser Version testen. Ich hab sie leider nicht mehr am Start.

------------------
Gruß

Michi

"Es ist schon alles gesagt, nur noch nicht von allen." (Karl Valentin)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 19237
Registriert: 03.06.2002

System: F1
und Google

erstellt am: 07. Mai. 2015 08:48    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CSchubert 10 Unities + Antwort hilfreich

Entsorger liegt richtig, ist ein 2010Problem, schau also ob das neueste ServicePack installiert ist, mehr kann man nicht machen.
(habe es in 2010 ohne SP nachvollziehen können)

Sonst bleibt nur den Klasslayer zum ändern/erstellen zu nutzen.

------------------
CAD on demand GmbH - Beratung und Programmierung rund um AutoCAD

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CSchubert
Mitglied
Ausgrabungsingenieur


Sehen Sie sich das Profil von CSchubert an!   Senden Sie eine Private Message an CSchubert  Schreiben Sie einen Gästebucheintrag für CSchubert

Beiträge: 42
Registriert: 10.05.2005

Windows 7
ACAD 2010
TachyCAD, PhoToPlan

erstellt am: 07. Mai. 2015 08:55    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Erst mal vielen Dank für's "dran bleiben" !!
Von dem Kollegen, der die Zeichnung bearbeitet hatte ich die Rückmeldung bekommen, dass die Lösungsansätze aus dem anderen Thread nicht weiter helfen. Hab mich jetzt selbst nochmal dran gesetzt: Der Umweg über KLASSLAYER funktioniert, ABER: Sobald der Standard-Layereigenschaftsmanager wieder geöffnet wird (LAYER), werden die hinzugefügten Filterdefinitionen wieder gelöscht (wahrscheinlich kam deshalb die Aussage, dass auch dieser Weg nicht weiter hilft). Interessanterweise tritt das bei der Zeichnung von cadffm nicht auf. Die die mit ACAD2013 erstellten Definitionen bleiben auch in der 2010er-Version und bei Benutzung des LAYER-Befehls erhalten, solange man nicht versucht, per LAYER weitere Definitionen hinzuzufügen. Dann gehen nämlich wieder alle Filter ab dem 13. verloren. Gleiches gilt für die Zeichnung von Marco.
Hab das Ganze dann hier auch nochmal mit einer 2013er-Version getestet, dort gibt es keine Probleme. Es scheint sich also wie von Michi vermutet um einen Bug der 2010er-Version zu handeln.

Zusammenfassend also: Es handelt sich um ein 2010-spezifisches Problem, dass sich unter dann zwingend dauerhafter Benutzung des Befehls KLASSLAYER umgehen lässt.

Vielen Dank für Eure Hinweise und Hilfe!!

Christof

[Diese Nachricht wurde von CSchubert am 07. Mai. 2015 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz