Hot News:

Unser Angebot:

  Foren auf CAD.de (alle Foren)
  Inventor .NET
  Problem mit Kürzel STRG+V

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
  
Gut zu wissen: Hilfreiche Tipps und Tricks aus der Praxis prägnant, und auf den Punkt gebracht für Autodesk Produkte
Autor Thema:  Problem mit Kürzel STRG+V (1638 mal gelesen)
yamaha
Mitglied
Konstrukteur


Sehen Sie sich das Profil von yamaha an!   Senden Sie eine Private Message an yamaha  Schreiben Sie einen Gästebucheintrag für yamaha

Beiträge: 372
Registriert: 19.05.2004

Autocad/Inventor 2019, Windows 7 Pro 64Bit

erstellt am: 29. Sep. 2011 21:36    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen,
kennt Ihr das Problem das man Texte aus der Zwischenablage nicht mit dem Kürzel STRG+V in eine Textbox einzufügen kann.
Ich habe eine Anwendung als Exe, bei der funktioniert alles einwandfrei.
Beim Add-In in Inventor funktioniert es nicht.
Bin schon alle Einstellungen durchgegangen aber leider habe ich keinen Fehler erkannt. Im Google-Web stehen zum Teil Berichte das dies bei .Net vorkommen kann, aber auch dort habe ich keine Lösung für das Phänomen erhalten.
Dies ist ja nun kein spezielles Problem der Inventor API,
aber vielleicht weiß ja doch einer eine Lösung.
Vielen Dank für Ihre Hilfe.

------------------
Gruß Jörn

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas01
Mitglied
Dipl.-Ing.(FH) Konstrukteur


Sehen Sie sich das Profil von Andreas01 an!   Senden Sie eine Private Message an Andreas01  Schreiben Sie einen Gästebucheintrag für Andreas01

Beiträge: 227
Registriert: 05.08.2004

Inventor 2020
i7
32 GB RAM
Quatro FX 4000
WIN10-64bit

erstellt am: 30. Sep. 2011 08:57    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Hallo,
ja das Problem kenne ich leider auch, eine Lösung habe ich leider nicht.

Gruß
Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

yamaha
Mitglied
Konstrukteur


Sehen Sie sich das Profil von yamaha an!   Senden Sie eine Private Message an yamaha  Schreiben Sie einen Gästebucheintrag für yamaha

Beiträge: 372
Registriert: 19.05.2004

Autocad/Inventor 2019, Windows 7 Pro 64Bit

erstellt am: 04. Okt. 2011 08:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Andreas,
ich habe mittlerweile herausgefunden, das es funktioniert, wenn
man das entsprechende Formular mit .showdialog aufruft.
Aber (Auszug aus der Hilfe):
=====================================
Wenn ein Formular als modal angezeigt wird, wird der Code, der der ShowDialog-Methode folgt, erst nach dem Schließen des Dialogfelds ausgeführt. Wird das Formular jedoch nicht modal angezeigt, wird der auf die Show-Methode folgende Code gleichzeitig mit der Anzeige des Formulars ausgeführt.
=====================================
Und das ist dann auch nicht gut. 

------------------
Gruß Jörn

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Evil_Bart
Mitglied
CAD Admin (Freiberuflich)


Sehen Sie sich das Profil von Evil_Bart an!   Senden Sie eine Private Message an Evil_Bart  Schreiben Sie einen Gästebucheintrag für Evil_Bart

Beiträge: 137
Registriert: 14.08.2003

- Win XP SP3
CAD:
- Inventor 2009 Pro
- AM 2009
- SAP/PLM

erstellt am: 02. Jun. 2015 13:08    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Hallo zusammen
Nun habe ich genau diese Problem und wollte mich mal erkundigen ob
irgend jemand da schon eine Lösung gefunden hat.

Gruß
Andreas


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Chris 31
Mitglied
Konstrukteur und Mädchen für alles


Sehen Sie sich das Profil von Chris 31 an!   Senden Sie eine Private Message an Chris 31  Schreiben Sie einen Gästebucheintrag für Chris 31

Beiträge: 575
Registriert: 23.04.2013

Inventor 2015 Professional
Windows 7 64 bit
16GB RAM
nVidia Quadro 600

erstellt am: 03. Jun. 2015 06:20    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Hallo,

was genau ist denn dein Problem?

Du möchtest in eine Form etwas in ein Textfeld einfügen, während im Hintergrund der aufrufende Code weiterläuft?

------------------
MFG

Chris

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Evil_Bart
Mitglied
CAD Admin (Freiberuflich)


Sehen Sie sich das Profil von Evil_Bart an!   Senden Sie eine Private Message an Evil_Bart  Schreiben Sie einen Gästebucheintrag für Evil_Bart

Beiträge: 137
Registriert: 14.08.2003

- Win XP SP3
CAD:
- Inventor 2009 Pro
- AM 2009
- SAP/PLM

erstellt am: 03. Jun. 2015 06:33    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Hi und und guten Morgen
Einfach Copy&Paste (STRG+C - STRG+V) in einer Form+Textbox aus einem  Add-In. (siehe Beitrag ganz oben!)

Gruß
Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Chris 31
Mitglied
Konstrukteur und Mädchen für alles


Sehen Sie sich das Profil von Chris 31 an!   Senden Sie eine Private Message an Chris 31  Schreiben Sie einen Gästebucheintrag für Chris 31

Beiträge: 575
Registriert: 23.04.2013

Inventor 2015 Professional
Windows 7 64 bit
16GB RAM
nVidia Quadro 600

erstellt am: 03. Jun. 2015 06:43    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Ja, aber soll das Programm währenddessen im Hintergrund weitere Sachen ausführen, oder warten, bis die Eingabe auf der Form erfolgt ist?

------------------
MFG

Chris

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Evil_Bart
Mitglied
CAD Admin (Freiberuflich)


Sehen Sie sich das Profil von Evil_Bart an!   Senden Sie eine Private Message an Evil_Bart  Schreiben Sie einen Gästebucheintrag für Evil_Bart

Beiträge: 137
Registriert: 14.08.2003

- Win XP SP3
CAD:
- Inventor 2009 Pro
- AM 2009
- SAP/PLM

erstellt am: 03. Jun. 2015 06:55    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Wenn die Form geladen ist (.show) wurde alles abgearbeitet (z.B. lesen von Properties).
Nun sollen Textfelder editiert werden. Und hier funktioniert Copy&Paste nicht.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Chris 31
Mitglied
Konstrukteur und Mädchen für alles


Sehen Sie sich das Profil von Chris 31 an!   Senden Sie eine Private Message an Chris 31  Schreiben Sie einen Gästebucheintrag für Chris 31

Beiträge: 575
Registriert: 23.04.2013

Inventor 2015 Professional
Windows 7 64 bit
16GB RAM
nVidia Quadro 600

erstellt am: 03. Jun. 2015 07:07    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Rufst du die Form mit .Show oder mit .showdialog auf?

mit .showdialog sollte es eigentlich funktionieren.


EDIT: Sorry, hab das (.Show) überlesen.
Dann versuchs mal mit der .showdialog.


------------------
MFG

Chris

[Diese Nachricht wurde von Chris 31 am 03. Jun. 2015 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Fiedel93felix
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Fiedel93felix an!   Senden Sie eine Private Message an Fiedel93felix  Schreiben Sie einen Gästebucheintrag für Fiedel93felix

Beiträge: 448
Registriert: 19.02.2014

Autodesk Inventor 2014
Microsoft Visual Basic 2010

erstellt am: 03. Jun. 2015 07:11    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Hast du dir den Beitrag überhaupt richtig durchgelesen Andreas?


Im 2. Beitrag von Yamaha wird doch erklärt wie es geht.....
Und da du nichts im hintergrund machen lässt ist das ja auch kein Problem....
also ersetzt du einfach dein
      "Formular".show
durch
      "Formular".showdialog

Und schon funktioniert es!

Nur wenn du im hintergrund Berechnungen oder irgendwas laufen haben willst klappt .showdialog nicht.

MfG Felix

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Evil_Bart
Mitglied
CAD Admin (Freiberuflich)


Sehen Sie sich das Profil von Evil_Bart an!   Senden Sie eine Private Message an Evil_Bart  Schreiben Sie einen Gästebucheintrag für Evil_Bart

Beiträge: 137
Registriert: 14.08.2003

- Win XP SP3
CAD:
- Inventor 2009 Pro
- AM 2009
- SAP/PLM

erstellt am: 03. Jun. 2015 07:21    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Ich habe mich nicht ganz richtig ausgedrückt!
Also:
- Form laden mit
Code:
Form.show

- Jetzt werden einige Properties gelesen und in die dazugehörigen Textfelder geschrieben (es wird also was gelesen! Daher geht es nicht mit .Showdialog).
- Wenn das fertig ist dann wartet die Form auf Eingaben.

Ich hatte die Frage so verstanden ob ab HIER noch etwas passieren soll!

Gruß
Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Fiedel93felix
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Fiedel93felix an!   Senden Sie eine Private Message an Fiedel93felix  Schreiben Sie einen Gästebucheintrag für Fiedel93felix

Beiträge: 448
Registriert: 19.02.2014

Autodesk Inventor 2014
Microsoft Visual Basic 2010

erstellt am: 03. Jun. 2015 07:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Naja du hast das auch richtig verstanden.....denke ich.

Also deine Form wird geöffnet
dann werden iprops eingelesen
dann sollen die auf form angezeigt werden
dann Eingabe mit STRG+V
?
So is doch der Ablauf?

Dann mit .Showdialog

Showdialog kannst du soweit ich weiß nur nicht nehmen wenn du im Hintergrund (während der Eingabe) was machen lässt.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Chris 31
Mitglied
Konstrukteur und Mädchen für alles


Sehen Sie sich das Profil von Chris 31 an!   Senden Sie eine Private Message an Chris 31  Schreiben Sie einen Gästebucheintrag für Chris 31

Beiträge: 575
Registriert: 23.04.2013

Inventor 2015 Professional
Windows 7 64 bit
16GB RAM
nVidia Quadro 600

erstellt am: 03. Jun. 2015 07:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Guten Morgen Felix,

genau so sehe ich das auch.

In dem Form.Load die Properties lesen und in die Felder füllen lassen. Die Form mit Form.ShowDialog aufrufen und dann sollte auch STRG+V funktionieren.

------------------
MFG

Chris

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Evil_Bart
Mitglied
CAD Admin (Freiberuflich)


Sehen Sie sich das Profil von Evil_Bart an!   Senden Sie eine Private Message an Evil_Bart  Schreiben Sie einen Gästebucheintrag für Evil_Bart

Beiträge: 137
Registriert: 14.08.2003

- Win XP SP3
CAD:
- Inventor 2009 Pro
- AM 2009
- SAP/PLM

erstellt am: 03. Jun. 2015 08:09    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Hallo Felix, Hallo Chris
Nun hab ich es auch endlich verstanden!
Habs gerade ausprobiert.. Copy&Past funktioniert!

Vielen Dank für die Mühe und Gruß aus Kiel
Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Fiedel93felix
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Fiedel93felix an!   Senden Sie eine Private Message an Fiedel93felix  Schreiben Sie einen Gästebucheintrag für Fiedel93felix

Beiträge: 448
Registriert: 19.02.2014

Autodesk Inventor 2014
Microsoft Visual Basic 2010

erstellt am: 03. Jun. 2015 08:13    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Das klingt sehr gut 

Dann noch viel erfolg beim Programmieren 

MfG Felix

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Chris 31
Mitglied
Konstrukteur und Mädchen für alles


Sehen Sie sich das Profil von Chris 31 an!   Senden Sie eine Private Message an Chris 31  Schreiben Sie einen Gästebucheintrag für Chris 31

Beiträge: 575
Registriert: 23.04.2013

Inventor 2015 Professional
Windows 7 64 bit
16GB RAM
nVidia Quadro 600

erstellt am: 03. Jun. 2015 08:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für yamaha 10 Unities + Antwort hilfreich

Kein Problem,

Gruß aus dem tiefsten Bayern an die alte Heimat. (Komme eigentlich aus Rendsburg)

------------------
MFG

Chris

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2023 CAD.de | Impressum | Datenschutz