Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  AutoCAD Architecture ACA (ADT)
  If- Then Abfragen, ACA2011

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   If- Then Abfragen, ACA2011 (1183 mal gelesen)
Hannes_G
Mitglied



Sehen Sie sich das Profil von Hannes_G an!   Senden Sie eine Private Message an Hannes_G  Schreiben Sie einen Gästebucheintrag für Hannes_G

Beiträge: 26
Registriert: 04.03.2005

Windows 7Pro,SP1
Intel Core i7-2600 3.4GHz, 8GB-RAM,
NVIDIA Qudro 2000
ACA2011-ACA2013
DACH-Erweiterung
HP DesignJet 1050C/1055CM, 1100, 5500PS

erstellt am: 19. Aug. 2011 16:10    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Zonen-Test.zip

 
Hallo zusammen,

ich habe mich mit dem Beitrag von Thorsten Simon zu If- Then Abfragen beschäftigt und möchte eine Bauteiltabelle mit einer Zonenauswertung erstellen. Leider komme ich da nicht an das gewünschte/gezeigte Ergebnis. Immer wenn ich eine eigene Abfrage definiere wird mir als Ergebnis in der Bauteiltabelle der gesamte Skriptcode/die Formel angezeigt.
Selbst das Kopieren eines vorhandenen Scriptes bzw. einer Formel funktioniert nicht, da hier der Bezug zur Eigenschaftsdefinition verloren geht. Auch das wiederherstellen des Bezuges zur Eigenschaft bringt da keine Besserung.

Anbei meine Test-Datei.
Die linke Tabelle (Räume–Summen Flächenarten test) habe ich aus dem portfolio von ACA kopiert, eine Spalte (NF6a) eingefügt und sollte eigentlich das gleiche Anzeigen wie in Spalte NF6, weil ich hier die Formel aus Spalte NF6 kopiert habe.
Die rechte Tabelle (Benchmark – Flächen nach DIN…) habe ich komplett neu aufgebaut.
In der Spalte NF Büro sollte das Ergebnis

0 m²
2455,20 m²
0 m²

und in der Spalte VF Mall

3619,86m²
0 m²
0 m²

stehen.

Kann mir jemand sagen was hier falsch läuft?

Vielen Dank im Voraus

Gruß
Hannes

[Diese Nachricht wurde von Hannes_G am 19. Aug. 2011 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

dani100
Mitglied
Architekt (Dipl.-Ing.)


Sehen Sie sich das Profil von dani100 an!   Senden Sie eine Private Message an dani100  Schreiben Sie einen Gästebucheintrag für dani100

Beiträge: 360
Registriert: 22.09.2003

ACA 2014 (2017/2019)
WIN 8.1, DACH-Erweiterungen

erstellt am: 21. Aug. 2011 17:25    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Hannes_G 10 Unities + Antwort hilfreich

Es liegt m.E. an der Format-Einstellung im Formel-Dialog (Mitte rechts).
Wenn man da "Standard" wählt müßte es gehen.
Warum das so ist weiß ich aber auch nicht.

Dani

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Hannes_G
Mitglied



Sehen Sie sich das Profil von Hannes_G an!   Senden Sie eine Private Message an Hannes_G  Schreiben Sie einen Gästebucheintrag für Hannes_G

Beiträge: 26
Registriert: 04.03.2005

Windows 7Pro,SP1
Intel Core i7-2600 3.4GHz, 8GB-RAM,
NVIDIA Qudro 2000
ACA2011-ACA2013
DACH-Erweiterung
HP DesignJet 1050C/1055CM, 1100, 5500PS

erstellt am: 21. Aug. 2011 22:00    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Ein Traum...
Daran lag es.
Vielen, vielen Dank für die Info Dani!


Hannes

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

tmoehlenhoff
Moderator
Gutzum, CAD-Therapeut und BIM-Priester ;-)




Sehen Sie sich das Profil von tmoehlenhoff an!   Senden Sie eine Private Message an tmoehlenhoff  Schreiben Sie einen Gästebucheintrag für tmoehlenhoff

Beiträge: 2996
Registriert: 14.10.2002

AutoCAD, AutoCAD Architecture, Revit Architecture, Building Design und Honeymoon Suite und das ganze auch gerne mal auf einem Mac

erstellt am: 22. Aug. 2011 10:09    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Hannes_G 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von dani100:

...
Warum das so ist weiß ich aber auch nicht.
...
Dani

Das ist so weil die anderen Formate in der Regel noch ein Präfix oder Suffix ergänzen (z.B. ein m²) und damit rechnet es sich dann schlecht, weil es nicht mehr nur eine Zahl ist. Bei Standard fällt dies weg und somit löst man damit das Problem.

sayonara
Torsten
ACAD-Systemhaus Bremen

------------------
Tadle nicht den Fluss, wenn Du ins Wasser fällst.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz