Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Solid Edge
  Hintergrundblatt tauschen in ST6

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Hintergrundblatt tauschen in ST6 (3903 mal gelesen)
Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 29. Jan. 2014 15:44    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo miteinander,

bisher tauschen wir bei Zeichnungen, die wir überarbeiten das Hintergrundblatt mit dem Makro CBSheets_V1025.exe.
Obwohl das Makro schon etwas älter ist, hat es bisher klaglos bis ST5 funktioniert.
Auf meiner Testinstallation von ST6 MP3 sind nach dem Tausch plötzlich die Hintergrundblätter leer, obwohl zwischendurch die richtigen Hintergrundblätter aufblitzen.
Nutzt jemand anderes auch das Makro und kann das Verhalten bei ST6 nachvollziehen?
Wie aktualisiert Ihr die Hintergrundblätter bei alten Zeichnungen, die revisioniert werden?

------------------
Gruß Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

RayBan
Mitglied
CAD/PLM-Consultant


Sehen Sie sich das Profil von RayBan an!   Senden Sie eine Private Message an RayBan  Schreiben Sie einen Gästebucheintrag für RayBan

Beiträge: 620
Registriert: 04.02.2002

ST10 aktuelles MP
Win 7 64-Bit Prof
EdgePLM COMPACT
EdgePLM Parts

erstellt am: 29. Jan. 2014 19:01    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Hallo,

das ist mir auch schon aufgefallen aber eine Lösung kenn ich auch noch nicht. Da es ein Freewaretool ist bleibt zu hoffen, dass der Entwickler es nochmal anpasst.
Das wäre wohl die einfachste Lösung.

Gruß Markus

------------------
Und er sagte noch: "noch nicht klicken".....

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 30. Jan. 2014 15:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo miteinander,

mit den Optionen im Makro lässt sich nichts machen.
Soweit ich herausgefunden habe, kann am Makro nicht viel fehlen.
Die Hintergrundblätter werden sauber geputzt.
Der Inhalt der Hintergründe der Vorlage wird extrahiert.
Es fehlt nur das Ablegen auf dem Hintergrundblatt.
Nach dem Ende des Makros ist der Inhalt des letzten Hintergrundblatts der Vorlage in der Zwischenablage.
Auch ein Block der in unserer Vorlage enthalten ist, ist in die neue Datei übertragen.
Leider kenne ich mich mit Programmierung nicht aus.
Der Quelltext wäre über die Quelle des Makrodownloads bei www.incobase.de zu beziehen.

siehe auch den Beitrag von vor 2 Jahren: http://ww3.cad.de/foren/ubb/Forum3/HTML/009678.shtml

------------------
Gruß
Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ckunkel72
Mitglied
CAD Konstruktion Maschinenbau


Sehen Sie sich das Profil von ckunkel72 an!   Senden Sie eine Private Message an ckunkel72  Schreiben Sie einen Gästebucheintrag für ckunkel72

Beiträge: 183
Registriert: 20.02.2013

Windows 10 Pro x64
SolidEdge ST9 MP5
Visual Studio Community 2017

erstellt am: 31. Jan. 2014 08:17    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Hallo Andreas,

den Quelltext für dieses Makro gibt's dort nicht. Ich habe auf jedenfall nichts gefunden.

Gruß Christian.

------------------
Seit Januar 2013 vollständig verschoben und syncronisiert.

http://c-k-m.info

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 31. Jan. 2014 08:36    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


ChangeVorlage_V1025_Quellcode.zip

 
Hallo Christian,

ich hab nochmal geschaut und die Quellen gefunden.
Wir wollten das Makro mal anpassen sind aber nicht damit zurecht gekommen.
Es ist noch in VB6 geschrieben.
Also hier der Quellcode.

------------------
Gruß Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Matthias Leemann
Mitglied
Masch. Ing HTL


Sehen Sie sich das Profil von Matthias Leemann an!   Senden Sie eine Private Message an Matthias Leemann  Schreiben Sie einen Gästebucheintrag für Matthias Leemann

Beiträge: 358
Registriert: 03.10.2003

Windows 10 Pro
Solid Edge 2019

erstellt am: 31. Jan. 2014 15:41    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

ich programmiere nur mit VB.NET aber es gibt ab der Solid Edge ST6 einen neuen Befehl: "Paste to original Position". Der sollte Command-ID 11099 haben.
Wenn dieser Befehl für das Einfügen ab Zwischenablage verwendet wird, dann sollte es wieder gehen.
Hatte in meinem Hintergrund Austausch Tool genau das gleiche Problem ab ST6.
Gruss aus der Schweiz
Matthias Leemann

------------------
SE ST4
SePropManager.NET und SeDimPro2 von
www.leemann-software.net

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 05. Feb. 2014 16:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Einstellung.png

 
Hallo miteinander,

das Makro funktioniert doch, wenn in den Optionen das richtige Häkchen gesetzt ist:

SE > Optionen  > Allgemeinen > (Bereich) Bevorzugtes 2D-Einfügeverhalten
Stellen Sie sie die Optionen auf > An Ursprünglicher Position einfügen


------------------
Gruß Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 13. Feb. 2014 14:00    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


ChangeVorlage_V1026_Quellcode.zip

 
Hallo miteinander,

wir haben das Makro doch bei uns neu kompiliert bekommen, und siehe da, es funktioniert auch unter ST6, egal wie das Häckchen gesetzt ist.
Allerdings funktioniert das Makro bei uns nicht mehr mit ST5.
Wir haben das Makro "versioniert" in 1.026 , außerdem haben wir ein aussagekräftiges Icon eingefügt.
Bitte testet, ob das Verhalten bei Euch genauso ist.

------------------
Gruß Andreas

[Diese Nachricht wurde von Andreas 70 am 13. Feb. 2014 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 07. Apr. 2015 17:18    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo miteinander,

nach einem Jahr steht der Umstieg auf ST7 an.
Leider funktioniert das Makro zum Hintergrundblattwechsel mit der neuen Version ST7 nicht.
Hat jemand anderes dieses Makro im Einsatz und schon mit ST7 getestet?
Hat jemand eine Idee, warum es nicht mehr funktioniert?

------------------
Gruß Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 07. Apr. 2015 17:22    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo miteinander,

ich hätte die Beiträge vorher nochmal richtig lesen sollen.
Mein Eintrag mit den Einstellungen in den Optionen löst das Problem.

------------------
Gruß Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Mike Ulbrich
Ehrenmitglied
PLM-Specialist


Sehen Sie sich das Profil von Mike Ulbrich an!   Senden Sie eine Private Message an Mike Ulbrich  Schreiben Sie einen Gästebucheintrag für Mike Ulbrich

Beiträge: 1556
Registriert: 11.04.2005

erstellt am: 28. Apr. 2015 08:13    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Hallo Zusammen,

ich muss den Thread noch einmal ausgraben.
Ich finde in meiner ST4 leider die Option nicht auf die Andreas verweist. Wo ist diese denn in ST4 zu finden?
Das wird auch der Grunde sein weshalb bei mir keine Hintergrundblätter ausgetauscht werden, vermute ich mal.

Gruß Mike

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

RayBan
Mitglied
CAD/PLM-Consultant


Sehen Sie sich das Profil von RayBan an!   Senden Sie eine Private Message an RayBan  Schreiben Sie einen Gästebucheintrag für RayBan

Beiträge: 620
Registriert: 04.02.2002

ST10 aktuelles MP
Win 7 64-Bit Prof
EdgePLM COMPACT
EdgePLM Parts

erstellt am: 28. Apr. 2015 09:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Hallo,

die erwähnte Option gibt es erst ab ST6...

Da muss es wohl an etwas anderem liegen..

Gruß Markus

------------------
Und er sagte noch: "noch nicht klicken".....

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ObiTom
Mitglied
Konstruktion


Sehen Sie sich das Profil von ObiTom an!   Senden Sie eine Private Message an ObiTom  Schreiben Sie einen Gästebucheintrag für ObiTom

Beiträge: 99
Registriert: 09.12.2012

Start mit V18 die bis ST4 im Schrank lag.
Mit SE ST4 gelernt zu laufen,
jetzt SE ST6
Win 7
FAN von Syncronus, Sequenziell ist von gestern.

erstellt am: 03. Mrz. 2017 08:48    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Hallo Andreas,

der Beitrag ist zwar schon ein paar Jahre alt aber für mich gerade aktuell da ich immer noch mit ST6 unterwegs bin.
Ich habe mir das Zip geladen, aber bekomme eine Fehlermeldung das irgendeine Datei fehlen sollte.
Wie wendet mal denn das Programm an, muss SE laufen?
Wo sollte das entpackte Zip liegen, im Verzeichnis SE?

für eine Rückantwort bin ich jetzt schon dankbar.

mfg Obermaier

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 03. Mrz. 2017 09:51    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Tom,

das Programm liegt bei uns auf einem Serverpfad und muss nicht lokal liegen.
Das Makro wird aus SolidEdge heraus ausgeführt und benötigt keine weiteren Programme.
Bei der ersten Ausführung müsst Ihr allerdings Pfad und Name Eurer Vorlagen Draft eingeben.
Vielleicht gibt es Probleme bei der Pfadauflösung, wenn die Vorlage auf dem Server liegt. (UNC und so)
Ansonsten muss Du die Fehlermeldung mal hochladen, da können vielleicht andere helfen. Ich habe von Programmierung keine Ahnung.
Übrigens ist das Makro auch in ST9 noch sinnvoll, weil die eingebaute Funktion zum Hintergrundblatttausch praktisch unbrauchbar ist.

------------------
Gruß Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Dragonbeat
Mitglied
CAD care


Sehen Sie sich das Profil von Dragonbeat an!   Senden Sie eine Private Message an Dragonbeat  Schreiben Sie einen Gästebucheintrag für Dragonbeat

Beiträge: 1496
Registriert: 24.03.2006

Solid Edge ST2019 MP4
Smap3D / Partfinder Advanced V9.6
AutoCAD LT 2019
Blender 2.78
Intel Core i7 6700k @ 4,00 GHz
32 GB Ram
NVIDIA GeForce GTX 1080
Windows 10 64bit

erstellt am: 14. Mrz. 2017 07:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Da wir in Kürze auf die ST9 umsteigen wollen und wir das Tool auch nutzen,
wollte ich mal fragen, ob es mit ST9 auch problemlos läuft?

------------------
Gruß
René

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

wolha
Moderator
CAD - Consultant


Sehen Sie sich das Profil von wolha an!   Senden Sie eine Private Message an wolha  Schreiben Sie einen Gästebucheintrag für wolha

Beiträge: 4703
Registriert: 30.01.2002

Solid Edge 2019 win10
CAMWorks
Primus PDM
FEMAP
Dynamic Designer

erstellt am: 14. Mrz. 2017 08:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Dragonbeat:
Da wir in Kürze auf die ST9 umsteigen wollen und wir das Tool auch nutzen,
wollte ich mal fragen, ob es mit ST9 auch problemlos läuft?



In der ST9 gibt es den Befehl "Hintergrundblatt ersetzen" direkt in SE.
Ich würde diese zuerst einmal verwenden.

------------------
mfg

Wolfgang Hackl
CAD/CAM - Consult

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 14. Mrz. 2017 08:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Rene,

der integrierte Befehl zum Hintergrundblatttausch ist einen einzige Clickorgie und bereinigt das Hintergrundblatt nicht von dort abgelegten Blöcken.
Wenn ihr z.B. das Schriftfeld als Block erstellt habt und das wegen Adress- oder Logowechsel tauschen wollt, funktioniert das nicht.
Auch der Wechsel bei allen Blattformaten in einem Rutsch funktioniert nicht.
Aber das Makro funktioniert ja noch tadellos in ST9.

------------------
Gruß Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ckunkel72
Mitglied
CAD Konstruktion Maschinenbau


Sehen Sie sich das Profil von ckunkel72 an!   Senden Sie eine Private Message an ckunkel72  Schreiben Sie einen Gästebucheintrag für ckunkel72

Beiträge: 183
Registriert: 20.02.2013

Windows 10 Pro x64
SolidEdge ST9 MP5
Visual Studio Community 2017

erstellt am: 06. Apr. 2017 14:59    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Hallo zusammen,
ich muss auch mal wieder die Hintergrundblätter tauschen. Mit ST9 MP5 funktioniert es, nachdem ich den Layer der Rahmen wieder auf "Lokalisierbar machen" gesetzt habe.
Vielleicht stolpert da nochmal jemand drüber.

------------------
Seit Januar 2013 vollständig verschoben und syncronisiert.

https://c-k-m.info

[Diese Nachricht wurde von ckunkel72 am 06. Apr. 2017 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 10. Apr. 2019 14:50    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


ChangeBackground-Error.png

 
Hallo miteinader,

wir stehen vor dem Umstieg auf SE2019.
Das oben genannte Makro verhält sich auf verschiedenen rechnern unterschiedlich.
Alle Rechner haben Windows10 installiert.
Einer ist von Win7 auf Windows101803 geupdatet worden. Auf dem Rechner funktioniert das Makro.
Auf dem rechner war vorher auch SolidEdge ST9 installiert.
Auf weiteren Rechnern haben wir von Windows7 auf Windows10 1809 geupdatet da funktioniert das Makro in ST9 nicht mehr mit der Meldung "SolidEdge ist mehrfach gestartet! Hintergrundblätter können nicht getauscht werden"
Jetzt haben wir einen jungfäulichen Rechner mit Windows10 1809 und SE2019 ohne alte SolidEdge Installationen oder Reste davon.
Da kommt bei Aufruf des Makros nur noch eine Meldung einer fehlenden mscomctl.ocx Komponnete.
Ich hatte in einem andern Forum mal was von entfernten 32bit Komponenten gelesen, die auf manchen Rechnern von alten SolidEdge Installationen halt noch vorhanden sind.
Weiß jemand wie man das alte Makro wieder zum laufen bringt?
Das prinzipielle Funktionieren habe ich ja gesehen.
Alternative Makros sind umständlicher merken sich die Optionen nicht oder bereinigen die Hintergrundblätter nicht von Blöcken.

------------------
Gruß Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Matthias Leemann
Mitglied
Masch. Ing HTL


Sehen Sie sich das Profil von Matthias Leemann an!   Senden Sie eine Private Message an Matthias Leemann  Schreiben Sie einen Gästebucheintrag für Matthias Leemann

Beiträge: 358
Registriert: 03.10.2003

Windows 10 Pro
Solid Edge 2019

erstellt am: 10. Apr. 2019 17:12    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Hoi Andreas
versuche mal das View and Markup zu installieren. Damit laufen meistens die alten Makros wieder.
Gruss Matthias

------------------
SE 2019
SePropManager.NET und SeDimPro2 von
www.leemann-software.net

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

wolha
Moderator
CAD - Consultant


Sehen Sie sich das Profil von wolha an!   Senden Sie eine Private Message an wolha  Schreiben Sie einen Gästebucheintrag für wolha

Beiträge: 4703
Registriert: 30.01.2002

Solid Edge 2019 win10
CAMWorks
Primus PDM
FEMAP
Dynamic Designer

erstellt am: 10. Apr. 2019 18:01    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Hallo


wobei diese OCX Komponente nicht aus Solid Edge kommt, sondern aus den alten Microsoft Libraries der VB6 bzw. alten 32 bit .net

Da bleibt nur, diese nochmals zu finden und manuell nach zu registrieren.
Habe ich selber auch noch und es funktioniert im Grunde genommen wunderbar.

mscomctl.ocx ist glaub eich die MS Common Control OCX für diverse Steuerelemente.
Bei meinen Makros war dies der MS FlexGrid.

------------------
mfg

Wolfgang Hackl
CAD/CAM - Consult

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

herbertboss
Mitglied
Techniker


Sehen Sie sich das Profil von herbertboss an!   Senden Sie eine Private Message an herbertboss  Schreiben Sie einen Gästebucheintrag für herbertboss

Beiträge: 273
Registriert: 15.04.2012

erstellt am: 10. Apr. 2019 19:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich


ChangeVorlage_V1026_Quellcode.zip

 
Hallo

Anbei die Version 1026 hat bei mir bis ST10 funkioniert,
bei ST2019 kommt Zeiweise die Meldung Solid ist 2 x gestartet.
MfG
Boss

------------------
Asus P8C-WS
Intel Xeon 1240 V2 3,40 GHz
MSI GTX 1060 6 GB
16,0 GB-Ram
Win 10 Pro
ST19
und Fujitsu mit
Xeon 2125 4.0 GHZ
32 GB Ram Quadro P4000
Win 10 Pro 1809
ST19

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Arne Peters
Ehrenmitglied V.I.P. h.c.
CAD Dokumentation / Training / Programmierung / Datenbanken


Sehen Sie sich das Profil von Arne Peters an!   Senden Sie eine Private Message an Arne Peters  Schreiben Sie einen Gästebucheintrag für Arne Peters

Beiträge: 6326
Registriert: 05.2002.24

Solid Edge Seminarunterlagen
Training, Beratung, Programmierung

erstellt am: 11. Apr. 2019 06:41    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Das mscomctl Thema ist manchmal etwas zäh.
Es liegt daran, dass in der Registry verschiedene Versionen bzw. die falsche registriert sind und ggf. auch eine falsche Version auf dem Rechner ist.
Es gibt im Internet Lösungen dazu.
Das einfache registrieren reicht meist nicht.

Evtl. hoift Dir der folgende Link weiter. Da ist das etwas näher erläutert.

https://www.fmsinc.com/MicrosoftAccess/Controls/mscomctl/

------------------
Arne

[Diese Nachricht wurde von Arne Peters am 11. Apr. 2019 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 11. Apr. 2019 10:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo miteinander,

ich habe jetzt das View und Markup nachträglich installieren lassen.
Leider kommt bei Makroaufruf die gleiche Fehlermeldung.
Außerdem habe ich festgestellt, dass der Aufruf von View und Markup ewig lange dauert. Ist das bei Euch auch so, oder ist das eventuell nicht richtig installiert.

------------------
Gruß Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Arne Peters
Ehrenmitglied V.I.P. h.c.
CAD Dokumentation / Training / Programmierung / Datenbanken


Sehen Sie sich das Profil von Arne Peters an!   Senden Sie eine Private Message an Arne Peters  Schreiben Sie einen Gästebucheintrag für Arne Peters

Beiträge: 6326
Registriert: 05.2002.24

Solid Edge Seminarunterlagen
Training, Beratung, Programmierung

erstellt am: 12. Apr. 2019 08:04    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Das View und Markup braucht vor allem beim ersten Start immer ewig. Liegt evtl am VisView. Ist aber auch eine gruseliege Oberfläche. 

Für Deine Zwecke brauchst Du das aber nicht. Beim V&M geht es nur um zwei 32 bit Bibliotheken, die den Zugriff auf die Dateiegenschaften und die Installationsdaten ohne SE ermöglichen.
Deshalb ändert sich auch die Medlung nicht.

SE per Programm zu starten und bei geöffnetem SE Programme laufen zu lassen geht auch mit 32bit Programmen.

Dass das Programm nicht mit allen Versionen läuft, liegt m.W. an einem Fehler in der Api. Da ist damals schon modeng aufgelaufen.

------------------
Arne

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Arne Peters
Ehrenmitglied V.I.P. h.c.
CAD Dokumentation / Training / Programmierung / Datenbanken


Sehen Sie sich das Profil von Arne Peters an!   Senden Sie eine Private Message an Arne Peters  Schreiben Sie einen Gästebucheintrag für Arne Peters

Beiträge: 6326
Registriert: 05.2002.24

Solid Edge Seminarunterlagen
Training, Beratung, Programmierung

erstellt am: 12. Apr. 2019 08:21    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Ich hab gestern mit einem Freund über das Thema gesprochen.
Er sagte, die meisten Firmen installaieren Office immer noch als 32bit Variante, da viele Libraries in 64 bit nicht da sind. Mit .Net mag es gehen. Wenn man mit VBA entwickelt, fehlt aber vieles.

Also evtl. mal ein 32bit Office installieren.

------------------
Arne

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 16. Apr. 2019 10:07    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


SEmehrfachgestartet.png

 
Hallo miteinander,

View und Markup zu installieren bringt nix.
Die OCX Datei habe ich von einem Win10 Rechner auf dem das Makro mit SE2019 funktioniert gefunden, kopiert und registriert.
Das Makro läuft damit wieder an, aber weigert sich beim Ausführen mit der Fehlermeldung, dass SE mehrfach gestartet sei.
Hat hier noch jemand eine Tipp, was man da tun könnte?
Bei dem Makro sind die Quellen ja mit dabei.
Mit Programmieren kenne ich mich nicht aus. Ist das Umsetzen des Codes und compilieren in .Net wirklich wie neu schreiben?

------------------
Gruß Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Arne Peters
Ehrenmitglied V.I.P. h.c.
CAD Dokumentation / Training / Programmierung / Datenbanken


Sehen Sie sich das Profil von Arne Peters an!   Senden Sie eine Private Message an Arne Peters  Schreiben Sie einen Gästebucheintrag für Arne Peters

Beiträge: 6326
Registriert: 05.2002.24

Solid Edge Seminarunterlagen
Training, Beratung, Programmierung

erstellt am: 16. Apr. 2019 10:28    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Evtl. könnte der Pfad zu den Vorlagen Probleme machen.
Das ist doch noch ein VB6 Programm. Oder?

Ich habe hier die 1.0.15 probiert. Läuft. 

------------------
Arne

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

herbertboss
Mitglied
Techniker


Sehen Sie sich das Profil von herbertboss an!   Senden Sie eine Private Message an herbertboss  Schreiben Sie einen Gästebucheintrag für herbertboss

Beiträge: 273
Registriert: 15.04.2012

erstellt am: 16. Apr. 2019 11:48    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Hallo
Es dürfte am Makro liegen habe bei mir den selben Fehler
mit der ST10 gab es keine Probleme.
Irgendwie glaubt das Makro das Solid mehfach gestarte ist.
MfG
Boss

------------------
Asus P8C-WS
Intel Xeon 1240 V2 3,40 GHz
MSI GTX 1060 6 GB
16,0 GB-Ram
Win 10 Pro
ST19
und Fujitsu mit
Xeon 2125 4.0 GHZ
32 GB Ram Quadro P4000
Win 10 Pro 1809
ST19

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Arne Peters
Ehrenmitglied V.I.P. h.c.
CAD Dokumentation / Training / Programmierung / Datenbanken


Sehen Sie sich das Profil von Arne Peters an!   Senden Sie eine Private Message an Arne Peters  Schreiben Sie einen Gästebucheintrag für Arne Peters

Beiträge: 6326
Registriert: 05.2002.24

Solid Edge Seminarunterlagen
Training, Beratung, Programmierung

erstellt am: 16. Apr. 2019 12:11    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas 70 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von herbertboss:
Hallo
Es dürfte am Makro liegen habe bei mir den selben Fehler
mit der ST10 gab es keine Probleme.
Irgendwie glaubt das Makro das Solid mehfach gestarte ist.
MfG
Boss

Eher an SE.

------------------
Arne

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas 70
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Andreas 70 an!   Senden Sie eine Private Message an Andreas 70  Schreiben Sie einen Gästebucheintrag für Andreas 70

Beiträge: 51
Registriert: 20.05.2011

Win7 64, SolidEdge ST9 64 MP13,
Dell Precision 5810
Nvidia Quadro K4200

erstellt am: 16. Apr. 2019 12:54    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Aber das komische ist, dass ich einen Rechner mit SE2019 und Win 10 habe, wo das Makro funktioniert. Prinzipiell geht es also.

------------------
Gruß Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz