Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SIMULIA/ABAQUS
  Problem bei Simulation mit hohler STEP-Datei

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Problem bei Simulation mit hohler STEP-Datei (578 mal gelesen)
  
Die Gewinne der Zukunft werden mit intelligenten, autonomen Elektrofahrzeugen eingefahren. (3DEXPERIENCE)
VO777
Mitglied



Sehen Sie sich das Profil von VO777 an!   Senden Sie eine Private Message an VO777  Schreiben Sie einen Gästebucheintrag für VO777

Beiträge: 16
Registriert: 27.02.2017

erstellt am: 02. Mai. 2017 13:14    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


SchnittModelingSTEP.PNG


SchnittResultsSTEP.PNG


ResultsIGES.PNG

 
Hallo zusammen,

ich habe ein Problem beim Arbeiten mit STEP-Dateien in ABAQUS. Der Import funktioniert soweit, allerdings gibt es bei den Ergebnissen einige Ungereimtheiten.

Und zwar importiere ich eine hohle Hülle, die als aus Silikon festelegt und von einem äußeren Druck belastet wird. Beim Modeling wird mir die Hülle noch als hohl angezeigt.
Bei den Results allerdings zeigt sich keine Verformung an der Hülle und es hat sich herausgestellt, dass diese aus irgendeinem Grund auf einmal als Vollmaterial angezeigt wird...?
Weiß jemand woran das liegt, kann ich daran etwas ändern durch irgendwelche Einstellungen?

Wenn ich die Datei als IGES importiere, tritt das Problem nicht auf und die Hülle verformt sich wie erwartet. Jedoch würde ich gerne STEP verwenden, da ich eine ganze Baugruppe mit vielen weiteren Teilen importieren möchte und das soweit ich weiß als IGES nicht möglich ist...

Vielen Dank für jede Hilfe

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Mustaine
Ehrenmitglied V.I.P. h.c.



Sehen Sie sich das Profil von Mustaine an!   Senden Sie eine Private Message an Mustaine  Schreiben Sie einen Gästebucheintrag für Mustaine

Beiträge: 3393
Registriert: 04.08.2005

Abaqus

erstellt am: 02. Mai. 2017 14:22    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für VO777 10 Unities + Antwort hilfreich

Nach dem Import erstmal prüfen, ob das Bauteil ein Solid oder ein Flächenverbund ist.
Tools > Query > Part Attributes


Außerdem mal nach anderen Problemen schauen.
Tools > Query > Geometry Diagnostics

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

VO777
Mitglied



Sehen Sie sich das Profil von VO777 an!   Senden Sie eine Private Message an VO777  Schreiben Sie einen Gästebucheintrag für VO777

Beiträge: 16
Registriert: 27.02.2017

erstellt am: 02. Mai. 2017 14:49    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke für deine Antwort.

Habe die beiden Sachen mal ausgeführt und folgenden outprint bekommen:
"
Part: "Hülle neu",  Modeling space: 3D,  Type: Deformable
It is a solid part(2 cells, 8 solid faces, 12 edges, 8 vertices)

The part "Hülle neu" has no invalid entities.

The geometry in the part "Hülle neu" has no imprecise entities.

The geometry in the part "Hülle neu" has no free edges.

2 solid cells were found and highlighted.

The geometry in the part "Hülle neu" has no shell faces.

The geometry in the part "Hülle neu" has no wire edges.
"


Scheint also alles sauber zu sein.
Die IGES-Datei mit der es funktioniert ist ja auch immer genau das gleiche Teil, daher sowieso komisch, dass es mal klappt und mal nicht...
Als .CATPart zeigt sich übrigens das gleiche Problem wie mit STEP, nur als Info nebenbei.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Mustaine
Ehrenmitglied V.I.P. h.c.



Sehen Sie sich das Profil von Mustaine an!   Senden Sie eine Private Message an Mustaine  Schreiben Sie einen Gästebucheintrag für Mustaine

Beiträge: 3393
Registriert: 04.08.2005

Abaqus

erstellt am: 02. Mai. 2017 16:13    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für VO777 10 Unities + Antwort hilfreich

Ich könnte es mal testen, wenn du ein einfaches Bauteil als step-Datei hochlädst.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

VO777
Mitglied



Sehen Sie sich das Profil von VO777 an!   Senden Sie eine Private Message an VO777  Schreiben Sie einen Gästebucheintrag für VO777

Beiträge: 16
Registriert: 27.02.2017

erstellt am: 02. Mai. 2017 16:20    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Hulleneu.STEP

 
Gerne, das ist die Datei mit der ich momentan arbeite.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Mustaine
Ehrenmitglied V.I.P. h.c.



Sehen Sie sich das Profil von Mustaine an!   Senden Sie eine Private Message an Mustaine  Schreiben Sie einen Gästebucheintrag für Mustaine

Beiträge: 3393
Registriert: 04.08.2005

Abaqus

erstellt am: 02. Mai. 2017 18:16    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für VO777 10 Unities + Antwort hilfreich

Mhhh, seltsam. Es kommen zwei Zellen an, man sieht aber immer nur eine. Selbst mit der Cutting Plane. Erst wenn ich die äußere Zelle ausblende, sieht man die innere. Blende ich die äußere wieder ein, verschwindet die innere. Sowas habe ich noch nie gehabt.

Im Mesh-Modul werden beide Zellen vernetzt, aber auch da habe ich dasselbe Verhalten in der Visualisierung.

Du solltest in Solidworks mal schauen, ob da ein Körper im Inneren noch aktiv ist. Evtl. einer der für den Cut verwendet wurde. Spiele da mal mit den Optionen und schau dann mal was in CAE ankommt.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Pam Crash
Moderator
Moderator


Sehen Sie sich das Profil von Pam Crash an!   Senden Sie eine Private Message an Pam Crash  Schreiben Sie einen Gästebucheintrag für Pam Crash

Beiträge: 411
Registriert: 29.04.2008

erstellt am: 03. Mai. 2017 13:13    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für VO777 10 Unities + Antwort hilfreich

Innen- und Außenfläche des Körpers haben keine Verbindung zueinander und kennen sich nicht. Beim Vernetzen entsteht so der Vollkörper aus der Außenfläche

------------------
Pam

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

VO777
Mitglied



Sehen Sie sich das Profil von VO777 an!   Senden Sie eine Private Message an VO777  Schreiben Sie einen Gästebucheintrag für VO777

Beiträge: 16
Registriert: 27.02.2017

erstellt am: 03. Mai. 2017 14:13    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Zitat:
Original erstellt von Mustaine:
Mhhh, seltsam. Es kommen zwei Zellen an, man sieht aber immer nur eine. Selbst mit der Cutting Plane. Erst wenn ich die äußere Zelle ausblende, sieht man die innere. Blende ich die äußere wieder ein, verschwindet die innere. Sowas habe ich noch nie gehabt.

Im Mesh-Modul werden beide Zellen vernetzt, aber auch da habe ich dasselbe Verhalten in der Visualisierung.

Du solltest in Solidworks mal schauen, ob da ein Körper im Inneren noch aktiv ist. Evtl. einer der für den Cut verwendet wurde. Spiele da mal mit den Optionen und schau dann mal was in CAE ankommt.


Ich habe den Körper durch Erstellen eines Vollzylinders und anschließendem Aushöhlen erstellt, daher existieren wohl die Daten dieses entfernten Innenkörpers wie du sagst.
Ich habe das Ganze nun mal in Inventor probiert - mit dem gleichen Resultat. Anschließend habe ich den Körper nicht durch Aushöhlen erstellt, sondern erst den Boden, darauf die Wand extrudiert und anschließend noch den Deckel - auch hier zeigte sich aber das gleiche Problem.

Nun habe ich einfach mal ein kleines Loch in den Körper eingefügt und damit quasi den Status des eingeschlossenen Volumens verhindert. Damit tritt das Problem nicht nicht mehr auf!
Damit ergibt das hier...

Zitat:
Original erstellt von Pam Crash:
Innen- und Außenfläche des Körpers haben keine Verbindung zueinander und kennen sich nicht. Beim Vernetzen entsteht so der Vollkörper aus der Außenfläche


...natürlich erst Recht Sinn. Lässt sich das denn verhindern? Muss ja eigentlich möglich sein, sonst wäre ja jeder hohle Körper in ABAQUS als Vollmaterial simuliert...
Und ebenso fraglich ist, warum das ganze nicht passiert, wenn ich die gleiche Datei als IGES importiere 

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Pam Crash
Moderator
Moderator


Sehen Sie sich das Profil von Pam Crash an!   Senden Sie eine Private Message an Pam Crash  Schreiben Sie einen Gästebucheintrag für Pam Crash

Beiträge: 411
Registriert: 29.04.2008

erstellt am: 04. Mai. 2017 07:28    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für VO777 10 Unities + Antwort hilfreich

Exportierst Du sowohl Flächen als auch Volumina beim Anlegen der stp/igs-Dateien?

------------------
Pam

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

VO777
Mitglied



Sehen Sie sich das Profil von VO777 an!   Senden Sie eine Private Message an VO777  Schreiben Sie einen Gästebucheintrag für VO777

Beiträge: 16
Registriert: 27.02.2017

erstellt am: 04. Mai. 2017 14:16    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


ExportEinstellungenSTEP.PNG


ExportEinstellungenIGES.PNG

 
Anbei hier mal die ursprünglichen Einstellungen, die ich in Solidworks genutzt hatte.
Ich habe es nun mal probiert, wenn für die STEP-Dateien "Flächen-/Kanteneigenschaften exportieren" ausgeschaltet ist und auch wenn "Export 3D Kurven-Features" angeschaltet ist. Beides zeigt aber keine Lösung für das Problem...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz