Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SIMULIA/ABAQUS
  Python-Script: Connectivities stimmen mit Inputfile nicht überein

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Python-Script: Connectivities stimmen mit Inputfile nicht überein (496 mal gelesen)
  
Die Gewinne der Zukunft werden mit intelligenten, autonomen Elektrofahrzeugen eingefahren. (3DEXPERIENCE)
krobi01
Mitglied
Student

Sehen Sie sich das Profil von krobi01 an!   Senden Sie eine Private Message an krobi01  Schreiben Sie einen Gästebucheintrag für krobi01

Beiträge: 1
Registriert: 08.05.2015

erstellt am: 08. Mai. 2015 10:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo an alle! 

Bin noch eher ein Abaqus Neuling und habe vor einem Monat mit dem Python Scripting begonnen. Ich sollte im Zuge meiner Masterarbeit so eine Art Edge und Corner Detection für Modelle aus Shell Elementen machen. Um den Code zu testen habe ich mir immer so kleine Modelle zusammengebaut, an denen es eigentlich recht gut funktioniert.

Nun aber zu meinem Problem:
Ich habe vorige Woche ein recht großes Modell (ca 30 000 Elementen) als Inputfile bekommen, habe es in Abaqus/CAE importiert und wollte meinen Code mal dran testen. Es kam dann eine Fehlermeldung, dass einzelne Knoten nicht gefunden wurden. Dann habe ich mal die Element Connectivities im Inputfile mit jenen Element Connectivities, welche ich über ein Python Script abfrage, verglichen. Diese passen überhaupt nicht überein, keine Ahnung warum!? Element Connectivities im Input File und im CAE, was ich über Tools->Query abfragen kann, passen jedoch zusammen.
Aber vielleicht hat es damit etwas zu tun, dass im Input File die Knoten Labels bei 2 beginnen und zwischendrin auch wieder mal Knoten Labels fehlen!? Beim importieren des Input Files gibt es auch diese Warnung: "Warning: Undefined node and element ids have been removed from some node and element sets". Das Input File wurde mit FEMAP erstellt.

Vielleicht kann mir hier ja jemand sagen ob bzw. wie ich das in den Griff bekommen kann, also wie ich mir über ein Python-Script die richtigen Element Connectivities ausgeben lassen kann!??? Bei meinen kleinen Modellen funktioniert es einwandfrei.

Ich danke euch schon mal im Voraus
LG
krobi 

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Mustaine
Ehrenmitglied V.I.P. h.c.



Sehen Sie sich das Profil von Mustaine an!   Senden Sie eine Private Message an Mustaine  Schreiben Sie einen Gästebucheintrag für Mustaine

Beiträge: 3393
Registriert: 04.08.2005

Abaqus

erstellt am: 08. Mai. 2015 11:45    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für krobi01 10 Unities + Antwort hilfreich

Schreib in die .inp

*Preprint, model=yes


Lass sie dann mal durch einen Datacheck laufen und schau in die .dat. Vielleicht hilft dir das.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz