Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SIMULIA/ABAQUS
  Plot von Pfad automatisch erstellen

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Plot von Pfad automatisch erstellen (765 mal gelesen)
  
Die Gewinne der Zukunft werden mit intelligenten, autonomen Elektrofahrzeugen eingefahren. (3DEXPERIENCE)
roachnbua
Mitglied
Student


Sehen Sie sich das Profil von roachnbua an!   Senden Sie eine Private Message an roachnbua  Schreiben Sie einen Gästebucheintrag für roachnbua

Beiträge: 25
Registriert: 27.01.2015

SIMULIA/ABAQUS

erstellt am: 09. Apr. 2015 15:50    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Servus zusammen.

Ich bin gerade dabei über der Command Line einige Dinge zu automatisieren, indem ich die Befehle einmal schreibe und dann nur noch reinkopiere. Ich möchte einen Plot von einem Pfad automatisch abspeichern, aber irgendwie klappt das nicht. Ich habe es einmal selbst durchgeführt und dann aus der ppy-Datei rauskopiert. Also müsste es doch eigentlich stimmen oder nicht?

Der Befehl wäre:

pth = session.paths['Oberpfad']
session.XYDataFromPath(name='Benennung', path=pth, includeIntersections=False,
    pathStyle='PATH_POINTS', numIntervals=10, shape=DEFORMED,
    labelType='NORM_DISTANCE')

Als Fehler kommt immer wieder dass PATH_POINTS nicht definiert sind. Warum?

Bei einem anderen Befehl war das ähnlich:

session.Path(name='Unterpfad', type=1, expression=(('SCHAUFELSEKTOR-1',

Normal steht bei type=NOTE_LIST, aber indem ich dort eine eins reingeschrieben habe funktioniert es jetzt. Tue ich das übrigens beim obigen Befehl, beschwert er sich über die shape und den labelType.

Kann mir da jemand weiter helfen? Danke

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Mustaine
Ehrenmitglied V.I.P. h.c.



Sehen Sie sich das Profil von Mustaine an!   Senden Sie eine Private Message an Mustaine  Schreiben Sie einen Gästebucheintrag für Mustaine

Beiträge: 3393
Registriert: 04.08.2005

Abaqus

erstellt am: 09. Apr. 2015 21:19    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für roachnbua 10 Unities + Antwort hilfreich

Schau mal ins Scripting Reference Manual. Einige von deinen Befehle sind so nicht möglich.


39.1.1 Path(...)
Siehe Optionen beim type-Parameter an.


55.1.8 XYDataFromPath(...)
PATH_POINTS und NORM_DISTANCE dürften kein String sein.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

roachnbua
Mitglied
Student


Sehen Sie sich das Profil von roachnbua an!   Senden Sie eine Private Message an roachnbua  Schreiben Sie einen Gästebucheintrag für roachnbua

Beiträge: 25
Registriert: 27.01.2015

SIMULIA/ABAQUS

erstellt am: 10. Apr. 2015 09:10    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

In beiden Punkten steht doch im Prinzip auch nichts anderes und da habe ich auch schon davor nachgelesen.

Bei shape steht zum Beispiel: A SymbolicConstant specifying the model shape to use. Possible values are UNDEFORMED and DEFORMED.

Aber wenn ich DEFORMED so reinschreibe, bringt er immer wieder das diese Variable so nicht definiert ist. Dasselbe gilt für PATH_POINTS, TYPE usw.

Was ich aber nicht verstehe. Ich habe das Vorgehen einmal in Abaqus gemacht und dann die Mitschrift aus der rpy-Datei kopiert. Warum funktioniert es mit dieser Kopie nicht? Also ich kann aus dem Scripting Reference Modul nichts sinnvolles rauslesen was mir hilft.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Mustaine
Ehrenmitglied V.I.P. h.c.



Sehen Sie sich das Profil von Mustaine an!   Senden Sie eine Private Message an Mustaine  Schreiben Sie einen Gästebucheintrag für Mustaine

Beiträge: 3393
Registriert: 04.08.2005

Abaqus

erstellt am: 10. Apr. 2015 12:21    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für roachnbua 10 Unities + Antwort hilfreich


platte.txt


script_edge_path_plot_mises.txt

 
Ich kann dir nicht sagen wo bei deinem Skript das Problem ist, da ich nicht weiß was genau du gemacht hast.

Im Anhang ein kleines Beispiel das prima funktioniert.

[Diese Nachricht wurde von Mustaine am 10. Apr. 2015 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz