Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SIMULIA/ABAQUS
  Fehlermeldung bei Einbindung von 'ABA_PARAM.inc'

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Fehlermeldung bei Einbindung von 'ABA_PARAM.inc' (1737 mal gelesen)
sergejfährlich
Mitglied
Student


Sehen Sie sich das Profil von sergejfährlich an!   Senden Sie eine Private Message an sergejfährlich  Schreiben Sie einen Gästebucheintrag für sergejfährlich

Beiträge: 39
Registriert: 20.08.2009

erstellt am: 24. Mai. 2012 09:32    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo liebes Forum,

mich plagt schon wieder ein neues Problem mit der Einbindung von Nutzerschnittstellen, nachdem ich bereits erfolglos gegoogelt und recherchiert habe. Ich habe eine Simulation bei der ich 3 user-subroutines einsetzen möchte: MPC, Orient und UMAT. Diese Schnittstellen habe ich in eigenständigen Dateien programmiert und diese per include Befehl in eine übergeordnete Datei namens "Schnittstellen.f" eingebunden. Die Datei sieht daher ungefähr wie folgt aus:

include + Pfad für MPC
include + Pfad für Orient
include + Pfad für UMAT.

In Abaqus habe ich dann im job Menu die Datei "Schnittstellen.f" angehangen. Jetzt kommt bei mir der Fehler: "error #5102: Cannot open include file 'ABA_PARAM.INC'". Dieser include Befehl steht ja in jeder Nutzerschnittstelle mit drin. Daraufhin habe ich meinen Abaqus-Ordner nach dieser Datei durchsucht (speziell site), bin aber leider nicht fündig geworden. Verrückt ist, dass es funktioniert, wenn ich nur eine einzelne Schnittstelle direkt einbinde.

Hat jemand dieses Problem schon einmal gehabt bzw. kennt einen Ausweg?

VG Hendrik

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Nicksen
Mitglied
wissenschaftlicher Mitarbeiter


Sehen Sie sich das Profil von Nicksen an!   Senden Sie eine Private Message an Nicksen  Schreiben Sie einen Gästebucheintrag für Nicksen

Beiträge: 239
Registriert: 04.05.2007

erstellt am: 24. Mai. 2012 10:04    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für sergejfährlich 10 Unities + Antwort hilfreich

Hast du in der Hauptdatei "Schnittstellen.f" auch die ABA_PARAM.inc eingebunden?

Diese Zeile muss in jeder FORTRAN Datei stehen.
Ansonsten: Kopier dir die ABA_Param.inc ins aktuelle Arbeitsverzeichnis. Das kann mitunter auch funktionieren.

Oder so wie ich: Kopiere alle Routinen in eine Main-Routine ohne weitere include Befehle für die Einzelroutinen. Dann sollte es auch klappen. Ist ja dann im Grunde, wie eine einzige Datei.

mfg

------------------
===============
==  Dingsen  ==
===============

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz