Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SIMULIA/ABAQUS
  system error code 144

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   system error code 144 (2535 mal gelesen)
Ahmetoglu
Mitglied
Student


Sehen Sie sich das Profil von Ahmetoglu an!   Senden Sie eine Private Message an Ahmetoglu  Schreiben Sie einen Gästebucheintrag für Ahmetoglu

Beiträge: 24
Registriert: 20.06.2008

erstellt am: 14. Mai. 2009 16:04    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen,

versuche gerade eine Subroutine zum Laufen zu bringen (Uuarm), die leider nicht mehr funktioniert.
ein noch funktionierendes Input file hatte ich noch gespeichert gehabt, und dieser läuft auch ohne weiteres durch.
Baue ich jedoch ein weiteres genauso auf wie das funktionierende bekomme ich folgende Fehlermeldung:

Abaqus Error: The executable C:\SIMULIA\Abaqus\6.8-1\exec\standard.exe
aborted with system error code 144.
Please check the .dat, .msg, and .sta files for error messages if the files
exist.  If there are no error messages and you cannot resolve the problem,
please run the command "abaqus job=support information=support" to report and
save your system information.  Use the same command to run Abaqus that you
used when the problem occurred.  Please contact your local Abaqus support
office and send them the input file, the file support.log which you just
created, the executable name, and the error code.
Abaqus/Analysis exited with errors

Kennt jmd. diesen Fehler??

Würde mich freuen wenn mir jmd. helfen könnte.

Vielen Dank im Voraus.

Gruß,
HK

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Nicksen
Mitglied
wissenschaftlicher Mitarbeiter


Sehen Sie sich das Profil von Nicksen an!   Senden Sie eine Private Message an Nicksen  Schreiben Sie einen Gästebucheintrag für Nicksen

Beiträge: 239
Registriert: 04.05.2007

erstellt am: 14. Mai. 2009 16:49    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Ahmetoglu 10 Unities + Antwort hilfreich

Wenn nichts im *.dat zu finden ist oder das *.msg file nicht vorhanden, dann kann es an einer Formatierung der Variablen, ein Problem mit dem "implicit real" oder ein Speicherzuweisungsproblem oder sonstwas anderes sein.

Um es anders zu formulieren:
Dieser Fehler sagt nichts konkretes aus. Schau bitte nach, was im dat und im msg steht und ggf. poste dies noch einmal hier. Dann finden wir evtl. den Bug.

Gruß Nicksen

------------------
==========
==  Dingsen  ==
==========

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Ahmetoglu
Mitglied
Student


Sehen Sie sich das Profil von Ahmetoglu an!   Senden Sie eine Private Message an Ahmetoglu  Schreiben Sie einen Gästebucheintrag für Ahmetoglu

Beiträge: 24
Registriert: 20.06.2008

erstellt am: 14. Mai. 2009 18:04    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


dat.txt


msg.txt

 
Hallo,
habe mal die .msg und .dat hochgeladen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Nicksen
Mitglied
wissenschaftlicher Mitarbeiter


Sehen Sie sich das Profil von Nicksen an!   Senden Sie eine Private Message an Nicksen  Schreiben Sie einen Gästebucheintrag für Nicksen

Beiträge: 239
Registriert: 04.05.2007

erstellt am: 15. Mai. 2009 08:12    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Ahmetoglu 10 Unities + Antwort hilfreich

Offenbar ein Fehler in der Routine selbst.

Kannst du diese mal hochladen?
Offensichtlich erfolgt der Absturz nicht vor dem Durchlauf sondern waehrend des Laufes. Da kann es an Speicherzuweisungen, Formatierungen oder sonstwas liegen.

Wenn es also nicht zu geheim ist, dann stell bitte die Routine hier ein. Bestimmt hilft das bei der Suche.

Gruß

------------------
==========
==  Dingsen  ==
==========

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Ahmetoglu
Mitglied
Student


Sehen Sie sich das Profil von Ahmetoglu an!   Senden Sie eine Private Message an Ahmetoglu  Schreiben Sie einen Gästebucheintrag für Ahmetoglu

Beiträge: 24
Registriert: 20.06.2008

erstellt am: 15. Mai. 2009 08:55    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


BH.txt

 
no problem.
danke dir im Voraus schon mal für deine Mühe!

Die Sache ist nur die, bei einem anderen bauteil funktioniert die Subroutine einwandfrei.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Ahmetoglu
Mitglied
Student


Sehen Sie sich das Profil von Ahmetoglu an!   Senden Sie eine Private Message an Ahmetoglu  Schreiben Sie einen Gästebucheintrag für Ahmetoglu

Beiträge: 24
Registriert: 20.06.2008

erstellt am: 27. Mai. 2009 10:14    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


C1.txt


C2.txt

 
Hi Nicksen,
anbei die Dateien:
C1 funktioniert nicht
C2 funktioniert!!!

für beide jeweils BH.for benutzt.

Wo arbeitest du denn wenn ich fragen darf??

Vielen Dank Nicksen
Gruß
Ahmetoglu

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

carsten1983
Mitglied
Doktorand


Sehen Sie sich das Profil von carsten1983 an!   Senden Sie eine Private Message an carsten1983  Schreiben Sie einen Gästebucheintrag für carsten1983

Beiträge: 125
Registriert: 11.10.2007

erstellt am: 27. Mai. 2009 12:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Ahmetoglu 10 Unities + Antwort hilfreich

Gibt es nur einen Pfad der durch die Subroutine führt?
Ich habe ein paar ifs und thens gesehen. Bist du dir sicher, dass niemals der Fall eintreten kann, dass eine Variable die später verwendet wird durch die Verzweigungen vorher nicht definiert wurde?

Wenn die Routine schonmal gelaufen ist, könnte dies eine Ursache sein.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Nicksen
Mitglied
wissenschaftlicher Mitarbeiter


Sehen Sie sich das Profil von Nicksen an!   Senden Sie eine Private Message an Nicksen  Schreiben Sie einen Gästebucheintrag für Nicksen

Beiträge: 239
Registriert: 04.05.2007

erstellt am: 28. Mai. 2009 12:44    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Ahmetoglu 10 Unities + Antwort hilfreich


Ahmetoglu.zip

 
Im Anhang sind deine Dateien und ein kleiner Text dazu.

Den Abbruch hab ich leider nicht verhindern koennen, aber ich erhalte einen anderen Fehler, als den von dir beschriebenen.

Der Hinweis von carsten1983 ist gut. Ich hab die Formeln nicht auseinander genommen, aber im Modell C2.inp tritt etwas nicht auf, das bei C1.inp vorkommt. Durchaus kann dies eine Ursache fuer das Auftreten bzw. Nichtauftreten des Fehlers sein.

Wie gesagt, ich erhalte einen anderen Fehler: illegal floating point operation
Division durch Null, fehlende Zuweisung einer benoetigten Variable oder sonstwas. Es tritt nicht im Null-Inkrement auf sondern im eigentlichen Step und Inkrement 1. Dort allerdings auch nicht am Anfang sondern irgendwann mittendrin. Elementnummern, Knotennummern, Rechenzeit und Stepzeit hab ich nicht weiter ueberprueft. Die Fehlersuche kann eine Weile dauern.

Bitte versuch dein Glueck, ein paar Vermutungen hab ich in Textform im Archiv mit angebracht.

Viel Erfolg!!!

Gruß
Nicksen

------------------
==========
==  Dingsen  ==
==========

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

streifenkarl
Mitglied
ing


Sehen Sie sich das Profil von streifenkarl an!   Senden Sie eine Private Message an streifenkarl  Schreiben Sie einen Gästebucheintrag für streifenkarl

Beiträge: 17
Registriert: 18.12.2006

erstellt am: 01. Jun. 2009 13:38    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Ahmetoglu 10 Unities + Antwort hilfreich

Hallo,

macht euch nicht zu viele gedanken. Der Fehler liegt ganz klar bei Abaqus.
Wir haben diese Problem schon seit Veröffentlichung von Abaqus 6.8.1 erkannt. Es ist leider so, daß viele Userroutinen auf Win 64 und Linux 64 Systemen mit Intel-Fortran 10.xx.xx kaum lauffähig sind und wenn dann nur mit 1 CPU was noch ein zusätzliches Problem darstellt.


Abhilfe: Downgrade auf eine alte Abaqus Version. (6.5 und 6.6 läuft stabil)


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz