Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SIMULIA/ABAQUS
  Subroutine - *PRINT-Befehl

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Subroutine - *PRINT-Befehl (1230 mal gelesen)
  
Die Gewinne der Zukunft werden mit intelligenten, autonomen Elektrofahrzeugen eingefahren. (3DEXPERIENCE)
Andreas79
Mitglied
Student


Sehen Sie sich das Profil von Andreas79 an!   Senden Sie eine Private Message an Andreas79  Schreiben Sie einen Gästebucheintrag für Andreas79

Beiträge: 134
Registriert: 16.12.2004

erstellt am: 23. Jun. 2008 12:53    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,
ich arbeite mit der Subroutine UMAT und habe mir zur Kontrolle immer eine Variable in der .log-Datei ausgeben lassen. Jetzt löschte ich den
Code:
PRINT *, Variable
. Danach folgte die unten angehängte Fehlermeldung. Eigentlich dürfte der PRINT-Befehl doch keine Auswirkungen auf den Fortran-Code haben - oder? Hat jemand von Euch eine Idee?

Danke und Gruß.
Andreas79

Code:
Traceback (most recent call last): File "Python/monitorMechanism.py", line 285, in read
error: (10054, 'Connection reset by peer')
Error in job ELIP_Test_Umat: The executable C:\Programme\ABAQUS\6.7-1\exec\standard.exe aborted with system error code 144.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Nicksen
Mitglied
wissenschaftlicher Mitarbeiter


Sehen Sie sich das Profil von Nicksen an!   Senden Sie eine Private Message an Nicksen  Schreiben Sie einen Gästebucheintrag für Nicksen

Beiträge: 239
Registriert: 04.05.2007

erstellt am: 23. Jun. 2008 13:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas79 10 Unities + Antwort hilfreich

Haste aus Spaß mal die Zeile wieder eingefuegt, um zu sehen, ob es wirklich daran liegt?

------------------
==========
==  Dingsen  ==
==========

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas79
Mitglied
Student


Sehen Sie sich das Profil von Andreas79 an!   Senden Sie eine Private Message an Andreas79  Schreiben Sie einen Gästebucheintrag für Andreas79

Beiträge: 134
Registriert: 16.12.2004

erstellt am: 23. Jun. 2008 13:28    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Ja, leider liegt es daran. Ich muss aber nicht genau die Variable ausgeben lassen. Hab es jetzt auf das erste Element und den ersten Integrationspunkt beschränkt und es läuft. Hauptsache der *PRINT-Befehl steht drin.

Es läuft wieder, aber das ist garantiert nicht die Lösung...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Nicksen
Mitglied
wissenschaftlicher Mitarbeiter


Sehen Sie sich das Profil von Nicksen an!   Senden Sie eine Private Message an Nicksen  Schreiben Sie einen Gästebucheintrag für Nicksen

Beiträge: 239
Registriert: 04.05.2007

erstellt am: 23. Jun. 2008 13:35    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas79 10 Unities + Antwort hilfreich

Liest du waehrend deiner Routine irgendwas aus dem *.log ein?

Ich hatte einen trace-back blabla Fehler auch einmal, bei der Verarbeitung von Ergebnissen aus dem dat-file. Da eine Variable, die blockweise Nullen aufweist nicht ausgeschrieben werden sondern "all values are Zero" kommt, stieg mein parser aus.

Moeglicherweise greift die Routine auf eine bestimmte Stelle im log zu, die ohne die print Anweisung eine Zeile hoeher steht.

Ist aber alles Spekulation. Eigenartig bleibt der Fall mit Sicherheit. Wenn du die Loesung hast, dann setz die Gemeinde bitte ins Licht. Damit man fuer spaeter auch schlauer ist.

Danke im Voraus und eine schoene Woche!

------------------
==========
==  Dingsen  ==
==========

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Andreas79
Mitglied
Student


Sehen Sie sich das Profil von Andreas79 an!   Senden Sie eine Private Message an Andreas79  Schreiben Sie einen Gästebucheintrag für Andreas79

Beiträge: 134
Registriert: 16.12.2004

erstellt am: 23. Jun. 2008 13:45    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Vielen Dank für die Mühe, Nicksen.
Nein, ich lese nichts aus der .log-File aus. Der Fehler 144 kam bei mir bisher immer, wenn ich eine Variablenzuweisung nicht/falsch vorgenommen hatte.

Falls ich den Fehler finden sollte, werde ich ihn natürlich posten. Gibt's weitere Ideen?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

carsten1983
Mitglied
Doktorand


Sehen Sie sich das Profil von carsten1983 an!   Senden Sie eine Private Message an carsten1983  Schreiben Sie einen Gästebucheintrag für carsten1983

Beiträge: 125
Registriert: 11.10.2007

erstellt am: 22. Jan. 2009 09:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Andreas79 10 Unities + Antwort hilfreich

Hat sich hier mittlerweile was getan? Hab gerade fast das selbe Problem, nur mit write statt print

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz