Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  TurboCAD
  Datenbank

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Datenbank (1350 mal gelesen)
jossie
Mitglied
Astronom im Ruhestand


Sehen Sie sich das Profil von jossie an!   Senden Sie eine Private Message an jossie  Schreiben Sie einen Gästebucheintrag für jossie

Beiträge: 350
Registriert: 21.03.2008

TC 21 Pro Platinum, Windows10 (64bit), 24GByte RAM, Intel i7 950, ATI Radeon HD5700 Grafikkarte

erstellt am: 28. Mrz. 2010 20:20    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen und guten Abend,

darf ich an die TurboCAD-Gemeinde eine Frage zur Datenbank stellen? Ich habe eine Zeichnung auf meinem Laptop bearbeitet und einen Bericht definiert (TC15.2). Leider bekomme ich beim Anzeigen des Berichts immer die Fehlermeldung "Der erstellte Bericht ist leer".

Wenn ich diese Datei dann auf meinen Desktop kopiere, so ist die Berichtsdefinition zu allem Überfluss auch noch weg, d.h. die Berichtsliste ist leer. Die benutzerdefinierten Eigenschaften der Bauteile sind noch vorhanden.

Kann mir jemand sagen, was ich da falsch mache?

Danke und Gruß

Hermann-Josef

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

udohallmann
Mitglied
Schreiner


Sehen Sie sich das Profil von udohallmann an!   Senden Sie eine Private Message an udohallmann  Schreiben Sie einen Gästebucheintrag für udohallmann

Beiträge: 582
Registriert: 26.03.2009

TC 20 Platinum
FUJITSU Workstation
WIN 7 pro 32Bit 4(2,94)GB RAM 2,8GH
ATI Fire pro V3700 (FireGL)256 MB

erstellt am: 29. Mrz. 2010 07:19    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für jossie 10 Unities + Antwort hilfreich

Hallo Hermann,
wenn du nachdem der Bericht bearbeitet wurde vergisst mit OK zu bestätigen und das Fenster
schließt, gehen die Einstellungen verloren.
Nur eine Möglichkeit die mir spontan einfällt.
Hast du schon öfter mit der Datenbank gearbeitet?
Wennn`s nicht hilft häng doch mal deine Datei dran.

Gruß Udo Hallmann

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

jossie
Mitglied
Astronom im Ruhestand


Sehen Sie sich das Profil von jossie an!   Senden Sie eine Private Message an jossie  Schreiben Sie einen Gästebucheintrag für jossie

Beiträge: 350
Registriert: 21.03.2008

TC 21 Pro Platinum, Windows10 (64bit), 24GByte RAM, Intel i7 950, ATI Radeon HD5700 Grafikkarte

erstellt am: 29. Mrz. 2010 17:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Bericht.zip

 
Hallo Udo,

recht herzlichen Dank für die Rückmeldung.

Okay muss ich gedrückt haben, denn ich sehe die Elemente, die ich zum Ausprobieren in den Bericht aufnehmen wollte (siehe Screenshot).

Dies ist mein erster Gehversuch mit Datenbanken in TC. Ich habe die Hoffnung, damit Stücklisten inklusive Abmessungen erstellen zu können.

Ob der Bericht im angehängten TC-File mitkommt, weiss ich nicht. Denn beim Kopieren vom Laptop auf den Desktop ging er verloren ...

Beste Grüße

Hermann-Josef

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

udohallmann
Mitglied
Schreiner


Sehen Sie sich das Profil von udohallmann an!   Senden Sie eine Private Message an udohallmann  Schreiben Sie einen Gästebucheintrag für udohallmann

Beiträge: 582
Registriert: 26.03.2009

TC 20 Platinum
FUJITSU Workstation
WIN 7 pro 32Bit 4(2,94)GB RAM 2,8GH
ATI Fire pro V3700 (FireGL)256 MB

erstellt am: 29. Mrz. 2010 19:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für jossie 10 Unities + Antwort hilfreich

Hallo Hermann,

in Eigenschaften-Benutzerdefinert waren die Felddefinitionen nicht angefügt.
Laut deinem screenshot war der Bericht richtig definiert.
Also, Objekt anklicken-Eigenschaften-Benutzerdefiniert-Anfügen,
dann deine Felddefinitionen entsprechend auswählen.
Bei mir funktioniert es.
Du brauchst die Maße nicht von Hand in die Benutzerdefinierten Eigenschaften
eintragen, das geht auch über die Bemaßung automatisch.
Aber erstelle jetzt erst mal den Bericht, wenn dich das interessiert
melde dich noch mal.

Gruß
Udo Hallmann

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

jossie
Mitglied
Astronom im Ruhestand


Sehen Sie sich das Profil von jossie an!   Senden Sie eine Private Message an jossie  Schreiben Sie einen Gästebucheintrag für jossie

Beiträge: 350
Registriert: 21.03.2008

TC 21 Pro Platinum, Windows10 (64bit), 24GByte RAM, Intel i7 950, ATI Radeon HD5700 Grafikkarte

erstellt am: 29. Mrz. 2010 20:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Guten Abend Udo,

nun dachte ich schon, das wars. Ich habe auch die Dokumentation nochmals nachgelesen. Aber es klappt immer noch nicht.

Zum Testen habe ich eine einfache Datei erstellt:

Rechteck und dann extrudiert.
Feld "Länge" definiert.
Objekt ausgewählt,  Eigenschaften Anfügen Länge
Für Länge einen Wert angegeben
Datenbank Bericht. Länge als Berichtfeld hinzugefügt.
Mit OKAY bestätigt
Bericht...  Gibt Fehlermeldung wie bisher: Leerer Bericht.

Tut mir leid, aber irgendwie hab ichs wohl noch nicht ganz verstanden.

Vielen Dank für die Hilfestellung und einen schönen Abend

Hermann-Josef

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

udohallmann
Mitglied
Schreiner


Sehen Sie sich das Profil von udohallmann an!   Senden Sie eine Private Message an udohallmann  Schreiben Sie einen Gästebucheintrag für udohallmann

Beiträge: 582
Registriert: 26.03.2009

TC 20 Platinum
FUJITSU Workstation
WIN 7 pro 32Bit 4(2,94)GB RAM 2,8GH
ATI Fire pro V3700 (FireGL)256 MB

erstellt am: 29. Mrz. 2010 21:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für jossie 10 Unities + Antwort hilfreich

Hallo Hermann,

zeichne spasshalber einen Quader (mit dem Werkzeug "Quader"),
dann einen Bericht erstellen und wähle unter Objekte "Quader"
die Breite, Höhe und Länge aus.
Mal sehen was dann passiert.
Schau auch mal bei deinen PM`s rein, hab dir was geschrieben.


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

mlaufer
Mitglied
Konstrukteur


Sehen Sie sich das Profil von mlaufer an!   Senden Sie eine Private Message an mlaufer  Schreiben Sie einen Gästebucheintrag für mlaufer

Beiträge: 1108
Registriert: 10.07.2001

TC 25.0 Pro Platinum D,64-bit
Intel i7 4800MQ, 2,70 GHz,
Win7 P 64-bit, 16 GB RAM,
SSD 512 GB, NVidia Quadro K4100M

erstellt am: 30. Mrz. 2010 15:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für jossie 10 Unities + Antwort hilfreich


BerichtMB.jpg

 
Hallo Hermann!

Einen Bericht zu erstellen klappt mit deiner Zeichnung einwandfrei.

Anbei Bild.

Den Bericht selber mußt Du auf der Festplatte abspeichern.
Zum Beispiel im Excel - Format. Den Bericht kannst Du dann
in Excel weiter bearbeiten, falls benötigt. In folgenden Formaten
kann man den Bericht abspeichern: xls, mdb, csv oder txt.

Die Arbeitsweise ist, einem Bauteil die Teiledaten zuzuordnen.
Entweder mit EXTRAS/DATENBANK/OBJEKTDATEN BEARBEITEN.
Oder mit Rechtsklick auf EIGENSCHAFTEN/BENUTZERDEFINIERT.
Bei deiner Zeichnung sind die Objektdaten nur im Modelbereich
vorhanden und nicht im Papierbereich.
Danach wird das gewünschte Berichtslayout mit EXTRAS/DATENBANK/
BERICHT erstellt. Hier wählt man die gewünschten Titel aus, die
dann im entgültigen Bericht erscheinen sollen. Dieses Berichts-
format speichert man zur späterern Verwendung ab und ist dann
in TC vorhanden. Mit diesen Berichslayout erstellt
man nun den eigentlichen Bericht, der die Zeichnungs-Teiledaten
enthält. Und dieser Bericht kann dann auf der Festpaltte
abgespeichert, oder als Stückliste auch in die Zeichnung selber
im Papierbereich eingefügt werden.
Nach schließen des Hilfsmittels zur Berichtserstellung,
ist der Bericht dann in der Zeichnung wieder verschwunden und
muß bei Bedarf dann wieder neu erstellt werden.

Ich hoffe, das ich Dir etwas Klarheit verschaffen konnte.

Viele Grüße:

Manfred!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

jossie
Mitglied
Astronom im Ruhestand


Sehen Sie sich das Profil von jossie an!   Senden Sie eine Private Message an jossie  Schreiben Sie einen Gästebucheintrag für jossie

Beiträge: 350
Registriert: 21.03.2008

TC 21 Pro Platinum, Windows10 (64bit), 24GByte RAM, Intel i7 950, ATI Radeon HD5700 Grafikkarte

erstellt am: 30. Mrz. 2010 20:29    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Manfred,

vielen Dank für Deine Ausführungen. Leider funktioniert das bei mir überhaupt nicht.

Selbst das einfache Beispiel Quader, das Udo angeregt hat, führt bei mir zur Meldung "Der erstellte Bericht ist leer".

Ich arbeite im Modellbereich, die Zuordnung der benutzerdefinierten Eigenschaften wird korrekt angezeigt, wenn ich auf Eigenschaften / benutzerdefiniert gehe.

Ich werde mich nochmals im Handbuch an der Anleitung entlang hangeln müssen. Wenn das auch nichts hilft, dann ist vielleicht mit meiner Installation was im Argen ...

Beste Grüße

Hermann-Josef

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

jossie
Mitglied
Astronom im Ruhestand


Sehen Sie sich das Profil von jossie an!   Senden Sie eine Private Message an jossie  Schreiben Sie einen Gästebucheintrag für jossie

Beiträge: 350
Registriert: 21.03.2008

TC 21 Pro Platinum, Windows10 (64bit), 24GByte RAM, Intel i7 950, ATI Radeon HD5700 Grafikkarte

erstellt am: 30. Mrz. 2010 20:59    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Datenbank_demo.pdf

 
Hallo zusammen,

nun habe ich doch noch das, was ich mache, mit 2 Screenshots festgehalten. Ist ja eigentlich ganz einfach, wenn man das Beispiel Quader nimmt:

Quader erstellen und auswählen
Extras / Datenbank / Bericht
Erstellen / aus verfügbaren Feldern auswählen / Objekte - Quader - Länge usw. hinzufügen >> und mit OKAY beenden.
Bericht... zum Erstellen des Berichts.

Dann kommt die Fehlermeldung: "Der Bericht ist leer".

Da kann man doch eigentlich nicht viel falsch machen :-(. Hab mir auch nochmals aufmerksam die Dokumentation angesehen. Wenn ich nicht gerade blind bin, sollte das so funktionieren. Wenn Ihr mit meiner Datei da was raus bekommt, so muss das wohl an meiner TC-Installation liegen ???

Noch einen schönen Abend und bis bald

Hermann-Josef

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

udohallmann
Mitglied
Schreiner


Sehen Sie sich das Profil von udohallmann an!   Senden Sie eine Private Message an udohallmann  Schreiben Sie einen Gästebucheintrag für udohallmann

Beiträge: 582
Registriert: 26.03.2009

TC 20 Platinum
FUJITSU Workstation
WIN 7 pro 32Bit 4(2,94)GB RAM 2,8GH
ATI Fire pro V3700 (FireGL)256 MB

erstellt am: 30. Mrz. 2010 21:04    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für jossie 10 Unities + Antwort hilfreich

Hallo Hermann,

ich glaube nicht das es an dir liegt, eher an der Installation.
Nachdem ich in meiner Version 15 den Patch augespielt hatte war die Datenbank komplett weg.
Installier TC 15 doch mal neu, aber erst mal ohne Patch.

Gruß
Udo Hallmann

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

jossie
Mitglied
Astronom im Ruhestand


Sehen Sie sich das Profil von jossie an!   Senden Sie eine Private Message an jossie  Schreiben Sie einen Gästebucheintrag für jossie

Beiträge: 350
Registriert: 21.03.2008

TC 21 Pro Platinum, Windows10 (64bit), 24GByte RAM, Intel i7 950, ATI Radeon HD5700 Grafikkarte

erstellt am: 30. Mrz. 2010 21:13    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Udo,

danke für den Hinweis, dass Du mit der Datenbank mit TC15 auch Probleme hattest. Das gibt Hoffnung. Die Datenbank liegt mir schon am Herzen. Wäre toll, wenn das funktioniert. Hab auch Deinen Beitrag zu diesem Thema über die Bemaßung gefunden. Wenn es mal läuft, werde ich das versuchen.

Ich werde auf meinem Laptop probeweise TC neu installieren, aber nicht mehr heute abend :-)

Beste Grüße

Hermann-Josef

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

mlaufer
Mitglied
Konstrukteur


Sehen Sie sich das Profil von mlaufer an!   Senden Sie eine Private Message an mlaufer  Schreiben Sie einen Gästebucheintrag für mlaufer

Beiträge: 1108
Registriert: 10.07.2001

TC 25.0 Pro Platinum D,64-bit
Intel i7 4800MQ, 2,70 GHz,
Win7 P 64-bit, 16 GB RAM,
SSD 512 GB, NVidia Quadro K4100M

erstellt am: 31. Mrz. 2010 14:16    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für jossie 10 Unities + Antwort hilfreich


BerichtHolz.jpg


BerichtWuerfel1.jpg

 
Hallo Hermann!

Ich habe nun nochmal alles mit der Version 15 ausprobiert.
(Zuvor mit der aktuellen Version 16.)
Funktioniert alles. Bilder anbei.
Meine Version: 15.2 Build 46.0
Bei deiner Zeichnung Georg_std.tcw wurde ganz normal der
Bericht erstellt, wie es sein sollte.
Eine neue Installation kann ja nicht schaden.
Viele Grüße und viel Glück dabei:
Manfred!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

jossie
Mitglied
Astronom im Ruhestand


Sehen Sie sich das Profil von jossie an!   Senden Sie eine Private Message an jossie  Schreiben Sie einen Gästebucheintrag für jossie

Beiträge: 350
Registriert: 21.03.2008

TC 21 Pro Platinum, Windows10 (64bit), 24GByte RAM, Intel i7 950, ATI Radeon HD5700 Grafikkarte

erstellt am: 31. Mrz. 2010 17:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Udo und Manfred,

so, nun habe ich TC deinstalliert und Version 15 neu aufgespielt. Damit funktioniert der Bericht. Das Problem liegt also wohl am Patch auf 15.2 (bei mir build 52).

Nochmals vielen Dank für Eure Tipps.

Hermann-Josef

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz