Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  TurboCAD
  3D wird nicht gefüllt

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   3D wird nicht gefüllt (1325 mal gelesen)
thomasz
Mitglied


Sehen Sie sich das Profil von thomasz an!   Senden Sie eine Private Message an thomasz  Schreiben Sie einen Gästebucheintrag für thomasz

Beiträge: 2
Registriert: 10.03.2006

erstellt am: 10. Mrz. 2006 14:36    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo!

Habe eine Anfängerfrage.

Habe einige Linien und Bögen zu einem Grunsriss
zusammengefügt und möchte diese nun als Polylinie verbinden.
Der Menüpunkt ist aber ausgegraut.

Ich möchte diese Linien mit einer Höhe (Z) versehen, es
wird aber hier (natürlich) so nur ein Gerüst erstellt und
die Fläche nicht gefüllt.

Wo mach ich da einen Fehler?

Gruß
Thomas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

arom
Ehrenmitglied
Interiordesign


Sehen Sie sich das Profil von arom an!   Senden Sie eine Private Message an arom  Schreiben Sie einen Gästebucheintrag für arom

Beiträge: 1599
Registriert: 01.11.2004

TC 20 Pro
Blender
MOI 3D V2

erstellt am: 10. Mrz. 2006 15:13    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasz 10 Unities + Antwort hilfreich

Vielleicht bist du nicht im Drahtgitterbereich?

Gruss arom

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

debebaboil
Mitglied
Taxifahrer


Sehen Sie sich das Profil von debebaboil an!   Senden Sie eine Private Message an debebaboil  Schreiben Sie einen Gästebucheintrag für debebaboil

Beiträge: 79
Registriert: 12.08.2004

XP-Home
AMD Athlon XP 3200+
1024 MB
Geforce FX-5200<P>TC 8.2 pro

erstellt am: 10. Mrz. 2006 15:29    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasz 10 Unities + Antwort hilfreich

Hallo Thomas !

Zunächst einmal: mit welcher Version arbeitest Du überhaupt ?
Für die Version 8.2 kann ich folgendes sagen:
Polylinien werden nur dann ausgefüllt dargestellt, wenn sie auch wirklich geschlossen sind. Dazu müssen sie aus tatsächlich verbindbaren Einzellinien/Polylinien und Bögen erstellt sein, die sich das gleiche Koordinatensystem teilen und exakt aneinander angrenzen. Mit schlampigen Zeichnungen und dem Befehl >Polylinie verbinden< wirst Du immer Schwierigkeiten haben.
Es gibt aber auch die Möglichkeit über den Befehl >Auswahlpunkt Schraffur< das Objekt zu schraffieren, der Schraffur im Kontextmenü die Eigenschaft >Muster: kein<  zuzuweisen und auf diese Weise eine geschlossene Grenz-Polylinie zu erhalten. Die ist dann in einer 3D-Darstellung gefüllt. Allerdings gehen bei dieser Vorgehensweise die Skalierungsknoten von in der Zeichnung eventuell vorhandenen Bogensegmenten verloren.

Viele Grüsse

debebaboil


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

thomasz
Mitglied


Sehen Sie sich das Profil von thomasz an!   Senden Sie eine Private Message an thomasz  Schreiben Sie einen Gästebucheintrag für thomasz

Beiträge: 2
Registriert: 10.03.2006

erstellt am: 10. Mrz. 2006 15:49    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo!

Ich arbeite mit V11.

Die Bögen und Linien habe ich allesamt mit dem Fang "erstellt".
Aber ich habe jetzt festgestellt, dass wenn ich ein bereits
fertiges 3D-Modell hier im Modellbereich lösche, sich auch
die Polylinien wieder verbinden lassen. Aber ich werde das
auch nochmals anders testen, wie ich die Linien geschlossen bekomme.

Habe also z.B. zwei Kreise, dann zwei Linien mit dem Tangendenfang
dazu gemacht. Dann die beiden Kreise geteilt (Objekt teilen) und
mit "Objekte verbinden" jeweils die Bögen und Linien verbunden. So
ergibt sich bspw. die Draufsicht eines Riemens.
Und diesem "Gebilde" möchte ich nun ein Z zuweisen und zwar so,
dass auch der Mittelteil, welcher durch die Kontur gebildet wurde
auch mit gefüllt ist.

Gruß
Thomas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

arom
Ehrenmitglied
Interiordesign


Sehen Sie sich das Profil von arom an!   Senden Sie eine Private Message an arom  Schreiben Sie einen Gästebucheintrag für arom

Beiträge: 1599
Registriert: 01.11.2004

TC 20 Pro
Blender
MOI 3D V2

erstellt am: 10. Mrz. 2006 17:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasz 10 Unities + Antwort hilfreich

Hallo Thomasz,

du willst also einen Körper herstellen.
Am besten geht das mit Normale Extrusion...Zusammengesetzes Profil verwenden. Dabei wird automatische die gesamte Polylinie verwendet.

Gruss arom 

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

debebaboil
Mitglied
Taxifahrer


Sehen Sie sich das Profil von debebaboil an!   Senden Sie eine Private Message an debebaboil  Schreiben Sie einen Gästebucheintrag für debebaboil

Beiträge: 79
Registriert: 12.08.2004

XP-Home
AMD Athlon XP 3200+
1024 MB
Geforce FX-5200<P>TC 8.2 pro

erstellt am: 10. Mrz. 2006 18:12    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasz 10 Unities + Antwort hilfreich

Hallo Thomas !

Von meiner Steinzeit-Version weiss ich, dass die Fangfunktionen genau in dem Bereich, den Du beschrieben hast, oftmals nicht perfekt funktionieren, obwohl sich der Befehl >Polylinie verbinden< ausführen lässt. Wenn man dann aber nah genug heranzoomt an die Verbindungsstellen kann man erkennen, dass die Linien sich ein wenig überlappen und somit - anders als es einem das Programm weismachen will - doch keine Polylinie ergeben. Da kamen dann genau die von dir beschriebenen unbefriedigenden 3D-Gebilde bei raus. In solchen Fällen habe ich die Linien oft mühsam über den Knoten-Bearbeitungsmodus und Scheitelpunktfang miteinander verbinden müssen.
Wär mal interessant, zu erfahren, ob es diese Probleme/Ungenauigkeiten in der aktuellen Version auch noch gibt ?!?

Viele Grüsse

debebaboil

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

RexDanni
Moderator



Sehen Sie sich das Profil von RexDanni an!   Senden Sie eine Private Message an RexDanni  Schreiben Sie einen Gästebucheintrag für RexDanni

Beiträge: 1993
Registriert: 06.06.2000

TurboCAD V2018 Pro Platinum German
Workstation HP Z4 G6
Intel Xeon W2123 3,6GHz, 8,25 MB
16GB DDR4 SDRAM
256 HP T Turbo Drive PCle SSD
Windows 10 pro 64 for Workstations
NVIDIA Quadro M4000 8GB

erstellt am: 13. Mrz. 2006 10:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasz 10 Unities + Antwort hilfreich

Hallo debebaboil,

da muss ich Dir jetzt aber wiedersprechen!
Selbst in meiner aller ersten Steinzeitversion 2.0 hat der Fang schon absolut zuverlässig gearbeitet.

Solche von Dir beschriebenen Fehler liegen nicht am Programm sondern am User. Häufig wird z.B. der Rasterfang zusammen mit anderen Fängen verwendet, dabei kann es passieren das wenn der Rasterpunkt direkt neben z.B. einem Scheitelpunkt liegt, der User zwar meint er habe den Scheitelpunkt gefangen, in Wirklichkeit der Rasterpunkt gefangen wurde.
Ähnliches gilt wenn der Ortomodus gleichzeitig mit Fängen verwendet wird, hier kann es zu einer parallel Verschiebung der Fangpunkte kommen.

Das beste Mittel gegen solche "Fehlfänge" ist, das Werkzeug Magnetischer Punkt anzeigen" zu aktivieren, den da wird bei der Verwendung des Fangwerkzeugs, dieses nicht nur sozusagen magnetisch angezogen, sondern auch ein Symbol des gerade vom Programm verwendeten Fangpuntes angezeigt.
So sehe ich auf den ersten Blick ob der richtige Punkt gefangen wird oder nicht.

Das oben beschrieben Problem mit den nicht zu verbindenden Polylinien, kommt recht häufig vor wenn man zwischen den 2D und 3D Modus wechselt. Dabei kann es ungewollt zu Verschiebungen des Koordinatensystems bzw. der Arbeitsbene kommen was zu oben genannten Problemen führt. 

Abhilfe schafft hier der Befehl "Auf Arbeitseben verschieben",
oder der von Dir beschriebene Trick mit der Schraffur den ich immer in früheren TC Versionen angewand habe, als es das Werkzeug "Polylinien verbinden" in TC noch nicht gab.

Hans Jörg 

------------------
TurboCAD Training Center
CNC Modellbautechnik Bayer

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

debebaboil
Mitglied
Taxifahrer


Sehen Sie sich das Profil von debebaboil an!   Senden Sie eine Private Message an debebaboil  Schreiben Sie einen Gästebucheintrag für debebaboil

Beiträge: 79
Registriert: 12.08.2004

XP-Home
AMD Athlon XP 3200+
1024 MB
Geforce FX-5200<P>TC 8.2 pro

erstellt am: 13. Mrz. 2006 23:31    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasz 10 Unities + Antwort hilfreich

Hallo Hans-Joerg!

Also das mit dem Fangen krieg ich schon ganz gut hin und den magnetischen Punkt lasse ich mir aus genau den von dir beschriebenen Gründen immer anzeigen. Auch der Befehl >Auf Arbeitebene platzieren< ist mir - insbesondere bei gespiegelten Objekten - in seiner Funktion durchaus geläufig. Ich habe nicht geschriebenen, dass die Fangfunktionen per se nicht funktionieren, sondern dass Thomas möglicherweise einen Sonderfall erwischt hat, mit dem auch ich mehrmals - aber aus unerfindlichen Gründen nicht immer - Probleme hatte.
Das Problem enstand bei folgenden Vorgehensweisen:
1. Teilen eines Kreises mit dem Befehl >Objekt teilen< am Scheitelpunkt einer zuvor mit dem Tangentenfang an diesem Objekt angelegten Linie.
2. Fangen eines Skalierungspunktes des Kreises im Knotenbearbeitungsmodus am Scheitelpunkt einer ebenfalls mit Tangentenfang zuvor am genannten Kreis angelegten Linie
In beiden Fällen kam es zu folgenden Auswirkungen:
Der Befehl >Polylinie verbinden< liess sich sowohl in der manuellen als auch in der automatischen Version problemlos ausführen und das entstandene Objekt liess sich auch als Polylinie auswählen. Bei der Stärkenzuweisung wurde aber - wie von Thomas beschrieben - die Mitte nicht ausgefüllt.
Ich habe mir dann die Polylinie im Knotenbearbeitungmodus angesehen und Scheitelpunkt für Scheitelpunkt sehr (!!!) nah herangezoomt. Dabei konnte ich feststellen, dass sich Bogensegment und Linie teilweise überkreuzten und keinen gemeinsamen Knoten hatten. Nach dem Verbinden mittels Scheitelpunktfang war die Mitte des entstandenen Riemens plötzlich ausgefüllt.
Bei anderen Vorgehensweisen hatte ich dieses Problem noch nicht aber über die herstellerfreundliche Pauschalaussage, dass so ein Problem am User läge, werde ich mich noch ein bischen weiter wundern...

Viele Grüsse

debebaboil

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

RexDanni
Moderator



Sehen Sie sich das Profil von RexDanni an!   Senden Sie eine Private Message an RexDanni  Schreiben Sie einen Gästebucheintrag für RexDanni

Beiträge: 1993
Registriert: 06.06.2000

TurboCAD V2018 Pro Platinum German
Workstation HP Z4 G6
Intel Xeon W2123 3,6GHz, 8,25 MB
16GB DDR4 SDRAM
256 HP T Turbo Drive PCle SSD
Windows 10 pro 64 for Workstations
NVIDIA Quadro M4000 8GB

erstellt am: 13. Mrz. 2006 23:54    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasz 10 Unities + Antwort hilfreich

hallo debebaboil

das Problem resultiert aus der Mischung von verschiedenen Fängen und dem Knotenbearbeitungsmodus.
hast Du den Kreis explodiert oder was verstehst Du unter "skalierungspunkt"?
Evtl. solltest Du in einem solchen Fall nicht den Fang "Tangente" nutzen sondern besser das Linienwerkzeug Linie "zur Tangente" bzw. "von Tangente"

Mein Wiederspruch bezog sich auf deine pauschale Aussage über ältere Versionen von TC. Du erweckst dabei den Eindruck als ob diese über eine fehlerhafte Fangfunktion verfügen, was so einfach nicht richtig ist.

Auch spitzfindige Äusserungen wie  "herstellerfreundliche Pauschalaussage" kannst Du dir mir gegenüber sparen!
In TC läuft genügend schief wie z.B. die geänderte Funktionsweise des Schalters "kein Fang" in der Version 11,da brauchen wir nix dazu dichten.

Das wars.
Hans Jörg 

------------------
TurboCAD Training Center
CNC Modellbautechnik Bayer

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

arom
Ehrenmitglied
Interiordesign


Sehen Sie sich das Profil von arom an!   Senden Sie eine Private Message an arom  Schreiben Sie einen Gästebucheintrag für arom

Beiträge: 1599
Registriert: 01.11.2004

TC 20 Pro
Blender
MOI 3D V2

erstellt am: 14. Mrz. 2006 00:38    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasz 10 Unities + Antwort hilfreich

Hallo debabeboil,

ich habe Hans-Jörg beim letzten CAD-Anwendertreffen in Stuttgart kennengelernt und kann Dir auf Grund eines Gespräches, welches ich mit Ihm gehabt habe versichern, dass seine Aussage keine herstellerfreundliche Pauschalaussage war, sondern das er sich sehr kritisch, in Form von konstruktiver Kritik, mit dem Programm auseinandersetzt und nicht zur Gattung der Kriecher gehört.


Zum Fangen von Punkten kann ich nur eins sagen: ETK.


Gruss arom

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

debebaboil
Mitglied
Taxifahrer


Sehen Sie sich das Profil von debebaboil an!   Senden Sie eine Private Message an debebaboil  Schreiben Sie einen Gästebucheintrag für debebaboil

Beiträge: 79
Registriert: 12.08.2004

XP-Home
AMD Athlon XP 3200+
1024 MB
Geforce FX-5200<P>TC 8.2 pro

erstellt am: 14. Mrz. 2006 09:53    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für thomasz 10 Unities + Antwort hilfreich

Hallo Hans-Joerg und Arom !

Ich wollte jetzt niemandem gegen das Bein pinkeln aber ich finde die gemachte Aussage, das so etwas am User liegt nach wie vor nicht richtig. Wenn eine Funktion angeboten wird, dann sollte sie auch funktionieren. Und gerade für Anfänger wäre es wichtig, nicht an Klippen hängenbleiben zu müssen, die in keinem Plan verzeichnet sind. Wenn ich Hans-Joerg durch meine Bemerkung in die Nähe eines `Kriechers´ gerückt haben sollte, dann tut mir das leid. Ich neige manchmal zu Spitzfindigkeiten, das gebe ich zu ...
Den Kreis habe ich übrigens nicht explodiert, sondern nur im Knotenbearbeitungsmodus den grünen und roten Punkt zur Änderung des Öffnungswinkels des Kreises/Bogens benutzt und diesen dann am Scheitelpunkt der Tangente gefangen. Aus mathematischer Sicht hätte diese Vorgehensweise funktionieren müssen - tat sie aber nicht immer.
Auch mit >Objekt teilen< gab´s ähnliche Probleme.
Weshalb ich seitdem  den von Hans-Joerg beschriebenen Weg wähle (Tangente Bogen zu Bogen und ähnliches). Es war aber eben mühsam, dem Problem auf den Grund zu gehen und da ist dann eine Aussage wie die vom Fehler des Users einfach nicht hilfreich.

Viele Grüsse

debebaboil

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz