Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SolidWorks
  Fehlermeldungen bei Verknüpfungen

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
  
Gut zu wissen: Hilfreiche Tipps und Tricks aus der Praxis prägnant, und auf den Punkt gebracht für SOLIDWORKS
Autor Thema:  Fehlermeldungen bei Verknüpfungen (271 mal gelesen)
Panthera67
Mitglied



Sehen Sie sich das Profil von Panthera67 an!   Senden Sie eine Private Message an Panthera67  Schreiben Sie einen Gästebucheintrag für Panthera67

Beiträge: 53
Registriert: 09.08.2021

SOLIDWORKS 2021 SP3.0
Micorsoft Windows 10

erstellt am: 16. Jan. 2023 12:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

Ich mache generell viele Verknüpfungen wenn im Modus "Bauteile" arbeite. Am Anfang gibt es keine Probleme, aber nach einer gewissen Zeit, wenn ich die Baugruppe in eine andere Baugruppe einfügen möchte wird mir ein Fehler angezeigt. Wenn ich nun in das ursprüngliche Bauteil gehe, werden mir dann dort auch die selben Fehler angezeigt. Es sind immer Fehler bezüglich Verknüpfungen.

Eines der Elemente oder referenzierten Features dieser Verknüpfung ist unterdrückt, ungültig oder nicht mehr vorhanden.
Eines der Elemente oder referenzierten Features dieser Verknüpfung ist unterdrückt, ungültig oder nicht mehr vorhanden.
Eines der Elemente oder referenzierten Features dieser Verknüpfung ist unterdrückt, ungültig oder nicht mehr vorhanden.

usw.

Ich kann mir nicht erklären wo diese herkommen. habt ihr Tipps wie ich diese vermeiden kann?

Vielen Dank und Grüße
Panthera

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Ralf Tide
Moderator
Beratender Ingenieur




Sehen Sie sich das Profil von Ralf Tide an!   Senden Sie eine Private Message an Ralf Tide  Schreiben Sie einen Gästebucheintrag für Ralf Tide

Beiträge: 4862
Registriert: 06.08.2001

Sehr seltsame Dinge passiern <Klaus Lage - Toy Story>
.-)

erstellt am: 16. Jan. 2023 12:53    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Panthera67 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Panthera67:
...Am Anfang gibt es keine Probleme, aber nach einer gewissen Zeit, wenn ich die Baugruppe in eine andere Baugruppe einfügen möchte wird mir ein Fehler angezeigt. Wenn ich nun in das ursprüngliche Bauteil gehe, werden mir dann dort auch die selben Fehler angezeigt. Es sind immer Fehler bezüglich Verknüpfungen...

Ich kann mir nicht erklären wo diese herkommen. habt ihr Tipps wie ich diese vermeiden kann?


Ich denke es fehlt an der entsprechenden Grundschulung.

Ein Erklärungsversuch:
Wenn Du mit Referenzen in einer Baugruppe (A) arbeitest, dan werden die Referenzen in den Bauteilen über diese Baugruppe (A) erzeugt. Wenn Du nun diese Bauteile in eine neue Baugruppe (B) einfügst, dann sind die Referenzen (z.B. bestimmte Kanten, bei Unterbaugruppen natürlich auch Verknüpfungen) immer noch in der ursprünglichen Baugruppe A.

Ein Analysewerkzeig:
Um die Abhängigkeiten zu sehen, kannst Du den Befehl Referenzen suchen... verwenden.

Eine Abhilfemöglichkeit:
Wenn Du eine Unterbaugruppe (X) ohne Referenzen in der übergeordneten Baugruppe erstellt hast, kannst Du eine Kopie der Unterbaugruppe (X) mit Pack&Go machen und z.B. einen Suffix (z.B.: _2) vergeben. Diese neue Unterbaugruppe (X_2) ist eine Kopie der Unterbaugruppe X aber die Referenzen der Komponenten sind nicht mehr über X sondern über X_2 erzeugt...

HTH
Ralf

------------------

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Panthera67
Mitglied



Sehen Sie sich das Profil von Panthera67 an!   Senden Sie eine Private Message an Panthera67  Schreiben Sie einen Gästebucheintrag für Panthera67

Beiträge: 53
Registriert: 09.08.2021

SOLIDWORKS 2021 SP3.0
Micorsoft Windows 10

erstellt am: 16. Jan. 2023 16:22    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke für die Antwort. Du hast absolut Recht: Ich habe noch nie eine Schulung für 3D Programme bekommen.

Beim einsetzen der Referenzen gibt es keine Probleme. Das ist meistens eine Schraube, die ich an ein Loch setzen will und die dann da auch für immer und ewig bleiben soll. Erst wenn ich die Baugruppe(A) in eine Baugruppe(B) einbaue und das Projekt abspeichere und wieder starte, dann wird mir zu 70% ein Fehler bezüglich der Referenzen angezeigt. Also nicht immer und das immer nur bei den Schrauben aber nicht bei allen.
Auch deine Erklärung erschließt sich mir nicht. Ich verstehe nicht, warum einfach nicht die Schraube an ihrem Platz bleiben darf.
Kann es sein das ich die Referenzen falsch setze?
Also als erstens mache ich immer die Schraube Deckungsgleich mit der Platte, damit die Höhe Stimmt. Und dann mache ich sie Konzentrisch mit dem Loch.

Gibt es ein Video, welches ein ähnliches Problem behandelt?

Danke

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Panthera67
Mitglied



Sehen Sie sich das Profil von Panthera67 an!   Senden Sie eine Private Message an Panthera67  Schreiben Sie einen Gästebucheintrag für Panthera67

Beiträge: 53
Registriert: 09.08.2021

SOLIDWORKS 2021 SP3.0
Micorsoft Windows 10

erstellt am: 16. Jan. 2023 16:32    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke für die Antwort. Du hast absolut Recht: Ich habe noch nie eine Schulung für 3D Programme bekommen.

Beim einsetzen der Referenzen gibt es keine Probleme. Das ist meistens eine Schraube, die ich an ein Loch setzen will und die dann da auch für immer und ewig bleiben soll. Erst wenn ich die Baugruppe(A) in eine Baugruppe(B) einbaue und das Projekt abspeichere und wieder starte, dann wird mir zu 70% ein Fehler bezüglich der Referenzen angezeigt. Also nicht immer und das immer nur bei den Schrauben aber nicht bei allen.
Auch deine Erklärung erschließt sich mir nicht. Ich verstehe nicht, warum einfach nicht die Schraube an ihrem Platz bleiben darf.
Kann es sein das ich die Referenzen falsch setze?
Also als erstens mache ich immer die Schraube Deckungsgleich mit der Platte, damit die Höhe Stimmt. Und dann mache ich sie Konzentrisch mit dem Loch.

Gibt es ein Video, welches ein ähnliches Problem behandelt?

Danke

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

dopplerm
Ehrenmitglied V.I.P. h.c.
Konstrukteur


Sehen Sie sich das Profil von dopplerm an!   Senden Sie eine Private Message an dopplerm  Schreiben Sie einen Gästebucheintrag für dopplerm

Beiträge: 3448
Registriert: 11.02.2005

Win 10
SWX 2019 SP 5.0

erstellt am: 17. Jan. 2023 09:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Panthera67 10 Unities + Antwort hilfreich

mein vorgehen:
Baugruppe in der die Schrauben eingebaut werden öffnen,
damit du nicht mehr in einer Überbaugruppe bist
hier die Schrauben einfügen, dann sollten die Verknüpfungen passen

ich vermute nehmlich, dass du irgendwie auf die Überbaugruppe, oder Nachbarbaugruppe verknüpfst

lg Martin

------------------
ich spiel noch immer gern mit Bauklötzen, nur sind sie jetzt teurer 

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Christian_W
Ehrenmitglied V.I.P. h.c.
Konstrukteur (Dipl-Ing)


Sehen Sie sich das Profil von Christian_W an!   Senden Sie eine Private Message an Christian_W  Schreiben Sie einen Gästebucheintrag für Christian_W

Beiträge: 2962
Registriert: 04.04.2001

SWX2021sp5 WIN10
proAlpha6.2e00/calinkV9
(Tactonworks)
(Medusa7, NesCAD2010,
solidEdge19) CSWP 12/2015

erstellt am: 17. Jan. 2023 10:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Panthera67 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Panthera67:
... Ich habe noch nie eine Schulung für 3D Programme bekommen.

... dann wird mir zu 70% ein Fehler bezüglich der Referenzen angezeigt. Also nicht immer und das immer nur bei den Schrauben aber nicht bei allen.
...
Gibt es ein Video, welches ein ähnliches Problem behandelt?


Hallo Panthera,

bei SolidWorks werden Online-Lektionen mitgeliefert. Geh mal auf das Fragezeichen (Hilfe) und dann auf "Lehrbücher" - da sollten viele Grundlagen dabei sein.

aus deiner Formulierung - "gehe ins Teil" kommt man schnell auf eine falsche Fährte. Man kann mit externen Referenzen arbeiten, darauf bezog sich die Antwort.
du findest im Featurebaum die Verknüpfungen in der Baugruppe angezeigt, aber auch nochmal "im" Teil - dort nur die, die auch das Teil betreffen - sind aber die gleichen wie in der Baugruppe. Ich vermute jetzt, du meinst die. (anders als ext. Referenzen werden die Verknüpfungen aber nicht im Teil gespeichert.)
Normalerweise ist da auch stabil - Frage: wie machst du die Löcher?

Gruß, christian

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Panthera67
Mitglied



Sehen Sie sich das Profil von Panthera67 an!   Senden Sie eine Private Message an Panthera67  Schreiben Sie einen Gästebucheintrag für Panthera67

Beiträge: 53
Registriert: 09.08.2021

SOLIDWORKS 2021 SP3.0
Micorsoft Windows 10

erstellt am: 17. Jan. 2023 11:01    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke an alle die geantwortet haben.

Zitat:
Original erstellt von Christian_W:

Normalerweise ist da auch stabil - Frage: wie machst du die Löcher?

Gruß, christian


Ich erstelle ein neues Teil. Dann mache ich eine einfache Blechzeichnung z.B. ein Rechteck. Dieses wird mit Abschluss der Skizze automatisch extrudiert. In das Blech füge ich dann die gewünschten Bohrungen mit der Funktion "Features" und "Bohrungsassistent" ein. Das Teil wird abgespeichert und in eine Baugruppe hinzugefügt und mit den entsprechenden Schrauben referenziert. Diese Baugruppe wird dann in eine weitere Baugruppe eingefügt.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Christian_W
Ehrenmitglied V.I.P. h.c.
Konstrukteur (Dipl-Ing)


Sehen Sie sich das Profil von Christian_W an!   Senden Sie eine Private Message an Christian_W  Schreiben Sie einen Gästebucheintrag für Christian_W

Beiträge: 2962
Registriert: 04.04.2001

SWX2021sp5 WIN10
proAlpha6.2e00/calinkV9
(Tactonworks)
(Medusa7, NesCAD2010,
solidEdge19) CSWP 12/2015

erstellt am: 17. Jan. 2023 11:48    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Panthera67 10 Unities + Antwort hilfreich

Hört sich erstmal nicht ungewöhnlich an ...

kannst du vielleicht mal eine musterbaugruppe erstellen, in der das zu sehen ist und die hier hochladen? (1 Schraube, 1 Blech, Baugruppe, übergeordnete Baugruppe in zip gepackt).

Gruß, Christian

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Panthera67
Mitglied



Sehen Sie sich das Profil von Panthera67 an!   Senden Sie eine Private Message an Panthera67  Schreiben Sie einen Gästebucheintrag für Panthera67

Beiträge: 53
Registriert: 09.08.2021

SOLIDWORKS 2021 SP3.0
Micorsoft Windows 10

erstellt am: 18. Jan. 2023 11:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


muster.zip

 
Zitat:
Original erstellt von Christian_W:
Hört sich erstmal nicht ungewöhnlich an ...

kannst du vielleicht mal eine musterbaugruppe erstellen, in der das zu sehen ist und die hier hochladen? (1 Schraube, 1 Blech, Baugruppe, übergeordnete Baugruppe in zip gepackt).

Gruß, Christian


Ja, das habe ich gemacht.
In der Zip. Datei findest du die Baugruppe, wo 2 Schrauben mit einem Blech-Teil verknüpft sind. Die Fehler sind nun tatsächlich auch in dieser Baugruppe aufgetaucht, weshalb ich es hochlade.

danke

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Christian_W
Ehrenmitglied V.I.P. h.c.
Konstrukteur (Dipl-Ing)


Sehen Sie sich das Profil von Christian_W an!   Senden Sie eine Private Message an Christian_W  Schreiben Sie einen Gästebucheintrag für Christian_W

Beiträge: 2962
Registriert: 04.04.2001

SWX2021sp5 WIN10
proAlpha6.2e00/calinkV9
(Tactonworks)
(Medusa7, NesCAD2010,
solidEdge19) CSWP 12/2015

erstellt am: 18. Jan. 2023 14:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Panthera67 10 Unities + Antwort hilfreich

Ah, du hast die Schraube als step Datei eingebunden.
wir haben 3D-Interconnect ausgestellt und speichern die Teile/Baugruppen als SoldiWorks Teile (sldprt) bzw. ggf. auch als Baugruppe (sldasm).

Meine Vermutung ist, dass es daran liegen könnte.
ich würde die Schrauben als SolidWorks Teil speichern, ggf. eine benannte Verknüpfungsebene und Achse hinzufügen, und es damit probieren.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Panthera67
Mitglied



Sehen Sie sich das Profil von Panthera67 an!   Senden Sie eine Private Message an Panthera67  Schreiben Sie einen Gästebucheintrag für Panthera67

Beiträge: 53
Registriert: 09.08.2021

SOLIDWORKS 2021 SP3.0
Micorsoft Windows 10

erstellt am: 18. Jan. 2023 14:35    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke das werde ich Probieren

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Christian_W
Ehrenmitglied V.I.P. h.c.
Konstrukteur (Dipl-Ing)


Sehen Sie sich das Profil von Christian_W an!   Senden Sie eine Private Message an Christian_W  Schreiben Sie einen Gästebucheintrag für Christian_W

Beiträge: 2962
Registriert: 04.04.2001

SWX2021sp5 WIN10
proAlpha6.2e00/calinkV9
(Tactonworks)
(Medusa7, NesCAD2010,
solidEdge19) CSWP 12/2015

erstellt am: 18. Jan. 2023 14:51    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Panthera67 10 Unities + Antwort hilfreich

Ergänzungen:
- für Schrauben nutzen wir die Varbox (sowas ähnliches wie Toolbox) und haben damit parametrisch aufgebaute Schrauben in angepassten Größen direkt als SWX-Format.
  vielleicht bekommst du aus der Toolbox auch brauchbare Schrauben?
- ein erster Versuch (SWX2021sp5) mit deiner STEP hat die Verknüpfungsfehler bei mir nicht produziert. Aber wenn es nur bei 70% auftritt, muss ich wohl noch ein paar mal ...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2023 CAD.de | Impressum | Datenschutz