Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  CATIA V5 Infrastruktur
  CATBatImpXMLSet Licensing

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   CATBatImpXMLSet Licensing (2469 mal gelesen)
segl
Mitglied
CAD Systemadmin

Sehen Sie sich das Profil von segl an!   Senden Sie eine Private Message an segl  Schreiben Sie einen Gästebucheintrag für segl

Beiträge: 9
Registriert: 13.07.2005

erstellt am: 02. Okt. 2007 21:08    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

auf dem langen Weg zu einer vernünftigen Lizenzsteuerung bin ich auf folgendes Phänomen gestossen:

Catia V5R17SP03HF19 im Admin Modus starten
MD2 Lizenz setzen und alles in den License Settings sperren
Catia beenden
Mit CATBatGenXMLSet -admin ein XML File davon erzeugen
Das bestehende Licensing.CATSettings löschen
Mit CATBatImpXMLSet -admin das erzeugte XML File wieder einlesen
Catia starten

Die MD2 Lizenz ist dann zwar ausgewählt, jedoch sind alle Locks verschwunden.

Weiß jemand, warum???

Vielen Dank schonmal
Klaus

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Willie
Mitglied
IT


Sehen Sie sich das Profil von Willie an!   Senden Sie eine Private Message an Willie  Schreiben Sie einen Gästebucheintrag für Willie

Beiträge: 28
Registriert: 09.09.2004

Catia V4 und V5.
IRIX, HP-UX, AIX, Windows XP.
Abaqus, Nastran, Medina, Autoform, Hyperworks.
Icem Surf, Pro/E.

erstellt am: 31. Okt. 2007 15:31    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für segl 10 Unities + Antwort hilfreich

Die XML datei ist ja lesbar und muss ungefaehr so aussehen.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE CATSettingRepository [
<!ELEMENT CATSettingRepository (Attribute*)>
<!ATTLIST CATSettingRepository Name NMTOKEN #REQUIRED>
<!ELEMENT Attribute (Value*)>
<!ATTLIST Attribute Name CDATA #REQUIRED
                  Type CDATA #REQUIRED
                  Size NMTOKEN #REQUIRED
                  Lock (Locked|JustLocked|Unlocked) "Unlocked">

mit der ausnahme das bei dir "JustLocked" eingetragen werden muss.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Dieter7
Mitglied
Konstrukteur und CAD-Admin


Sehen Sie sich das Profil von Dieter7 an!   Senden Sie eine Private Message an Dieter7  Schreiben Sie einen Gästebucheintrag für Dieter7

Beiträge: 94
Registriert: 12.10.2007

erstellt am: 08. Nov. 2007 22:03    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für segl 10 Unities + Antwort hilfreich

So sehen bei mir die exportierten XML-Files auch aus, wenn ich z.B. FrameGeneral.CATSettings FrameConfig.CATSettings oder DialogEditStack.CATSettings oder DialogPosition.CATSettings oder..
exportiere. 

Hat jemand mit dem Batch-Befehl schon was anderes ausgelesen? Beim Zurückimportieren kann ja auch nicht viel mehr zurückkommen als was im xml-File steht: Nichts 

Meine Befehlsfolge lautet (in DOS-Batch-Script):

set CATIA=C:\Programme\Dassault Systemes\B16\intel_a\code\bin
set xml=.\xml
md %XML%
"%CATIA%"\CATBatGenXMLSet.exe %xml% %1%

Dieses Script rufe ich aus dem jeweiligen Settings-Verzeichnis auf, in dem das Settingsfile steht, als Parameter der volle Name des Settings-Files (ohne Pfad).

Wo ist da was faul?

------------------
Gruß
Dieter

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

hallstein
Mitglied
Dipl. Ing. Maschinenbau (FH)


Sehen Sie sich das Profil von hallstein an!   Senden Sie eine Private Message an hallstein  Schreiben Sie einen Gästebucheintrag für hallstein

Beiträge: 144
Registriert: 16.04.2001

erstellt am: 15. Nov. 2007 21:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für segl 10 Unities + Antwort hilfreich

Hallo Dieter,

versuchs mal mitset CATIA=C:\Programme\Dassault Systemes\B16\intel_a\code\bin
set xml=.\xml
md %XML%
"%CATIA%"\catstart -run "CATBatGenXMLSet.exe %xml% %1%"

Gruß Knut

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Dieter7
Mitglied
Konstrukteur und CAD-Admin


Sehen Sie sich das Profil von Dieter7 an!   Senden Sie eine Private Message an Dieter7  Schreiben Sie einen Gästebucheintrag für Dieter7

Beiträge: 94
Registriert: 12.10.2007

erstellt am: 16. Nov. 2007 10:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für segl 10 Unities + Antwort hilfreich

Hallo Knut

danke für den Vorschlag. Hat leider auch nichts genutzt. Die xml-Files sind alle nur rudimentär.
Hat überhaupt jemand erfolgreich ein xml-file mit Inhalten aus einem CATSessioin-file exportiert? Sonst scheint es mir doch ein (grober) CATIA-Bug zu sein.

Gruß
Dieter

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Dieter7
Mitglied
Konstrukteur und CAD-Admin


Sehen Sie sich das Profil von Dieter7 an!   Senden Sie eine Private Message an Dieter7  Schreiben Sie einen Gästebucheintrag für Dieter7

Beiträge: 94
Registriert: 12.10.2007

erstellt am: 16. Nov. 2007 10:25    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für segl 10 Unities + Antwort hilfreich

Hallo zusammen!

Habe die Lösung gefunden:
Das CATSettings-File muß als Parameter ohne Extension '.CATSettings' angegeben werden.
Sonst läuft der Befehl ohne Fehlermeldung ins leere..
Außerdem konnte ich die Option -admin verwenden.

Gruß
Dieter

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz