Hot News aus dem CAD.de-Newsletter:

Unser Angebot:

  Foren auf CAD.de (alle Foren)
  VBasic / vb.net / vbs / wsh
  vb.net-Meldung: InvalidArgument=Value mit dem Wert 580 ist für Panel2MinSize ungültig

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   vb.net-Meldung: InvalidArgument=Value mit dem Wert 580 ist für Panel2MinSize ungültig (515 mal gelesen)
KMassler
Ehrenmitglied V.I.P. h.c.
CAD Admin + Mädchen für Alles...



Sehen Sie sich das Profil von KMassler an!   Senden Sie eine Private Message an KMassler  Schreiben Sie einen Gästebucheintrag für KMassler

Beiträge: 2624
Registriert: 06.11.2000

** CSWP 01/2008 **
HP Z440, 16GB, Quadro K2200;
SWX2016 SP4;
SAP/PLM;
DriveWorks Pro;
Programmierung: VBA, aktuell VB.NET 2017

erstellt am: 26. Okt. 2016 10:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo vb.net-Experten,

ich bekomme seit kurzem in einem Projekt immer die Nachricht
"InvalidArgument=Value mit dem Wert 580 ist für Panel2MinSize ungültig"

Das Panel2 hat bei MinimumSize aber die Standardwerte 0;0 stehen. Ich habe keine Ahnung, wo die 580 her kommen.
Mit einem Doppelklick auf die Meldung lande ich im Form-Designer auf der Zeile
"CType(Me.pbLogo, System.ComponentModel.ISupportInitialize).EndInit()", die mit dem Panel aber auch gar nichts zu tun hat (pbLogo ist eine Picturebox), im gesamten Designer kommt der Wert 580 nirgendwo vor, der Begriff "Panel2MinSize" ebenfalls nicht.

Auch nach dem Löschen des Panel2 bleibt die Nachricht erhalten 

Ich stehe voll auf dem Schlauch- woher kommt das und wie bekomme ich das wieder weg? 

------------------
Klaus

http://www.al-ko.com/de/fahrzeugtechnik/ | mein Gästebuch

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

RSchulz
Ehrenmitglied V.I.P. h.c.
Teamleader IT-CAD



Sehen Sie sich das Profil von RSchulz an!   Senden Sie eine Private Message an RSchulz  Schreiben Sie einen Gästebucheintrag für RSchulz

Beiträge: 5490
Registriert: 12.04.2007

erstellt am: 26. Okt. 2016 11:13    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für KMassler 10 Unities + Antwort hilfreich

Hallo Klaus,

ohne Projekt, wird dir glaube ich aber auch keiner helfen können...

------------------
MFG
Rick Schulz

Nettiquette (CAD.de)  -  Was ist die Systeminfo?  -  Wie man Fragen richtig stellt.  -  Unities

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Patrick Weber
Mitglied
Konstruktionstechniker, Admin


Sehen Sie sich das Profil von Patrick Weber an!   Senden Sie eine Private Message an Patrick Weber  Schreiben Sie einen Gästebucheintrag für Patrick Weber

Beiträge: 657
Registriert: 20.11.2006

Win7 Pro SP1 64Bit
HP Z230, Core i5, 8GB RAM, nv Quadro K600
Creo Elements/Direct 19.0 M010
ModelManager 19.0 M010
clisp,VB.net,VBA,AHK,php,javascript

erstellt am: 26. Okt. 2016 12:57    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für KMassler 10 Unities + Antwort hilfreich

Volltextsuche im Projektordner (nicht aus VS heraus) schon gemacht? (z.B. mit der FreeCommander XE Portable Suchfunktion o.ä.)
Will ein Event an Panel2 was ändern?
Trifft das ungefähr auf dich zu? https://social.msdn.micr osoft.com/Forums/windows/en-US/ee6abc76-f35a-41a4-a1ff-5be942ae3425/splitcontainer-panel-minsize-defect?forum=winformsdesigner
EDIT: Und die üblichen hilfreichen Angaben fehlen: Famework-Version und VisualStudio-Version.

------------------
Patrick


[Diese Nachricht wurde von Patrick Weber am 26. Okt. 2016 editiert.]

[Diese Nachricht wurde von Patrick Weber am 26. Okt. 2016 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

KMassler
Ehrenmitglied V.I.P. h.c.
CAD Admin + Mädchen für Alles...



Sehen Sie sich das Profil von KMassler an!   Senden Sie eine Private Message an KMassler  Schreiben Sie einen Gästebucheintrag für KMassler

Beiträge: 2624
Registriert: 06.11.2000

** CSWP 01/2008 **
HP Z440, 16GB, Quadro K2200;
SWX2016 SP4;
SAP/PLM;
DriveWorks Pro;
Programmierung: VBA, aktuell VB.NET 2017

erstellt am: 26. Okt. 2016 13:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Zitat:
Original erstellt von Patrick Weber:
...EDIT: Und die üblichen hilfreichen Angaben fehlen: Famework-Version und VisualStudio-Version.

Du hast ja recht, sry.
In meiner "normalen" Sysinfo steht das (zumindest die Version) drin, die wird hier aber warum auch immer nicht angezeigt.
Aktuell verwende ich VS 2015, das Projekt nutzt max. Framework 4.

Das mit der Textsuche hat mich darauf gebracht, dass ich ein Panel2 in einer anderen Form übersehen hatte. Aber auch da war MinimumSize auf 0;0 gestellt.
Ich habe dieses Panel2 ebenfalls gelöscht- die Nachricht blieb erhalten.

Aber jetzt nach einem Neustart ist sie weg. Ich weiß aber immer noch nicht, wie es dazu gekommen ist bzw. wodurch ich sie jetzt tatächlich behoben habe.
Naja, Hauptsache es geht wieder.

Vielen Dank euch  

[Edit]Ah..jetzt kommt die Sysinfo auch hier  Was so ein kleiner Haken bewirken kann ...  [/Edit]

------------------
Klaus

http://www.al-ko.com/de/fahrzeugtechnik/ | mein Gästebuch

[Diese Nachricht wurde von KMassler am 26. Okt. 2016 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Patrick Weber
Mitglied
Konstruktionstechniker, Admin


Sehen Sie sich das Profil von Patrick Weber an!   Senden Sie eine Private Message an Patrick Weber  Schreiben Sie einen Gästebucheintrag für Patrick Weber

Beiträge: 657
Registriert: 20.11.2006

erstellt am: 26. Okt. 2016 13:49    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für KMassler 10 Unities + Antwort hilfreich

Ich vermute, beim InitializeComponent-Part wurde was falsches mitgegeben, was dann auch nach Löschen des Steuerelements behalten wurde. Habe ich schon paar Mal erlebt und musste es dann chirurgisch im Texteditor entfernen.

------------------
Patrick

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2019 CAD.de | Impressum | Datenschutz