Forum:Pro ENGINEER
Thema:ProProgram und Parameter
Möchten Sie sich registrieren?
Wer darf antworten? Registrierte Benutzer können Beiträge verfassen.
Hinweise zur Registrierung Sie müssen registriert sein, um Beiträge oder Antworten auf Beiträge schreiben zu können.
Ihr Benutzername:
Ihr Kennwort:   Kennwort vergessen?
Anhang:    Datei(en) anhängen  <?>   Anhänge verwalten  <?>
Grafik für den Beitrag:                                                
                                                       
Ihre Antwort:

Fachbegriff
URL
Email
Fett
Kursiv
Durchgestr.
Liste
*
Bild
Zitat
Code

*HTML ist AUS
*UBB-Code ist AN
Smilies Legende
Netiquette

10 20 40

Optionen Smilies in diesem Beitrag deaktivieren.
Signatur anfügen: die Sie bei den Voreinstellungen angegeben haben.

Wenn Sie bereits registriert sind, aber Ihr Kennwort vergessen haben, klicken Sie bitte hier.

Bitte drücken Sie nicht mehrfach auf "Antwort speichern".

*Ist HTML- und/oder UBB-Code aktiviert, dann können Sie HTML und/oder UBB Code in Ihrem Beitrag verwenden.

T H E M A     A N S E H E N
Anna.EB

Beiträge: 44 / 0

Wildfire 4
Excel 07

Guten Tag zusammen,
Und wieder habe ich eine Frage, zu der ich keine Antwort weiß. Vielleicht wurde das Thema ja schon diskutiert und ihr könnt mir n Link schicken...ich finde leider nichts...

Also ich versuche mein Problem mal zu schildern.
Ich habe in meiner Unterbaugruppe, mittels der Familientabelle Varianten erstellt. Diese will ich in der Hauptbaugruppe einbauen. Um das zu "automatisieren" habe ich mir Beziehungen geschrieben, die Parameter erstellen mit den Richtigen Varianten Namen. Nun wollte ich im ProProgramm den Parameter Namen eintragen und ProE wechselt mir je nach Beziehung die Komponenten aus....Allerdings hat es bisher nur beim ersten mal geklappt, wenn ich jetzt die Beziehungen anpasse, wechselt er mir die Komponente nicht?!?

Hier mal die Beziehung die den Parameter steuert:
LA_GLIED_1_MODEL = KETTEN_LA_GLIED +"_"+ LA_GLIED_1 + "_" +  KETTENGLIED_1

und zugehörige ProProgramm-Ausschnitt:
ADD SUBASSEMBLY (LA_GLIED_1_MODEL)
INTERNAL COMPONENT ID 427
END ADD

Als Fehler erscheint:
Ersetzen von Komponente DUMMY_C_12_1 (M427) durch Pro/Program in Baugruppe KETTE_01 fehlgeschlagen.
Regenerierung wird wegen Fehlschlägen bei Ausführung von Pro/Program abgebrochen.

Danke schon mal in Voraus!

------------------
Liebe Grüße eure Anna

Anna.EB

Beiträge: 44 / 0

Wildfire 4
Excel 07

Hab den Fehler...
Wer lesen und schreiben kann, ist klar im Vorteil  
Immer alles genau kontrollieren und blos keine Fehler machen!! (hatte den Namen falsch  )

------------------
Liebe Grüße eure Anna

[Diese Nachricht wurde von Anna.EB am 31. Jul. 2014 editiert.]