Forum:Lisp
Thema:MTEXT mit entmake setzen
Möchten Sie sich registrieren?
Wer darf antworten? Registrierte Benutzer können Beiträge verfassen.
Hinweise zur Registrierung Sie müssen registriert sein, um Beiträge oder Antworten auf Beiträge schreiben zu können.
Ihr Benutzername:
Ihr Kennwort:   Kennwort vergessen?
Anhang:    Datei(en) anhängen  <?>   Anhänge verwalten  <?>
Grafik für den Beitrag:                                                
                                                       
Ihre Antwort:

Fachbegriff
URL
Email
Fett
Kursiv
Durchgestr.
Liste
*
Bild
Zitat
Code

*HTML ist AUS
*UBB-Code ist AN
Smilies Legende
Netiquette

10 20 40

Optionen Smilies in diesem Beitrag deaktivieren.
Signatur anfügen: die Sie bei den Voreinstellungen angegeben haben.

Wenn Sie bereits registriert sind, aber Ihr Kennwort vergessen haben, klicken Sie bitte hier.

Bitte drücken Sie nicht mehrfach auf "Antwort speichern".

*Ist HTML- und/oder UBB-Code aktiviert, dann können Sie HTML und/oder UBB Code in Ihrem Beitrag verwenden.

T H E M A     A N S E H E N
romi1

Beiträge: 634 / 4

Xeon E3-1245V2
16GB RAM
Windows 10 Professional 64 bit
AutoCAD 2014

Hallo!

Habe mir ein Lisp geschrieben, welche diverse Daten extrahiert und diese formatiert (mit Tabulatoren, ...) in die Variable "mtext-zeile" schreibt; diese Daten sollen dann zum Schluß als MTEXT mit entmake in die Zeichnung gesetzt werden:

Code:
  (entmake                                                                               
    (list
      (cons 0  "MTEXT")
      (cons 100  "AcDbEntity")
      (cons 100 "AcDbMText")
      (list '10 (car einsetzp) (cadr einsetzp))
      (cons 40 2.5)                                                                       
      (cons 41 250)
      (cons 1 mtext-zeile)
      (cons 50 0.0)
    )         
  )


Das funktioniert aber scheinbar nur dann, wenn die Variable "mtext-zeile" nicht zu viele Zeichen enthält. Wenn zu viele Zeichen in der Variable, wird einfach nichts ausgegeben - auch keine Fehlermeldung. Ich möchte aber auch längere Texte mit dieser Routine ausgeben; Wie kann ich das Problem beheben?

Gruß,
Roman

CADmium

Beiträge: 13496 / 249

.

Erstell einfach mal mit dem MText-Befehl so einen MText mit mehr als 255 Zeichen. und dann schau dir die Rückgabe von (entget(car(entsel))) mit Anwahl dieses Mtextes an .. besonders auf die GC1 und die GC3  

... und dann passe deinen Code entsprechend an. (und poste ihn hier)

oder du guckst dir die entsprechenden activeX methoden an ... da ist es etwas enfacher ( Den Textstring zu setzen)
------------------
      - Thomas -          
"Bei 99% aller Probleme ist die umfassende Beschreibung des Problems bereits mehr als die Hälfte der Lösung desselben."

romi1

Beiträge: 634 / 4

Xeon E3-1245V2
16GB RAM
Windows 10 Professional 64 bit
AutoCAD 2014

Hallo!

Vielen Dank für den Tipp! Hab' das Lisp nun also folgendermaßen umgebaut, und es scheint zu funktionieren:

Code:
(setq li1                                                                               
    (list
      (cons 0  "MTEXT")
      (cons 100  "AcDbEntity")
      (cons 100 "AcDbMText")
      (list '10 (car einsetzp) (cadr einsetzp))
      (cons 40 2.5)                                                                       
      (cons 41 250)
      (cons 50 0.0)
    )
  )
  (if
    (< (strlen mtext-zeile) 250)
    (setq li2 (list (cons 1 mtext-zeile)))
    (progn
      (setq li2 ())
      (while
        (> (strlen mtext-zeile) 250)
        (setq li2        (cons (cons 3 (substr mtext-zeile 1 249)) li2)
              mtext-zeile (substr mtext-zeile 250)
        )
      )
      (setq li2 (reverse (cons (cons 1 mtext-zeile) li2)))
    )
  )
 
  (entmake (append li1 li2))