Forum:E3.series
Thema:Skript-Problem in DBEditor
Möchten Sie sich registrieren?
Wer darf antworten? Registrierte Benutzer können Beiträge verfassen.
Hinweise zur Registrierung Sie müssen registriert sein, um Beiträge oder Antworten auf Beiträge schreiben zu können.
Ihr Benutzername:
Ihr Kennwort:   Kennwort vergessen?
Anhang:    Datei(en) anhängen  <?>   Anhänge verwalten  <?>
Grafik für den Beitrag:                                                
                                                       
Ihre Antwort:

Fachbegriff
URL
Email
Fett
Kursiv
Durchgestr.
Liste
*
Bild
Zitat
Code

*HTML ist AUS
*UBB-Code ist AN
Smilies Legende
Netiquette

10 20 40

Optionen Smilies in diesem Beitrag deaktivieren.
Signatur anfügen: die Sie bei den Voreinstellungen angegeben haben.

Wenn Sie bereits registriert sind, aber Ihr Kennwort vergessen haben, klicken Sie bitte hier.

Bitte drücken Sie nicht mehrfach auf "Antwort speichern".

*Ist HTML- und/oder UBB-Code aktiviert, dann können Sie HTML und/oder UBB Code in Ihrem Beitrag verwenden.

T H E M A     A N S E H E N
tetsu

Beiträge: 1 / 0

Hallo Zusammen,

ich habe ein kleines Skript im Datenbank-Editor erstellt. Mit der Version 2018 19.13.0.0 funktioniert das Skript einwandfrei. Seitdem Update auf die Version 2018 19.23.0.0 hat es leider immer die Fehlermeldung "E - Werkzeug C:\Desktop\test.vbs konnte nicht ausgeführt werden, da bereits ein Skript läuft", wenn ich nochmals das Skript laufen lasse. Nach der Erscheinung dieser Fehlermeldung kann ich die anderen Skripts nicht mehr benutzen. Ich muss das DBEditor erstmal schließen und dann wieder neu öffnen. In der neuen Version 2018 19.23.0.0 funktioniert das Skript nur einmal, irgendwie kann das Skript nicht mehr quittieren.

Gibt es die Möglichkeit, ein Menü im DBEditor erstellen zu können, ähnlich wie im Projekt mittel des Classes "UserMenuItemInterface"?

Ich freue mich auf eure Rückmeldung.

Vielen Dank

Gruß

tetsu
  

[Diese Nachricht wurde von tetsu am 06. Aug. 2019 editiert.]

AndreasK

Beiträge: 1006 / 5

Unter allen Umständen kann Vernunft durch Vernunft aufgeklärt werden (Alexander von Humboldt)

Nur ein Test, weil ein Mitglied einen Fehler in Sachen Antwortmöglichkeit meldete ...

------------------
Beste Grüße

Andreas Kippenberg

K0NFUZIUS

Beiträge: 228 / 0

Hi tetsu,
Willkommen im E3.series Forum. Ich habe leider gerade in paar technische Probleme mit cad.de. Deswegen entschuldige die späte Antwort.

Warum das Script nicht mehr das tut was es vorher tat kann ich natürlich nur mutmaßen ohne das Skript gesehen zu haben.
Versuche einmal folgendes:


  • Erstelle einmal einen Verknüpfung zur E3.series.exe und ergänze diese mit dem Parameter -unregister
  • Starte die Verknüpfung als Administrator.
  • Warte kurz. E3.series startet sich im Hintergrund und beendet sich automatisch und führt eine Deregistrierung der COM Schnittstelle durch.
  • Starte E3.series nun (ohne Parameter) ebenfalls wieder als Administrator.
  • E3.series startet und führt die COM Registrierung durch
  • Schließe E3.series
  • Starte E3.series unter Deinem normalen Benutzer
  • Starte Dein Skript

Sollte das keine Abhilfe schaffen müsste ich mal ein Blick auf Dein Skript werfen.
Das UserMenuItemInterface ist leider im DBE nicht vorhanden, dir bleibt als Workaround nur das händische Anlegen des Befehls über das Menü unter dem Punkt "Anpassen".
Gruß Jörg
K0NFUZIUS

Beiträge: 228 / 0

Hallo tetsu,
Könntest Du am Ende Deines Skriptes bitte einmal

Code:
Set e3 = Nothing

machen. "e3" wäre in dem Beispiel Dein DBEApplicationObject

Das sollte helfen.
Herzlichen Gruß

Jörg