Forum:SolidWorks
Thema:Makro unter PAC4SWX läuft nicht (ohne Pac schon)
Möchten Sie sich registrieren?
Wer darf antworten? Registrierte Benutzer können Beiträge verfassen.
Hinweise zur Registrierung Sie müssen registriert sein, um Beiträge oder Antworten auf Beiträge schreiben zu können.
Ihr Benutzername:
Ihr Kennwort:   Kennwort vergessen?
Anhang:    Datei(en) anhängen  <?>   Anhänge verwalten  <?>
Grafik für den Beitrag:                                                
                                                       
Ihre Antwort:

Fachbegriff
URL
Email
Fett
Kursiv
Durchgestr.
Liste
*
Bild
Zitat
Code

*HTML ist AUS
*UBB-Code ist AN
Smilies Legende
Netiquette

10 20 40

Optionen Smilies in diesem Beitrag deaktivieren.
Signatur anfügen: die Sie bei den Voreinstellungen angegeben haben.

Wenn Sie bereits registriert sind, aber Ihr Kennwort vergessen haben, klicken Sie bitte hier.

Bitte drücken Sie nicht mehrfach auf "Antwort speichern".

*Ist HTML- und/oder UBB-Code aktiviert, dann können Sie HTML und/oder UBB Code in Ihrem Beitrag verwenden.

T H E M A     A N S E H E N
StefanBerlitz

Beiträge: 8756 / 682

SunZu sagt:
Analysiere die Vorteile, die
du aus meinem Ratschlag ziehst.
Dann gliedere deine Kräfte
entsprechend und mache dir
außergewöhnliche Taktiken zunutze.

Hallo Philwag,

wie GDawg schon geschrieben hat vermute ich auch eine falsche Einstellung in PAC4SWX für die Parameter. Nach deinem Screenshot des Makros muss bei Module als Wert dateiname eingetragen werden (so heißt dein Modul im Makro) und als Procedure (Startprozedur) die main.

Ich hab dein Makro von oben einfach rauskopiert, in ein neues Makro bei mir geschmissen und in PAC4SWX eingebunden, klappt bei mir einwandfrei. Ich hab das Testmakro und den Screenshot meiner Einstellungen angehangen; vielleicht versuchst du es mit dem Makro mal, vielleicht ist noch irgendwas anderes in dem Makro selbst komisch. Ich hab allerdings von der lokalen Platte aus gearbeitet, nicht aus einem UNC-Pfad.

Anmerkung: wenn das Makro mittels PAC4SWX ans laufen kommt bitte nicht wundern, wenn es so aussieht, als tut sich in den Dokumenten nichts  PAC4SWX speichert nicht von sich aus, dass musst du in deinem Makro noch selbst übernehmen, sonst macht es die Dateieigenschaften dran und PAC4SWX schließt das wieder ohne zu speichern ... 

Ciao,
Stefan

------------------
Inoffizielle deutsche SolidWorks Hilfeseite    http://solidworks.cad.de