Forum:CATIA V6
Thema:Rules, Aktivieren von Boolean Operationen
Möchten Sie sich registrieren?
Wer darf antworten? Registrierte Benutzer können Beiträge verfassen.
Hinweise zur Registrierung Sie müssen registriert sein, um Beiträge oder Antworten auf Beiträge schreiben zu können.
Ihr Benutzername:
Ihr Kennwort:   Kennwort vergessen?
Anhang:    Datei(en) anhängen  <?>   Anhänge verwalten  <?>
Grafik für den Beitrag:                                                
                                                       
Ihre Antwort:

Fachbegriff
URL
Email
Fett
Kursiv
Durchgestr.
Liste
*
Bild
Zitat
Code

*HTML ist AUS
*UBB-Code ist AN
Smilies Legende
Netiquette

10 20 40

Optionen Smilies in diesem Beitrag deaktivieren.
Signatur anfügen: die Sie bei den Voreinstellungen angegeben haben.

Wenn Sie bereits registriert sind, aber Ihr Kennwort vergessen haben, klicken Sie bitte hier.

Bitte drücken Sie nicht mehrfach auf "Antwort speichern".

*Ist HTML- und/oder UBB-Code aktiviert, dann können Sie HTML und/oder UBB Code in Ihrem Beitrag verwenden.

T H E M A     A N S E H E N
s.bert

Beiträge: 53 / 0

Hallo zusammen,

ich bin neue hier im Forum und habe sofort eine kleine Frage.

Ich nutze Catia V6 2013.

Erklärung des Problems, bei der Erstellung eines PartBodys sollen 2 Boolean (Add) hinzugefügt werden. Bei einem Fall die eine bei einem anderen Fall die andere. Die Regel Funktioniert. Das Problem ist jedoch das beide Add-Operationen mit dem dahinter liegendem Shaft über die selben Parameter gespeist werden. Wird nun die eine Add Funktion deaktiviert( über eine Regel), entsteht eine Fehlermeldung da im Shaft der Deaktivierten Add-Funktion eine Skizze nicht korrekt ist.

Ich kann leider nur die bestehenden Parameter benutzen.
Mein Problem ist, wieso gibt Catia mir eine Fehlermeldung obwohl doch im Baum die Add-Operation deaktiviert ist.
Deaktiviere ich den darunter liegenden Shaft , funktioniert es. sind jedoch mehrere Shafts unter der Add-Operation müssten somit alle ausgeschalter werden.

Jemand eine Idee?

Gruß Sven

Gruß Sven

moppesle

Beiträge: 3308 / 0

CATIA V5 R19 SP9
WIN 7 64bit

Hallo Sven,

willkommen im Forum.

Ordne dir die Shafts separat in den Struckturbaum und erzeuge eine Kopie mit Link.
Diese dann verboolen und aktivieren/deaktivieren. somit brauchst du die Skizzen nicht gesondert aktivieren/deaktivieren.

schönes Wochenende.

------------------
Gruß Uwe

Auch Catia ist nur ein Mensch!    

s.bert

Beiträge: 53 / 0

Hallo Uwe,

danke deiner schnellen Antwort.

Ich versuche es noch etwas genauer zu beschreiben. Es sind wie in dem Bild im ersten Post zu sehen 2 Shafts, beide Shafts bekommen wie in der Skizze zu sehen den selben innen Durchmesser. Nun wird über eine Designtable der Außendurchmesser gesteuert bei Configuration A soll das Modell A mit dem Außendurchmesser erscheinen. Da aber der Parameter im Hintergrund auch an Modell B, das ausgeblendet ist, weiter gegeben wird, wird die Skizze zerschossen und eine Fehler Meldung entsteht. Jedoch ist das Modell B ja aufgrund der Regel deaktiviert, trotzdem kommt die Fehlermeldung hoch das in dem ausgeschalteten Modell ein Fehler vorliegt. Wie umgehe ich dies bzw. wie baue ich das Modell auf das es nicht passiert?

Gruß Sven

moppesle

Beiträge: 3308 / 0

CATIA V5 R19 SP9
WIN 7 64bit

Hallo Sven,

ich verstehe schon dein Problem.

Die Anwort die ich oben geschrieben habe solltest du umsetzen.
leider kann ich zu V6 nichts sagen, da ich es nicht zur Hand habe.

Also, die Shafts in einem extra Körper verboolen. Diesen dann verdecken.

Jeweils eien Kopie mit Link des Shafts.Diese dann im Parbody verboolen und in deine Rule einbeziehen.

Anderfalls must du alle Kindelemente explizit in deiner Rule aufnehmen und gesondert deaktivieren.

Code:

if String.1 =="0"
{PartBody\Pad.1\Activity =false
PartBody\Sketch.1\Activity =false}

else
{PartBody\Pad.1\Activity =true
PartBody\Sketch.1\Activity =true}



------------------
Gruß Uwe

Auch Catia ist nur ein Mensch!    

s.bert

Beiträge: 53 / 0

Ich danke dir... das sieht sehr gut aus.