Xref - probleme / Rund um AutoCAD
Florian030 06. Nov. 2006, 13:32

Hilfe ! BITTE ! DRINGEND!
ich habe folgendes problem:
in meiner Ausführungszeichnung habe ich diverse verschachtelte xrefs, d.h xrefs, die in sich wiederum xrefs haben, verwendet.
Die xrefs sind Lagepläne, die ich gemailt bekommen habe und ursprünglich im dxf.format waren.

Seit dieser Zeit habe ich probleme mit zwei punkten:
1) verschiedenste Layer werden in der Druckansicht und im Druck selbst  nicht gedruckt
2) Bestimmte Express Befehle z.B. Ansichtsreihenfolge funktionieren gar nicht mehr
3) Anwendungs-Absturz bei Copy+Paste von Objekten 

Was kann ich tun , habe versucht die xrefs alle zu binden, aber hilft nichts. Muß ich sie rausschmeißen?
Wie krieg ich meine saubere Zeichnung wieder hin???
Vielen Dank!
Florian

Angelika Hädrich 06. Nov. 2006, 13:48

Hallo Florian,

könnte ja sein, daß es etwas in der Zeichnungsdatenbank einer (oder mehrerer) referenzierten Zeichnung oder in der Hauptzeichnung "zertan" hat.

Wenn Du schon alle Referenzen gebunden hast - hast Du allerdings nur noch Deine Hauptzeichnung...

Also im Normalfall, bei komischen Verhalten einer DWG folgendes durchführen:

* hat die Zeichnung Referenzen, dann immer zuerst jede Ref-Zeichnung dem Vollwaschgang unterziehen, zuletzt die Hauptzeichnung

gegen Fehler in der Zeichnungsdatenbank:

* Datei mit Wiederherstellen öffnen - auch wenn keine Fehler angesagt werden danach speichern.
* Datei prüfen auch wenn keine Fehler angesagt werden danach speichern.
* Datei bereinigen - alle benannten Objekte raus, die Du nicht definitiv noch verwenden willst, danach speichern.
* anschließend nochmal prüfen...

Wenn dann immer noch Probleme da sind - wieder melden.

Gruß Angelika

g.r 06. Nov. 2006, 13:54

Hi Florian,
zu 1. Layer im Ansichtfenster gefroren? Liegt irgendetwas event. auf defpoints? Sind alle Xref´s zugeordnet oder einige auch überlagert anstelle von zugeordnet?

Zu 2. Die Ansichtsreihenfolge musst du in der entsprechenden Originaldatei richten. Nicht in Referenzen. Einige Elemente, vornehmlich  Solids und dergl. können trotzdem in der Referenz oben liegen, obwohl im Original die Anzeige korrekt ist. Ich sortiere die Display neu durch schieben der Element um den Wert 0. Durch die Auswahl werden diese Element in der Displayliste wieder ganz nachoben gebracht. Als Xref musst diese Datei wneu laden. Sollte danach funzen.

zu 3. Zu komplexe Auswahl ---> Paff!

Nutze im Xref-Manager die Strukturansicht, besser bei Huckepackreferenzen.

günter

Zitat:
Was kann ich tun , habe versucht die xrefs alle zu binden, aber hilft nichts. Muß ich sie rausschmeißen?

gehe deine Einzeldateien bis zur letzten zusammenfassenden Datei durch.
Prüfe jeden Referenzierungsschritt nach. Danach den nächsten ... usw.
Je ruhiger um so besser  (Hilfe ! BITTE ! DRINGEND!)
In der Ruhe liegt die Kraft!