Aufruf externer Programme / RUPLAN
ELCAD-User14 22. Mai. 2018, 12:19

Hallo Kollegen,
kann mir jemand sagen, ob ich aus Ruplan heraus ein externes Programm aufrufen kann (z.B. Explorer)?
Mein Wunsch ist es, z.B. über ein Symbolicon den Explorer mit dem Pfad der Ruplan hilfe c:\Ruplan472\Doku_472\Doku\Deu\RUPLAN\ aufzurufen. Kann Ruplan das und wie lautet die Notation?
Vielen Dank im voraus.

Hochi 22. Mai. 2018, 17:30

Hallo Mario,
dazu sind 2 Schritte nötig:
1. S-AWT, dazu im Programmierhandbuch M&CMD suchen.
2. Benutzer-Icon mit der Sammel-AWT belegen (geht glaube ich über M#USR oder so etwas).
Viel Erfolg
Hochi

ELCAD-User14 23. Mai. 2018, 08:39

Hallo Hochi,
danke für deine Antwort.
Punkt 2 ist mir klar, aber zu Punkt 1 muss ich erst nachschauen. Ich geb' Bescheid, wenn ich mehr weiß oder es hinbekommen habe.

Bis denne

cad_hans 23. Mai. 2018, 13:07

hallo,

so schaut soetwas bei mir aus

D A&MSGMOD B
D A&MSGLVL E

D A&MODULE "M&CMD"
D A&CMDDAT NDOWIX.CMD
D A&CMDDEV C:\RUPLAN4\TEMPAWT\

E


cmddat beschreibt den Programmnamen, cmddev den pfad.
zum starten aus sammal-awt im m-modus

ELCAD-User14 24. Mai. 2018, 14:28

Hallo Hans,
danke für deinen Tipp. Ich bin zwar weiter als vorher, aber halt nicht am Ende.
Meine AWT läuft und macht, was sie soll. Aber ich bekomme diese nicht mit einer Sammel-AWT aufgerufen.
Die Sammel-AWT lautet:  S1=EXPLORER, S3=M.
Die AWT heisst Explorer und macht, was sie soll (bei Einzelaufruf).

Die Infosys schmeisst folgendes raus:
MFCOD  463-I-801 | 24504: >MD_CMD_GRU_FA_04<          Dieses Symbol habe ich gedrückt.
MFCOD  463-I-802 | 24504: >SYMB< >:[K1/EXPLORER;]<    Aufruf der Sammel-AWT.
MFCOD  463-I-801 | 24504: T:Explorer-Doku            Anzeigetext.
MFCOD  463-I-801 | 24504: S:Exploreraufruf zur Ruplan-Doku  dito.
RNGNAC 430-I-000 | Neue Befehlsfolge
MHRBTT 430-I-001 | Anzahl der geänderten Datenpositionen: 1
RXGNTB 460-I-Z01 | Geladen: EXPLORER    (7) (AWT-Bank: 1)
RAVWAW 471-F-004 | AWT-Maske >            < ist nicht vorhanden
RAEXEA 472-E-009 | Abbruch der Sammel-AWT >EXPLORER    < am Element

Was mache ich falsch???

cad_hans 24. Mai. 2018, 15:41

hallo,

der Name der sammel-awt beginnt aber mit einem A&.

das heisst, an deinem Symbol musst du die sammel-awt starten mit:

irgendeinem fantasie ident der an dem Symbol nicht existiert z.b. AAA und als feldinhalt gibst du 'A&AWTNAME' an.


schau mal wie A&OFI gestartet wird.

ELCAD-User14 24. Mai. 2018, 16:23

Hallo Hans,
nun hab ich es: ich hatte die Sammel-AWT nur mit dem Namen und nicht A&NAME aufgerufen.

Tja, kaum macht man alles richtig, funzt es auch! 

Nochmal danke an Hochi und Hans.